]> git.pld-linux.org Git - packages/python3.git/blob - python3.spec
3432afd81b6ce2d2fcf38a226c4e8c61a7bf3447
[packages/python3.git] / python3.spec
1 #
2
3 # Conditional build:
4 %bcond_with     info                    # info pages (requires emacs)
5 %bcond_without  tkinter                 # disables tkinter module building
6 %bcond_with     tests                   # disables Python testing
7 %bcond_with     verbose_tests           # runs tests in verbose mode
8 #
9 # tests which will not work on 64-bit platforms
10 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
11 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
12 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
13
14 # tests which fail because of some unknown/unresolved reason (this list should be empty)
15 #   test_site: fails because our site.py is patched to include both /usr/share/... and /usr/lib...
16 #   test_gdb: fails, as the gdb uses old python version
17 %define         broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib test_zlib test_gdb test_site
18
19 %define py_ver          3.2
20 %define py_abi          %{py_ver}mu
21 %define py_prefix       %{_prefix}
22 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
23 %define py_incdir       %{_includedir}/python%{py_abi}
24 %define py_sitedir      %{py_libdir}/site-packages
25 %define py_dyndir       %{py_libdir}/lib-dynload
26
27 Summary:        Very high level scripting language with X interface
28 Summary(es.UTF-8):      Lenguaje script de alto nivel con interfaz X
29 Summary(fr.UTF-8):      Langage de script de très haut niveau avec interface X
30 Summary(pl.UTF-8):      Python - język obiektowy wysokiego poziomu
31 Summary(pt_BR.UTF-8):   Linguagem de programação interpretada de alto nível
32 Summary(ru.UTF-8):      Язык программирования очень высокого уровня с X-интерфейсом
33 Summary(tr.UTF-8):      X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
34 Summary(uk.UTF-8):      Мова програмування дуже високого рівня з X-інтерфейсом
35 Name:           python3
36 Version:        %{py_ver}.2
37 Release:        1
38 Epoch:          1
39 License:        PSF
40 Group:          Applications
41 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
42 # Source0-md5:  3720ce9460597e49264bbb63b48b946d
43 Patch0:         %{name}-pythonpath.patch
44 Patch1:         %{name}-ac_fixes.patch
45 Patch2:         %{name}-lib64.patch
46 Patch3:         %{name}-noarch_to_datadir.patch
47 Patch4:         %{name}-bug11254.patch
48 Patch5:         %{name}-no_cmdline_tests.patch
49 URL:            http://www.python.org/
50 BuildRequires:  autoconf >= 2.65
51 BuildRequires:  bluez-libs-devel
52 BuildRequires:  bzip2-devel
53 BuildRequires:  db-devel >= 4
54 %{?with_info:BuildRequires:     emacs >= 21}
55 BuildRequires:  expat-devel >= 1:1.95.7
56 BuildRequires:  file
57 BuildRequires:  gdbm-devel >= 1.8.3
58 BuildRequires:  gmp-devel >= 4.0
59 BuildRequires:  libffi-devel
60 BuildRequires:  libstdc++-devel
61 BuildRequires:  ncurses-ext-devel >= 5.2
62 BuildRequires:  openssl-devel >= 0.9.8
63 BuildRequires:  readline-devel >= 5.0
64 BuildRequires:  rpm-pythonprov
65 BuildRequires:  sed >= 4.0
66 BuildRequires:  sqlite3-devel >= 3.3.5
67 BuildRequires:  tar >= 1:1.22
68 %{?with_info:BuildRequires:     tetex-makeindex}
69 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
70 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
71 BuildRequires:  zlib-devel
72 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         specflags_ppc   -D__ppc__=1
76 %define         specflags_ppc64 -D__ppc64__=1
77
78 %if %{with verbose_tests}
79 %define test_flags -v -l -x
80 %else
81 %define test_flags -w -l -x
82 %endif
83
84 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
85 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
86 %else
87 %define test_list %{nobuilder_tests} %{broken_tests}
88 %endif
89
90 %ifarch sparc
91 %define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
92 %endif
93
94 %description
95 Python is an interpreted, interactive, object-oriented programming
96 language. It incorporates modules, exceptions, dynamic typing, very
97 high level dynamic data types, and classes. Python combines remarkable
98 power with very clear syntax. It has interfaces to many system calls
99 and libraries, as well as to various window systems, and is extensible
100 in C or C++. It is also usable as an extension language for
101 applications that need a programmable interface. Finally, Python is
102 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
103 MS-DOS, Windows, Windows NT, and OS/2.
104
105 This package contains the Python binary.
106
107 %description -l de.UTF-8
108 Python ist eine interpretierte, interaktive, objektorientierte
109 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
110 Python enthält Module, Klassen, Exceptions, High-Level dynamische
111 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
112 zu vielen Systemaufrufen und Libraries, sowie verschiedene
113 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
114
115 Programmierer können neue built-in-Module für Python in C oder C++
116 schreiben. Python kann auch als Erweiterungssprache für Applikationen
117 benutzt werden, die ein programmierbares Interface brauchen. Dieses
118 Paket enthält die meisten Standard-Python-Module, und Module zum
119 Ansprechen von Tix (Tk-widget set) und RPM.
120
121 %description -l es.UTF-8
122 Python es un lenguaje de scripts interpretado orientado a objetos.
123 Contiene soporte para carga dinámica de objetos, clases, módulos y
124 excepciones.
125
126 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
127 través de código C, tornando Python fácil de usar en ambientes
128 particulares/personalizados. Este paquete Python incluye la mayoría de
129 los módulos padrón Python, junto con módulos para crear interfaces
130 para el conjunto de componentes Tix para Tk y RPM.
131
132 %description -l fr.UTF-8
133 Python est un langage de script interprété et orienté objet. Il gère
134 le chargement dynamique des objets, les classes, les modules et les
135 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
136 avec du code C est simple, ce qui rend Python facile à utiliser dans
137 des configs personnalisées.
138
139 Ce paquetage Python contient la plupart des modules Python standards,
140 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
141 et RPM.
142
143 %description -l pl.UTF-8
144 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
145 językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
146 typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
147 sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
148 wielu wywołań systemowych i bibliotek, w tym również do różnych
149 bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
150 poprzez odpowiednie moduły pisane w C lub C++. Python może być również
151 użyty jako element aplikacji, którym potrzebny jest interpreter do
152 skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
153 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
154 OS/2.
155
156 Ten pakiet zawiera binarkę Pythona.
157
158 %description -l pt_BR.UTF-8
159 Python é uma linguagem de scripts interpretada orientada a objetos.
160 Contém suporte para carga dinâmica de objetos, classes, módulos e
161 exceções. Adicionar interfaces para novos sistemas de biblioteca
162 através de código C é simples, tornando Python fácil de usar em
163 ambientes particulares/personalizados.
164
165 Este pacote Python inclui a maioria do módulos padrão Python, junto
166 com módulos para interfaceamento para o conjunto de componentes Tix
167 para Tk e RPM.
168
169 %description -l ru.UTF-8
170 Python - это интерпретируемый, объектно-ориентированный язык
171 программирования. Он поддерживает динамическую загрузку объектов,
172 классы, модули и обработку исключительных ситуаций (exceptions).
173 Простота добавления интерфейсов к новым системным библиотекам через
174 код на языке C делает Python хорошим выбором для использования в
175 специальных конфигурациях.
176
177 %description -l tr.UTF-8
178 Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
179 sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
180 destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
181 paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
182 arayüz birimlerini de içerir.
183
184 %description -l uk.UTF-8
185 Python - це інтерпретована, об'єктно-орієнтована мова програмування.
186 Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
187 виключних ситуацій (exceptions). Простота додавання інтерфейсів для
188 нових системних бібліотек через код на мові C робить Python добрим
189 вибором для використання в спеціальних конфігураціях.
190
191 %package libs
192 Summary:        Python library
193 Summary(pl.UTF-8):      Biblioteka języka Python
194 Group:          Libraries/Python
195 # broken detection in rpm/pythondeps.sh
196 Provides:       python(abi) = %{py_ver}
197 # for compatibility with existing Ac packages
198 Provides:       python(bytecode) = %{py_ver}
199 %{!?with_info:Obsoletes:        python3-doc-info}
200
201 %description libs
202 Python shared library and very essental modules for Python binary.
203
204 %description libs -l pl.UTF-8
205 Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
206 dla Pythona.
207
208 %package modules
209 Summary:        Python modules
210 Summary(pl.UTF-8):      Moduły języka Python
211 Group:          Libraries/Python
212 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
213 Obsoletes:      python3-modules-sqlite
214
215 %description modules
216 Python officially distributed modules.
217
218 %description modules -l pl.UTF-8
219 Oficjalnie rozprowadzane moduły języka Python.
220
221 %package -n pydoc3
222 Summary:        Python interactive module documentation access support
223 Summary(pl.UTF-8):      Interaktywne korzystanie z dokumentacji modułów języka Python
224 Group:          Applications
225 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
226
227 %description -n pydoc3
228 Python interactive module documentation access support.
229
230 %description -n pydoc3 -l pl.UTF-8
231 Interaktywne korzystanie z dokumentacji modułów języka Python.
232
233 %package -n idle3
234 Summary:        IDE for Python language
235 Summary(pl.UTF-8):      IDE dla języka Python
236 Group:          Applications
237 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
238
239 %description -n idle3
240 IDE for Python language.
241
242 %description -n idle3 -l pl.UTF-8
243 IDE dla języka Python.
244
245 %package devel
246 Summary:        Libraries and header files for building python code
247 Summary(de.UTF-8):      Libraries und Header-Dateien zum Erstellen von Python-Code
248 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para construir programas en python
249 Summary(fr.UTF-8):      Bibliothèques et en-têtes pour construire du code python
250 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki Pythona
251 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para o Python
252 Summary(ru.UTF-8):      Библиотеки и хедеры для построения кода на языке Python
253 Summary(tr.UTF-8):      Python ile geliştirme yapmak için gerekli dosyalar
254 Summary(uk.UTF-8):      Бібліотеки та хедери для програмування на мові Python
255 Group:          Development/Languages/Python
256 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
257
258 %description devel
259 The Python interpreter is relatively easy to extend with dynamically
260 loaded extensions and to embed in other programs. This package
261 contains the header files and libraries which are needed to do both of
262 these tasks.
263
264 %description devel -l de.UTF-8
265 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
266 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
267 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
268 die für beide Aufgaben erforderlich sind.
269
270 %description devel -l es.UTF-8
271 El interpretador Python permite incluir con facilidad extensiones
272 cargadas dinámicamente. Python es también fácil de ser empotrado en
273 otros programas. Este paquete contiene los archivos de inclusión y
274 bibliotecas necesarios para estas dos tareas.
275
276 %description devel -l fr.UTF-8
277 L'interpréteur Python est relativement facile à étendre avec des
278 extensions chargées dynamiquement et à insérer dans d'autres
279 programmes. Ce paquetage contient les en-têtes et les bibliothèques
280 nécessaires à ces deux tâches.
281
282 %description devel -l pl.UTF-8
283 Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
284 dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
285 osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
286 wszystko inne co potrzebne do tych celów.
287
288 %description devel -l pt_BR.UTF-8
289 O interpretador Python permite incluir com facilidade extensões
290 carregadas dinamicamente. Python é também fácil de ser embutido em
291 outros programas. Este pacote contém os arquivos de inclusão e
292 bibliotecas necessários para estas duas tarefas.
293
294 %description devel -l ru.UTF-8
295 Интерпретатор Python относительно легко расширяется при помощи
296 динамически загружаемых расширений и встраивается в другие программы.
297 Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
298 задач.
299
300 %description devel -l tr.UTF-8
301 Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
302 dosyalarını ve kitaplıkları içerir.
303
304 %description devel -l uk.UTF-8
305 Інтерпретатор Python відносно легко розширюється за допомогою
306 розширень з динамічною загрузкою та вбудовується в інші програми. Цей
307 пакет містить хедери та бібліотеки, необхідні для обох цих задач.
308
309 %package devel-src
310 Summary:        Python module sources
311 Summary(pl.UTF-8):      Pliki źródłowe modułów Pythona
312 Group:          Development/Languages/Python
313 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
314
315 %description devel-src
316 Python module sources.
317
318 %description devel-src -l pl.UTF-8
319 Pliki źródłowe modułów Pythona.
320
321 %package devel-tools
322 Summary:        Python development tools
323 Summary(pl.UTF-8):      Narzędzia programistyczne języka Python
324 Group:          Development/Languages/Python
325 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
326
327 %description devel-tools
328 Python development tools such as profilers and debugger.
329
330 %description devel-tools -l pl.UTF-8
331 Narzędzia programistyczne języka Python takie jak profiler oraz
332 debugger.
333
334 %package 2to3
335 Summary:        Automated Python 2 to 3 code translation
336 Summary(pl.UTF-8):      Automatyczne tłumaczenie kodu Pythona 2 do 3
337 Group:          Development/Languages/Pythona
338
339 %description 2to3
340 2to3 is a Python program that reads Python 2.x source code and applies
341 a series of fixers to transform it into valid Python 3.x code. The
342 standard library contains a rich set of fixers that will handle almost
343 all code. 2to3 supporting library lib2to3 is, however, a flexible and
344 generic library, so it is possible to write your own fixers for 2to3.
345 lib2to3 could also be adapted to custom applications in which Python
346 code needs to be edited automatically.
347
348 %description 2to3 -l pl.UTF-8
349 2to3 to program w Pythonie czytający od źródłowy w Pythonie 2.x i
350 aplikujący serię poprawek przekształcających go w poprawny kod w
351 Pythonie 3.x. Biblioteka standardowa zawiera duży zbiór poprawek
352 obsługujących większość kodu. Biblioteka wspierająca 2to3 (lib2to3)
353 jest jednak elastyczną i ogólną biblioteką, więc można pisać własne
354 poprawki dla 2to3. lib2to3 można także zaadaptować na potrzeby
355 własnych zastosowań, w których kod w Pythonie musi być modyfikowany
356 automatycznie.
357
358 %package static
359 Summary:        Static python library
360 Summary(pl.UTF-8):      Statyczna biblioteka Pythona
361 Group:          Development/Languages/Python
362 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
363
364 %description static
365 Static python library.
366
367 %description static -l pl.UTF-8
368 Statyczna biblioteka Pythona.
369
370 %package doc-info
371 Summary:        Documentation on Python in texinfo format
372 Summary(pl.UTF-8):      Dokumentacja do Pythona w formacie texinfo
373 Group:          Documentation
374
375 %description doc-info
376 Documentation on Python in texinfo format.
377
378 %description doc-info -l pl.UTF-8
379 Dokumentacja do Pythona w formacie texinfo.
380
381 %package tkinter
382 Summary:        Standard Python interface to the Tk GUI toolkit
383 Summary(de.UTF-8):      Grafische Tk-Schnittstelle für Python
384 Summary(es.UTF-8):      Interfaz de GUI Tk para Python
385 Summary(fr.UTF-8):      Interface graphique Tk pour Python
386 Summary(pl.UTF-8):      Standardowy interfejs Pythona do biblioteki Tk
387 Summary(pt_BR.UTF-8):   Interface GUI Tk para Phyton
388 Summary(tr.UTF-8):      Python için grafik kullanıcı arayüzü
389 Group:          Libraries/Python
390 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
391 Requires:       tcl >= 8.4.3
392 Requires:       tix >= 1:8.1.4-4
393 Requires:       tk >= 8.4.3
394
395 %description tkinter
396 Standard Python interface to the Tk GUI toolkit.
397
398 %description tkinter -l de.UTF-8
399 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
400 vielen Konfigurations-Tools genutzt.
401
402 %description tkinter -l es.UTF-8
403 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
404 herramientas de configuración.
405
406 %description tkinter -l fr.UTF-8
407 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
408 beaucoup des outils de configuration.
409
410 %description tkinter -l pl.UTF-8
411 Standardowy interfejs Pythona do biblioteki Tk.
412
413 %description tkinter -l pt_BR.UTF-8
414 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
415 muitas ferramentas de configuração.
416
417 %description tkinter -l ru.UTF-8
418 Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
419
420 %description tkinter -l tr.UTF-8
421 Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
422 kullanılan grafik bir arayüzdür.
423
424 %description tkinter -l uk.UTF-8
425 Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
426
427 %package examples
428 Summary:        Example programs in Python
429 Summary(pl.UTF-8):      Przykładowe programy w Pythonie
430 Group:          Development/Languages/Python
431
432 %description examples
433 Example programs in Python.
434
435 These are for Python 2.3.4, not %{version}.
436
437 %description examples -l pl.UTF-8
438 Przykładowe programy w Pythonie.
439
440 Przykłady te są dla Pythona 2.3.4, nie %{version}.
441
442 %prep
443 %setup -q -n Python-%{version}
444 %patch0 -p1
445 %patch1 -p1
446 %patch2 -p1
447 %patch3 -p1
448 %patch4 -p1
449 %patch5 -p1
450
451 %build
452 %{__autoconf}
453 CPPFLAGS="-I/usr/include/ncursesw %{rpmcppflags}"; export CPPFLAGS
454 %configure \
455         --with-cxx-main="%{__cxx}" \
456         --enable-shared \
457         --enable-ipv6 \
458         --with-dbmliborder=gdbm:bdb \
459         --with-wide-unicode \
460         --with-signal-module \
461         --with-tsc \
462         --with-threads \
463         --with-doc-strings \
464         --with-fpectl \
465         --with-system-ffi \
466         --with-computed-gotos \
467         LINKCC='$(PURIFY) $(CXX)' \
468         LDSHARED='$(CC) $(CFLAGS) -shared' \
469         BLDSHARED='$(CC) $(CFLAGS) -shared' \
470         LDFLAGS="%{rpmcflags} %{rpmldflags}"
471
472 %{__make} \
473         OPT="%{rpmcflags} -fno-caller-saves" 2>&1 | awk '
474 BEGIN { fail = 0; logmsg = ""; }
475 {
476         if ($0 ~ /\*\*\* WARNING:/) {
477                 fail = 1;
478                 logmsg = logmsg $0;
479         }
480         print $0;
481 }
482 END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
483
484 LC_ALL=C
485 export LC_ALL
486 %if %{with tests}
487 binlibdir=`echo build/lib.*`
488 %{__make} test \
489         TESTOPTS="%{test_flags} %{test_list}" \
490         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:`pwd`/$binlibdir ./python -tt"
491 %endif
492
493 %install
494 rm -rf $RPM_BUILD_ROOT
495 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
496         $RPM_BUILD_ROOT{%{py_sitedir},%{py_sitescriptdir}}/__pycache__ \
497         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
498         $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1} \
499         $RPM_BUILD_ROOT/etc/shrc.d
500
501 %{__make} install \
502         DESTDIR=$RPM_BUILD_ROOT
503
504 %if %{with info}
505 %{__make} -C Doc/info
506 install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
507 %endif
508
509 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
510 cp -a Tools $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
511
512 #
513 # create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
514 #
515
516 # for python devel tools
517 for script in timeit profile pdb pstats; do
518     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
519 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
520
521 echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
522         >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
523
524 sed 's/=/ /' \
525         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
526         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
527
528 # for python modules
529 for script in smtpd webbrowser; do
530     echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
531 done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
532
533 sed 's/=/ /' \
534         < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
535         > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
536
537 # xgettext specific for Python code
538 #
539 # we will have two commands: pygettext.py (an alias) and pygettext;
540 # this way there are no import (which is impossible now) conflicts and
541 # pygettext.py is provided for compatibility
542 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
543
544 # just to cut the noise, as they are not packaged (now)
545 # first tests (probably could be packaged)
546 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/test
547 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
548 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
549 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/email/test
550 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/importlib/test
551 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
552 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
553 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/tkinter/test
554 %{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/unittest/test
555
556 # other files
557 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
558 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
559 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
560 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
561 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
562 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
563
564 # currently provided by python-2to3, consider switching to this one
565 %{__rm} $RPM_BUILD_ROOT%{_bindir}/2to3
566
567 # that seems to be only an empty extension template,
568 # which seems to be built only {with tests}
569 %{__rm} -f $RPM_BUILD_ROOT%{py_dyndir}/xxlimited.*.so
570
571 # already in %%doc
572 %{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
573
574 %clean
575 rm -rf $RPM_BUILD_ROOT
576
577 %post   libs -p /sbin/ldconfig
578 %postun libs -p /sbin/ldconfig
579
580 %post   doc-info -p /sbin/postshell
581 -/usr/sbin/fix-info-dir -c %{_infodir}
582
583 %postun doc-info -p /sbin/postshell
584 -/usr/sbin/fix-info-dir -c %{_infodir}
585
586 %files
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_bindir}/python%{py_ver}
589 %attr(755,root,root) %{_bindir}/python%{py_abi}
590 %attr(755,root,root) %{_bindir}/python3
591 %{_mandir}/man1/python%{py_ver}.1*
592
593 %files libs
594 %defattr(644,root,root,755)
595 %doc LICENSE
596 %attr(755,root,root) %{_libdir}/libpython%{py_abi}.so.*.*
597
598 %dir %{py_incdir}
599 %{py_incdir}/pyconfig.h
600
601 %dir %{py_libdir}
602 %dir %{py_dyndir}
603 %dir %{py_sitedir}
604 %dir %{py_sitedir}/__pycache__
605 %dir %{py_scriptdir}
606 %dir %{py_sitescriptdir}
607 %dir %{py_sitescriptdir}/__pycache__
608 %{py_scriptdir}/__pycache__
609
610 # shared modules required by python library
611 %attr(755,root,root) %{py_dyndir}/_struct.cpython-*.so
612
613 # modules required by python library
614 %{py_scriptdir}/_abcoll.py
615 %{py_scriptdir}/_weakrefset.py
616 %{py_scriptdir}/abc.py
617 %{py_scriptdir}/bisect.py
618 %{py_scriptdir}/codecs.py
619 %{py_scriptdir}/collections.py
620 %{py_scriptdir}/copyreg.py
621 %{py_scriptdir}/functools.py
622 %{py_scriptdir}/genericpath.py
623 %{py_scriptdir}/heapq.py
624 %{py_scriptdir}/keyword.py
625 %{py_scriptdir}/linecache.py
626 %{py_scriptdir}/locale.py
627 %{py_scriptdir}/io.py
628 %{py_scriptdir}/posixpath.py
629 %{py_scriptdir}/re.py
630 %{py_scriptdir}/reprlib.py
631 %{py_scriptdir}/site.py
632 %{py_scriptdir}/sre_*.py
633 %{py_scriptdir}/stat.py
634 %{py_scriptdir}/sysconfig.py
635 %{py_scriptdir}/token.py
636 %{py_scriptdir}/tokenize.py
637 %{py_scriptdir}/traceback.py
638 %{py_scriptdir}/weakref.py
639 %{py_scriptdir}/os.py
640 # needed by the dynamic sys.lib patch
641 %{py_scriptdir}/types.py
642
643 # encodings required by python library
644 %dir %{py_scriptdir}/encodings
645 %{py_scriptdir}/encodings/__pycache__
646 %{py_scriptdir}/encodings/*.py
647
648 %dir %{py_libdir}/config-%{py_abi}
649 %attr(755,root,root) %{py_libdir}/config-%{py_abi}/makesetup
650 %attr(755,root,root) %{py_libdir}/config-%{py_abi}/install-sh
651 %{py_libdir}/config-%{py_abi}/Makefile
652 %{py_libdir}/config-%{py_abi}/Setup
653 %{py_libdir}/config-%{py_abi}/Setup.config
654 %{py_libdir}/config-%{py_abi}/Setup.local
655 %{py_libdir}/config-%{py_abi}/config.c
656 %{py_libdir}/config-%{py_abi}/config.c.in
657 %{py_libdir}/config-%{py_abi}/python.o
658
659 %files modules
660 %defattr(644,root,root,755)
661 /etc/shrc.d/python*-modules*
662 %exclude %{py_scriptdir}/_abcoll.py
663 %exclude %{py_scriptdir}/_weakrefset.py
664 %exclude %{py_scriptdir}/abc.py
665 %exclude %{py_scriptdir}/bisect.py
666 %exclude %{py_scriptdir}/codecs.py
667 %exclude %{py_scriptdir}/collections.py
668 %exclude %{py_scriptdir}/copyreg.py
669 %exclude %{py_scriptdir}/functools.py
670 %exclude %{py_scriptdir}/genericpath.py
671 %exclude %{py_scriptdir}/heapq.py
672 %exclude %{py_scriptdir}/io.py
673 %exclude %{py_scriptdir}/keyword.py
674 %exclude %{py_scriptdir}/linecache.py
675 %exclude %{py_scriptdir}/locale.py
676 %exclude %{py_scriptdir}/posixpath.py
677 %exclude %{py_scriptdir}/pdb.py
678 %exclude %{py_scriptdir}/profile.py
679 %exclude %{py_scriptdir}/pstats.py
680 %exclude %{py_scriptdir}/pydoc.py
681 %exclude %{py_scriptdir}/re.py
682 %exclude %{py_scriptdir}/reprlib.py
683 %exclude %{py_scriptdir}/site.py
684 %exclude %{py_scriptdir}/sre_*.py
685 %exclude %{py_scriptdir}/stat.py
686 %exclude %{py_scriptdir}/sysconfig.py
687 %exclude %{py_scriptdir}/timeit.py
688 %exclude %{py_scriptdir}/token.py
689 %exclude %{py_scriptdir}/tokenize.py
690 %exclude %{py_scriptdir}/traceback.py
691 %exclude %{py_scriptdir}/weakref.py
692 %exclude %{py_scriptdir}/os.py
693 %exclude %{py_scriptdir}/encodings/*.py
694 %exclude %{py_scriptdir}/types.py
695
696 %{py_scriptdir}/*.py
697
698 %{py_dyndir}/Python-%{version}-py*.egg-info
699
700 #
701 # list .so modules to be sure that all of them are built
702 #
703
704 %attr(755,root,root) %{py_dyndir}/_bisect.cpython-*.so
705 %attr(755,root,root) %{py_dyndir}/_codecs_cn.cpython-*.so
706 %attr(755,root,root) %{py_dyndir}/_codecs_hk.cpython-*.so
707 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.cpython-*.so
708 %attr(755,root,root) %{py_dyndir}/_codecs_jp.cpython-*.so
709 %attr(755,root,root) %{py_dyndir}/_codecs_kr.cpython-*.so
710 %attr(755,root,root) %{py_dyndir}/_codecs_tw.cpython-*.so
711 %attr(755,root,root) %{py_dyndir}/_csv.cpython-*.so
712 %attr(755,root,root) %{py_dyndir}/_ctypes*.cpython-*.so
713 %attr(755,root,root) %{py_dyndir}/_curses_panel.cpython-*.so
714 %attr(755,root,root) %{py_dyndir}/_curses.cpython-*.so
715 %attr(755,root,root) %{py_dyndir}/_datetime.cpython-*.so
716 %ifnarch sparc64
717 %attr(755,root,root) %{py_dyndir}/_dbm.cpython-*.so
718 %endif
719 %attr(755,root,root) %{py_dyndir}/_elementtree.cpython-*.so
720 %attr(755,root,root) %{py_dyndir}/_gdbm.cpython-*.so
721 %attr(755,root,root) %{py_dyndir}/_hashlib.cpython-*.so
722 %attr(755,root,root) %{py_dyndir}/_heapq.cpython-*.so
723 %attr(755,root,root) %{py_dyndir}/_json.cpython-*.so
724 %attr(755,root,root) %{py_dyndir}/_lsprof.cpython-*.so
725 %attr(755,root,root) %{py_dyndir}/_multibytecodec.cpython-*.so
726 %attr(755,root,root) %{py_dyndir}/_multiprocessing.cpython-*.so
727 %attr(755,root,root) %{py_dyndir}/_pickle.cpython-*.so
728 %attr(755,root,root) %{py_dyndir}/_posixsubprocess.cpython-*.so
729 %attr(755,root,root) %{py_dyndir}/_random.cpython-*.so
730 %attr(755,root,root) %{py_dyndir}/_socket.cpython-*.so
731 %attr(755,root,root) %{py_dyndir}/_ssl.cpython-*.so
732 %attr(755,root,root) %{py_dyndir}/_testcapi.cpython-*.so
733 %attr(755,root,root) %{py_dyndir}/array.cpython-*.so
734 %attr(755,root,root) %{py_dyndir}/atexit.cpython-*.so
735 %attr(755,root,root) %{py_dyndir}/audioop.cpython-*.so
736 %attr(755,root,root) %{py_dyndir}/binascii.cpython-*.so
737 %attr(755,root,root) %{py_dyndir}/bz2.cpython-*.so
738 %attr(755,root,root) %{py_dyndir}/cmath.cpython-*.so
739 %attr(755,root,root) %{py_dyndir}/crypt.cpython-*.so
740 %attr(755,root,root) %{py_dyndir}/fcntl.cpython-*.so
741 %attr(755,root,root) %{py_dyndir}/grp.cpython-*.so
742 %attr(755,root,root) %{py_dyndir}/math.cpython-*.so
743 %attr(755,root,root) %{py_dyndir}/mmap.cpython-*.so
744 %attr(755,root,root) %{py_dyndir}/nis.cpython-*.so
745 %attr(755,root,root) %{py_dyndir}/ossaudiodev.cpython-*.so
746 %attr(755,root,root) %{py_dyndir}/parser.cpython-*.so
747 %attr(755,root,root) %{py_dyndir}/pyexpat.cpython-*.so
748 %attr(755,root,root) %{py_dyndir}/readline.cpython-*.so
749 %attr(755,root,root) %{py_dyndir}/resource.cpython-*.so
750 %attr(755,root,root) %{py_dyndir}/select.cpython-*.so
751 %attr(755,root,root) %{py_dyndir}/syslog.cpython-*.so
752 %attr(755,root,root) %{py_dyndir}/termios.cpython-*.so
753 %attr(755,root,root) %{py_dyndir}/time.cpython-*.so
754 %attr(755,root,root) %{py_dyndir}/spwd.cpython-*.so
755 %attr(755,root,root) %{py_dyndir}/unicodedata.cpython-*.so
756 %attr(755,root,root) %{py_dyndir}/zlib.cpython-*.so
757
758 %dir %{py_scriptdir}/plat-*
759 %{py_scriptdir}/plat-*/__pycache__
760 %{py_scriptdir}/plat-*/*.py
761
762 %{py_scriptdir}/concurrent
763
764 %dir %{py_scriptdir}/ctypes
765 %dir %{py_scriptdir}/ctypes/macholib
766 %{py_scriptdir}/ctypes/__pycache__
767 %{py_scriptdir}/ctypes/macholib/__pycache__
768
769 %{py_scriptdir}/ctypes/*.py
770 %{py_scriptdir}/ctypes/macholib/*.py
771 %doc %{py_scriptdir}/ctypes/macholib/README.ctypes
772
773 %dir %{py_scriptdir}/curses
774 %{py_scriptdir}/curses/__pycache__
775 %{py_scriptdir}/curses/*.py
776
777 %dir %{py_scriptdir}/dbm
778 %{py_scriptdir}/dbm/__pycache__
779 %{py_scriptdir}/dbm/*.py
780
781 %dir %{py_scriptdir}/distutils
782 %dir %{py_scriptdir}/distutils/command
783 %doc %{py_scriptdir}/distutils/README
784 %{py_scriptdir}/distutils/__pycache__
785 %{py_scriptdir}/distutils/command/__pycache__
786 %{py_scriptdir}/distutils/*.py
787 %{py_scriptdir}/distutils/command/*.py
788 %{py_scriptdir}/distutils/command/command_template
789
790 %dir %{py_scriptdir}/email
791 %dir %{py_scriptdir}/email/mime
792 %{py_scriptdir}/email/__pycache__
793 %{py_scriptdir}/email/mime/__pycache__
794 %{py_scriptdir}/email/*.py
795 %{py_scriptdir}/email/mime/*.py
796
797 %dir %{py_scriptdir}/html
798 %{py_scriptdir}/html/*.py
799 %{py_scriptdir}/html/__pycache__
800
801 %dir %{py_scriptdir}/http
802 %{py_scriptdir}/http/__pycache__
803 %{py_scriptdir}/http/*.py
804
805 %dir %{py_scriptdir}/importlib
806 %{py_scriptdir}/importlib/__pycache__
807 %{py_scriptdir}/importlib/*.py
808
809 %dir %{py_scriptdir}/json
810 %{py_scriptdir}/json/__pycache__
811 %{py_scriptdir}/json/*.py
812
813 %dir %{py_scriptdir}/logging
814 %{py_scriptdir}/logging/__pycache__
815 %{py_scriptdir}/logging/*.py
816
817 %dir %{py_scriptdir}/multiprocessing
818 %{py_scriptdir}/multiprocessing/__pycache__
819 %{py_scriptdir}/multiprocessing/*.py
820 %dir %{py_scriptdir}/multiprocessing/dummy
821 %{py_scriptdir}/multiprocessing/dummy/__pycache__
822 %{py_scriptdir}/multiprocessing/dummy/*.py
823
824 %{py_scriptdir}/turtledemo
825 %{py_scriptdir}/unittest
826
827 %dir %{py_scriptdir}/urllib
828 %{py_scriptdir}/urllib/__pycache__
829 %{py_scriptdir}/urllib/*.py
830
831 %dir %{py_scriptdir}/wsgiref
832 %{py_scriptdir}/wsgiref/__pycache__
833 %{py_scriptdir}/wsgiref/*.py
834 %{py_scriptdir}/wsgiref.egg-info
835
836 %dir %{py_scriptdir}/xml
837 %dir %{py_scriptdir}/xml/dom
838 %dir %{py_scriptdir}/xml/etree
839 %dir %{py_scriptdir}/xml/parsers
840 %dir %{py_scriptdir}/xml/sax
841 %{py_scriptdir}/xml/__pycache__
842 %{py_scriptdir}/xml/dom/__pycache__
843 %{py_scriptdir}/xml/etree/__pycache__
844 %{py_scriptdir}/xml/parsers/__pycache__
845 %{py_scriptdir}/xml/sax/__pycache__
846 %{py_scriptdir}/xml/*.py
847 %{py_scriptdir}/xml/dom/*.py
848 %{py_scriptdir}/xml/etree/*.py
849 %{py_scriptdir}/xml/parsers/*.py
850 %{py_scriptdir}/xml/sax/*.py
851
852 %dir %{py_scriptdir}/xmlrpc
853 %{py_scriptdir}/xmlrpc/__pycache__
854 %{py_scriptdir}/xmlrpc/*.py
855
856 %attr(755,root,root) %{py_dyndir}/_sqlite3.cpython-*.so
857 %dir %{py_scriptdir}/sqlite3
858 %{py_scriptdir}/sqlite3/__pycache__
859 %{py_scriptdir}/sqlite3/*.py
860
861 %files -n pydoc3
862 %defattr(644,root,root,755)
863 %attr(755,root,root) %{_bindir}/pydoc3
864 %attr(755,root,root) %{_bindir}/pydoc3.2
865 %{py_scriptdir}/pydoc.py
866 %dir %{py_scriptdir}/pydoc_data
867 %{py_scriptdir}/pydoc_data/__pycache__
868 %{py_scriptdir}/pydoc_data/*.py
869 %{py_scriptdir}/pydoc_data/*.css
870
871 %files -n idle3
872 %defattr(644,root,root,755)
873 %attr(755,root,root) %{_bindir}/idle3
874 %attr(755,root,root) %{_bindir}/idle3.2
875 %dir %{py_scriptdir}/idlelib
876 %dir %{py_scriptdir}/idlelib/Icons
877 %{py_scriptdir}/idlelib/__pycache__
878 %{py_scriptdir}/idlelib/*.py
879 %doc %{py_scriptdir}/idlelib/*.txt
880 %doc %{py_scriptdir}/idlelib/ChangeLog
881 %{py_scriptdir}/idlelib/Icons/*
882 %{py_scriptdir}/idlelib/*.def
883
884 %files devel
885 %defattr(644,root,root,755)
886 %doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
887 %attr(755,root,root) %{_bindir}/python%{py_ver}-config
888 %attr(755,root,root) %{_bindir}/python%{py_abi}-config
889 %attr(755,root,root) %{_bindir}/python3-config
890 %attr(755,root,root) %{_libdir}/libpython%{py_abi}.so
891 %attr(755,root,root) %{_libdir}/libpython3.so
892 %{py_incdir}/*.h
893 %exclude %{py_incdir}/pyconfig.h
894 %{_pkgconfigdir}/python-%{py_ver}.pc
895
896 %files devel-tools
897 %defattr(644,root,root,755)
898 /etc/shrc.d/python*-devel*
899
900 %attr(755,root,root) %{_bindir}/pygettext%{py_ver}
901
902 %{py_scriptdir}/pdb.py
903 %{py_scriptdir}/profile.py
904 %{py_scriptdir}/pstats.py
905 %{py_scriptdir}/timeit.py
906
907 %files 2to3
908 %attr(755,root,root) %{_bindir}/2to3-%{py_ver}
909 %dir %{py_scriptdir}/lib2to3
910 %{py_scriptdir}/lib2to3/__pycache__
911 %{py_scriptdir}/lib2to3/*.txt
912 %{py_scriptdir}/lib2to3/*.pickle
913 %{py_scriptdir}/lib2to3/*.py
914 %dir %{py_scriptdir}/lib2to3/fixes
915 %{py_scriptdir}/lib2to3/fixes/__pycache__
916 %{py_scriptdir}/lib2to3/fixes/*.py
917 %dir %{py_scriptdir}/lib2to3/pgen2
918 %{py_scriptdir}/lib2to3/pgen2/__pycache__
919 %{py_scriptdir}/lib2to3/pgen2/*.py
920
921 %files static
922 %defattr(644,root,root,755)
923 %{_libdir}/libpython%{py_abi}.a
924
925 %files examples
926 %defattr(644,root,root,755)
927 %{_examplesdir}/%{name}-%{version}
928
929 %if %{with info}
930 %files doc-info
931 %defattr(644,root,root,755)
932 %{_infodir}/*.info*
933 %endif
934
935 %if %{with tkinter}
936 %files tkinter
937 %defattr(644,root,root,755)
938 %dir %{py_scriptdir}/tkinter
939 %{py_scriptdir}/tkinter/__pycache__
940 %{py_scriptdir}/tkinter/*.py
941 %attr(755,root,root) %{py_dyndir}/_tkinter.cpython-*.so
942 %endif
This page took 0.099646 seconds and 2 git commands to generate.