]> git.pld-linux.org Git - packages/python3-tldextract.git/blob - python3-tldextract.spec
up to 3.4.4
[packages/python3-tldextract.git] / python3-tldextract.spec
1 #
2 %define         module          tldextract
3 Summary:        Accurately separate the TLD from the registered domain and subdomains of a URL
4 Name:           python3-%{module}
5 Version:        3.4.4
6 Release:        1
7 License:        BSD
8 Group:          Libraries/Python
9 #Source0Download: https://pypi.org/simple/tldextract/
10 Source0:        https://files.pythonhosted.org/packages/source/t/tldextract/%{module}-%{version}.tar.gz
11 # Source0-md5:  06617f12c12acc534517228d191928ef
12 URL:            https://github.com/john-kurkowski/tldextract/stargazers
13 BuildRequires:  python3
14 BuildRequires:  python3-modules >= 1:3.7
15 BuildRequires:  python3-setuptools
16 BuildRequires:  python3-setuptools_scm
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 Requires:       python3-modules >= 1:3.7
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Accurately separate the TLD from the registered domain and
25 subdomains of a URL, using the Public Suffix List. By default,
26 this includes the public ICANN TLDs and their exceptions. You can
27 optionally support the Public Suffix List's private domains as
28 well.
29
30 %prep
31 %setup -q -n %{module}-%{version}
32
33 %build
34 %py3_build
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38
39 %py3_install
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files -n python3-%{module}
45 %defattr(644,root,root,755)
46 %doc CHANGELOG.md README.md
47 %attr(755,root,root) %{_bindir}/tldextract
48 %{py3_sitescriptdir}/%{module}
49 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
This page took 0.02643 seconds and 3 git commands to generate.