]> git.pld-linux.org Git - packages/python.git/blob - python.spec
- pass devel tools scripts arguments correctly
[packages/python.git] / python.spec
1
2 #
3 # todo:
4 # - fix locale test to use configured locale instead of en_US (or sth.)
5 #
6
7 # Conditional build:
8 %bcond_without tkinter  # disables tkinter module building
9 %bcond_without tests    # disables Python testing
10 #
11 %define py_ver         2.3
12 %define py_prefix      %{_prefix}
13 %define py_libdir      %{py_prefix}/lib/python%{py_ver}
14 %define py_incdir      %{_includedir}/python%{py_ver}
15 %define py_sitedir     %{py_libdir}/site-packages
16 %define py_dyndir      %{py_libdir}/lib-dynload
17 %define py_comp        ./python -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
18 %define py_ocomp       ./python -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
19
20 Summary:        Very high level scripting language with X interface
21 Summary(de):    Very High-Level-Script-Sprache mit X-Oberfläche
22 Summary(es):    Lenguaje script de alto nivel con interface X
23 Summary(fr):    Langage de script de tés haut niveau avec interface X
24 Summary(pl):    Python - jêzyk obiektowy wysokiego poziomu
25 Summary(pt_BR): Linguagem de programação interpretada, orientada a objeto de alto nível
26 Summary(ru):    ñÚÙË ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ ÏÞÅÎØ ×ÙÓÏËÏÇÏ ÕÒÏ×ÎÑ Ó X-ÉÎÔÅÒÆÅÊÓÏÍ
27 Summary(tr):    X arayüzlü, yüksek düzeyli, kabuk yorumlayýcý dili
28 Summary(uk):    íÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÄÕÖÅ ×ÉÓÏËÏÇÏ Ò¦×ÎÑ Ú X-¦ÎÔÅÒÆÅÊÓÏÍ
29 Name:           python
30 Version:        %{py_ver}.3
31 Release:        0.1.c1
32 Epoch:          1
33 License:        PSF
34 Group:          Applications
35 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}c1.tar.bz2
36 # Source0-md5:  51eefdde28f833972126bdae199a23f1
37 Source1:        http://www.python.org/ftp/python/doc/%{version}c1/html-%{version}c1.tar.bz2
38 # Source1-md5:  e5e022497720ae4aa8b169c4c37a0460
39 Patch0:         %{name}-readline.patch
40 Patch1:         %{name}-%{name}path.patch
41 Patch2:         %{name}-default_encoding.patch
42 Patch3:         %{name}-no_ndbm.patch
43 Patch4:         %{name}-ac_fixes.patch
44 URL:            http://www.python.org/
45 BuildRequires:  autoconf
46 BuildRequires:  db-devel >= 4
47 BuildRequires:  gdbm-devel >= 1.8.3
48 BuildRequires:  expat-devel >= 1.95.7
49 BuildRequires:  gmp-devel => 4.0
50 BuildRequires:  ncurses-devel >= 5.2
51 BuildRequires:  openssl-devel >= 0.9.7c
52 BuildRequires:  readline-devel >= 4.2
53 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
54 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
55 BuildRequires:  zlib-devel
56 Requires:       python-libs = %{epoch}:%{version}
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58 Provides:       %{name} = %{py_ver}
59 Obsoletes:      python-xml
60 Obsoletes:      python-intl
61 Obsoletes:      python-curses
62 Obsoletes:      python-gdbm
63 Obsoletes:      python-zlib
64 Obsoletes:      python2
65 Obsoletes:      python2-devel
66
67 %description
68 Python is an interpreted, interactive, object-oriented programming
69 language. It incorporates modules, exceptions, dynamic typing, very
70 high level dynamic data types, and classes. Python combines remarkable
71 power with very clear syntax. It has interfaces to many system calls
72 and libraries, as well as to various window systems, and is extensible
73 in C or C++. It is also usable as an extension language for
74 applications that need a programmable interface. Finally, Python is
75 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
76 MS-DOS, Windows, Windows NT, and OS/2.
77
78 %description -l de
79 Python ist eine interpretierte, interaktive, objektorientierte
80 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
81 Python enthält Module, Klassen, Exceptions, High-Level dynamische
82 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
83 zu vielen Systemaufrufen und Libraries, sowie verschiedene
84 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
85
86 Programmierer können neue built-in-Module für Python in C oder C++
87 schreiben. Python kann auch als Erweiterungssprache für Applikationen
88 benutzt werden, die ein programmierbares Interface brauchen. Dieses
89 Paket enthält die meisten Standard-Python-Module, und Module zum
90 Ansprechen von Tix (Tk-widget set) und RPM.
91
92 %description -l es
93 Python es un lenguaje de scripts interpretado orientado a objetos.
94 Contiene soporte para carga dinámica de objetos, clases, módulos y
95 excepciones.
96
97 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
98 través de código C, tornando Python fácil de usar en ambientes
99 articulares/ personalizados. Este paquete Python incluye la mayoría de
100 los módulos padrón Python, junto con módulos para crear interfaces
101 para el conjunto de componentes Tix para Tk y RPM.
102
103 %description -l fr
104 Python est un langage de script interprété et orienté objet. Il gère
105 le chargement dynamique des objets, les classes, les modules et les
106 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
107 avec du code C est simple, ce qui rend Python facile à utiliser dans
108 des configs personnalisées.
109
110 Ce paquetage Python contient la plupart des modules Python standards,
111 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
112 et RPM.
113
114 %description -l pl
115 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
116 jêzykiem programowania. Jest modularny, obs³uguje wyj±tki, dynamiczne
117 typy, zaawansowane dynamiczne struktury danych i klasy. Python ³±czy w
118 sobie du¿e mo¿liwo¶ci i przejrzyst± sk³adniê. Posiada interfejsy do
119 wielu wywo³añ systemowych i bibliotek, w tym równie¿ do ró¿nych
120 bibliotek okienkowych. Mo¿liwo¶ci jego mo¿na jeszcze rozszerzaæ
121 poprzez odpowiednie modu³y pisane w C lub C++. Python mo¿e byæ równie¿
122 u¿yty jako element aplikacji, którym potrzebny jest interpreter do
123 skryptów. I wreszcie, Python jest wieloplatformowy, dzia³a na wielu
124 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
125 OS/2.
126
127 %description -l pt_BR
128 Python é uma linguagem de scripts interpretada orientada a objetos.
129 Contém suporte para carga dinâmica de objetos, classes, módulos e
130 exceções. Adicionar interfaces para novos sistemas de biblioteca
131 através de código C é simples, tornando Python fácil de usar em
132 ambientes particulares/personalizados.
133
134 Este pacote Python inclui a maioria do módulos padrão Python, junto
135 com módulos para interfaceamento para o conjunto de componentes Tix
136 para Tk e RPM.
137
138 %description -l ru
139 Python - ÜÔÏ ÉÎÔÅÒÐÒÅÔÉÒÕÅÍÙÊ, ÏÂßÅËÔÎÏ-ÏÒÉÅÎÔÉÒÏ×ÁÎÎÙÊ ÑÚÙË
140 ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ. ïΠÐÏÄÄÅÒÖÉ×ÁÅÔ ÄÉÎÁÍÉÞÅÓËÕÀ ÚÁÇÒÕÚËÕ ÏÂßÅËÔÏ×,
141 ËÌÁÓÓÙ, ÍÏÄÕÌÉ É ÏÂÒÁÂÏÔËÕ ÉÓËÌÀÞÉÔÅÌØÎÙÈ ÓÉÔÕÁÃÉÊ (exceptions).
142 ðÒÏÓÔÏÔÁ ÄÏÂÁ×ÌÅÎÉÑ ÉÎÔÅÒÆÅÊÓÏ× Ë ÎÏ×ÙÍ ÓÉÓÔÅÍÎÙÍ ÂÉÂÌÉÏÔÅËÁÍ ÞÅÒÅÚ
143 ËÏÄ ÎÁ ÑÚÙËÅ C ÄÅÌÁÅÔ Python ÈÏÒÏÛÉÍ ×ÙÂÏÒÏÍ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ×
144 ÓÐÅÃÉÁÌØÎÙÈ ËÏÎÆÉÇÕÒÁÃÉÑÈ.
145
146 %description -l tr
147 Python, nesneye yönelik bir kabuk yorumlayýcýdýr. Nesnelerin,
148 sýnýflarýn, modüllerin ve aykýrý durumlarýn dinamik yüklenmelerine
149 destek verir. C koduyla birlikte kullanýmý son derece kolaydýr. Bu
150 paket, standart Python birimlerinin çoðunun yanýsýra Tk ve RPM için
151 arayüz birimlerini de içerir.
152
153 %description -l uk
154 Python - ÃÅ ¦ÎÔÅÒÐÒÅÔÏ×ÁÎÁ, ÏÂ'¤ËÔÎÏ-ÏÒ¦¤ÎÔÏ×ÁÎÁ ÍÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ.
155 ÷¦Î Ð¦ÄÔÒÉÍÕ¤ ÄÉÎÁͦÞÎÕ ÚÁÇÒÕÚËÕ ÏÂ'¤ËÔ¦×, ËÌÁÓÉ, ÍÏÄÕ̦ ÔÁ ÏÂÒÏÂËÕ
156 ×ÉËÌÀÞÎÉÈ ÓÉÔÕÁæʠ(exceptions). ðÒÏÓÔÏÔÁ ÄÏÄÁ×ÁÎÎÑ ¦ÎÔÅÒÆÅÊӦנÄÌÑ
157 ÎÏ×ÉÈ ÓÉÓÔÅÍÎÉȠ¦Â̦ÏÔÅË ÞÅÒÅÚ ËÏÄ ÎÁ ÍÏצ C ÒÏÂÉÔØ Python ÄÏÂÒÉÍ
158 ×ÉÂÏÒÏÍ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎÑ × ÓÐÅæÁÌØÎÉÈ ËÏÎƦÇÕÒÁæÑÈ.
159
160 %package libs
161 Summary:        Python library
162 Summary(pl):    Biblioteka jêzyka Python
163 Group:          Libraries/Python
164 Provides:       %{name}-libs = %{py_ver}
165
166 %description libs
167 Python library.
168
169 %description libs -l pl
170 Biblioteka jêzyka Python.
171
172 %package modules
173 Summary:        Python modules
174 Summary(pl):    Modu³y jêzyka Python
175 Group:          Libraries/Python
176 Provides:       %{name}-modules = %{py_ver}
177 Requires:       %{name} = %{epoch}:%{version}
178 Obsoletes:      python-logging
179 Obsoletes:      python-xmlrpc <= 1.0.1
180
181 %description modules
182 Python modules.
183
184 %description modules -l pl
185 Modu³y jêzyka Python.
186
187 %package -n pydoc
188 Summary:        Python interactive module documentation access support
189 Summary(pl):    Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python
190 Group:          Applications
191 Requires:       %{name}-modules = %{epoch}:%{version}
192 Obsoletes:      python-pydoc
193
194 %description -n pydoc
195 Python interactive module documentation access support.
196
197 %description -n pydoc -l pl
198 Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python.
199
200 %package -n idle
201 Summary:        IDE for Python language
202 Summary(pl):    IDE dla jêzyka Python
203 Group:          Applications
204 Requires:       %{name}-modules = %{epoch}:%{version}
205 Obsoletes:      python-idle
206
207 %description -n idle
208 IDE for Python language.
209
210 %description -n idle -l pl
211 IDE dla jêzyka Python.
212
213 %package devel
214 Summary:        Libraries and header files for building python code
215 Summary(de):    Libraries und Header-Dateien zum Erstellen von Python-Code
216 Summary(es):    Bibliotecas y archivos de inclusión para construir programas en python
217 Summary(fr):    Bibliothèques et en-têtes pour construire du code python
218 Summary(pl):    Pliki nag³ówkowe i biblioteki Pythona
219 Summary(pt_BR): Bibliotecas e arquivos de inclusão para o Python
220 Summary(ru):    âÉÂÌÉÏÔÅËÉ É ÈÅÄÅÒÙ ÄÌÑ ÐÏÓÔÒÏÅÎÉÑ ËÏÄÁ ÎÁ ÑÚÙËÅ Python
221 Summary(tr):    Python ile geliþtirme yapmak için gerekli dosyalar
222 Summary(uk):    â¦Â̦ÏÔÅËÉ ÔÁ ÈÅÄÅÒÉ ÄÌÑ ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÎÁ ÍÏצ Python
223 Group:          Development/Languages/Python
224 Requires:       %{name}-libs = %{epoch}:%{version}
225
226 %description devel
227 The Python interpreter is relatively easy to extend with dynamically
228 loaded extensions and to embed in other programs. This package
229 contains the header files and libraries which are needed to do both of
230 these tasks.
231
232 %description devel -l de
233 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
234 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
235 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
236 die für beide Aufgaben erforderlich sind.
237
238 %description devel -l es
239 El interpretador Python permite incluir con facilidad extensiones
240 cargadas dinámicamente. Python es también fácil de ser empotrado en
241 otros programas. Este paquete contiene los archivos de inclusión y
242 bibliotecas necesarios para estas dos tareas.
243
244 %description devel -l fr
245 L'interpréteur Python est relativement facile à étendre avec des
246 extensions chargées dynamiquement et à insérer dans d'autres
247 programmes. Ce paquetage contient les en-têtes et les bibliothèques
248 nécessaires à ces deux tâches.
249
250 %description devel -l pl
251 Interpreter Pythona jest w miarê ³atwy do rozszerzania przy pomocy
252 dynamicznie ³adowanych rozszerzeñ napisanych w C lub C++ oraz
253 osadzania w innych programach. Ten pakiet zawiera pliki nag³ówkowe i
254 wszystko inne co potrzebne do tych celów.
255
256 %description devel -l pt_BR
257 O interpretador Python permite incluir com facilidade extensões
258 carregadas dinamicamente. Python é também fácil de ser embutido em
259 outros programas. Este pacote contém os arquivos de inclusão e
260 bibliotecas necessários para estas duas tarefas.
261
262 %description devel -l ru
263 éÎÔÅÒÐÒÅÔÁÔÏÒ Python ÏÔÎÏÓÉÔÅÌØÎÏ ÌÅÇËÏ ÒÁÓÛÉÒÑÅÔÓÑ ÐÒÉ ÐÏÍÏÝÉ
264 ÄÉÎÁÍÉÞÅÓËÉ ÚÁÇÒÕÖÁÅÍÙÈ ÒÁÓÛÉÒÅÎÉÊ É ×ÓÔÒÁÉ×ÁÅÔÓÑ × ÄÒÕÇÉÅ ÐÒÏÇÒÁÍÍÙ.
265 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÈÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÏÂÅÉÈ ÜÔÉÈ
266 ÚÁÄÁÞ.
267
268 %description devel -l tr
269 Bu paket, Python ile geliþtirme yapýlabilmesi için gerekli baþlýk
270 dosyalarýný ve kitaplýklarý içerir.
271
272 %description devel -l uk
273 ¶ÎÔÅÒÐÒÅÔÁÔÏÒ Python ×¦ÄÎÏÓÎÏ ÌÅÇËÏ ÒÏÚÛÉÒÀ¤ÔØÓÑ ÚÁ ÄÏÐÏÍÏÇÏÀ
274 ÒÏÚÛÉÒÅÎØ Ú ÄÉÎÁͦÞÎÏÀ ÚÁÇÒÕÚËÏÀ ÔÁ ×ÂÕÄÏ×Õ¤ÔØÓÑ × ¦ÎÛ¦ ÐÒÏÇÒÁÍÉ. ãÅÊ
275 ÐÁËÅԠͦÓÔÉÔØ ÈÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÏÂÏÈ ÃÉÈ ÚÁÄÁÞ.
276
277 %package devel-src
278 Summary:        Python module sources
279 Summary(pl):    Pliki ¼ród³owe modu³ów Pythona
280 Group:          Development/Languages/Python
281 Requires:       %{name}-modules = %{epoch}:%{version}
282
283 %description devel-src
284 Python module sources.
285
286 %description devel-src -l pl
287 Pliki ¼ród³owe modu³ów Pythona.
288
289 %package devel-tools
290 Summary:        Python development tools
291 Summary(pl):    Narzêdzia programistyczne jêzyka Python
292 Group:          Development/Languages/Python
293 Requires:       %{name}-modules = %{epoch}:%{version}
294 Requires:       %{name} = %{epoch}:%{version}
295
296 %description devel-tools
297 Python development tools such as profilers and debugger.
298
299 %description devel-tools -l pl
300 Narzêdzia programistyczne jêzyka Python takie jak profiler oraz debugger.
301
302 %package static
303 Summary:        Static python library
304 Summary(pl):    Statyczna biblioteka Pythona
305 Group:          Development/Languages/Python
306 Provides:       %{name}-static = %{py_ver}
307 Requires:       %{name}-devel = %{epoch}:%{version}
308
309 %description static
310 Static python library.
311
312 %description static -l pl
313 Statyczna biblioteka Pythona.
314
315 %package doc
316 Summary:        Documentation on Python
317 Summary(de):    Dokumentation zu Python
318 Summary(es):    Documentación para Python
319 Summary(fr):    Documentation sur Python
320 Summary(pl):    Dokumentacja do Pythona
321 Summary(pt_BR): Documentação para a linguagem de programação Python
322 Summary(ru):    äÏËÕÍÅÎÔÁÃÉÑ ÐÏ ÑÚÙËÕ Python
323 Summary(tr):    Python belgeleri
324 Summary(uk):    äÏËÕÍÅÎÔÁæѠÐÏ ÍÏצ Python
325 Group:          Documentation
326 Requires:       %{name} = %{epoch}:%{version}
327 Obsoletes:      python-docs
328
329 %description doc
330 This package contains documentation on the Python language and
331 interpretor as a mix of plain ASCII files and LaTeX sources.
332
333 %description doc -l de
334 Dieses Paket enthält Dokumentationen zu Python (Sprache und
335 Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
336
337 %description doc -l es
338 Documentación para Python. Contiene archivos en texto y PostScript.
339
340 %description doc -l fr
341 Ce paquetage contient la documentation sur le langage python et sur
342 son interpréteur sous forme de fichiers ASCII et LaTeX.
343
344 %description doc -l pl
345 Oficjalna dokumentacja do Pythona. Zawiera przyk³adowe programy,
346 narzêdzia i dokumentacjê. Strony podrêcznika man znajduj± siê w
347 g³ównym pakiecie. Ten pakiet nie zawiera ¼róde³ dokumentacji
348 napisanych w LaTeXu, tylko gotowe do wykorzystania pliki
349 postscriptowe i HTML.
350
351 %description doc -l pt_BR
352 O pacote python-doc contém documentação para a linguagem de
353 programação e para o interpretador Python. Fornecida em arquivos texto
354 e Postcript.
355
356 %description doc -l ru
357 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÏËÕÍÅÎÔÁÃÉÀ ÐÏ ÓÏÂÓÔ×ÅÎÎÏ ÑÚÙËÕ Python É ÐÏ
358 ÉÓÐÏÌÎÑÀÝÅÍÕ ÅÇÏ ÉÎÔÅÒÐÒÅÔÁÔÏÒÕ × ×ÉÄÅ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÙÈ ÆÁÊÌÏ× É
359 ÉÓÈÏÄÎÙÈ ÔÅËÓÔÏ× × ÆÏÒÍÁÔÅ LaTeX.
360
361 %description doc -l tr
362 Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyalarý ve
363 LaTeX kaynaklarýnýn bir karýþýmý olan yorumlayýcýyý içerir.
364
365 %description doc -l uk
366 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÄÏËÕÍÅÎÔÁæÀ ÐÏ ×ÌÁÓÎÅ ÍÏצ Python ÔÁ ÐÏ ×ÉËÏÎÕÀÞÏÍÕ
367 §§ ¦ÎÔÅÒÐÒÅÔÁÔÏÒÕ Õ ×ÉÇÌÑĦ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÉÈ ÆÁÊ̦נÔÁ ×ÉȦÄÎÉÈ
368 ÔÅËÓԦנՠÆÏÒÍÁÔ¦ LaTeX.
369
370 %package tkinter
371 Summary:        Standard Python interface to the Tk GUI toolkit
372 Summary(de):    Grafischer Oberfläche für Python
373 Summary(es):    Interface GUI para Phyton
374 Summary(fr):    Interface graphique pour python
375 Summary(pl):    Standardowy interfejs Pythona do biblioteki Tk
376 Summary(pt_BR): Interface GUI para Phyton
377 Summary(tr):    Python için grafik kullanýcý arayüzü
378 Group:          Libraries/Python
379 Requires:       %{name}-modules = %{epoch}:%{version}
380 Requires:       tcl >= 8.0.3
381 Requires:       tk  >= 8.0.3
382 Requires:       tix >= 4.1.0.6
383 Obsoletes:      tkinter
384
385 %description tkinter
386 Standard Python interface to the Tk GUI toolkit.
387
388 %description tkinter -l de
389 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
390 vielen Konfigurations-Tools genutzt.
391
392 %description tkinter -l es
393 Una interface gráfica para Python, basada en Tcl/Tk, y usada por
394 muchas herramientas de configuración.
395
396 %description tkinter -l fr
397 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
398 beaucoup des outils de configuration.
399
400 %description tkinter -l pl
401 Standardowy interfejs Pythona do biblioteki Tk.
402
403 %description tkinter -l pt_BR
404 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
405 muitas ferramentas de configuração.
406
407 %description tkinter -l ru
408 çÒÁÆÉÞÅÓËÉÊ ÉÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÓÔÒÏÅÎÎÙÊ ÎÁ Tcl/Tk.
409
410 %description tkinter -l tr
411 Python için Tcl/Tk'ye dayalý ve pek çok ayarlama aracý tarafýndan
412 kullanýlan grafik bir arayüzdür.
413
414 %description tkinter -l uk
415 çÒÁƦÞÎÉÊ ¦ÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÂÕÄÏ×ÁÎÉÊ ÎÁ Tcl/Tk.
416
417 %package old
418 Summary:        Depreciated Python modules
419 Summary(pl):    Nieaktualne modu³y jêzyka Python
420 Group:          Libraries/Python
421 Requires:       %{name}-modules = %{epoch}:%{version}
422
423 %description old
424 Install this package when one of your program written in Python is old
425 as Miss Universum of 1918, who only you want to see... ooops, which
426 only you want to run.
427
428 %description old -l pl
429 Zainstaluj ten pakiet, wtedy kiedy jeden z Twoich programów napisanych
430 w jêzyku Python jest tak stary jak Miss Universum z roku 1918, któr±
431 tylko ty chcesz zobaczyæ... przepraszam, który tylko ty chcesz
432 uruchomiæ.
433
434 %package examples
435 Summary:        Example programs in Python
436 Summary(pl):    Przyk³adowe programy w Pythonie
437 Group:          Development/Languages/Python
438 Requires:       %{name}-devel = %{epoch}:%{version}
439 Obsoletes:      python-tools
440
441 %description examples
442 Example programs in Python.
443
444 %description examples -l pl
445 Przyk³adowe programy w Pythonie.
446
447 %prep
448 %setup -q -n Python-%{version}c1
449 %patch0 -p1
450 %patch1 -p1
451 %patch2 -p1
452 %patch3 -p1
453 %patch4 -p1
454
455 tar -xf %{SOURCE1} --use=bzip2
456
457 %build
458 %{__autoconf}
459
460 CPPFLAGS="-I%{_includedir}/ncurses"; export CPPFLAGS
461 %configure \
462         --with-threads \
463         --enable-unicode=ucs4 \
464         --enable-shared
465
466 %{__make} OPT="%{rpmcflags}"
467
468 LC_ALL=C
469 export LC_ALL
470 %{?with_tests:%{__make} test}
471
472 %install
473 rm -rf $RPM_BUILD_ROOT
474 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} $RPM_BUILD_ROOT%{_mandir}/man1
475
476 %{__make} install \
477         DESTDIR=$RPM_BUILD_ROOT
478
479 install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
480
481 install libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}
482 ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
483 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython.so
484 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{py_ver}.so
485
486 rm -f $RPM_BUILD_ROOT%{_bindir}/python%{py_ver}
487
488 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
489 cp -ar Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
490
491 # create several useful scripts, such as timeit.py, profile.py, pdb.py
492 for script in timeit.py profile.py pdb.py pstats.py; do
493     cat <<END > $RPM_BUILD_ROOT%{_bindir}/$script
494 #!/bin/sh
495 exec python %{py_libdir}/${script}c "\$@"
496 END
497 done
498
499 %clean
500 rm -rf $RPM_BUILD_ROOT
501
502 %post   libs -p /sbin/ldconfig
503 %postun libs -p /sbin/ldconfig
504
505 %files
506 %defattr(644,root,root,755)
507 %attr(755,root,root) %{_bindir}/python
508 %{_mandir}/man1/*
509
510 # readline support for python binary
511 %attr(755,root,root) %{py_dyndir}/readline.so
512
513 %files modules
514 %defattr(644,root,root,755)
515 %exclude %{py_libdir}/UserDict.py[co]
516 %exclude %{py_libdir}/codecs.py[co]
517 %exclude %{py_libdir}/copy_reg.py[co]
518 %exclude %{py_libdir}/locale.py[co]
519 %exclude %{py_libdir}/posixpath.py[co]
520 %exclude %{py_libdir}/pdb.py[co]
521 %exclude %{py_libdir}/profile.py[co]
522 %exclude %{py_libdir}/pstats.py[co]
523 %exclude %{py_libdir}/pydoc.py[co]
524 %exclude %{py_libdir}/site.py[co]
525 %exclude %{py_libdir}/stat.py[co]
526 %exclude %{py_libdir}/timeit.py[co]
527 %exclude %{py_libdir}/os.py[co]
528 %exclude %{py_libdir}/encodings/*.py[co]
529
530 %{py_libdir}/*.py[co]
531
532 #
533 # list .so modules to be sure that all of them are built
534 #
535
536 # three modules below does not work on 64-bit architectures
537 # see Python README file for explanation
538 %ifnarch alpha sparc64 ppc64
539 %attr(755,root,root) %{py_dyndir}/audioop.so
540 %attr(755,root,root) %{py_dyndir}/rgbimg.so
541 %attr(755,root,root) %{py_dyndir}/imageop.so
542 # sizeof(long) != sizeof(int), so dl module will not be built on 64-bit
543 # platforms
544 %attr(755,root,root) %{py_dyndir}/dl.so
545 %endif
546
547 %attr(755,root,root) %{py_dyndir}/_bsddb.so
548 %attr(755,root,root) %{py_dyndir}/_csv.so
549 %attr(755,root,root) %{py_dyndir}/_curses.so
550 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
551 %attr(755,root,root) %{py_dyndir}/_locale.so
552 %attr(755,root,root) %{py_dyndir}/_random.so
553 %attr(755,root,root) %{py_dyndir}/_socket.so
554 %attr(755,root,root) %{py_dyndir}/_ssl.so
555 %attr(755,root,root) %{py_dyndir}/_testcapi.so
556 %attr(755,root,root) %{py_dyndir}/_weakref.so
557 %attr(755,root,root) %{py_dyndir}/array.so
558 %attr(755,root,root) %{py_dyndir}/binascii.so
559 %attr(755,root,root) %{py_dyndir}/bz2.so
560 %attr(755,root,root) %{py_dyndir}/cPickle.so
561 %attr(755,root,root) %{py_dyndir}/cStringIO.so
562 %attr(755,root,root) %{py_dyndir}/cmath.so
563 %attr(755,root,root) %{py_dyndir}/crypt.so
564 %attr(755,root,root) %{py_dyndir}/datetime.so
565 %attr(755,root,root) %{py_dyndir}/dbm.so
566 %attr(755,root,root) %{py_dyndir}/fcntl.so
567 %attr(755,root,root) %{py_dyndir}/gdbm.so
568 %attr(755,root,root) %{py_dyndir}/grp.so
569 %attr(755,root,root) %{py_dyndir}/itertools.so
570 %attr(755,root,root) %{py_dyndir}/linuxaudiodev.so
571 %attr(755,root,root) %{py_dyndir}/math.so
572 %attr(755,root,root) %{py_dyndir}/md5.so
573 %attr(755,root,root) %{py_dyndir}/mmap.so
574 %attr(755,root,root) %{py_dyndir}/mpz.so
575 %attr(755,root,root) %{py_dyndir}/nis.so
576 %attr(755,root,root) %{py_dyndir}/operator.so
577 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
578 %attr(755,root,root) %{py_dyndir}/parser.so
579 %attr(755,root,root) %{py_dyndir}/pcre.so
580 %attr(755,root,root) %{py_dyndir}/pwd.so
581 %attr(755,root,root) %{py_dyndir}/pyexpat.so
582 %attr(755,root,root) %{py_dyndir}/regex.so
583 %attr(755,root,root) %{py_dyndir}/resource.so
584 %attr(755,root,root) %{py_dyndir}/rotor.so
585 %attr(755,root,root) %{py_dyndir}/select.so
586 %attr(755,root,root) %{py_dyndir}/sha.so
587 %attr(755,root,root) %{py_dyndir}/strop.so
588 %attr(755,root,root) %{py_dyndir}/syslog.so
589 %attr(755,root,root) %{py_dyndir}/termios.so
590 %attr(755,root,root) %{py_dyndir}/time.so
591 %attr(755,root,root) %{py_dyndir}/timing.so
592 %attr(755,root,root) %{py_dyndir}/unicodedata.so
593 %attr(755,root,root) %{py_dyndir}/xreadlines.so
594 %attr(755,root,root) %{py_dyndir}/zlib.so
595
596 %dir %{py_libdir}/plat-*
597 %attr(755,root,root) %{py_libdir}/plat-*/regen
598 %{py_libdir}/plat-*/*.py[co]
599
600 %dir %{py_libdir}/bsddb
601 %{py_libdir}/bsddb/*.py[co]
602
603 %dir %{py_libdir}/compiler
604 %{py_libdir}/compiler/*.py[co]
605
606 %dir %{py_libdir}/curses
607 %{py_libdir}/curses/*.py[co]
608
609 %dir %{py_libdir}/distutils
610 %{py_libdir}/distutils/*.py[co]
611
612 %dir %{py_libdir}/distutils/command
613 %{py_libdir}/distutils/command/*.py[co]
614
615 %dir %{py_libdir}/email
616 %{py_libdir}/email/*.py[co]
617
618 %dir %{py_libdir}/logging
619 %{py_libdir}/logging/*.py[co]
620
621 %dir %{py_libdir}/xml
622 %{py_libdir}/xml/*.py[co]
623
624 %dir %{py_libdir}/xml/parsers
625 %{py_libdir}/xml/parsers/*.py[co]
626
627 %dir %{py_libdir}/xml/sax
628 %{py_libdir}/xml/sax/*.py[co]
629
630 %dir %{py_libdir}/xml/dom
631 %{py_libdir}/xml/dom/*.py[co]
632
633 %files libs
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{_libdir}/libpython*so.*
636
637 %dir %{py_dyndir}
638 %dir %{py_libdir}
639 %dir %{py_sitedir}
640
641 # required shared modules by python library
642 %attr(755,root,root) %{py_dyndir}/struct.so
643
644 # required modules by python library
645 %{py_libdir}/UserDict.py[co]
646 %{py_libdir}/codecs.py[co]
647 %{py_libdir}/copy_reg.py[co]
648 %{py_libdir}/locale.py[co]
649 %{py_libdir}/posixpath.py[co]
650 %{py_libdir}/site.py[co]
651 %{py_libdir}/stat.py[co]
652 %{py_libdir}/os.py[co]
653
654 # required encodings by python library
655 %dir %{py_libdir}/encodings
656 %{py_libdir}/encodings/*.py[co]
657
658 %files -n pydoc
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_bindir}/pydoc
661 %{py_libdir}/pydoc.py[co]
662
663 %files -n idle
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{_bindir}/idle
666 %dir %{py_libdir}/idlelib
667 %dir %{py_libdir}/idlelib/Icons
668 %{py_libdir}/idlelib/*.py[co]
669 %{py_libdir}/idlelib/Icons/*
670 %{py_libdir}/idlelib/*.def
671
672 %files devel
673 %defattr(644,root,root,755)
674 %doc Misc/{ACKS,NEWS,README}
675 %attr(755,root,root) %{_libdir}/lib*.so
676 %dir %{py_incdir}
677 %{py_incdir}/*.h
678
679 %dir %{py_libdir}/config
680 %attr(755,root,root) %{py_libdir}/config/makesetup
681 %attr(755,root,root) %{py_libdir}/config/install-sh
682 %{py_libdir}/config/Makefile
683 %{py_libdir}/config/Makefile.pre.in
684 %{py_libdir}/config/Setup
685 %{py_libdir}/config/Setup.config
686 %{py_libdir}/config/Setup.local
687 %{py_libdir}/config/config.c
688 %{py_libdir}/config/config.c.in
689 %{py_libdir}/config/python.o
690
691 %files devel-src
692 %defattr(644,root,root,755)
693 %attr(-,root,root) %{py_libdir}/*.py
694 %{py_libdir}/plat-*/*.py
695 %{py_libdir}/bsddb/*.py
696 %{py_libdir}/compiler/*.py
697 %{py_libdir}/curses/*.py
698 %{py_libdir}/distutils/*.py
699 %{py_libdir}/distutils/command/*.py
700 %{py_libdir}/email/*.py
701 %{py_libdir}/hotshot/*.py
702 %{py_libdir}/logging/*.py
703 %{py_libdir}/xml/*.py
704 %{py_libdir}/xml/parsers/*.py
705 %{py_libdir}/xml/sax/*.py
706 %{py_libdir}/xml/dom/*.py
707 %{py_libdir}/encodings/*.py
708 %{py_libdir}/idlelib/*.py
709
710 %files devel-tools
711 %defattr(644,root,root,755)
712 %doc Lib/profile.doc Lib/pdb.doc
713 %attr(755,root,root) %{_bindir}/timeit.py
714 %attr(755,root,root) %{_bindir}/profile.py
715 %attr(755,root,root) %{_bindir}/pdb.py
716 %attr(755,root,root) %{_bindir}/pstats.py
717
718 %attr(755,root,root) %{py_dyndir}/_hotshot.so
719 %dir %{py_libdir}/hotshot
720 %{py_libdir}/hotshot/*.py[co]
721 %{py_libdir}/pdb.py[co]
722 %{py_libdir}/profile.py[co]
723 %{py_libdir}/pstats.py[co]
724 %{py_libdir}/timeit.py[co]
725
726 %files static
727 %defattr(644,root,root,755)
728 %{_libdir}/lib*.a
729
730 %files examples
731 %defattr(644,root,root,755)
732 %{_examplesdir}/%{name}-%{version}
733
734 %files doc
735 %defattr(644,root,root,755)
736 %doc Python-Docs-%{version}c1/*
737 %dir %{py_libdir}/test
738 %attr(-,root,root) %{py_libdir}/test/*
739 %attr(-,root,root) %{py_libdir}/email/test/*
740 %attr(-,root,root) %{py_libdir}/bsddb/test/*
741
742 %if %{with tkinter}
743 %files tkinter
744 %defattr(644,root,root,755)
745 %{py_libdir}/lib-tk
746 %attr(755,root,root) %{py_dyndir}/_tkinter.so
747 %endif
748
749 %files old
750 %defattr(644,root,root,755)
751 %dir %{py_libdir}/lib-old
752 %{py_libdir}/lib-old/*.py[co]
This page took 0.089991 seconds and 4 git commands to generate.