]> git.pld-linux.org Git - packages/python.git/blob - python.spec
- rebuild with fixed path in devel subpackage
[packages/python.git] / python.spec
1 #
2 # TODO
3 # - test_distutils fails for unknown reason: (does it still do with new lib64 patch?)
4 #   AssertionError: '/tmp/tmpaomC0l/installation/share/python' != '/tmp/tmpaomC0l/installation/lib/python'
5 # - change searchpath order so /usr/lib* is before /usr/share
6 # - kill lib-tk from searchpath
7 # - kill BR: file requirement from lib64 patch
8 #
9 # Conditional build:
10 %bcond_without  info                    # don't build info pages (requires emacs)
11 %bcond_without  tkinter                 # disables tkinter module building
12 %bcond_without  tests                   # disables Python testing
13 %bcond_with     verbose_tests           # runs tests in verbose mode
14 #
15 # tests which will not work on 64-bit platforms
16 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
17 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
18 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
19 # tests which fail because of some unknown/unresolved reason (this list should be empty)
20 %define         broken_tests test_anydbm test_bsddb test_re test_shelve test_whichdb test_zipimport test_distutils
21
22 %define beta            c1
23
24 %define py_ver          2.5
25 %define py_prefix       %{_prefix}
26 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
27 %define py_incdir       %{_includedir}/python%{py_ver}
28 %define py_sitedir      %{py_libdir}/site-packages
29 %define py_dyndir       %{py_libdir}/lib-dynload
30
31 Summary:        Very high level scripting language with X interface
32 Summary(es):    Lenguaje script de alto nivel con interfaz X
33 Summary(fr):    Langage de script de très haut niveau avec interface X
34 Summary(pl):    Python - jêzyk obiektowy wysokiego poziomu
35 Summary(pt_BR): Linguagem de programação interpretada de alto nível
36 Summary(ru):    ñÚÙË ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ ÏÞÅÎØ ×ÙÓÏËÏÇÏ ÕÒÏ×ÎÑ Ó X-ÉÎÔÅÒÆÅÊÓÏÍ
37 Summary(tr):    X arayüzlü, yüksek düzeyli, kabuk yorumlayýcý dili
38 Summary(uk):    íÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÄÕÖÅ ×ÉÓÏËÏÇÏ Ò¦×ÎÑ Ú X-¦ÎÔÅÒÆÅÊÓÏÍ
39 Name:           python
40 Version:        %{py_ver}
41 Release:        0.%{beta}.2
42 Epoch:          1
43 License:        PSF
44 Group:          Applications
45 Source0:        http://www.python.org/ftp/python/%{py_ver}/Python-%{version}%{beta}.tar.bz2
46 # Source0-md5:  1e8a7a7c6fe14003e325c14b335f3d6c
47 Source1:        http://www.python.org/ftp/python/doc/%{version}%{beta}/html-%{version}%{beta}.tar.bz2
48 # Source1-md5:  8e2f02780725c87957860354e611e4cf
49 Patch0:         %{name}-readline.patch                                                                                                  
50 Patch1:         %{name}-%{name}path.patch                                                                                               
51 Patch2:         %{name}-no_ndbm.patch                                                                                                   
52 Patch3:         %{name}-ac_fixes.patch                                                                                                  
53 Patch4:         %{name}-noarch_to_datadir.patch                                                                                         
54 Patch5:         %{name}-lib64.patch                                                                                                     
55 Patch6:         %{name}-doc_path.patch                                                                                                  
56 Patch7:         %{name}-info.patch     
57 # probably no longer required, can't verify
58 Patch8:         %{name}-sparc_fix.patch     
59 URL:            http://www.python.org/
60 BuildRequires:  autoconf
61 BuildRequires:  bzip2-devel
62 BuildRequires:  db-devel >= 4
63 %{?with_info:BuildRequires:     emacs >= 21}
64 BuildRequires:  expat-devel >= 1:1.95.7
65 BuildRequires:  file
66 BuildRequires:  gdbm-devel >= 1.8.3
67 BuildRequires:  gmp-devel >= 4.0
68 BuildRequires:  libstdc++-devel
69 BuildRequires:  ncurses-ext-devel >= 5.2
70 BuildRequires:  openssl-devel >= 0.9.7d
71 BuildRequires:  readline-devel >= 5.0
72 BuildRequires:  rpm-pythonprov
73 BuildRequires:  sed >= 4.0
74 BuildRequires:  sqlite3-devel >= 3.3.5
75 %{?with_info:BuildRequires:     tetex-makeindex}
76 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
77 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
78 BuildRequires:  zlib-devel
79 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
80 Obsoletes:      python-curses
81 Obsoletes:      python-gdbm
82 Obsoletes:      python-intl
83 Obsoletes:      python-xml
84 Obsoletes:      python-zlib
85 Obsoletes:      python2
86 Obsoletes:      python2-devel
87 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89 %if %{with verbose_tests}
90 %define test_flags -v -l -x
91 %else
92 %define test_flags -l -x
93 %endif
94
95 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
96 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
97 %else
98 %define test_list %{nobuilder_tests} %{broken_tests}
99 %endif
100
101 %description
102 Python is an interpreted, interactive, object-oriented programming
103 language. It incorporates modules, exceptions, dynamic typing, very
104 high level dynamic data types, and classes. Python combines remarkable
105 power with very clear syntax. It has interfaces to many system calls
106 and libraries, as well as to various window systems, and is extensible
107 in C or C++. It is also usable as an extension language for
108 applications that need a programmable interface. Finally, Python is
109 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
110 MS-DOS, Windows, Windows NT, and OS/2.
111
112 This package contains the Python binary.
113
114 %description -l de
115 Python ist eine interpretierte, interaktive, objektorientierte
116 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
117 Python enthält Module, Klassen, Exceptions, High-Level dynamische
118 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
119 zu vielen Systemaufrufen und Libraries, sowie verschiedene
120 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
121
122 Programmierer können neue built-in-Module für Python in C oder C++
123 schreiben. Python kann auch als Erweiterungssprache für Applikationen
124 benutzt werden, die ein programmierbares Interface brauchen. Dieses
125 Paket enthält die meisten Standard-Python-Module, und Module zum
126 Ansprechen von Tix (Tk-widget set) und RPM.
127
128 %description -l es
129 Python es un lenguaje de scripts interpretado orientado a objetos.
130 Contiene soporte para carga dinámica de objetos, clases, módulos y
131 excepciones.
132
133 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
134 través de código C, tornando Python fácil de usar en ambientes
135 particulares/personalizados. Este paquete Python incluye la mayoría de
136 los módulos padrón Python, junto con módulos para crear interfaces
137 para el conjunto de componentes Tix para Tk y RPM.
138
139 %description -l fr
140 Python est un langage de script interprété et orienté objet. Il gère
141 le chargement dynamique des objets, les classes, les modules et les
142 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
143 avec du code C est simple, ce qui rend Python facile à utiliser dans
144 des configs personnalisées.
145
146 Ce paquetage Python contient la plupart des modules Python standards,
147 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
148 et RPM.
149
150 %description -l pl
151 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
152 jêzykiem programowania. Jest modularny, obs³uguje wyj±tki, dynamiczne
153 typy, zaawansowane dynamiczne struktury danych i klasy. Python ³±czy w
154 sobie du¿e mo¿liwo¶ci i przejrzyst± sk³adniê. Posiada interfejsy do
155 wielu wywo³añ systemowych i bibliotek, w tym równie¿ do ró¿nych
156 bibliotek okienkowych. Mo¿liwo¶ci jego mo¿na jeszcze rozszerzaæ
157 poprzez odpowiednie modu³y pisane w C lub C++. Python mo¿e byæ równie¿
158 u¿yty jako element aplikacji, którym potrzebny jest interpreter do
159 skryptów. I wreszcie, Python jest wieloplatformowy, dzia³a na wielu
160 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
161 OS/2.
162
163 Ten pakiet zawiera binarkê Pythona.
164
165 %description -l pt_BR
166 Python é uma linguagem de scripts interpretada orientada a objetos.
167 Contém suporte para carga dinâmica de objetos, classes, módulos e
168 exceções. Adicionar interfaces para novos sistemas de biblioteca
169 através de código C é simples, tornando Python fácil de usar em
170 ambientes particulares/personalizados.
171
172 Este pacote Python inclui a maioria do módulos padrão Python, junto
173 com módulos para interfaceamento para o conjunto de componentes Tix
174 para Tk e RPM.
175
176 %description -l ru
177 Python - ÜÔÏ ÉÎÔÅÒÐÒÅÔÉÒÕÅÍÙÊ, ÏÂßÅËÔÎÏ-ÏÒÉÅÎÔÉÒÏ×ÁÎÎÙÊ ÑÚÙË
178 ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ. ïΠÐÏÄÄÅÒÖÉ×ÁÅÔ ÄÉÎÁÍÉÞÅÓËÕÀ ÚÁÇÒÕÚËÕ ÏÂßÅËÔÏ×,
179 ËÌÁÓÓÙ, ÍÏÄÕÌÉ É ÏÂÒÁÂÏÔËÕ ÉÓËÌÀÞÉÔÅÌØÎÙÈ ÓÉÔÕÁÃÉÊ (exceptions).
180 ðÒÏÓÔÏÔÁ ÄÏÂÁ×ÌÅÎÉÑ ÉÎÔÅÒÆÅÊÓÏ× Ë ÎÏ×ÙÍ ÓÉÓÔÅÍÎÙÍ ÂÉÂÌÉÏÔÅËÁÍ ÞÅÒÅÚ
181 ËÏÄ ÎÁ ÑÚÙËÅ C ÄÅÌÁÅÔ Python ÈÏÒÏÛÉÍ ×ÙÂÏÒÏÍ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ×
182 ÓÐÅÃÉÁÌØÎÙÈ ËÏÎÆÉÇÕÒÁÃÉÑÈ.
183
184 %description -l tr
185 Python, nesneye yönelik bir kabuk yorumlayýcýdýr. Nesnelerin,
186 sýnýflarýn, modüllerin ve aykýrý durumlarýn dinamik yüklenmelerine
187 destek verir. C koduyla birlikte kullanýmý son derece kolaydýr. Bu
188 paket, standart Python birimlerinin çoðunun yanýsýra Tk ve RPM için
189 arayüz birimlerini de içerir.
190
191 %description -l uk
192 Python - ÃÅ ¦ÎÔÅÒÐÒÅÔÏ×ÁÎÁ, ÏÂ'¤ËÔÎÏ-ÏÒ¦¤ÎÔÏ×ÁÎÁ ÍÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ.
193 ÷¦Î Ð¦ÄÔÒÉÍÕ¤ ÄÉÎÁͦÞÎÕ ÚÁÇÒÕÚËÕ ÏÂ'¤ËÔ¦×, ËÌÁÓÉ, ÍÏÄÕ̦ ÔÁ ÏÂÒÏÂËÕ
194 ×ÉËÌÀÞÎÉÈ ÓÉÔÕÁæʠ(exceptions). ðÒÏÓÔÏÔÁ ÄÏÄÁ×ÁÎÎÑ ¦ÎÔÅÒÆÅÊӦנÄÌÑ
195 ÎÏ×ÉÈ ÓÉÓÔÅÍÎÉȠ¦Â̦ÏÔÅË ÞÅÒÅÚ ËÏÄ ÎÁ ÍÏצ C ÒÏÂÉÔØ Python ÄÏÂÒÉÍ
196 ×ÉÂÏÒÏÍ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎÑ × ÓÐÅæÁÌØÎÉÈ ËÏÎƦÇÕÒÁæÑÈ.
197
198 %package libs
199 Summary:        Python library
200 Summary(pl):    Biblioteka jêzyka Python
201 Group:          Libraries/Python
202 # broken detection in rpm/pythondeps.sh
203 Provides:       python(abi) = %{py_ver}
204 # for compatibility with existing Ac packages
205 Provides:       python(bytecode) = %{py_ver}
206
207 %description libs
208 Python shared library and very essental modules for Python binary.
209
210 %description libs -l pl
211 Biblioteka wspó³dzielona jêzyka Python oraz bardzo podstawowe modu³y
212 dla Pythona.
213
214 %package modules
215 Summary:        Python modules
216 Summary(pl):    Modu³y jêzyka Python
217 Group:          Libraries/Python
218 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
219 Obsoletes:      python-ctypes
220 Obsoletes:      python-logging
221 Obsoletes:      python-old
222 Obsoletes:      python-optik
223 Obsoletes:      python-xmlrpc <= 1.0.1
224
225 %description modules
226 Python officially distributed modules.
227
228 %description modules -l pl
229 Oficjalnie rozprowadzane modu³y jêzyka Python.
230
231 %package -n pydoc
232 Summary:        Python interactive module documentation access support
233 Summary(pl):    Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python
234 Group:          Applications
235 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
236 Obsoletes:      python-pydoc
237
238 %description -n pydoc
239 Python interactive module documentation access support.
240
241 %description -n pydoc -l pl
242 Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python.
243
244 %package -n idle
245 Summary:        IDE for Python language
246 Summary(pl):    IDE dla jêzyka Python
247 Group:          Applications
248 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
249 Obsoletes:      python-idle
250
251 %description -n idle
252 IDE for Python language.
253
254 %description -n idle -l pl
255 IDE dla jêzyka Python.
256
257 %package devel
258 Summary:        Libraries and header files for building python code
259 Summary(de):    Libraries und Header-Dateien zum Erstellen von Python-Code
260 Summary(es):    Bibliotecas y archivos de inclusión para construir programas en python
261 Summary(fr):    Bibliothèques et en-têtes pour construire du code python
262 Summary(pl):    Pliki nag³ówkowe i biblioteki Pythona
263 Summary(pt_BR): Bibliotecas e arquivos de inclusão para o Python
264 Summary(ru):    âÉÂÌÉÏÔÅËÉ É ÈÅÄÅÒÙ ÄÌÑ ÐÏÓÔÒÏÅÎÉÑ ËÏÄÁ ÎÁ ÑÚÙËÅ Python
265 Summary(tr):    Python ile geliþtirme yapmak için gerekli dosyalar
266 Summary(uk):    â¦Â̦ÏÔÅËÉ ÔÁ ÈÅÄÅÒÉ ÄÌÑ ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÎÁ ÍÏצ Python
267 Group:          Development/Languages/Python
268 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
269
270 %description devel
271 The Python interpreter is relatively easy to extend with dynamically
272 loaded extensions and to embed in other programs. This package
273 contains the header files and libraries which are needed to do both of
274 these tasks.
275
276 %description devel -l de
277 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
278 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
279 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
280 die für beide Aufgaben erforderlich sind.
281
282 %description devel -l es
283 El interpretador Python permite incluir con facilidad extensiones
284 cargadas dinámicamente. Python es también fácil de ser empotrado en
285 otros programas. Este paquete contiene los archivos de inclusión y
286 bibliotecas necesarios para estas dos tareas.
287
288 %description devel -l fr
289 L'interpréteur Python est relativement facile à étendre avec des
290 extensions chargées dynamiquement et à insérer dans d'autres
291 programmes. Ce paquetage contient les en-têtes et les bibliothèques
292 nécessaires à ces deux tâches.
293
294 %description devel -l pl
295 Interpreter Pythona jest w miarê ³atwy do rozszerzania przy pomocy
296 dynamicznie ³adowanych rozszerzeñ napisanych w C lub C++ oraz
297 osadzania w innych programach. Ten pakiet zawiera pliki nag³ówkowe i
298 wszystko inne co potrzebne do tych celów.
299
300 %description devel -l pt_BR
301 O interpretador Python permite incluir com facilidade extensões
302 carregadas dinamicamente. Python é também fácil de ser embutido em
303 outros programas. Este pacote contém os arquivos de inclusão e
304 bibliotecas necessários para estas duas tarefas.
305
306 %description devel -l ru
307 éÎÔÅÒÐÒÅÔÁÔÏÒ Python ÏÔÎÏÓÉÔÅÌØÎÏ ÌÅÇËÏ ÒÁÓÛÉÒÑÅÔÓÑ ÐÒÉ ÐÏÍÏÝÉ
308 ÄÉÎÁÍÉÞÅÓËÉ ÚÁÇÒÕÖÁÅÍÙÈ ÒÁÓÛÉÒÅÎÉÊ É ×ÓÔÒÁÉ×ÁÅÔÓÑ × ÄÒÕÇÉÅ ÐÒÏÇÒÁÍÍÙ.
309 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÈÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÏÂÅÉÈ ÜÔÉÈ
310 ÚÁÄÁÞ.
311
312 %description devel -l tr
313 Bu paket, Python ile geliþtirme yapýlabilmesi için gerekli baþlýk
314 dosyalarýný ve kitaplýklarý içerir.
315
316 %description devel -l uk
317 ¶ÎÔÅÒÐÒÅÔÁÔÏÒ Python ×¦ÄÎÏÓÎÏ ÌÅÇËÏ ÒÏÚÛÉÒÀ¤ÔØÓÑ ÚÁ ÄÏÐÏÍÏÇÏÀ
318 ÒÏÚÛÉÒÅÎØ Ú ÄÉÎÁͦÞÎÏÀ ÚÁÇÒÕÚËÏÀ ÔÁ ×ÂÕÄÏ×Õ¤ÔØÓÑ × ¦ÎÛ¦ ÐÒÏÇÒÁÍÉ. ãÅÊ
319 ÐÁËÅԠͦÓÔÉÔØ ÈÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÏÂÏÈ ÃÉÈ ÚÁÄÁÞ.
320
321 %package devel-src
322 Summary:        Python module sources
323 Summary(pl):    Pliki ¼ród³owe modu³ów Pythona
324 Group:          Development/Languages/Python
325 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
326
327 %description devel-src
328 Python module sources.
329
330 %description devel-src -l pl
331 Pliki ¼ród³owe modu³ów Pythona.
332
333 %package devel-tools
334 Summary:        Python development tools
335 Summary(pl):    Narzêdzia programistyczne jêzyka Python
336 Group:          Development/Languages/Python
337 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
338
339 %description devel-tools
340 Python development tools such as profilers and debugger.
341
342 %description devel-tools -l pl
343 Narzêdzia programistyczne jêzyka Python takie jak profiler oraz
344 debugger.
345
346 %package static
347 Summary:        Static python library
348 Summary(pl):    Statyczna biblioteka Pythona
349 Group:          Development/Languages/Python
350 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
351
352 %description static
353 Static python library.
354
355 %description static -l pl
356 Statyczna biblioteka Pythona.
357
358 %package doc
359 Summary:        Documentation on Python
360 Summary(de):    Dokumentation zu Python
361 Summary(es):    Documentación para Python
362 Summary(fr):    Documentation sur Python
363 Summary(pl):    Dokumentacja do Pythona
364 Summary(pt_BR): Documentação para a linguagem de programação Python
365 Summary(ru):    äÏËÕÍÅÎÔÁÃÉÑ ÐÏ ÑÚÙËÕ Python
366 Summary(tr):    Python belgeleri
367 Summary(uk):    äÏËÕÍÅÎÔÁæѠÐÏ ÍÏצ Python
368 Group:          Documentation
369 Obsoletes:      python-docs
370
371 %description doc
372 This package contains documentation on the Python language and
373 interpretor as a mix of plain ASCII files and LaTeX sources.
374
375 %description doc -l de
376 Dieses Paket enthält Dokumentationen zu Python (Sprache und
377 Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
378
379 %description doc -l es
380 Documentación para Python. Contiene archivos en texto y PostScript.
381
382 %description doc -l fr
383 Ce paquetage contient la documentation sur le langage python et sur
384 son interpréteur sous forme de fichiers ASCII et LaTeX.
385
386 %description doc -l pl
387 Oficjalna dokumentacja do Pythona. Zawiera przyk³adowe programy,
388 narzêdzia i dokumentacjê. Strony podrêcznika man znajduj± siê w
389 g³ównym pakiecie. Ten pakiet nie zawiera ¼róde³ dokumentacji
390 napisanych w LaTeXu, tylko gotowe do wykorzystania pliki postscriptowe
391 i HTML.
392
393 %description doc -l pt_BR
394 O pacote python-doc contém documentação para a linguagem de
395 programação e para o interpretador Python. Fornecida em arquivos texto
396 e Postcript.
397
398 %description doc -l ru
399 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÏËÕÍÅÎÔÁÃÉÀ ÐÏ ÓÏÂÓÔ×ÅÎÎÏ ÑÚÙËÕ Python É ÐÏ
400 ÉÓÐÏÌÎÑÀÝÅÍÕ ÅÇÏ ÉÎÔÅÒÐÒÅÔÁÔÏÒÕ × ×ÉÄÅ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÙÈ ÆÁÊÌÏ× É
401 ÉÓÈÏÄÎÙÈ ÔÅËÓÔÏ× × ÆÏÒÍÁÔÅ LaTeX.
402
403 %description doc -l tr
404 Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyalarý ve
405 LaTeX kaynaklarýnýn bir karýþýmý olan yorumlayýcýyý içerir.
406
407 %description doc -l uk
408 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÄÏËÕÍÅÎÔÁæÀ ÐÏ ×ÌÁÓÎÅ ÍÏצ Python ÔÁ ÐÏ ×ÉËÏÎÕÀÞÏÍÕ
409 §§ ¦ÎÔÅÒÐÒÅÔÁÔÏÒÕ Õ ×ÉÇÌÑĦ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÉÈ ÆÁÊ̦נÔÁ ×ÉȦÄÎÉÈ
410 ÔÅËÓԦנՠÆÏÒÍÁÔ¦ LaTeX.
411
412 %package doc-info
413 Summary:        Documentation on Python in texinfo format
414 Summary(pl):    Dokumentacja do Pythona w formacie texinfo
415 Group:          Documentation
416
417 %description doc-info
418 Documentation on Python in texinfo format.
419
420 %description doc-info -l pl
421 Dokumentacja do Pythona w formacie texinfo.
422
423 %package tkinter
424 Summary:        Standard Python interface to the Tk GUI toolkit
425 Summary(de):    Grafische Tk-Schnittstelle für Python
426 Summary(es):    Interfaz de GUI Tk para Python
427 Summary(fr):    Interface graphique Tk pour Python
428 Summary(pl):    Standardowy interfejs Pythona do biblioteki Tk
429 Summary(pt_BR): Interface GUI Tk para Phyton
430 Summary(tr):    Python için grafik kullanýcý arayüzü
431 Group:          Libraries/Python
432 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
433 Requires:       tcl >= 8.4.3
434 Requires:       tix >= 1:8.1.4-4
435 Requires:       tk >= 8.4.3
436 Obsoletes:      tkinter
437
438 %description tkinter
439 Standard Python interface to the Tk GUI toolkit.
440
441 %description tkinter -l de
442 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
443 vielen Konfigurations-Tools genutzt.
444
445 %description tkinter -l es
446 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
447 herramientas de configuración.
448
449 %description tkinter -l fr
450 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
451 beaucoup des outils de configuration.
452
453 %description tkinter -l pl
454 Standardowy interfejs Pythona do biblioteki Tk.
455
456 %description tkinter -l pt_BR
457 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
458 muitas ferramentas de configuração.
459
460 %description tkinter -l ru
461 çÒÁÆÉÞÅÓËÉÊ ÉÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÓÔÒÏÅÎÎÙÊ ÎÁ Tcl/Tk.
462
463 %description tkinter -l tr
464 Python için Tcl/Tk'ye dayalý ve pek çok ayarlama aracý tarafýndan
465 kullanýlan grafik bir arayüzdür.
466
467 %description tkinter -l uk
468 çÒÁƦÞÎÉÊ ¦ÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÂÕÄÏ×ÁÎÉÊ ÎÁ Tcl/Tk.
469
470 %package examples
471 Summary:        Example programs in Python
472 Summary(pl):    Przyk³adowe programy w Pythonie
473 Group:          Development/Languages/Python
474 Obsoletes:      python-tools
475
476 %description examples
477 Example programs in Python.
478
479 These are for Python 2.3.4, not %{version}.
480
481 %description examples -l pl
482 Przyk³adowe programy w Pythonie.
483
484 Przyk³ady te s± dla Pythona 2.3.4, nie %{version}.
485
486 %prep
487 %setup -q -n Python-%{version}%{beta}
488 %patch0 -p1
489 %patch1 -p1
490 %patch2 -p1
491 %patch3 -p1
492 %patch5 -p1
493 %patch4 -p1
494 %patch6 -p1
495 %patch7 -p1
496
497 tar -xf %{SOURCE1} --use=bzip2
498
499 %build
500 sed -i -e 's#-ltermcap#-ltinfo#g' configure*
501 %{__autoconf}
502 CPPFLAGS="-I/usr/include/ncurses"; export CPPFLAGS
503 %configure \
504         --with-threads \
505         --with-cxx="%{__cxx}" \
506         --enable-unicode=ucs4 \
507         --enable-shared \
508         LINKCC='$(PURIFY) $(CXX)'
509
510 %{__make} \
511         OPT="%{rpmcflags}"
512
513 LC_ALL=C
514 export LC_ALL
515 %if %{with tests}
516 binlibdir=`echo build/lib.*`
517 %{__make} test \
518         TESTOPTS="%{test_flags} %{test_list}" \
519         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
520 %endif
521
522 %install
523 rm -rf $RPM_BUILD_ROOT
524 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
525         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
526         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
527         $RPM_BUILD_ROOT%{_infodir} \
528         $RPM_BUILD_ROOT/etc/shrc.d
529
530 %{__make} install \
531         DESTDIR=$RPM_BUILD_ROOT
532
533 %if %{with info}
534 %{__make} -C Doc/info
535 install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
536 %endif
537
538 install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
539
540 mv $RPM_BUILD_ROOT{%{py_libdir}/config,%{_libdir}}/libpython%{py_ver}.a
541 ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
542 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython.so
543 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{py_ver}.so
544
545 rm -f $RPM_BUILD_ROOT%{_bindir}/python%{py_ver}
546
547 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
548 cp -ar Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
549
550 #
551 # create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
552 #
553
554 # for python devel tools
555 for script in timeit profile pdb pstats; do
556     echo alias $script.py=\"python -m ${script}\"
557 done > $RPM_BUILD_ROOT/etc/shrc.d/python-devel.sh
558
559 echo alias pygettext.py='"pygettext"' \
560         >> $RPM_BUILD_ROOT/etc/shrc.d/python-devel.sh
561
562 sed 's/=/ /' \
563         < $RPM_BUILD_ROOT/etc/shrc.d/python-devel.sh \
564         > $RPM_BUILD_ROOT/etc/shrc.d/python-devel.csh
565
566 # for python modules
567 for script in smtpd webbrowser; do
568     echo alias $script.py=\"python -m ${script}\"
569 done > $RPM_BUILD_ROOT/etc/shrc.d/python-modules.sh
570
571 sed 's/=/ /' \
572         < $RPM_BUILD_ROOT/etc/shrc.d/python-modules.sh \
573         > $RPM_BUILD_ROOT/etc/shrc.d/python-modules.csh
574
575 # xgettext specific for Python code
576 #
577 # we will have two commands: pygettext.py (an alias) and pygettext;
578 # this way there are no import (which is impossible now) conflicts and
579 # pygettext.py is provided for compatibility
580 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext
581
582 # just to cut the noise, as they are not packaged (now)
583 # first tests
584 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/test
585 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/bsddb/test
586 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
587 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
588 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/email/test
589 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
590
591 # other files
592 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
593 find $RPM_BUILD_ROOT%{py_scriptdir} -name \*.egg-info -exec rm {} \;
594 find $RPM_BUILD_ROOT%{py_scriptdir} -name \*.bat -exec rm {} \;
595 find $RPM_BUILD_ROOT%{py_scriptdir} -name \*.txt -exec rm {} \;
596 find $RPM_BUILD_ROOT%{py_scriptdir} -name README\* -exec rm {} \;
597
598 %clean
599 rm -rf $RPM_BUILD_ROOT
600
601 %post   libs -p /sbin/ldconfig
602 %postun libs -p /sbin/ldconfig
603
604 %post doc-info
605 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
606
607 %postun doc-info
608 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
609
610 %files
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_bindir}/python
613 %{_mandir}/man1/*
614
615 %files modules
616 %defattr(644,root,root,755)
617 /etc/shrc.d/python-modules*
618 %exclude %{py_scriptdir}/UserDict.py[co]
619 %exclude %{py_scriptdir}/codecs.py[co]
620 %exclude %{py_scriptdir}/copy_reg.py[co]
621 %exclude %{py_scriptdir}/locale.py[co]
622 %exclude %{py_scriptdir}/posixpath.py[co]
623 %exclude %{py_scriptdir}/pdb.py[co]
624 %exclude %{py_scriptdir}/profile.py[co]
625 %exclude %{py_scriptdir}/pstats.py[co]
626 %exclude %{py_scriptdir}/pydoc.py[co]
627 %exclude %{py_scriptdir}/site.py[co]
628 %exclude %{py_scriptdir}/stat.py[co]
629 %exclude %{py_scriptdir}/timeit.py[co]
630 %exclude %{py_scriptdir}/os.py[co]
631 %exclude %{py_scriptdir}/encodings/*.py[co]
632 %exclude %{py_scriptdir}/types.py[co]
633
634 %{py_scriptdir}/*.py[co]
635
636 #
637 # list .so modules to be sure that all of them are built
638 #
639
640 # three modules below does not work on 64-bit architectures
641 # see Python README file for explanation
642 %ifnarch alpha ia64 ppc64 sparc64 %{x8664}
643 %attr(755,root,root) %{py_dyndir}/audioop.so
644 %attr(755,root,root) %{py_dyndir}/rgbimg.so
645 %attr(755,root,root) %{py_dyndir}/imageop.so
646 # sizeof(long) != sizeof(int), so dl module will not be built on 64-bit
647 # platforms
648 %attr(755,root,root) %{py_dyndir}/dl.so
649 %endif
650
651 %attr(755,root,root) %{py_dyndir}/array.so
652 %attr(755,root,root) %{py_dyndir}/binascii.so
653 %attr(755,root,root) %{py_dyndir}/_bisect.so
654 %attr(755,root,root) %{py_dyndir}/_bsddb.so
655 %attr(755,root,root) %{py_dyndir}/bz2.so
656 %attr(755,root,root) %{py_dyndir}/cmath.so
657 %attr(755,root,root) %{py_dyndir}/_codecs_cn.so
658 %attr(755,root,root) %{py_dyndir}/_codecs_hk.so
659 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
660 %attr(755,root,root) %{py_dyndir}/_codecs_jp.so
661 %attr(755,root,root) %{py_dyndir}/_codecs_kr.so
662 %attr(755,root,root) %{py_dyndir}/_codecs_tw.so
663 %attr(755,root,root) %{py_dyndir}/collections.so
664 %attr(755,root,root) %{py_dyndir}/cPickle.so
665 %attr(755,root,root) %{py_dyndir}/crypt.so
666 %attr(755,root,root) %{py_dyndir}/cStringIO.so
667 %attr(755,root,root) %{py_dyndir}/_csv.so
668 %attr(755,root,root) %{py_dyndir}/_ctypes.so
669 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
670 %attr(755,root,root) %{py_dyndir}/_curses.so
671 %attr(755,root,root) %{py_dyndir}/datetime.so
672 %attr(755,root,root) %{py_dyndir}/_elementtree.so
673 %attr(755,root,root) %{py_dyndir}/_functools.so
674 %attr(755,root,root) %{py_dyndir}/_hashlib.so
675 %attr(755,root,root) %{py_dyndir}/_heapq.so
676 %attr(755,root,root) %{py_dyndir}/_locale.so
677 %attr(755,root,root) %{py_dyndir}/_lsprof.so
678 %attr(755,root,root) %{py_dyndir}/_multibytecodec.so
679 %attr(755,root,root) %{py_dyndir}/_random.so
680 %attr(755,root,root) %{py_dyndir}/_socket.so
681 %attr(755,root,root) %{py_dyndir}/_sqlite3.so
682 %attr(755,root,root) %{py_dyndir}/_ssl.so
683 %attr(755,root,root) %{py_dyndir}/_testcapi.so
684 %attr(755,root,root) %{py_dyndir}/_weakref.so
685 %ifnarch sparc64
686 %attr(755,root,root) %{py_dyndir}/dbm.so
687 %endif
688 %attr(755,root,root) %{py_dyndir}/fcntl.so
689 %attr(755,root,root) %{py_dyndir}/gdbm.so
690 %attr(755,root,root) %{py_dyndir}/grp.so
691 %attr(755,root,root) %{py_dyndir}/itertools.so
692 %attr(755,root,root) %{py_dyndir}/linuxaudiodev.so
693 %attr(755,root,root) %{py_dyndir}/math.so
694 %attr(755,root,root) %{py_dyndir}/mmap.so
695 %attr(755,root,root) %{py_dyndir}/nis.so
696 %attr(755,root,root) %{py_dyndir}/operator.so
697 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
698 %attr(755,root,root) %{py_dyndir}/parser.so
699 %attr(755,root,root) %{py_dyndir}/pyexpat.so
700 %attr(755,root,root) %{py_dyndir}/readline.so
701 %attr(755,root,root) %{py_dyndir}/resource.so
702 %attr(755,root,root) %{py_dyndir}/select.so
703 %attr(755,root,root) %{py_dyndir}/strop.so
704 %attr(755,root,root) %{py_dyndir}/syslog.so
705 %attr(755,root,root) %{py_dyndir}/termios.so
706 %attr(755,root,root) %{py_dyndir}/time.so
707 %attr(755,root,root) %{py_dyndir}/spwd.so
708 %attr(755,root,root) %{py_dyndir}/unicodedata.so
709 %attr(755,root,root) %{py_dyndir}/zlib.so
710
711 %dir %{py_scriptdir}/plat-*
712 %{py_scriptdir}/plat-*/*.py[co]
713
714 %dir %{py_scriptdir}/bsddb
715 %{py_scriptdir}/bsddb/*.py[co]
716
717 %dir %{py_scriptdir}/compiler
718 %{py_scriptdir}/compiler/*.py[co]
719
720 %dir %{py_scriptdir}/ctypes
721 %dir %{py_scriptdir}/ctypes/macholib
722 %{py_scriptdir}/ctypes/*.py[co]
723 %{py_scriptdir}/ctypes/macholib/*.py[co]
724
725 %dir %{py_scriptdir}/curses
726 %{py_scriptdir}/curses/*.py[co]
727
728 %dir %{py_scriptdir}/distutils
729 %dir %{py_scriptdir}/distutils/command
730 %{py_scriptdir}/distutils/*.py[co]
731 %{py_scriptdir}/distutils/command/*.py[co]
732
733 %dir %{py_scriptdir}/email
734 %dir %{py_scriptdir}/email/mime
735 %{py_scriptdir}/email/*.py[co]
736 %{py_scriptdir}/email/mime/*.py[co]
737
738 %dir %{py_scriptdir}/logging
739 %{py_scriptdir}/logging/*.py[co]
740
741 %dir %{py_scriptdir}/sqlite3
742 %{py_scriptdir}/sqlite3/*.py[co]
743
744 %dir %{py_scriptdir}/wsgiref
745 %{py_scriptdir}/wsgiref/*.py[co]
746
747 %dir %{py_scriptdir}/xml
748 %dir %{py_scriptdir}/xml/dom
749 %dir %{py_scriptdir}/xml/etree
750 %dir %{py_scriptdir}/xml/parsers
751 %dir %{py_scriptdir}/xml/sax
752 %{py_scriptdir}/xml/*.py[co]
753 %{py_scriptdir}/xml/dom/*.py[co]
754 %{py_scriptdir}/xml/etree/*.py[co]
755 %{py_scriptdir}/xml/parsers/*.py[co]
756 %{py_scriptdir}/xml/sax/*.py[co]
757
758 %files libs
759 %defattr(644,root,root,755)
760 %attr(755,root,root) %{_libdir}/libpython*.so.*
761
762 %dir %{py_dyndir}
763 %dir %{py_scriptdir}
764 %dir %{py_libdir}
765 %dir %{py_sitescriptdir}
766 %dir %{py_sitedir}
767
768 # shared modules required by python library
769 %attr(755,root,root) %{py_dyndir}/_struct.so
770
771 # modules required by python library
772 %{py_scriptdir}/UserDict.py[co]
773 %{py_scriptdir}/codecs.py[co]
774 %{py_scriptdir}/copy_reg.py[co]
775 %{py_scriptdir}/locale.py[co]
776 %{py_scriptdir}/posixpath.py[co]
777 %{py_scriptdir}/site.py[co]
778 %{py_scriptdir}/stat.py[co]
779 %{py_scriptdir}/os.py[co]
780 # needed by the dynamic sys.lib patch
781 %{py_scriptdir}/types.py[co]
782
783 # encodings required by python library
784 %dir %{py_scriptdir}/encodings
785 %{py_scriptdir}/encodings/*.py[co]
786
787 %files -n pydoc
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_bindir}/pydoc
790 %{py_scriptdir}/pydoc.py[co]
791
792 %files -n idle
793 %defattr(644,root,root,755)
794 %attr(755,root,root) %{_bindir}/idle
795 %dir %{py_scriptdir}/idlelib
796 %dir %{py_scriptdir}/idlelib/Icons
797 %{py_scriptdir}/idlelib/*.py[co]
798 %{py_scriptdir}/idlelib/Icons/*
799 %{py_scriptdir}/idlelib/*.def
800
801 %files devel
802 %defattr(644,root,root,755)
803 %doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
804 %attr(755,root,root) %{_bindir}/python%{py_ver}-config
805 %attr(755,root,root) %{_libdir}/lib*.so
806 %dir %{py_incdir}
807 %{py_incdir}/*.h
808
809 %dir %{py_libdir}/config
810 %attr(755,root,root) %{py_libdir}/config/makesetup
811 %attr(755,root,root) %{py_libdir}/config/install-sh
812 %{py_libdir}/config/Makefile
813 %{py_libdir}/config/Makefile.pre.in
814 %{py_libdir}/config/Setup
815 %{py_libdir}/config/Setup.config
816 %{py_libdir}/config/Setup.local
817 %{py_libdir}/config/config.c
818 %{py_libdir}/config/config.c.in
819 %{py_libdir}/config/python.o
820
821 %files devel-src
822 %defattr(644,root,root,755)
823 %attr(-,root,root) %{py_scriptdir}/*.py
824 %{py_scriptdir}/plat-*/*.py
825 %{py_scriptdir}/bsddb/*.py
826 %{py_scriptdir}/ctypes/*.py
827 %{py_scriptdir}/ctypes/macholib/*.py
828 %{py_scriptdir}/compiler/*.py
829 %{py_scriptdir}/curses/*.py
830 %{py_scriptdir}/distutils/*.py
831 %{py_scriptdir}/distutils/command/*.py
832 %{py_scriptdir}/email/*.py
833 %{py_scriptdir}/email/mime/*.py
834 %{py_scriptdir}/hotshot/*.py
835 %{py_scriptdir}/logging/*.py
836 %{py_scriptdir}/sqlite3/*.py
837 %{py_scriptdir}/wsgiref/*.py
838 %{py_scriptdir}/xml/*.py
839 %{py_scriptdir}/xml/dom/*.py
840 %{py_scriptdir}/xml/etree/*.py
841 %{py_scriptdir}/xml/parsers/*.py
842 %{py_scriptdir}/xml/sax/*.py
843 %{py_scriptdir}/encodings/*.py
844 %{py_scriptdir}/idlelib/*.py
845
846 %files devel-tools
847 %defattr(644,root,root,755)
848 %doc Lib/pdb.doc
849 /etc/shrc.d/python-devel*
850
851 %attr(755,root,root) %{_bindir}/pygettext
852
853 %attr(755,root,root) %{py_dyndir}/_hotshot.so
854 %dir %{py_scriptdir}/hotshot
855 %{py_scriptdir}/hotshot/*.py[co]
856 %{py_scriptdir}/pdb.py[co]
857 %{py_scriptdir}/profile.py[co]
858 %{py_scriptdir}/pstats.py[co]
859 %{py_scriptdir}/timeit.py[co]
860
861 %files static
862 %defattr(644,root,root,755)
863 %{_libdir}/lib*.a
864
865 %files examples
866 %defattr(644,root,root,755)
867 %{_examplesdir}/%{name}-%{version}
868
869 %files doc
870 %defattr(644,root,root,755)
871 %doc Python-Docs-%{version}%{beta}/*
872
873 %if %{with info}
874 %files doc-info
875 %defattr(644,root,root,755)
876 %{_infodir}/*
877 %endif
878
879 %if %{with tkinter}
880 %files tkinter
881 %defattr(644,root,root,755)
882 %{py_scriptdir}/lib-tk
883 %attr(755,root,root) %{py_dyndir}/_tkinter.so
884 %endif
This page took 0.143594 seconds and 4 git commands to generate.