]> git.pld-linux.org Git - packages/python.git/blob - python.spec
- rel. 6 due to fixes in lib64 patch
[packages/python.git] / python.spec
1 # TODO
2 # - test_distutils fails for unknown reason: (does it still do with new lib64 patch?)
3 #   AssertionError: '/tmp/tmpaomC0l/installation/share/python' != '/tmp/tmpaomC0l/installation/lib/python'
4 # - change searchpath order so /usr/lib* is before /usr/share
5 # - kill lib-tk from searchpath
6 # - kill BR: file requirement from lib64 patch
7 #
8 # Conditional build:
9 %bcond_without  tkinter                 # disables tkinter module building
10 %bcond_without  tests                   # disables Python testing
11 %bcond_with     verbose_tests           # runs tests in verbose mode
12 #
13 # tests which will not work on 64-bit platforms
14 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
15 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
16 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
17 # tests which fail because of some unknown/unresolved reason (this list should be empty)
18 %define         broken_tests test_anydbm test_bsddb test_re test_shelve test_whichdb test_zipimport test_distutils
19
20 %define py_ver          2.4
21 %define py_prefix       %{_prefix}
22 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
23 %define py_incdir       %{_includedir}/python%{py_ver}
24 %define py_sitedir      %{py_libdir}/site-packages
25 %define py_dyndir       %{py_libdir}/lib-dynload
26
27 Summary:        Very high level scripting language with X interface
28 Summary(es):    Lenguaje script de alto nivel con interfaz X
29 Summary(fr):    Langage de script de très haut niveau avec interface X
30 Summary(pl):    Python - jêzyk obiektowy wysokiego poziomu
31 Summary(pt_BR): Linguagem de programação interpretada de alto nível
32 Summary(ru):    ñÚÙË ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ ÏÞÅÎØ ×ÙÓÏËÏÇÏ ÕÒÏ×ÎÑ Ó X-ÉÎÔÅÒÆÅÊÓÏÍ
33 Summary(tr):    X arayüzlü, yüksek düzeyli, kabuk yorumlayýcý dili
34 Summary(uk):    íÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÄÕÖÅ ×ÉÓÏËÏÇÏ Ò¦×ÎÑ Ú X-¦ÎÔÅÒÆÅÊÓÏÍ
35 Name:           python
36 Version:        %{py_ver}.2
37 Release:        6
38 Epoch:          1
39 License:        PSF
40 Group:          Applications
41 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
42 # Source0-md5:  98db1465629693fc434d4dc52db93838
43 Source1:        http://www.python.org/ftp/python/doc/%{version}/html-%{version}.tar.bz2
44 # Source1-md5:  4e3f177f32e15713130d9d9cf35f991f
45 Patch0:         %{name}-readline.patch
46 Patch1:         %{name}-%{name}path.patch
47 Patch2:         %{name}-no_ndbm.patch
48 Patch3:         %{name}-ac_fixes.patch
49 Patch4:         %{name}-noarch_to_datadir.patch
50 Patch5:         %{name}-lib64.patch
51 Patch6:         %{name}-doc_path.patch
52 Patch7:         %{name}-db44.patch
53 Patch8:         %{name}-ssl-nonblocking.patch
54 URL:            http://www.python.org/
55 BuildRequires:  autoconf
56 BuildRequires:  bzip2-devel
57 BuildRequires:  db-devel >= 4
58 BuildRequires:  expat-devel >= 1:1.95.7
59 BuildRequires:  file
60 BuildRequires:  gdbm-devel >= 1.8.3
61 BuildRequires:  gmp-devel >= 4.0
62 BuildRequires:  libstdc++-devel
63 BuildRequires:  ncurses-ext-devel >= 5.2
64 BuildRequires:  openssl-devel >= 0.9.7d
65 BuildRequires:  readline-devel >= 5.0
66 BuildRequires:  rpm-pythonprov
67 BuildRequires:  sed >= 4.0
68 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
69 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
70 BuildRequires:  zlib-devel
71 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
72 Obsoletes:      python-curses
73 Obsoletes:      python-gdbm
74 Obsoletes:      python-intl
75 Obsoletes:      python-xml
76 Obsoletes:      python-zlib
77 Obsoletes:      python2
78 Obsoletes:      python2-devel
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %if %{with verbose_tests}
82 %define test_flags -v -l -x 
83 %else
84 %define test_flags -l -x 
85 %endif
86
87 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
88 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
89 %else
90 %define test_list %{nobuilder_tests} %{broken_tests}
91 %endif
92
93 %description
94 Python is an interpreted, interactive, object-oriented programming
95 language. It incorporates modules, exceptions, dynamic typing, very
96 high level dynamic data types, and classes. Python combines remarkable
97 power with very clear syntax. It has interfaces to many system calls
98 and libraries, as well as to various window systems, and is extensible
99 in C or C++. It is also usable as an extension language for
100 applications that need a programmable interface. Finally, Python is
101 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
102 MS-DOS, Windows, Windows NT, and OS/2.
103
104 This package contains the Python binary.
105
106 %description -l de
107 Python ist eine interpretierte, interaktive, objektorientierte
108 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
109 Python enthält Module, Klassen, Exceptions, High-Level dynamische
110 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
111 zu vielen Systemaufrufen und Libraries, sowie verschiedene
112 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
113
114 Programmierer können neue built-in-Module für Python in C oder C++
115 schreiben. Python kann auch als Erweiterungssprache für Applikationen
116 benutzt werden, die ein programmierbares Interface brauchen. Dieses
117 Paket enthält die meisten Standard-Python-Module, und Module zum
118 Ansprechen von Tix (Tk-widget set) und RPM.
119
120 %description -l es
121 Python es un lenguaje de scripts interpretado orientado a objetos.
122 Contiene soporte para carga dinámica de objetos, clases, módulos y
123 excepciones.
124
125 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
126 través de código C, tornando Python fácil de usar en ambientes
127 particulares/personalizados. Este paquete Python incluye la mayoría de
128 los módulos padrón Python, junto con módulos para crear interfaces
129 para el conjunto de componentes Tix para Tk y RPM.
130
131 %description -l fr
132 Python est un langage de script interprété et orienté objet. Il gère
133 le chargement dynamique des objets, les classes, les modules et les
134 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
135 avec du code C est simple, ce qui rend Python facile à utiliser dans
136 des configs personnalisées.
137
138 Ce paquetage Python contient la plupart des modules Python standards,
139 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
140 et RPM.
141
142 %description -l pl
143 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
144 jêzykiem programowania. Jest modularny, obs³uguje wyj±tki, dynamiczne
145 typy, zaawansowane dynamiczne struktury danych i klasy. Python ³±czy w
146 sobie du¿e mo¿liwo¶ci i przejrzyst± sk³adniê. Posiada interfejsy do
147 wielu wywo³añ systemowych i bibliotek, w tym równie¿ do ró¿nych
148 bibliotek okienkowych. Mo¿liwo¶ci jego mo¿na jeszcze rozszerzaæ
149 poprzez odpowiednie modu³y pisane w C lub C++. Python mo¿e byæ równie¿
150 u¿yty jako element aplikacji, którym potrzebny jest interpreter do
151 skryptów. I wreszcie, Python jest wieloplatformowy, dzia³a na wielu
152 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
153 OS/2.
154
155 Ten pakiet zawiera binarkê Pythona.
156
157 %description -l pt_BR
158 Python é uma linguagem de scripts interpretada orientada a objetos.
159 Contém suporte para carga dinâmica de objetos, classes, módulos e
160 exceções. Adicionar interfaces para novos sistemas de biblioteca
161 através de código C é simples, tornando Python fácil de usar em
162 ambientes particulares/personalizados.
163
164 Este pacote Python inclui a maioria do módulos padrão Python, junto
165 com módulos para interfaceamento para o conjunto de componentes Tix
166 para Tk e RPM.
167
168 %description -l ru
169 Python - ÜÔÏ ÉÎÔÅÒÐÒÅÔÉÒÕÅÍÙÊ, ÏÂßÅËÔÎÏ-ÏÒÉÅÎÔÉÒÏ×ÁÎÎÙÊ ÑÚÙË
170 ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ. ïΠÐÏÄÄÅÒÖÉ×ÁÅÔ ÄÉÎÁÍÉÞÅÓËÕÀ ÚÁÇÒÕÚËÕ ÏÂßÅËÔÏ×,
171 ËÌÁÓÓÙ, ÍÏÄÕÌÉ É ÏÂÒÁÂÏÔËÕ ÉÓËÌÀÞÉÔÅÌØÎÙÈ ÓÉÔÕÁÃÉÊ (exceptions).
172 ðÒÏÓÔÏÔÁ ÄÏÂÁ×ÌÅÎÉÑ ÉÎÔÅÒÆÅÊÓÏ× Ë ÎÏ×ÙÍ ÓÉÓÔÅÍÎÙÍ ÂÉÂÌÉÏÔÅËÁÍ ÞÅÒÅÚ
173 ËÏÄ ÎÁ ÑÚÙËÅ C ÄÅÌÁÅÔ Python ÈÏÒÏÛÉÍ ×ÙÂÏÒÏÍ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ×
174 ÓÐÅÃÉÁÌØÎÙÈ ËÏÎÆÉÇÕÒÁÃÉÑÈ.
175
176 %description -l tr
177 Python, nesneye yönelik bir kabuk yorumlayýcýdýr. Nesnelerin,
178 sýnýflarýn, modüllerin ve aykýrý durumlarýn dinamik yüklenmelerine
179 destek verir. C koduyla birlikte kullanýmý son derece kolaydýr. Bu
180 paket, standart Python birimlerinin çoðunun yanýsýra Tk ve RPM için
181 arayüz birimlerini de içerir.
182
183 %description -l uk
184 Python - ÃÅ ¦ÎÔÅÒÐÒÅÔÏ×ÁÎÁ, ÏÂ'¤ËÔÎÏ-ÏÒ¦¤ÎÔÏ×ÁÎÁ ÍÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ.
185 ÷¦Î Ð¦ÄÔÒÉÍÕ¤ ÄÉÎÁͦÞÎÕ ÚÁÇÒÕÚËÕ ÏÂ'¤ËÔ¦×, ËÌÁÓÉ, ÍÏÄÕ̦ ÔÁ ÏÂÒÏÂËÕ
186 ×ÉËÌÀÞÎÉÈ ÓÉÔÕÁæʠ(exceptions). ðÒÏÓÔÏÔÁ ÄÏÄÁ×ÁÎÎÑ ¦ÎÔÅÒÆÅÊӦנÄÌÑ
187 ÎÏ×ÉÈ ÓÉÓÔÅÍÎÉȠ¦Â̦ÏÔÅË ÞÅÒÅÚ ËÏÄ ÎÁ ÍÏצ C ÒÏÂÉÔØ Python ÄÏÂÒÉÍ
188 ×ÉÂÏÒÏÍ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎÑ × ÓÐÅæÁÌØÎÉÈ ËÏÎƦÇÕÒÁæÑÈ.
189
190 %package libs
191 Summary:        Python library
192 Summary(pl):    Biblioteka jêzyka Python
193 Group:          Libraries/Python
194 # broken detection in rpm/pythondeps.sh
195 Provides:       python(abi) = %{py_ver}
196 # for compatibility with existing Ac packages
197 Provides:       python(bytecode) = %{py_ver}
198
199 %description libs
200 Python shared library and very essental modules for Python binary.
201
202 %description libs -l pl
203 Biblioteka wspó³dzielona jêzyka Python oraz bardzo podstawowe modu³y
204 dla Pythona.
205
206 %package modules
207 Summary:        Python modules
208 Summary(pl):    Modu³y jêzyka Python
209 Group:          Libraries/Python
210 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
211 Obsoletes:      python-logging
212 Obsoletes:      python-optik
213 Obsoletes:      python-xmlrpc <= 1.0.1
214
215 %description modules
216 Python officially distributed modules.
217
218 %description modules -l pl
219 Oficjalnie rozprowadzane modu³y jêzyka Python.
220
221 %package -n pydoc
222 Summary:        Python interactive module documentation access support
223 Summary(pl):    Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python
224 Group:          Applications
225 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
226 Obsoletes:      python-pydoc
227
228 %description -n pydoc
229 Python interactive module documentation access support.
230
231 %description -n pydoc -l pl
232 Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python.
233
234 %package -n idle
235 Summary:        IDE for Python language
236 Summary(pl):    IDE dla jêzyka Python
237 Group:          Applications
238 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
239 Obsoletes:      python-idle
240
241 %description -n idle
242 IDE for Python language.
243
244 %description -n idle -l pl
245 IDE dla jêzyka Python.
246
247 %package devel
248 Summary:        Libraries and header files for building python code
249 Summary(de):    Libraries und Header-Dateien zum Erstellen von Python-Code
250 Summary(es):    Bibliotecas y archivos de inclusión para construir programas en python
251 Summary(fr):    Bibliothèques et en-têtes pour construire du code python
252 Summary(pl):    Pliki nag³ówkowe i biblioteki Pythona
253 Summary(pt_BR): Bibliotecas e arquivos de inclusão para o Python
254 Summary(ru):    âÉÂÌÉÏÔÅËÉ É ÈÅÄÅÒÙ ÄÌÑ ÐÏÓÔÒÏÅÎÉÑ ËÏÄÁ ÎÁ ÑÚÙËÅ Python
255 Summary(tr):    Python ile geliþtirme yapmak için gerekli dosyalar
256 Summary(uk):    â¦Â̦ÏÔÅËÉ ÔÁ ÈÅÄÅÒÉ ÄÌÑ ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÎÁ ÍÏצ Python
257 Group:          Development/Languages/Python
258 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
259
260 %description devel
261 The Python interpreter is relatively easy to extend with dynamically
262 loaded extensions and to embed in other programs. This package
263 contains the header files and libraries which are needed to do both of
264 these tasks.
265
266 %description devel -l de
267 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
268 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
269 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
270 die für beide Aufgaben erforderlich sind.
271
272 %description devel -l es
273 El interpretador Python permite incluir con facilidad extensiones
274 cargadas dinámicamente. Python es también fácil de ser empotrado en
275 otros programas. Este paquete contiene los archivos de inclusión y
276 bibliotecas necesarios para estas dos tareas.
277
278 %description devel -l fr
279 L'interpréteur Python est relativement facile à étendre avec des
280 extensions chargées dynamiquement et à insérer dans d'autres
281 programmes. Ce paquetage contient les en-têtes et les bibliothèques
282 nécessaires à ces deux tâches.
283
284 %description devel -l pl
285 Interpreter Pythona jest w miarê ³atwy do rozszerzania przy pomocy
286 dynamicznie ³adowanych rozszerzeñ napisanych w C lub C++ oraz
287 osadzania w innych programach. Ten pakiet zawiera pliki nag³ówkowe i
288 wszystko inne co potrzebne do tych celów.
289
290 %description devel -l pt_BR
291 O interpretador Python permite incluir com facilidade extensões
292 carregadas dinamicamente. Python é também fácil de ser embutido em
293 outros programas. Este pacote contém os arquivos de inclusão e
294 bibliotecas necessários para estas duas tarefas.
295
296 %description devel -l ru
297 éÎÔÅÒÐÒÅÔÁÔÏÒ Python ÏÔÎÏÓÉÔÅÌØÎÏ ÌÅÇËÏ ÒÁÓÛÉÒÑÅÔÓÑ ÐÒÉ ÐÏÍÏÝÉ
298 ÄÉÎÁÍÉÞÅÓËÉ ÚÁÇÒÕÖÁÅÍÙÈ ÒÁÓÛÉÒÅÎÉÊ É ×ÓÔÒÁÉ×ÁÅÔÓÑ × ÄÒÕÇÉÅ ÐÒÏÇÒÁÍÍÙ.
299 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÈÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÏÂÅÉÈ ÜÔÉÈ
300 ÚÁÄÁÞ.
301
302 %description devel -l tr
303 Bu paket, Python ile geliþtirme yapýlabilmesi için gerekli baþlýk
304 dosyalarýný ve kitaplýklarý içerir.
305
306 %description devel -l uk
307 ¶ÎÔÅÒÐÒÅÔÁÔÏÒ Python ×¦ÄÎÏÓÎÏ ÌÅÇËÏ ÒÏÚÛÉÒÀ¤ÔØÓÑ ÚÁ ÄÏÐÏÍÏÇÏÀ
308 ÒÏÚÛÉÒÅÎØ Ú ÄÉÎÁͦÞÎÏÀ ÚÁÇÒÕÚËÏÀ ÔÁ ×ÂÕÄÏ×Õ¤ÔØÓÑ × ¦ÎÛ¦ ÐÒÏÇÒÁÍÉ. ãÅÊ
309 ÐÁËÅԠͦÓÔÉÔØ ÈÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÏÂÏÈ ÃÉÈ ÚÁÄÁÞ.
310
311 %package devel-src
312 Summary:        Python module sources
313 Summary(pl):    Pliki ¼ród³owe modu³ów Pythona
314 Group:          Development/Languages/Python
315 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
316
317 %description devel-src
318 Python module sources.
319
320 %description devel-src -l pl
321 Pliki ¼ród³owe modu³ów Pythona.
322
323 %package devel-tools
324 Summary:        Python development tools
325 Summary(pl):    Narzêdzia programistyczne jêzyka Python
326 Group:          Development/Languages/Python
327 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
328
329 %description devel-tools
330 Python development tools such as profilers and debugger.
331
332 %description devel-tools -l pl
333 Narzêdzia programistyczne jêzyka Python takie jak profiler oraz
334 debugger.
335
336 %package static
337 Summary:        Static python library
338 Summary(pl):    Statyczna biblioteka Pythona
339 Group:          Development/Languages/Python
340 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
341
342 %description static
343 Static python library.
344
345 %description static -l pl
346 Statyczna biblioteka Pythona.
347
348 %package doc
349 Summary:        Documentation on Python
350 Summary(de):    Dokumentation zu Python
351 Summary(es):    Documentación para Python
352 Summary(fr):    Documentation sur Python
353 Summary(pl):    Dokumentacja do Pythona
354 Summary(pt_BR): Documentação para a linguagem de programação Python
355 Summary(ru):    äÏËÕÍÅÎÔÁÃÉÑ ÐÏ ÑÚÙËÕ Python
356 Summary(tr):    Python belgeleri
357 Summary(uk):    äÏËÕÍÅÎÔÁæѠÐÏ ÍÏצ Python
358 Group:          Documentation
359 Obsoletes:      python-docs
360
361 %description doc
362 This package contains documentation on the Python language and
363 interpretor as a mix of plain ASCII files and LaTeX sources.
364
365 %description doc -l de
366 Dieses Paket enthält Dokumentationen zu Python (Sprache und
367 Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
368
369 %description doc -l es
370 Documentación para Python. Contiene archivos en texto y PostScript.
371
372 %description doc -l fr
373 Ce paquetage contient la documentation sur le langage python et sur
374 son interpréteur sous forme de fichiers ASCII et LaTeX.
375
376 %description doc -l pl
377 Oficjalna dokumentacja do Pythona. Zawiera przyk³adowe programy,
378 narzêdzia i dokumentacjê. Strony podrêcznika man znajduj± siê w
379 g³ównym pakiecie. Ten pakiet nie zawiera ¼róde³ dokumentacji
380 napisanych w LaTeXu, tylko gotowe do wykorzystania pliki postscriptowe
381 i HTML.
382
383 %description doc -l pt_BR
384 O pacote python-doc contém documentação para a linguagem de
385 programação e para o interpretador Python. Fornecida em arquivos texto
386 e Postcript.
387
388 %description doc -l ru
389 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÏËÕÍÅÎÔÁÃÉÀ ÐÏ ÓÏÂÓÔ×ÅÎÎÏ ÑÚÙËÕ Python É ÐÏ
390 ÉÓÐÏÌÎÑÀÝÅÍÕ ÅÇÏ ÉÎÔÅÒÐÒÅÔÁÔÏÒÕ × ×ÉÄÅ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÙÈ ÆÁÊÌÏ× É
391 ÉÓÈÏÄÎÙÈ ÔÅËÓÔÏ× × ÆÏÒÍÁÔÅ LaTeX.
392
393 %description doc -l tr
394 Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyalarý ve
395 LaTeX kaynaklarýnýn bir karýþýmý olan yorumlayýcýyý içerir.
396
397 %description doc -l uk
398 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÄÏËÕÍÅÎÔÁæÀ ÐÏ ×ÌÁÓÎÅ ÍÏצ Python ÔÁ ÐÏ ×ÉËÏÎÕÀÞÏÍÕ
399 §§ ¦ÎÔÅÒÐÒÅÔÁÔÏÒÕ Õ ×ÉÇÌÑĦ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÉÈ ÆÁÊ̦נÔÁ ×ÉȦÄÎÉÈ
400 ÔÅËÓԦנՠÆÏÒÍÁÔ¦ LaTeX.
401
402 %package tkinter
403 Summary:        Standard Python interface to the Tk GUI toolkit
404 Summary(de):    Grafische Tk-Schnittstelle für Python
405 Summary(es):    Interfaz de GUI Tk para Python
406 Summary(fr):    Interface graphique Tk pour Python
407 Summary(pl):    Standardowy interfejs Pythona do biblioteki Tk
408 Summary(pt_BR): Interface GUI Tk para Phyton
409 Summary(tr):    Python için grafik kullanýcý arayüzü
410 Group:          Libraries/Python
411 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
412 Requires:       tcl >= 8.4.3
413 Requires:       tix >= 1:8.1.4-4
414 Requires:       tk >= 8.4.3
415 Obsoletes:      tkinter
416
417 %description tkinter
418 Standard Python interface to the Tk GUI toolkit.
419
420 %description tkinter -l de
421 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
422 vielen Konfigurations-Tools genutzt.
423
424 %description tkinter -l es
425 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
426 herramientas de configuración.
427
428 %description tkinter -l fr
429 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
430 beaucoup des outils de configuration.
431
432 %description tkinter -l pl
433 Standardowy interfejs Pythona do biblioteki Tk.
434
435 %description tkinter -l pt_BR
436 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
437 muitas ferramentas de configuração.
438
439 %description tkinter -l ru
440 çÒÁÆÉÞÅÓËÉÊ ÉÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÓÔÒÏÅÎÎÙÊ ÎÁ Tcl/Tk.
441
442 %description tkinter -l tr
443 Python için Tcl/Tk'ye dayalý ve pek çok ayarlama aracý tarafýndan
444 kullanýlan grafik bir arayüzdür.
445
446 %description tkinter -l uk
447 çÒÁƦÞÎÉÊ ¦ÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÂÕÄÏ×ÁÎÉÊ ÎÁ Tcl/Tk.
448
449 %package old
450 Summary:        Deprecated Python modules
451 Summary(pl):    Nieaktualne modu³y jêzyka Python
452 Group:          Libraries/Python
453 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
454
455 %description old
456 Install this package when one of your program written in Python is old
457 as Miss Universum of 1918, who only you want to see... ooops, which
458 only you want to run.
459
460 %description old -l pl
461 Zainstaluj ten pakiet, wtedy kiedy jeden z Twoich programów napisanych
462 w jêzyku Python jest tak stary jak Miss Universum z roku 1918, któr±
463 tylko ty chcesz zobaczyæ... przepraszam, który tylko ty chcesz
464 uruchomiæ.
465
466 %package examples
467 Summary:        Example programs in Python
468 Summary(pl):    Przyk³adowe programy w Pythonie
469 Group:          Development/Languages/Python
470 Obsoletes:      python-tools
471
472 %description examples
473 Example programs in Python.
474
475 These are for Python 2.3.4, not %{version}.
476
477 %description examples -l pl
478 Przyk³adowe programy w Pythonie.
479
480 Przyk³ady te s± dla Pythona 2.3.4, nie %{version}.
481
482 %prep
483 %setup -q -n Python-%{version}
484 %patch0 -p1
485 %patch1 -p1
486 %patch2 -p1
487 %patch3 -p1
488 %patch5 -p1
489 %patch4 -p1
490 %patch6 -p1
491 %patch7 -p1
492 %patch8 -p1
493
494 tar -xf %{SOURCE1} --use=bzip2
495
496 %build
497 sed -i -e 's#-ltermcap#-ltinfo#g' configure*
498 %{__autoconf}
499 CPPFLAGS="-I/usr/include/ncurses"; export CPPFLAGS
500 %configure \
501         --with-threads \
502         --with-cxx="%{__cxx}" \
503         --enable-unicode=ucs4 \
504         --enable-shared \
505         LINKCC='$(PURIFY) $(CXX)'
506
507 %{__make} \
508         OPT="%{rpmcflags}"
509
510 LC_ALL=C
511 export LC_ALL
512 %if %{with tests}
513 binlibdir=`echo build/lib.*`
514 %{__make} test \
515         TESTOPTS="%{test_flags} %{test_list}" \
516         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
517 %endif
518
519 %install
520 rm -rf $RPM_BUILD_ROOT
521 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
522         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
523         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
524
525 %{__make} install \
526         DESTDIR=$RPM_BUILD_ROOT
527
528 install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
529
530 mv $RPM_BUILD_ROOT{%{py_libdir}/config,%{_libdir}}/libpython%{py_ver}.a
531 ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
532 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython.so
533 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{py_ver}.so
534
535 rm -f $RPM_BUILD_ROOT%{_bindir}/python%{py_ver}
536
537 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
538 cp -ar Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
539
540 SCRIPT_EXT=".py"
541 export SCRIPT_EXT
542
543 # create several useful scripts, such as timeit.py, profile.py, pdb.py, smtpd.py
544 for script in timeit profile pdb pstats smtpd; do
545     cat <<END > $RPM_BUILD_ROOT%{_bindir}/${script}$SCRIPT_EXT
546 #!/bin/sh
547 exec %{_bindir}/python %{py_scriptdir}/${script}.pyc \${1:+"\$@"}
548 END
549 done
550
551 # xgettext specific for Python code
552 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext$SCRIPT_EXT
553
554 # just to cut the noise, as they are not packaged (now)
555 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/test
556 rm -f $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
557
558 %clean
559 rm -rf $RPM_BUILD_ROOT
560
561 %post   libs -p /sbin/ldconfig
562 %postun libs -p /sbin/ldconfig
563
564 %files
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_bindir}/python
567 %{_mandir}/man1/*
568
569 %files modules
570 %defattr(644,root,root,755)
571 %exclude %{py_scriptdir}/UserDict.py[co]
572 %exclude %{py_scriptdir}/codecs.py[co]
573 %exclude %{py_scriptdir}/copy_reg.py[co]
574 %exclude %{py_scriptdir}/locale.py[co]
575 %exclude %{py_scriptdir}/posixpath.py[co]
576 %exclude %{py_scriptdir}/pdb.py[co]
577 %exclude %{py_scriptdir}/profile.py[co]
578 %exclude %{py_scriptdir}/pstats.py[co]
579 %exclude %{py_scriptdir}/pydoc.py[co]
580 %exclude %{py_scriptdir}/site.py[co]
581 %exclude %{py_scriptdir}/stat.py[co]
582 %exclude %{py_scriptdir}/timeit.py[co]
583 %exclude %{py_scriptdir}/os.py[co]
584 %exclude %{py_scriptdir}/encodings/*.py[co]
585 %exclude %{py_scriptdir}/types.py[co]
586
587 %{py_scriptdir}/*.py[co]
588
589 #
590 # list .so modules to be sure that all of them are built
591 #
592
593 # three modules below does not work on 64-bit architectures
594 # see Python README file for explanation
595 %ifnarch alpha ia64 ppc64 sparc64 %{x8664}
596 %attr(755,root,root) %{py_dyndir}/audioop.so
597 %attr(755,root,root) %{py_dyndir}/rgbimg.so
598 %attr(755,root,root) %{py_dyndir}/imageop.so
599 # sizeof(long) != sizeof(int), so dl module will not be built on 64-bit
600 # platforms
601 %attr(755,root,root) %{py_dyndir}/dl.so
602 %endif
603
604 %attr(755,root,root) %{py_dyndir}/_bisect.so
605 %attr(755,root,root) %{py_dyndir}/_bsddb.so
606 %attr(755,root,root) %{py_dyndir}/_codecs_cn.so
607 %attr(755,root,root) %{py_dyndir}/_codecs_hk.so
608 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
609 %attr(755,root,root) %{py_dyndir}/_codecs_jp.so
610 %attr(755,root,root) %{py_dyndir}/_codecs_kr.so
611 %attr(755,root,root) %{py_dyndir}/_codecs_tw.so
612 %attr(755,root,root) %{py_dyndir}/_csv.so
613 %attr(755,root,root) %{py_dyndir}/_curses.so
614 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
615 %attr(755,root,root) %{py_dyndir}/_heapq.so
616 %attr(755,root,root) %{py_dyndir}/_locale.so
617 %attr(755,root,root) %{py_dyndir}/_multibytecodec.so
618 %attr(755,root,root) %{py_dyndir}/_random.so
619 %attr(755,root,root) %{py_dyndir}/_socket.so
620 %attr(755,root,root) %{py_dyndir}/_ssl.so
621 %attr(755,root,root) %{py_dyndir}/_testcapi.so
622 %attr(755,root,root) %{py_dyndir}/_weakref.so
623 %attr(755,root,root) %{py_dyndir}/array.so
624 %attr(755,root,root) %{py_dyndir}/binascii.so
625 %attr(755,root,root) %{py_dyndir}/bz2.so
626 %attr(755,root,root) %{py_dyndir}/cPickle.so
627 %attr(755,root,root) %{py_dyndir}/cStringIO.so
628 %attr(755,root,root) %{py_dyndir}/cmath.so
629 %attr(755,root,root) %{py_dyndir}/collections.so
630 %attr(755,root,root) %{py_dyndir}/crypt.so
631 %attr(755,root,root) %{py_dyndir}/datetime.so
632 %ifnarch sparc64
633 %attr(755,root,root) %{py_dyndir}/dbm.so
634 %endif
635 %attr(755,root,root) %{py_dyndir}/fcntl.so
636 %attr(755,root,root) %{py_dyndir}/gdbm.so
637 %attr(755,root,root) %{py_dyndir}/grp.so
638 %attr(755,root,root) %{py_dyndir}/itertools.so
639 %attr(755,root,root) %{py_dyndir}/linuxaudiodev.so
640 %attr(755,root,root) %{py_dyndir}/math.so
641 %attr(755,root,root) %{py_dyndir}/md5.so
642 %attr(755,root,root) %{py_dyndir}/mmap.so
643 %attr(755,root,root) %{py_dyndir}/nis.so
644 %attr(755,root,root) %{py_dyndir}/operator.so
645 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
646 %attr(755,root,root) %{py_dyndir}/parser.so
647 %attr(755,root,root) %{py_dyndir}/pwd.so
648 %attr(755,root,root) %{py_dyndir}/pyexpat.so
649 %attr(755,root,root) %{py_dyndir}/readline.so
650 %attr(755,root,root) %{py_dyndir}/regex.so
651 %attr(755,root,root) %{py_dyndir}/resource.so
652 %attr(755,root,root) %{py_dyndir}/select.so
653 %attr(755,root,root) %{py_dyndir}/sha.so
654 %attr(755,root,root) %{py_dyndir}/strop.so
655 %attr(755,root,root) %{py_dyndir}/syslog.so
656 %attr(755,root,root) %{py_dyndir}/termios.so
657 %attr(755,root,root) %{py_dyndir}/time.so
658 %attr(755,root,root) %{py_dyndir}/timing.so
659 %attr(755,root,root) %{py_dyndir}/unicodedata.so
660 %attr(755,root,root) %{py_dyndir}/zlib.so
661
662 %dir %{py_scriptdir}/plat-*
663 %{py_scriptdir}/plat-*/*.py[co]
664
665 %dir %{py_scriptdir}/bsddb
666 %{py_scriptdir}/bsddb/*.py[co]
667
668 %dir %{py_scriptdir}/compiler
669 %{py_scriptdir}/compiler/*.py[co]
670
671 %dir %{py_scriptdir}/curses
672 %{py_scriptdir}/curses/*.py[co]
673
674 %dir %{py_scriptdir}/distutils
675 %{py_scriptdir}/distutils/*.py[co]
676
677 %dir %{py_scriptdir}/distutils/command
678 %{py_scriptdir}/distutils/command/*.py[co]
679
680 %dir %{py_scriptdir}/email
681 %{py_scriptdir}/email/*.py[co]
682
683 %dir %{py_scriptdir}/logging
684 %{py_scriptdir}/logging/*.py[co]
685
686 %dir %{py_scriptdir}/xml
687 %{py_scriptdir}/xml/*.py[co]
688
689 %dir %{py_scriptdir}/xml/parsers
690 %{py_scriptdir}/xml/parsers/*.py[co]
691
692 %dir %{py_scriptdir}/xml/sax
693 %{py_scriptdir}/xml/sax/*.py[co]
694
695 %dir %{py_scriptdir}/xml/dom
696 %{py_scriptdir}/xml/dom/*.py[co]
697
698 %files libs
699 %defattr(644,root,root,755)
700 %attr(755,root,root) %{_libdir}/libpython*.so.*
701
702 %dir %{py_dyndir}
703 %dir %{py_scriptdir}
704 %dir %{py_libdir}
705 %dir %{py_sitescriptdir}
706 %dir %{py_sitedir}
707
708 # shared modules required by python library
709 %attr(755,root,root) %{py_dyndir}/struct.so
710
711 # modules required by python library
712 %{py_scriptdir}/UserDict.py[co]
713 %{py_scriptdir}/codecs.py[co]
714 %{py_scriptdir}/copy_reg.py[co]
715 %{py_scriptdir}/locale.py[co]
716 %{py_scriptdir}/posixpath.py[co]
717 %{py_scriptdir}/site.py[co]
718 %{py_scriptdir}/stat.py[co]
719 %{py_scriptdir}/os.py[co]
720 # needed by the dynamic sys.lib patch
721 %{py_scriptdir}/types.py[co]
722
723 # encodings required by python library
724 %dir %{py_scriptdir}/encodings
725 %{py_scriptdir}/encodings/*.py[co]
726
727 %files -n pydoc
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_bindir}/pydoc
730 %{py_scriptdir}/pydoc.py[co]
731
732 %files -n idle
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{_bindir}/idle
735 %dir %{py_scriptdir}/idlelib
736 %dir %{py_scriptdir}/idlelib/Icons
737 %{py_scriptdir}/idlelib/*.py[co]
738 %{py_scriptdir}/idlelib/Icons/*
739 %{py_scriptdir}/idlelib/*.def
740
741 %files devel
742 %defattr(644,root,root,755)
743 %doc Misc/{ACKS,NEWS,README}
744 %attr(755,root,root) %{_libdir}/lib*.so
745 %dir %{py_incdir}
746 %{py_incdir}/*.h
747
748 %dir %{py_libdir}/config
749 %attr(755,root,root) %{py_libdir}/config/makesetup
750 %attr(755,root,root) %{py_libdir}/config/install-sh
751 %{py_libdir}/config/Makefile
752 %{py_libdir}/config/Makefile.pre.in
753 %{py_libdir}/config/Setup
754 %{py_libdir}/config/Setup.config
755 %{py_libdir}/config/Setup.local
756 %{py_libdir}/config/config.c
757 %{py_libdir}/config/config.c.in
758 %{py_libdir}/config/ccpython.o
759
760 %files devel-src
761 %defattr(644,root,root,755)
762 %attr(-,root,root) %{py_scriptdir}/*.py
763 %{py_scriptdir}/plat-*/*.py
764 %{py_scriptdir}/bsddb/*.py
765 %{py_scriptdir}/compiler/*.py
766 %{py_scriptdir}/curses/*.py
767 %{py_scriptdir}/distutils/*.py
768 %{py_scriptdir}/distutils/command/*.py
769 %{py_scriptdir}/email/*.py
770 %{py_scriptdir}/hotshot/*.py
771 %{py_scriptdir}/logging/*.py
772 %{py_scriptdir}/xml/*.py
773 %{py_scriptdir}/xml/parsers/*.py
774 %{py_scriptdir}/xml/sax/*.py
775 %{py_scriptdir}/xml/dom/*.py
776 %{py_scriptdir}/encodings/*.py
777 %{py_scriptdir}/idlelib/*.py
778
779 %files devel-tools
780 %defattr(644,root,root,755)
781 %doc Lib/profile.doc Lib/pdb.doc
782 %attr(755,root,root) %{_bindir}/timeit*
783 %attr(755,root,root) %{_bindir}/profile*
784 %attr(755,root,root) %{_bindir}/pdb*
785 %attr(755,root,root) %{_bindir}/pstats*
786 %attr(755,root,root) %{_bindir}/pygettext*
787 %attr(755,root,root) %{_bindir}/smtpd*
788
789 %attr(755,root,root) %{py_dyndir}/_hotshot.so
790 %dir %{py_scriptdir}/hotshot
791 %{py_scriptdir}/hotshot/*.py[co]
792 %{py_scriptdir}/pdb.py[co]
793 %{py_scriptdir}/profile.py[co]
794 %{py_scriptdir}/pstats.py[co]
795 %{py_scriptdir}/timeit.py[co]
796
797 %files static
798 %defattr(644,root,root,755)
799 %{_libdir}/lib*.a
800
801 %files examples
802 %defattr(644,root,root,755)
803 %{_examplesdir}/%{name}-%{version}
804
805 %files doc
806 %defattr(644,root,root,755)
807 %doc Python-Docs-%{version}/*
808
809 %if %{with tkinter}
810 %files tkinter
811 %defattr(644,root,root,755)
812 %{py_scriptdir}/lib-tk
813 %attr(755,root,root) %{py_dyndir}/_tkinter.so
814 %endif
815
816 %files old
817 %defattr(644,root,root,755)
818 %dir %{py_scriptdir}/lib-old
819 %{py_scriptdir}/lib-old/*.py[co]
This page took 0.094543 seconds and 4 git commands to generate.