]> git.pld-linux.org Git - packages/python.git/blob - python.spec
- rel 2; just drop smtplib patch
[packages/python.git] / python.spec
1 #
2 # Conditional build:
3 %bcond_without  tkinter                 # disables tkinter module building
4 %bcond_without  tests                   # disables Python testing
5 %bcond_with     verbose_tests           # runs tests in verbose mode
6 #
7 # tests which will not work on 64-bit platforms
8 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
9 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
10 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
11 # tests which fail because of some unknown/unresolved reason (this list should be empty)
12 %define         broken_tests test_anydbm test_bsddb test_re test_shelve test_whichdb test_zipimport test_distutils
13 # test_distutils fails for unknown reason:
14 # AssertionError: '/tmp/tmpaomC0l/installation/share/python' != '/tmp/tmpaomC0l/installation/lib/python'
15
16 %define py_ver          2.4
17 %define py_prefix       %{_prefix}
18 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
19 %define py_incdir       %{_includedir}/python%{py_ver}
20 %define py_sitedir      %{py_libdir}/site-packages
21 %define py_dyndir       %{py_libdir}/lib-dynload
22
23 Summary:        Very high level scripting language with X interface
24 Summary(es):    Lenguaje script de alto nivel con interfaz X
25 Summary(fr):    Langage de script de très haut niveau avec interface X
26 Summary(pl):    Python - jêzyk obiektowy wysokiego poziomu
27 Summary(pt_BR): Linguagem de programação interpretada de alto nível
28 Summary(ru):    ñÚÙË ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ ÏÞÅÎØ ×ÙÓÏËÏÇÏ ÕÒÏ×ÎÑ Ó X-ÉÎÔÅÒÆÅÊÓÏÍ
29 Summary(tr):    X arayüzlü, yüksek düzeyli, kabuk yorumlayýcý dili
30 Summary(uk):    íÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÄÕÖÅ ×ÉÓÏËÏÇÏ Ò¦×ÎÑ Ú X-¦ÎÔÅÒÆÅÊÓÏÍ
31 Name:           python
32 Version:        %{py_ver}.2
33 Release:        2
34 Epoch:          1
35 License:        PSF
36 Group:          Applications
37 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
38 # Source0-md5:  98db1465629693fc434d4dc52db93838
39 Source1:        http://www.python.org/ftp/python/doc/%{version}/html-%{version}.tar.bz2
40 # Source1-md5:  4e3f177f32e15713130d9d9cf35f991f
41 Patch0:         %{name}-readline.patch
42 Patch1:         %{name}-%{name}path.patch
43 Patch2:         %{name}-no_ndbm.patch
44 Patch3:         %{name}-ac_fixes.patch
45 Patch4:         %{name}-noarch_to_datadir.patch
46 Patch5:         %{name}-lib64.patch
47 Patch6:         %{name}-doc_path.patch
48 URL:            http://www.python.org/
49 BuildRequires:  autoconf
50 BuildRequires:  bzip2-devel
51 BuildRequires:  db-devel >= 4
52 BuildRequires:  expat-devel >= 1:1.95.7
53 BuildRequires:  gdbm-devel >= 1.8.3
54 BuildRequires:  gmp-devel >= 4.0
55 BuildRequires:  ncurses-ext-devel >= 5.2
56 BuildRequires:  libstdc++-devel
57 BuildRequires:  openssl-devel >= 0.9.7d
58 BuildRequires:  readline-devel >= 5.0
59 BuildRequires:  sed >= 4.0
60 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
61 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
62 BuildRequires:  zlib-devel
63 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
64 Obsoletes:      python-xml
65 Obsoletes:      python-intl
66 Obsoletes:      python-curses
67 Obsoletes:      python-gdbm
68 Obsoletes:      python-zlib
69 Obsoletes:      python2
70 Obsoletes:      python2-devel
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %if %{with verbose_tests}
74 %define test_flags -v -l -x 
75 %else
76 %define test_flags -l -x 
77 %endif
78
79 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
80 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
81 %else
82 %define test_list %{nobuilder_tests} %{broken_tests}
83 %endif
84
85 %description
86 Python is an interpreted, interactive, object-oriented programming
87 language. It incorporates modules, exceptions, dynamic typing, very
88 high level dynamic data types, and classes. Python combines remarkable
89 power with very clear syntax. It has interfaces to many system calls
90 and libraries, as well as to various window systems, and is extensible
91 in C or C++. It is also usable as an extension language for
92 applications that need a programmable interface. Finally, Python is
93 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
94 MS-DOS, Windows, Windows NT, and OS/2.
95
96 %description -l de
97 Python ist eine interpretierte, interaktive, objektorientierte
98 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
99 Python enthält Module, Klassen, Exceptions, High-Level dynamische
100 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
101 zu vielen Systemaufrufen und Libraries, sowie verschiedene
102 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
103
104 Programmierer können neue built-in-Module für Python in C oder C++
105 schreiben. Python kann auch als Erweiterungssprache für Applikationen
106 benutzt werden, die ein programmierbares Interface brauchen. Dieses
107 Paket enthält die meisten Standard-Python-Module, und Module zum
108 Ansprechen von Tix (Tk-widget set) und RPM.
109
110 %description -l es
111 Python es un lenguaje de scripts interpretado orientado a objetos.
112 Contiene soporte para carga dinámica de objetos, clases, módulos y
113 excepciones.
114
115 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
116 través de código C, tornando Python fácil de usar en ambientes
117 particulares/personalizados. Este paquete Python incluye la mayoría de
118 los módulos padrón Python, junto con módulos para crear interfaces
119 para el conjunto de componentes Tix para Tk y RPM.
120
121 %description -l fr
122 Python est un langage de script interprété et orienté objet. Il gère
123 le chargement dynamique des objets, les classes, les modules et les
124 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
125 avec du code C est simple, ce qui rend Python facile à utiliser dans
126 des configs personnalisées.
127
128 Ce paquetage Python contient la plupart des modules Python standards,
129 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
130 et RPM.
131
132 %description -l pl
133 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
134 jêzykiem programowania. Jest modularny, obs³uguje wyj±tki, dynamiczne
135 typy, zaawansowane dynamiczne struktury danych i klasy. Python ³±czy w
136 sobie du¿e mo¿liwo¶ci i przejrzyst± sk³adniê. Posiada interfejsy do
137 wielu wywo³añ systemowych i bibliotek, w tym równie¿ do ró¿nych
138 bibliotek okienkowych. Mo¿liwo¶ci jego mo¿na jeszcze rozszerzaæ
139 poprzez odpowiednie modu³y pisane w C lub C++. Python mo¿e byæ równie¿
140 u¿yty jako element aplikacji, którym potrzebny jest interpreter do
141 skryptów. I wreszcie, Python jest wieloplatformowy, dzia³a na wielu
142 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
143 OS/2.
144
145 %description -l pt_BR
146 Python é uma linguagem de scripts interpretada orientada a objetos.
147 Contém suporte para carga dinâmica de objetos, classes, módulos e
148 exceções. Adicionar interfaces para novos sistemas de biblioteca
149 através de código C é simples, tornando Python fácil de usar em
150 ambientes particulares/personalizados.
151
152 Este pacote Python inclui a maioria do módulos padrão Python, junto
153 com módulos para interfaceamento para o conjunto de componentes Tix
154 para Tk e RPM.
155
156 %description -l ru
157 Python - ÜÔÏ ÉÎÔÅÒÐÒÅÔÉÒÕÅÍÙÊ, ÏÂßÅËÔÎÏ-ÏÒÉÅÎÔÉÒÏ×ÁÎÎÙÊ ÑÚÙË
158 ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ. ïΠÐÏÄÄÅÒÖÉ×ÁÅÔ ÄÉÎÁÍÉÞÅÓËÕÀ ÚÁÇÒÕÚËÕ ÏÂßÅËÔÏ×,
159 ËÌÁÓÓÙ, ÍÏÄÕÌÉ É ÏÂÒÁÂÏÔËÕ ÉÓËÌÀÞÉÔÅÌØÎÙÈ ÓÉÔÕÁÃÉÊ (exceptions).
160 ðÒÏÓÔÏÔÁ ÄÏÂÁ×ÌÅÎÉÑ ÉÎÔÅÒÆÅÊÓÏ× Ë ÎÏ×ÙÍ ÓÉÓÔÅÍÎÙÍ ÂÉÂÌÉÏÔÅËÁÍ ÞÅÒÅÚ
161 ËÏÄ ÎÁ ÑÚÙËÅ C ÄÅÌÁÅÔ Python ÈÏÒÏÛÉÍ ×ÙÂÏÒÏÍ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ×
162 ÓÐÅÃÉÁÌØÎÙÈ ËÏÎÆÉÇÕÒÁÃÉÑÈ.
163
164 %description -l tr
165 Python, nesneye yönelik bir kabuk yorumlayýcýdýr. Nesnelerin,
166 sýnýflarýn, modüllerin ve aykýrý durumlarýn dinamik yüklenmelerine
167 destek verir. C koduyla birlikte kullanýmý son derece kolaydýr. Bu
168 paket, standart Python birimlerinin çoðunun yanýsýra Tk ve RPM için
169 arayüz birimlerini de içerir.
170
171 %description -l uk
172 Python - ÃÅ ¦ÎÔÅÒÐÒÅÔÏ×ÁÎÁ, ÏÂ'¤ËÔÎÏ-ÏÒ¦¤ÎÔÏ×ÁÎÁ ÍÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ.
173 ÷¦Î Ð¦ÄÔÒÉÍÕ¤ ÄÉÎÁͦÞÎÕ ÚÁÇÒÕÚËÕ ÏÂ'¤ËÔ¦×, ËÌÁÓÉ, ÍÏÄÕ̦ ÔÁ ÏÂÒÏÂËÕ
174 ×ÉËÌÀÞÎÉÈ ÓÉÔÕÁæʠ(exceptions). ðÒÏÓÔÏÔÁ ÄÏÄÁ×ÁÎÎÑ ¦ÎÔÅÒÆÅÊӦנÄÌÑ
175 ÎÏ×ÉÈ ÓÉÓÔÅÍÎÉȠ¦Â̦ÏÔÅË ÞÅÒÅÚ ËÏÄ ÎÁ ÍÏצ C ÒÏÂÉÔØ Python ÄÏÂÒÉÍ
176 ×ÉÂÏÒÏÍ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎÑ × ÓÐÅæÁÌØÎÉÈ ËÏÎƦÇÕÒÁæÑÈ.
177
178 %package libs
179 Summary:        Python library
180 Summary(pl):    Biblioteka jêzyka Python
181 Group:          Libraries/Python
182 # broken detection in rpm/pythondeps.sh
183 Provides:       python(abi) = %{py_ver}
184 # for compatibility with existing Ac packages
185 Provides:       python(bytecode) = %{py_ver}
186
187 %description libs
188 Python library.
189
190 %description libs -l pl
191 Biblioteka jêzyka Python.
192
193 %package modules
194 Summary:        Python modules
195 Summary(pl):    Modu³y jêzyka Python
196 Group:          Libraries/Python
197 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
198 Obsoletes:      python-logging
199 Obsoletes:      python-optik
200 Obsoletes:      python-xmlrpc <= 1.0.1
201
202 %description modules
203 Python modules.
204
205 %description modules -l pl
206 Modu³y jêzyka Python.
207
208 %package -n pydoc
209 Summary:        Python interactive module documentation access support
210 Summary(pl):    Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python
211 Group:          Applications
212 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
213 Obsoletes:      python-pydoc
214
215 %description -n pydoc
216 Python interactive module documentation access support.
217
218 %description -n pydoc -l pl
219 Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python.
220
221 %package -n idle
222 Summary:        IDE for Python language
223 Summary(pl):    IDE dla jêzyka Python
224 Group:          Applications
225 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
226 Obsoletes:      python-idle
227
228 %description -n idle
229 IDE for Python language.
230
231 %description -n idle -l pl
232 IDE dla jêzyka Python.
233
234 %package devel
235 Summary:        Libraries and header files for building python code
236 Summary(de):    Libraries und Header-Dateien zum Erstellen von Python-Code
237 Summary(es):    Bibliotecas y archivos de inclusión para construir programas en python
238 Summary(fr):    Bibliothèques et en-têtes pour construire du code python
239 Summary(pl):    Pliki nag³ówkowe i biblioteki Pythona
240 Summary(pt_BR): Bibliotecas e arquivos de inclusão para o Python
241 Summary(ru):    âÉÂÌÉÏÔÅËÉ É ÈÅÄÅÒÙ ÄÌÑ ÐÏÓÔÒÏÅÎÉÑ ËÏÄÁ ÎÁ ÑÚÙËÅ Python
242 Summary(tr):    Python ile geliþtirme yapmak için gerekli dosyalar
243 Summary(uk):    â¦Â̦ÏÔÅËÉ ÔÁ ÈÅÄÅÒÉ ÄÌÑ ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÎÁ ÍÏצ Python
244 Group:          Development/Languages/Python
245 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
246
247 %description devel
248 The Python interpreter is relatively easy to extend with dynamically
249 loaded extensions and to embed in other programs. This package
250 contains the header files and libraries which are needed to do both of
251 these tasks.
252
253 %description devel -l de
254 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
255 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
256 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
257 die für beide Aufgaben erforderlich sind.
258
259 %description devel -l es
260 El interpretador Python permite incluir con facilidad extensiones
261 cargadas dinámicamente. Python es también fácil de ser empotrado en
262 otros programas. Este paquete contiene los archivos de inclusión y
263 bibliotecas necesarios para estas dos tareas.
264
265 %description devel -l fr
266 L'interpréteur Python est relativement facile à étendre avec des
267 extensions chargées dynamiquement et à insérer dans d'autres
268 programmes. Ce paquetage contient les en-têtes et les bibliothèques
269 nécessaires à ces deux tâches.
270
271 %description devel -l pl
272 Interpreter Pythona jest w miarê ³atwy do rozszerzania przy pomocy
273 dynamicznie ³adowanych rozszerzeñ napisanych w C lub C++ oraz
274 osadzania w innych programach. Ten pakiet zawiera pliki nag³ówkowe i
275 wszystko inne co potrzebne do tych celów.
276
277 %description devel -l pt_BR
278 O interpretador Python permite incluir com facilidade extensões
279 carregadas dinamicamente. Python é também fácil de ser embutido em
280 outros programas. Este pacote contém os arquivos de inclusão e
281 bibliotecas necessários para estas duas tarefas.
282
283 %description devel -l ru
284 éÎÔÅÒÐÒÅÔÁÔÏÒ Python ÏÔÎÏÓÉÔÅÌØÎÏ ÌÅÇËÏ ÒÁÓÛÉÒÑÅÔÓÑ ÐÒÉ ÐÏÍÏÝÉ
285 ÄÉÎÁÍÉÞÅÓËÉ ÚÁÇÒÕÖÁÅÍÙÈ ÒÁÓÛÉÒÅÎÉÊ É ×ÓÔÒÁÉ×ÁÅÔÓÑ × ÄÒÕÇÉÅ ÐÒÏÇÒÁÍÍÙ.
286 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÈÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÏÂÅÉÈ ÜÔÉÈ
287 ÚÁÄÁÞ.
288
289 %description devel -l tr
290 Bu paket, Python ile geliþtirme yapýlabilmesi için gerekli baþlýk
291 dosyalarýný ve kitaplýklarý içerir.
292
293 %description devel -l uk
294 ¶ÎÔÅÒÐÒÅÔÁÔÏÒ Python ×¦ÄÎÏÓÎÏ ÌÅÇËÏ ÒÏÚÛÉÒÀ¤ÔØÓÑ ÚÁ ÄÏÐÏÍÏÇÏÀ
295 ÒÏÚÛÉÒÅÎØ Ú ÄÉÎÁͦÞÎÏÀ ÚÁÇÒÕÚËÏÀ ÔÁ ×ÂÕÄÏ×Õ¤ÔØÓÑ × ¦ÎÛ¦ ÐÒÏÇÒÁÍÉ. ãÅÊ
296 ÐÁËÅԠͦÓÔÉÔØ ÈÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÏÂÏÈ ÃÉÈ ÚÁÄÁÞ.
297
298 %package devel-src
299 Summary:        Python module sources
300 Summary(pl):    Pliki ¼ród³owe modu³ów Pythona
301 Group:          Development/Languages/Python
302 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
303
304 %description devel-src
305 Python module sources.
306
307 %description devel-src -l pl
308 Pliki ¼ród³owe modu³ów Pythona.
309
310 %package devel-tools
311 Summary:        Python development tools
312 Summary(pl):    Narzêdzia programistyczne jêzyka Python
313 Group:          Development/Languages/Python
314 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
315
316 %description devel-tools
317 Python development tools such as profilers and debugger.
318
319 %description devel-tools -l pl
320 Narzêdzia programistyczne jêzyka Python takie jak profiler oraz debugger.
321
322 %package static
323 Summary:        Static python library
324 Summary(pl):    Statyczna biblioteka Pythona
325 Group:          Development/Languages/Python
326 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
327
328 %description static
329 Static python library.
330
331 %description static -l pl
332 Statyczna biblioteka Pythona.
333
334 %package doc
335 Summary:        Documentation on Python
336 Summary(de):    Dokumentation zu Python
337 Summary(es):    Documentación para Python
338 Summary(fr):    Documentation sur Python
339 Summary(pl):    Dokumentacja do Pythona
340 Summary(pt_BR): Documentação para a linguagem de programação Python
341 Summary(ru):    äÏËÕÍÅÎÔÁÃÉÑ ÐÏ ÑÚÙËÕ Python
342 Summary(tr):    Python belgeleri
343 Summary(uk):    äÏËÕÍÅÎÔÁæѠÐÏ ÍÏצ Python
344 Group:          Documentation
345 Requires:       %{name} = %{epoch}:%{version}-%{release}
346 Obsoletes:      python-docs
347
348 %description doc
349 This package contains documentation on the Python language and
350 interpretor as a mix of plain ASCII files and LaTeX sources.
351
352 %description doc -l de
353 Dieses Paket enthält Dokumentationen zu Python (Sprache und
354 Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
355
356 %description doc -l es
357 Documentación para Python. Contiene archivos en texto y PostScript.
358
359 %description doc -l fr
360 Ce paquetage contient la documentation sur le langage python et sur
361 son interpréteur sous forme de fichiers ASCII et LaTeX.
362
363 %description doc -l pl
364 Oficjalna dokumentacja do Pythona. Zawiera przyk³adowe programy,
365 narzêdzia i dokumentacjê. Strony podrêcznika man znajduj± siê w
366 g³ównym pakiecie. Ten pakiet nie zawiera ¼róde³ dokumentacji
367 napisanych w LaTeXu, tylko gotowe do wykorzystania pliki
368 postscriptowe i HTML.
369
370 %description doc -l pt_BR
371 O pacote python-doc contém documentação para a linguagem de
372 programação e para o interpretador Python. Fornecida em arquivos texto
373 e Postcript.
374
375 %description doc -l ru
376 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÏËÕÍÅÎÔÁÃÉÀ ÐÏ ÓÏÂÓÔ×ÅÎÎÏ ÑÚÙËÕ Python É ÐÏ
377 ÉÓÐÏÌÎÑÀÝÅÍÕ ÅÇÏ ÉÎÔÅÒÐÒÅÔÁÔÏÒÕ × ×ÉÄÅ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÙÈ ÆÁÊÌÏ× É
378 ÉÓÈÏÄÎÙÈ ÔÅËÓÔÏ× × ÆÏÒÍÁÔÅ LaTeX.
379
380 %description doc -l tr
381 Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyalarý ve
382 LaTeX kaynaklarýnýn bir karýþýmý olan yorumlayýcýyý içerir.
383
384 %description doc -l uk
385 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÄÏËÕÍÅÎÔÁæÀ ÐÏ ×ÌÁÓÎÅ ÍÏצ Python ÔÁ ÐÏ ×ÉËÏÎÕÀÞÏÍÕ
386 §§ ¦ÎÔÅÒÐÒÅÔÁÔÏÒÕ Õ ×ÉÇÌÑĦ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÉÈ ÆÁÊ̦נÔÁ ×ÉȦÄÎÉÈ
387 ÔÅËÓԦנՠÆÏÒÍÁÔ¦ LaTeX.
388
389 %package tkinter
390 Summary:        Standard Python interface to the Tk GUI toolkit
391 Summary(de):    Grafische Tk-Schnittstelle für Python
392 Summary(es):    Interfaz de GUI Tk para Python
393 Summary(fr):    Interface graphique Tk pour Python
394 Summary(pl):    Standardowy interfejs Pythona do biblioteki Tk
395 Summary(pt_BR): Interface GUI Tk para Phyton
396 Summary(tr):    Python için grafik kullanýcý arayüzü
397 Group:          Libraries/Python
398 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
399 Requires:       tcl >= 8.4.3
400 Requires:       tix >= 1:8.1.4-4
401 Requires:       tk >= 8.4.3
402 Obsoletes:      tkinter
403
404 %description tkinter
405 Standard Python interface to the Tk GUI toolkit.
406
407 %description tkinter -l de
408 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
409 vielen Konfigurations-Tools genutzt.
410
411 %description tkinter -l es
412 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por
413 muchas herramientas de configuración.
414
415 %description tkinter -l fr
416 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
417 beaucoup des outils de configuration.
418
419 %description tkinter -l pl
420 Standardowy interfejs Pythona do biblioteki Tk.
421
422 %description tkinter -l pt_BR
423 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
424 muitas ferramentas de configuração.
425
426 %description tkinter -l ru
427 çÒÁÆÉÞÅÓËÉÊ ÉÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÓÔÒÏÅÎÎÙÊ ÎÁ Tcl/Tk.
428
429 %description tkinter -l tr
430 Python için Tcl/Tk'ye dayalý ve pek çok ayarlama aracý tarafýndan
431 kullanýlan grafik bir arayüzdür.
432
433 %description tkinter -l uk
434 çÒÁƦÞÎÉÊ ¦ÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÂÕÄÏ×ÁÎÉÊ ÎÁ Tcl/Tk.
435
436 %package old
437 Summary:        Deprecated Python modules
438 Summary(pl):    Nieaktualne modu³y jêzyka Python
439 Group:          Libraries/Python
440 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
441
442 %description old
443 Install this package when one of your program written in Python is old
444 as Miss Universum of 1918, who only you want to see... ooops, which
445 only you want to run.
446
447 %description old -l pl
448 Zainstaluj ten pakiet, wtedy kiedy jeden z Twoich programów napisanych
449 w jêzyku Python jest tak stary jak Miss Universum z roku 1918, któr±
450 tylko ty chcesz zobaczyæ... przepraszam, który tylko ty chcesz
451 uruchomiæ.
452
453 %package examples
454 Summary:        Example programs in Python
455 Summary(pl):    Przyk³adowe programy w Pythonie
456 Group:          Development/Languages/Python
457 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
458 Obsoletes:      python-tools
459
460 %description examples
461 Example programs in Python.
462
463 These are for Python 2.3.4, not %{version}.
464
465 %description examples -l pl
466 Przyk³adowe programy w Pythonie.
467
468 Przyk³ady te s± dla Pythona 2.3.4, nie %{version}.
469
470 %prep
471 %setup -q -n Python-%{version}
472 %patch0 -p1
473 %patch1 -p1
474 %patch2 -p1
475 %patch3 -p1
476 %patch4 -p1
477 %if "%{_lib}" == "lib64"
478 %patch5 -p1
479 %endif
480 %patch6 -p1
481
482 tar -xf %{SOURCE1} --use=bzip2
483
484 %build
485 sed -i -e 's#-ltermcap#-ltinfo#g' configure*
486 %{__autoconf}
487 CPPFLAGS="-I%{_includedir}/ncurses"; export CPPFLAGS
488 %configure \
489         --with-threads \
490         --with-cxx="%{__cxx}" \
491         --enable-unicode=ucs4 \
492         --enable-shared \
493         LINKCC='$(PURIFY) $(CXX)'
494
495 %{__make} \
496         OPT="%{rpmcflags}"
497
498 LC_ALL=C
499 export LC_ALL
500 %if %{with tests}
501 binlibdir=`echo build/lib.*`
502 %{__make} test \
503         TESTOPTS="%{test_flags} %{test_list}" \
504         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
505 %endif
506
507 %install
508 rm -rf $RPM_BUILD_ROOT
509 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
510         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
511         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
512
513 %{__make} install \
514         DESTDIR=$RPM_BUILD_ROOT
515
516 install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
517
518 install libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}
519 ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
520 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython.so
521 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{py_ver}.so
522
523 rm -f $RPM_BUILD_ROOT%{_bindir}/python%{py_ver}
524
525 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
526 cp -ar Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
527
528 SCRIPT_EXT=".py"
529 export SCRIPT_EXT
530
531 # create several useful scripts, such as timeit.py, profile.py, pdb.py, smtpd.py
532 for script in timeit profile pdb pstats smtpd; do
533     cat <<END > $RPM_BUILD_ROOT%{_bindir}/${script}$SCRIPT_EXT
534 #!/bin/sh
535 exec python %{py_scriptdir}/${script}.pyc "\$@"
536 END
537 done
538
539 # xgettext specific for Python code
540 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext$SCRIPT_EXT
541
542 %clean
543 rm -rf $RPM_BUILD_ROOT
544
545 %post   libs -p /sbin/ldconfig
546 %postun libs -p /sbin/ldconfig
547
548 %files
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_bindir}/python
551 %{_mandir}/man1/*
552
553 %files modules
554 %defattr(644,root,root,755)
555 %exclude %{py_scriptdir}/UserDict.py[co]
556 %exclude %{py_scriptdir}/codecs.py[co]
557 %exclude %{py_scriptdir}/copy_reg.py[co]
558 %exclude %{py_scriptdir}/locale.py[co]
559 %exclude %{py_scriptdir}/posixpath.py[co]
560 %exclude %{py_scriptdir}/pdb.py[co]
561 %exclude %{py_scriptdir}/profile.py[co]
562 %exclude %{py_scriptdir}/pstats.py[co]
563 %exclude %{py_scriptdir}/pydoc.py[co]
564 %exclude %{py_scriptdir}/site.py[co]
565 %exclude %{py_scriptdir}/stat.py[co]
566 %exclude %{py_scriptdir}/timeit.py[co]
567 %exclude %{py_scriptdir}/os.py[co]
568 %exclude %{py_scriptdir}/encodings/*.py[co]
569
570 %{py_scriptdir}/*.py[co]
571
572 #
573 # list .so modules to be sure that all of them are built
574 #
575
576 # three modules below does not work on 64-bit architectures
577 # see Python README file for explanation
578 %ifnarch alpha ia64 ppc64 sparc64 %{x8664}
579 %attr(755,root,root) %{py_dyndir}/audioop.so
580 %attr(755,root,root) %{py_dyndir}/rgbimg.so
581 %attr(755,root,root) %{py_dyndir}/imageop.so
582 # sizeof(long) != sizeof(int), so dl module will not be built on 64-bit
583 # platforms
584 %attr(755,root,root) %{py_dyndir}/dl.so
585 %endif
586
587 %attr(755,root,root) %{py_dyndir}/_bisect.so
588 %attr(755,root,root) %{py_dyndir}/_bsddb.so
589 %attr(755,root,root) %{py_dyndir}/_codecs_cn.so
590 %attr(755,root,root) %{py_dyndir}/_codecs_hk.so
591 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
592 %attr(755,root,root) %{py_dyndir}/_codecs_jp.so
593 %attr(755,root,root) %{py_dyndir}/_codecs_kr.so
594 %attr(755,root,root) %{py_dyndir}/_codecs_tw.so
595 %attr(755,root,root) %{py_dyndir}/_csv.so
596 %attr(755,root,root) %{py_dyndir}/_curses.so
597 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
598 %attr(755,root,root) %{py_dyndir}/_heapq.so
599 %attr(755,root,root) %{py_dyndir}/_locale.so
600 %attr(755,root,root) %{py_dyndir}/_multibytecodec.so
601 %attr(755,root,root) %{py_dyndir}/_random.so
602 %attr(755,root,root) %{py_dyndir}/_socket.so
603 %attr(755,root,root) %{py_dyndir}/_ssl.so
604 %attr(755,root,root) %{py_dyndir}/_testcapi.so
605 %attr(755,root,root) %{py_dyndir}/_weakref.so
606 %attr(755,root,root) %{py_dyndir}/array.so
607 %attr(755,root,root) %{py_dyndir}/binascii.so
608 %attr(755,root,root) %{py_dyndir}/bz2.so
609 %attr(755,root,root) %{py_dyndir}/cPickle.so
610 %attr(755,root,root) %{py_dyndir}/cStringIO.so
611 %attr(755,root,root) %{py_dyndir}/cmath.so
612 %attr(755,root,root) %{py_dyndir}/collections.so
613 %attr(755,root,root) %{py_dyndir}/crypt.so
614 %attr(755,root,root) %{py_dyndir}/datetime.so
615 %ifnarch sparc64
616 %attr(755,root,root) %{py_dyndir}/dbm.so
617 %endif
618 %attr(755,root,root) %{py_dyndir}/fcntl.so
619 %attr(755,root,root) %{py_dyndir}/gdbm.so
620 %attr(755,root,root) %{py_dyndir}/grp.so
621 %attr(755,root,root) %{py_dyndir}/itertools.so
622 %attr(755,root,root) %{py_dyndir}/linuxaudiodev.so
623 %attr(755,root,root) %{py_dyndir}/math.so
624 %attr(755,root,root) %{py_dyndir}/md5.so
625 %attr(755,root,root) %{py_dyndir}/mmap.so
626 %attr(755,root,root) %{py_dyndir}/nis.so
627 %attr(755,root,root) %{py_dyndir}/operator.so
628 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
629 %attr(755,root,root) %{py_dyndir}/parser.so
630 %attr(755,root,root) %{py_dyndir}/pwd.so
631 %attr(755,root,root) %{py_dyndir}/pyexpat.so
632 %attr(755,root,root) %{py_dyndir}/readline.so
633 %attr(755,root,root) %{py_dyndir}/regex.so
634 %attr(755,root,root) %{py_dyndir}/resource.so
635 %attr(755,root,root) %{py_dyndir}/select.so
636 %attr(755,root,root) %{py_dyndir}/sha.so
637 %attr(755,root,root) %{py_dyndir}/strop.so
638 %attr(755,root,root) %{py_dyndir}/syslog.so
639 %attr(755,root,root) %{py_dyndir}/termios.so
640 %attr(755,root,root) %{py_dyndir}/time.so
641 %attr(755,root,root) %{py_dyndir}/timing.so
642 %attr(755,root,root) %{py_dyndir}/unicodedata.so
643 %attr(755,root,root) %{py_dyndir}/zlib.so
644
645 %dir %{py_scriptdir}/plat-*
646 %attr(755,root,root) %{py_scriptdir}/plat-*/regen
647 %{py_scriptdir}/plat-*/*.py[co]
648
649 %dir %{py_scriptdir}/bsddb
650 %{py_scriptdir}/bsddb/*.py[co]
651
652 %dir %{py_scriptdir}/compiler
653 %{py_scriptdir}/compiler/*.py[co]
654
655 %dir %{py_scriptdir}/curses
656 %{py_scriptdir}/curses/*.py[co]
657
658 %dir %{py_scriptdir}/distutils
659 %{py_scriptdir}/distutils/*.py[co]
660
661 %dir %{py_scriptdir}/distutils/command
662 %{py_scriptdir}/distutils/command/*.py[co]
663
664 %dir %{py_scriptdir}/email
665 %{py_scriptdir}/email/*.py[co]
666
667 %dir %{py_scriptdir}/logging
668 %{py_scriptdir}/logging/*.py[co]
669
670 %dir %{py_scriptdir}/xml
671 %{py_scriptdir}/xml/*.py[co]
672
673 %dir %{py_scriptdir}/xml/parsers
674 %{py_scriptdir}/xml/parsers/*.py[co]
675
676 %dir %{py_scriptdir}/xml/sax
677 %{py_scriptdir}/xml/sax/*.py[co]
678
679 %dir %{py_scriptdir}/xml/dom
680 %{py_scriptdir}/xml/dom/*.py[co]
681
682 %files libs
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_libdir}/libpython*.so.*
685
686 %dir %{py_dyndir}
687 %dir %{py_scriptdir}
688 %dir %{py_libdir}
689 %dir %{py_sitescriptdir}
690 %dir %{py_sitedir}
691
692 # shared modules required by python library
693 %attr(755,root,root) %{py_dyndir}/struct.so
694
695 # modules required by python library
696 %{py_scriptdir}/UserDict.py[co]
697 %{py_scriptdir}/codecs.py[co]
698 %{py_scriptdir}/copy_reg.py[co]
699 %{py_scriptdir}/locale.py[co]
700 %{py_scriptdir}/posixpath.py[co]
701 %{py_scriptdir}/site.py[co]
702 %{py_scriptdir}/stat.py[co]
703 %{py_scriptdir}/os.py[co]
704
705 # encodings required by python library
706 %dir %{py_scriptdir}/encodings
707 %{py_scriptdir}/encodings/*.py[co]
708
709 %files -n pydoc
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_bindir}/pydoc
712 %{py_scriptdir}/pydoc.py[co]
713
714 %files -n idle
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_bindir}/idle
717 %dir %{py_scriptdir}/idlelib
718 %dir %{py_scriptdir}/idlelib/Icons
719 %{py_scriptdir}/idlelib/*.py[co]
720 %{py_scriptdir}/idlelib/Icons/*
721 %{py_scriptdir}/idlelib/*.def
722
723 %files devel
724 %defattr(644,root,root,755)
725 %doc Misc/{ACKS,NEWS,README}
726 %attr(755,root,root) %{_libdir}/lib*.so
727 %dir %{py_incdir}
728 %{py_incdir}/*.h
729
730 %dir %{py_libdir}/config
731 %attr(755,root,root) %{py_libdir}/config/makesetup
732 %attr(755,root,root) %{py_libdir}/config/install-sh
733 %{py_libdir}/config/Makefile
734 %{py_libdir}/config/Makefile.pre.in
735 %{py_libdir}/config/Setup
736 %{py_libdir}/config/Setup.config
737 %{py_libdir}/config/Setup.local
738 %{py_libdir}/config/config.c
739 %{py_libdir}/config/config.c.in
740 %{py_libdir}/config/ccpython.o
741 %{py_libdir}/config/libpython2.4.a
742
743 %files devel-src
744 %defattr(644,root,root,755)
745 %attr(-,root,root) %{py_scriptdir}/*.py
746 %{py_scriptdir}/plat-*/*.py
747 %{py_scriptdir}/bsddb/*.py
748 %{py_scriptdir}/compiler/*.py
749 %{py_scriptdir}/curses/*.py
750 %{py_scriptdir}/distutils/*.py
751 %{py_scriptdir}/distutils/command/*.py
752 %{py_scriptdir}/email/*.py
753 %{py_scriptdir}/hotshot/*.py
754 %{py_scriptdir}/logging/*.py
755 %{py_scriptdir}/xml/*.py
756 %{py_scriptdir}/xml/parsers/*.py
757 %{py_scriptdir}/xml/sax/*.py
758 %{py_scriptdir}/xml/dom/*.py
759 %{py_scriptdir}/encodings/*.py
760 %{py_scriptdir}/idlelib/*.py
761
762 %files devel-tools
763 %defattr(644,root,root,755)
764 %doc Lib/profile.doc Lib/pdb.doc
765 %attr(755,root,root) %{_bindir}/timeit*
766 %attr(755,root,root) %{_bindir}/profile*
767 %attr(755,root,root) %{_bindir}/pdb*
768 %attr(755,root,root) %{_bindir}/pstats*
769 %attr(755,root,root) %{_bindir}/pygettext*
770 %attr(755,root,root) %{_bindir}/smtpd*
771
772 %attr(755,root,root) %{py_dyndir}/_hotshot.so
773 %dir %{py_scriptdir}/hotshot
774 %{py_scriptdir}/hotshot/*.py[co]
775 %{py_scriptdir}/pdb.py[co]
776 %{py_scriptdir}/profile.py[co]
777 %{py_scriptdir}/pstats.py[co]
778 %{py_scriptdir}/timeit.py[co]
779
780 %files static
781 %defattr(644,root,root,755)
782 %{_libdir}/lib*.a
783
784 %files examples
785 %defattr(644,root,root,755)
786 %{_examplesdir}/%{name}-%{version}
787
788 %files doc
789 %defattr(644,root,root,755)
790 # FIXME
791 %doc Python-Docs-%{version}
792 %attr(-,root,root) %{py_scriptdir}/test
793 %attr(-,root,root) %{py_scriptdir}/email/test
794 %attr(-,root,root) %{py_scriptdir}/bsddb/test
795
796 %if %{with tkinter}
797 %files tkinter
798 %defattr(644,root,root,755)
799 %{py_scriptdir}/lib-tk
800 %attr(755,root,root) %{py_dyndir}/_tkinter.so
801 %endif
802
803 %files old
804 %defattr(644,root,root,755)
805 %dir %{py_scriptdir}/lib-old
806 %{py_scriptdir}/lib-old/*.py[co]
This page took 0.112094 seconds and 4 git commands to generate.