]> git.pld-linux.org Git - packages/python.git/blob - python.spec
- strict internal deps, unifications
[packages/python.git] / python.spec
1 #
2 # Conditional build:
3 %bcond_without tkinter          # disables tkinter module building
4 %bcond_without tests            # disables Python testing
5 %bcond_with verbose_tests       # runs tests in verbose mode
6 #
7 # tests which will not work on 64-bit platforms
8 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
9 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
10 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale
11 # tests which fail because of some unknown/unresolved reason (this list should be empty)
12 %define         broken_tests test_anydbm test_bsddb test_re test_shelve test_whichdb test_zipimport
13
14 %define py_ver         2.3
15 %define py_prefix      %{_prefix}
16 %define py_libdir      %{py_prefix}/%{_lib}/python%{py_ver}
17 %define py_scriptdir   %{py_prefix}/share/python%{py_ver}
18 %define py_incdir      %{_includedir}/python%{py_ver}
19 %define py_sitedir     %{py_libdir}/site-packages
20 %define py_sitescriptdir %{py_scriptdir}/site-packages
21 %define py_dyndir      %{py_libdir}/lib-dynload
22 %define py_comp        ./python -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
23 %define py_ocomp       ./python -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
24
25 Summary:        Very high level scripting language with X interface
26 Summary(de):    Very High-Level-Script-Sprache mit X-Oberfläche
27 Summary(es):    Lenguaje script de alto nivel con interface X
28 Summary(fr):    Langage de script de tés haut niveau avec interface X
29 Summary(pl):    Python - jêzyk obiektowy wysokiego poziomu
30 Summary(pt_BR): Linguagem de programação interpretada, orientada a objeto de alto nível
31 Summary(ru):    ñÚÙË ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ ÏÞÅÎØ ×ÙÓÏËÏÇÏ ÕÒÏ×ÎÑ Ó X-ÉÎÔÅÒÆÅÊÓÏÍ
32 Summary(tr):    X arayüzlü, yüksek düzeyli, kabuk yorumlayýcý dili
33 Summary(uk):    íÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÄÕÖÅ ×ÉÓÏËÏÇÏ Ò¦×ÎÑ Ú X-¦ÎÔÅÒÆÅÊÓÏÍ
34 Name:           python
35 Version:        %{py_ver}.3
36 Release:        4
37 Epoch:          1
38 License:        PSF
39 Group:          Applications
40 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
41 # Source0-md5:  70ada9f65742ab2c77a96bcd6dffd9b1
42 Source1:        http://www.python.org/ftp/python/doc/%{version}/html-%{version}.tar.bz2
43 # Source1-md5:  5ec6e5782a3caf5177a3d47272a0267f
44 Patch0:         %{name}-readline.patch
45 Patch1:         %{name}-%{name}path.patch
46 Patch2:         %{name}-default_encoding.patch
47 Patch3:         %{name}-no_ndbm.patch
48 Patch4:         %{name}-ac_fixes.patch
49 Patch5:         %{name}-noarch_to_datadir.patch
50 Patch6:         %{name}-lib64.patch
51 Patch7:         %{name}-doc_path.patch
52 URL:            http://www.python.org/
53 BuildRequires:  autoconf
54 BuildRequires:  db-devel >= 4
55 BuildRequires:  gdbm-devel >= 1.8.3
56 BuildRequires:  expat-devel >= 1.95.7
57 BuildRequires:  gmp-devel >= 4.0
58 BuildRequires:  ncurses-devel >= 5.2
59 BuildRequires:  openssl-devel >= 0.9.7d
60 BuildRequires:  readline-devel >= 4.2
61 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
62 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
63 BuildRequires:  zlib-devel
64 Requires:       python-libs = %{epoch}:%{version}-%{release}
65 Provides:       %{name} = %{py_ver}
66 Obsoletes:      python-xml
67 Obsoletes:      python-intl
68 Obsoletes:      python-curses
69 Obsoletes:      python-gdbm
70 Obsoletes:      python-zlib
71 Obsoletes:      python2
72 Obsoletes:      python2-devel
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %if %{with verbose_tests}
76 %define test_flags -v -l -x 
77 %else
78 %define test_flags -l -x 
79 %endif
80
81 %ifarch alpha sparc64 ppc64 amd64
82 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
83 %else
84 %define test_list %{nobuilder_tests} %{broken_tests}
85 %endif
86
87 %description
88 Python is an interpreted, interactive, object-oriented programming
89 language. It incorporates modules, exceptions, dynamic typing, very
90 high level dynamic data types, and classes. Python combines remarkable
91 power with very clear syntax. It has interfaces to many system calls
92 and libraries, as well as to various window systems, and is extensible
93 in C or C++. It is also usable as an extension language for
94 applications that need a programmable interface. Finally, Python is
95 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
96 MS-DOS, Windows, Windows NT, and OS/2.
97
98 %description -l de
99 Python ist eine interpretierte, interaktive, objektorientierte
100 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
101 Python enthält Module, Klassen, Exceptions, High-Level dynamische
102 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
103 zu vielen Systemaufrufen und Libraries, sowie verschiedene
104 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
105
106 Programmierer können neue built-in-Module für Python in C oder C++
107 schreiben. Python kann auch als Erweiterungssprache für Applikationen
108 benutzt werden, die ein programmierbares Interface brauchen. Dieses
109 Paket enthält die meisten Standard-Python-Module, und Module zum
110 Ansprechen von Tix (Tk-widget set) und RPM.
111
112 %description -l es
113 Python es un lenguaje de scripts interpretado orientado a objetos.
114 Contiene soporte para carga dinámica de objetos, clases, módulos y
115 excepciones.
116
117 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
118 través de código C, tornando Python fácil de usar en ambientes
119 articulares/ personalizados. Este paquete Python incluye la mayoría de
120 los módulos padrón Python, junto con módulos para crear interfaces
121 para el conjunto de componentes Tix para Tk y RPM.
122
123 %description -l fr
124 Python est un langage de script interprété et orienté objet. Il gère
125 le chargement dynamique des objets, les classes, les modules et les
126 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
127 avec du code C est simple, ce qui rend Python facile à utiliser dans
128 des configs personnalisées.
129
130 Ce paquetage Python contient la plupart des modules Python standards,
131 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
132 et RPM.
133
134 %description -l pl
135 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
136 jêzykiem programowania. Jest modularny, obs³uguje wyj±tki, dynamiczne
137 typy, zaawansowane dynamiczne struktury danych i klasy. Python ³±czy w
138 sobie du¿e mo¿liwo¶ci i przejrzyst± sk³adniê. Posiada interfejsy do
139 wielu wywo³añ systemowych i bibliotek, w tym równie¿ do ró¿nych
140 bibliotek okienkowych. Mo¿liwo¶ci jego mo¿na jeszcze rozszerzaæ
141 poprzez odpowiednie modu³y pisane w C lub C++. Python mo¿e byæ równie¿
142 u¿yty jako element aplikacji, którym potrzebny jest interpreter do
143 skryptów. I wreszcie, Python jest wieloplatformowy, dzia³a na wielu
144 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
145 OS/2.
146
147 %description -l pt_BR
148 Python é uma linguagem de scripts interpretada orientada a objetos.
149 Contém suporte para carga dinâmica de objetos, classes, módulos e
150 exceções. Adicionar interfaces para novos sistemas de biblioteca
151 através de código C é simples, tornando Python fácil de usar em
152 ambientes particulares/personalizados.
153
154 Este pacote Python inclui a maioria do módulos padrão Python, junto
155 com módulos para interfaceamento para o conjunto de componentes Tix
156 para Tk e RPM.
157
158 %description -l ru
159 Python - ÜÔÏ ÉÎÔÅÒÐÒÅÔÉÒÕÅÍÙÊ, ÏÂßÅËÔÎÏ-ÏÒÉÅÎÔÉÒÏ×ÁÎÎÙÊ ÑÚÙË
160 ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ. ïΠÐÏÄÄÅÒÖÉ×ÁÅÔ ÄÉÎÁÍÉÞÅÓËÕÀ ÚÁÇÒÕÚËÕ ÏÂßÅËÔÏ×,
161 ËÌÁÓÓÙ, ÍÏÄÕÌÉ É ÏÂÒÁÂÏÔËÕ ÉÓËÌÀÞÉÔÅÌØÎÙÈ ÓÉÔÕÁÃÉÊ (exceptions).
162 ðÒÏÓÔÏÔÁ ÄÏÂÁ×ÌÅÎÉÑ ÉÎÔÅÒÆÅÊÓÏ× Ë ÎÏ×ÙÍ ÓÉÓÔÅÍÎÙÍ ÂÉÂÌÉÏÔÅËÁÍ ÞÅÒÅÚ
163 ËÏÄ ÎÁ ÑÚÙËÅ C ÄÅÌÁÅÔ Python ÈÏÒÏÛÉÍ ×ÙÂÏÒÏÍ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ×
164 ÓÐÅÃÉÁÌØÎÙÈ ËÏÎÆÉÇÕÒÁÃÉÑÈ.
165
166 %description -l tr
167 Python, nesneye yönelik bir kabuk yorumlayýcýdýr. Nesnelerin,
168 sýnýflarýn, modüllerin ve aykýrý durumlarýn dinamik yüklenmelerine
169 destek verir. C koduyla birlikte kullanýmý son derece kolaydýr. Bu
170 paket, standart Python birimlerinin çoðunun yanýsýra Tk ve RPM için
171 arayüz birimlerini de içerir.
172
173 %description -l uk
174 Python - ÃÅ ¦ÎÔÅÒÐÒÅÔÏ×ÁÎÁ, ÏÂ'¤ËÔÎÏ-ÏÒ¦¤ÎÔÏ×ÁÎÁ ÍÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ.
175 ÷¦Î Ð¦ÄÔÒÉÍÕ¤ ÄÉÎÁͦÞÎÕ ÚÁÇÒÕÚËÕ ÏÂ'¤ËÔ¦×, ËÌÁÓÉ, ÍÏÄÕ̦ ÔÁ ÏÂÒÏÂËÕ
176 ×ÉËÌÀÞÎÉÈ ÓÉÔÕÁæʠ(exceptions). ðÒÏÓÔÏÔÁ ÄÏÄÁ×ÁÎÎÑ ¦ÎÔÅÒÆÅÊӦנÄÌÑ
177 ÎÏ×ÉÈ ÓÉÓÔÅÍÎÉȠ¦Â̦ÏÔÅË ÞÅÒÅÚ ËÏÄ ÎÁ ÍÏצ C ÒÏÂÉÔØ Python ÄÏÂÒÉÍ
178 ×ÉÂÏÒÏÍ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎÑ × ÓÐÅæÁÌØÎÉÈ ËÏÎƦÇÕÒÁæÑÈ.
179
180 %package libs
181 Summary:        Python library
182 Summary(pl):    Biblioteka jêzyka Python
183 Group:          Libraries/Python
184 Provides:       %{name}-libs = %{py_ver}
185
186 %description libs
187 Python library.
188
189 %description libs -l pl
190 Biblioteka jêzyka Python.
191
192 %package modules
193 Summary:        Python modules
194 Summary(pl):    Modu³y jêzyka Python
195 Group:          Libraries/Python
196 Requires:       %{name} = %{epoch}:%{version}-%{release}
197 Provides:       %{name}-modules = %{py_ver}
198 Obsoletes:      python-logging
199 Obsoletes:      python-xmlrpc <= 1.0.1
200
201 %description modules
202 Python modules.
203
204 %description modules -l pl
205 Modu³y jêzyka Python.
206
207 %package -n pydoc
208 Summary:        Python interactive module documentation access support
209 Summary(pl):    Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python
210 Group:          Applications
211 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
212 Obsoletes:      python-pydoc
213
214 %description -n pydoc
215 Python interactive module documentation access support.
216
217 %description -n pydoc -l pl
218 Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python.
219
220 %package -n idle
221 Summary:        IDE for Python language
222 Summary(pl):    IDE dla jêzyka Python
223 Group:          Applications
224 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
225 Obsoletes:      python-idle
226
227 %description -n idle
228 IDE for Python language.
229
230 %description -n idle -l pl
231 IDE dla jêzyka Python.
232
233 %package devel
234 Summary:        Libraries and header files for building python code
235 Summary(de):    Libraries und Header-Dateien zum Erstellen von Python-Code
236 Summary(es):    Bibliotecas y archivos de inclusión para construir programas en python
237 Summary(fr):    Bibliothèques et en-têtes pour construire du code python
238 Summary(pl):    Pliki nag³ówkowe i biblioteki Pythona
239 Summary(pt_BR): Bibliotecas e arquivos de inclusão para o Python
240 Summary(ru):    âÉÂÌÉÏÔÅËÉ É ÈÅÄÅÒÙ ÄÌÑ ÐÏÓÔÒÏÅÎÉÑ ËÏÄÁ ÎÁ ÑÚÙËÅ Python
241 Summary(tr):    Python ile geliþtirme yapmak için gerekli dosyalar
242 Summary(uk):    â¦Â̦ÏÔÅËÉ ÔÁ ÈÅÄÅÒÉ ÄÌÑ ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÎÁ ÍÏצ Python
243 Group:          Development/Languages/Python
244 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
245
246 %description devel
247 The Python interpreter is relatively easy to extend with dynamically
248 loaded extensions and to embed in other programs. This package
249 contains the header files and libraries which are needed to do both of
250 these tasks.
251
252 %description devel -l de
253 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
254 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
255 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
256 die für beide Aufgaben erforderlich sind.
257
258 %description devel -l es
259 El interpretador Python permite incluir con facilidad extensiones
260 cargadas dinámicamente. Python es también fácil de ser empotrado en
261 otros programas. Este paquete contiene los archivos de inclusión y
262 bibliotecas necesarios para estas dos tareas.
263
264 %description devel -l fr
265 L'interpréteur Python est relativement facile à étendre avec des
266 extensions chargées dynamiquement et à insérer dans d'autres
267 programmes. Ce paquetage contient les en-têtes et les bibliothèques
268 nécessaires à ces deux tâches.
269
270 %description devel -l pl
271 Interpreter Pythona jest w miarê ³atwy do rozszerzania przy pomocy
272 dynamicznie ³adowanych rozszerzeñ napisanych w C lub C++ oraz
273 osadzania w innych programach. Ten pakiet zawiera pliki nag³ówkowe i
274 wszystko inne co potrzebne do tych celów.
275
276 %description devel -l pt_BR
277 O interpretador Python permite incluir com facilidade extensões
278 carregadas dinamicamente. Python é também fácil de ser embutido em
279 outros programas. Este pacote contém os arquivos de inclusão e
280 bibliotecas necessários para estas duas tarefas.
281
282 %description devel -l ru
283 éÎÔÅÒÐÒÅÔÁÔÏÒ Python ÏÔÎÏÓÉÔÅÌØÎÏ ÌÅÇËÏ ÒÁÓÛÉÒÑÅÔÓÑ ÐÒÉ ÐÏÍÏÝÉ
284 ÄÉÎÁÍÉÞÅÓËÉ ÚÁÇÒÕÖÁÅÍÙÈ ÒÁÓÛÉÒÅÎÉÊ É ×ÓÔÒÁÉ×ÁÅÔÓÑ × ÄÒÕÇÉÅ ÐÒÏÇÒÁÍÍÙ.
285 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÈÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÏÂÅÉÈ ÜÔÉÈ
286 ÚÁÄÁÞ.
287
288 %description devel -l tr
289 Bu paket, Python ile geliþtirme yapýlabilmesi için gerekli baþlýk
290 dosyalarýný ve kitaplýklarý içerir.
291
292 %description devel -l uk
293 ¶ÎÔÅÒÐÒÅÔÁÔÏÒ Python ×¦ÄÎÏÓÎÏ ÌÅÇËÏ ÒÏÚÛÉÒÀ¤ÔØÓÑ ÚÁ ÄÏÐÏÍÏÇÏÀ
294 ÒÏÚÛÉÒÅÎØ Ú ÄÉÎÁͦÞÎÏÀ ÚÁÇÒÕÚËÏÀ ÔÁ ×ÂÕÄÏ×Õ¤ÔØÓÑ × ¦ÎÛ¦ ÐÒÏÇÒÁÍÉ. ãÅÊ
295 ÐÁËÅԠͦÓÔÉÔØ ÈÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÏÂÏÈ ÃÉÈ ÚÁÄÁÞ.
296
297 %package devel-src
298 Summary:        Python module sources
299 Summary(pl):    Pliki ¼ród³owe modu³ów Pythona
300 Group:          Development/Languages/Python
301 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
302
303 %description devel-src
304 Python module sources.
305
306 %description devel-src -l pl
307 Pliki ¼ród³owe modu³ów Pythona.
308
309 %package devel-tools
310 Summary:        Python development tools
311 Summary(pl):    Narzêdzia programistyczne jêzyka Python
312 Group:          Development/Languages/Python
313 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
314
315 %description devel-tools
316 Python development tools such as profilers and debugger.
317
318 %description devel-tools -l pl
319 Narzêdzia programistyczne jêzyka Python takie jak profiler oraz debugger.
320
321 %package static
322 Summary:        Static python library
323 Summary(pl):    Statyczna biblioteka Pythona
324 Group:          Development/Languages/Python
325 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
326 Provides:       %{name}-static = %{py_ver}
327
328 %description static
329 Static python library.
330
331 %description static -l pl
332 Statyczna biblioteka Pythona.
333
334 %package doc
335 Summary:        Documentation on Python
336 Summary(de):    Dokumentation zu Python
337 Summary(es):    Documentación para Python
338 Summary(fr):    Documentation sur Python
339 Summary(pl):    Dokumentacja do Pythona
340 Summary(pt_BR): Documentação para a linguagem de programação Python
341 Summary(ru):    äÏËÕÍÅÎÔÁÃÉÑ ÐÏ ÑÚÙËÕ Python
342 Summary(tr):    Python belgeleri
343 Summary(uk):    äÏËÕÍÅÎÔÁæѠÐÏ ÍÏצ Python
344 Group:          Documentation
345 Requires:       %{name} = %{epoch}:%{version}-%{release}
346 Obsoletes:      python-docs
347
348 %description doc
349 This package contains documentation on the Python language and
350 interpretor as a mix of plain ASCII files and LaTeX sources.
351
352 %description doc -l de
353 Dieses Paket enthält Dokumentationen zu Python (Sprache und
354 Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
355
356 %description doc -l es
357 Documentación para Python. Contiene archivos en texto y PostScript.
358
359 %description doc -l fr
360 Ce paquetage contient la documentation sur le langage python et sur
361 son interpréteur sous forme de fichiers ASCII et LaTeX.
362
363 %description doc -l pl
364 Oficjalna dokumentacja do Pythona. Zawiera przyk³adowe programy,
365 narzêdzia i dokumentacjê. Strony podrêcznika man znajduj± siê w
366 g³ównym pakiecie. Ten pakiet nie zawiera ¼róde³ dokumentacji
367 napisanych w LaTeXu, tylko gotowe do wykorzystania pliki
368 postscriptowe i HTML.
369
370 %description doc -l pt_BR
371 O pacote python-doc contém documentação para a linguagem de
372 programação e para o interpretador Python. Fornecida em arquivos texto
373 e Postcript.
374
375 %description doc -l ru
376 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÏËÕÍÅÎÔÁÃÉÀ ÐÏ ÓÏÂÓÔ×ÅÎÎÏ ÑÚÙËÕ Python É ÐÏ
377 ÉÓÐÏÌÎÑÀÝÅÍÕ ÅÇÏ ÉÎÔÅÒÐÒÅÔÁÔÏÒÕ × ×ÉÄÅ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÙÈ ÆÁÊÌÏ× É
378 ÉÓÈÏÄÎÙÈ ÔÅËÓÔÏ× × ÆÏÒÍÁÔÅ LaTeX.
379
380 %description doc -l tr
381 Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyalarý ve
382 LaTeX kaynaklarýnýn bir karýþýmý olan yorumlayýcýyý içerir.
383
384 %description doc -l uk
385 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÄÏËÕÍÅÎÔÁæÀ ÐÏ ×ÌÁÓÎÅ ÍÏצ Python ÔÁ ÐÏ ×ÉËÏÎÕÀÞÏÍÕ
386 §§ ¦ÎÔÅÒÐÒÅÔÁÔÏÒÕ Õ ×ÉÇÌÑĦ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÉÈ ÆÁÊ̦נÔÁ ×ÉȦÄÎÉÈ
387 ÔÅËÓԦנՠÆÏÒÍÁÔ¦ LaTeX.
388
389 %package tkinter
390 Summary:        Standard Python interface to the Tk GUI toolkit
391 Summary(de):    Grafischer Oberfläche für Python
392 Summary(es):    Interface GUI para Phyton
393 Summary(fr):    Interface graphique pour python
394 Summary(pl):    Standardowy interfejs Pythona do biblioteki Tk
395 Summary(pt_BR): Interface GUI para Phyton
396 Summary(tr):    Python için grafik kullanýcý arayüzü
397 Group:          Libraries/Python
398 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
399 Requires:       tcl >= 8.4.3
400 Requires:       tix >= 1:8.1.4-4
401 Requires:       tk  >= 8.4.3
402 Obsoletes:      tkinter
403
404 %description tkinter
405 Standard Python interface to the Tk GUI toolkit.
406
407 %description tkinter -l de
408 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
409 vielen Konfigurations-Tools genutzt.
410
411 %description tkinter -l es
412 Una interface gráfica para Python, basada en Tcl/Tk, y usada por
413 muchas herramientas de configuración.
414
415 %description tkinter -l fr
416 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
417 beaucoup des outils de configuration.
418
419 %description tkinter -l pl
420 Standardowy interfejs Pythona do biblioteki Tk.
421
422 %description tkinter -l pt_BR
423 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
424 muitas ferramentas de configuração.
425
426 %description tkinter -l ru
427 çÒÁÆÉÞÅÓËÉÊ ÉÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÓÔÒÏÅÎÎÙÊ ÎÁ Tcl/Tk.
428
429 %description tkinter -l tr
430 Python için Tcl/Tk'ye dayalý ve pek çok ayarlama aracý tarafýndan
431 kullanýlan grafik bir arayüzdür.
432
433 %description tkinter -l uk
434 çÒÁƦÞÎÉÊ ¦ÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÂÕÄÏ×ÁÎÉÊ ÎÁ Tcl/Tk.
435
436 %package old
437 Summary:        Depreciated Python modules
438 Summary(pl):    Nieaktualne modu³y jêzyka Python
439 Group:          Libraries/Python
440 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
441
442 %description old
443 Install this package when one of your program written in Python is old
444 as Miss Universum of 1918, who only you want to see... ooops, which
445 only you want to run.
446
447 %description old -l pl
448 Zainstaluj ten pakiet, wtedy kiedy jeden z Twoich programów napisanych
449 w jêzyku Python jest tak stary jak Miss Universum z roku 1918, któr±
450 tylko ty chcesz zobaczyæ... przepraszam, który tylko ty chcesz
451 uruchomiæ.
452
453 %package examples
454 Summary:        Example programs in Python
455 Summary(pl):    Przyk³adowe programy w Pythonie
456 Group:          Development/Languages/Python
457 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
458 Obsoletes:      python-tools
459
460 %description examples
461 Example programs in Python.
462
463 %description examples -l pl
464 Przyk³adowe programy w Pythonie.
465
466 %prep
467 %setup -q -n Python-%{version}
468 %patch0 -p1
469 %patch1 -p1
470 %patch2 -p1
471 %patch3 -p1
472 %patch4 -p1
473 %patch5 -p1
474 %if "%{_lib}" == "lib64"
475 %patch6 -p1
476 %endif
477 %patch7 -p1
478
479 tar -xf %{SOURCE1} --use=bzip2
480
481 %build
482 %{__autoconf}
483
484 CPPFLAGS="-I%{_includedir}/ncurses"; export CPPFLAGS
485 %configure \
486         --with-threads \
487         --enable-unicode=ucs4 \
488         --enable-shared
489
490 %{__make} \
491         OPT="%{rpmcflags}"
492
493 LC_ALL=C
494 export LC_ALL
495 %if %{with tests}
496 %{__make} test \
497         TESTOPTS="%{test_flags} %{test_list}"
498 %endif
499
500 %install
501 rm -rf $RPM_BUILD_ROOT
502 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
503         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1}
504
505 %{__make} install \
506         DESTDIR=$RPM_BUILD_ROOT
507
508 install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
509
510 install libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}
511 ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
512 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython.so
513 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{py_ver}.so
514
515 rm -f $RPM_BUILD_ROOT%{_bindir}/python%{py_ver}
516
517 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
518 cp -ar Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
519
520 # create several useful scripts, such as timeit.py, profile.py, pdb.py
521 for script in timeit.py profile.py pdb.py pstats.py; do
522     cat <<END > $RPM_BUILD_ROOT%{_bindir}/$script
523 #!/bin/sh
524 exec python %{py_scriptdir}/${script}c "\$@"
525 END
526 done
527
528 # xgettext specific for Python code
529 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}
530
531 %clean
532 rm -rf $RPM_BUILD_ROOT
533
534 %post   libs -p /sbin/ldconfig
535 %postun libs -p /sbin/ldconfig
536
537 %files
538 %defattr(644,root,root,755)
539 %attr(755,root,root) %{_bindir}/python
540 %{_mandir}/man1/*
541
542 # readline support for python binary
543 %attr(755,root,root) %{py_dyndir}/readline.so
544
545 %files modules
546 %defattr(644,root,root,755)
547 %exclude %{py_scriptdir}/UserDict.py[co]
548 %exclude %{py_scriptdir}/codecs.py[co]
549 %exclude %{py_scriptdir}/copy_reg.py[co]
550 %exclude %{py_scriptdir}/locale.py[co]
551 %exclude %{py_scriptdir}/posixpath.py[co]
552 %exclude %{py_scriptdir}/pdb.py[co]
553 %exclude %{py_scriptdir}/profile.py[co]
554 %exclude %{py_scriptdir}/pstats.py[co]
555 %exclude %{py_scriptdir}/pydoc.py[co]
556 %exclude %{py_scriptdir}/site.py[co]
557 %exclude %{py_scriptdir}/stat.py[co]
558 %exclude %{py_scriptdir}/timeit.py[co]
559 %exclude %{py_scriptdir}/os.py[co]
560 %exclude %{py_scriptdir}/encodings/*.py[co]
561
562 %{py_scriptdir}/*.py[co]
563
564 #
565 # list .so modules to be sure that all of them are built
566 #
567
568 # three modules below does not work on 64-bit architectures
569 # see Python README file for explanation
570 %ifnarch alpha sparc64 ppc64 amd64
571 %attr(755,root,root) %{py_dyndir}/audioop.so
572 %attr(755,root,root) %{py_dyndir}/rgbimg.so
573 %attr(755,root,root) %{py_dyndir}/imageop.so
574 # sizeof(long) != sizeof(int), so dl module will not be built on 64-bit
575 # platforms
576 %attr(755,root,root) %{py_dyndir}/dl.so
577 %endif
578
579 %attr(755,root,root) %{py_dyndir}/_bsddb.so
580 %attr(755,root,root) %{py_dyndir}/_csv.so
581 %attr(755,root,root) %{py_dyndir}/_curses.so
582 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
583 %attr(755,root,root) %{py_dyndir}/_locale.so
584 %attr(755,root,root) %{py_dyndir}/_random.so
585 %attr(755,root,root) %{py_dyndir}/_socket.so
586 %attr(755,root,root) %{py_dyndir}/_ssl.so
587 %attr(755,root,root) %{py_dyndir}/_testcapi.so
588 %attr(755,root,root) %{py_dyndir}/_weakref.so
589 %attr(755,root,root) %{py_dyndir}/array.so
590 %attr(755,root,root) %{py_dyndir}/binascii.so
591 %attr(755,root,root) %{py_dyndir}/bz2.so
592 %attr(755,root,root) %{py_dyndir}/cPickle.so
593 %attr(755,root,root) %{py_dyndir}/cStringIO.so
594 %attr(755,root,root) %{py_dyndir}/cmath.so
595 %attr(755,root,root) %{py_dyndir}/crypt.so
596 %attr(755,root,root) %{py_dyndir}/datetime.so
597 %attr(755,root,root) %{py_dyndir}/dbm.so
598 %attr(755,root,root) %{py_dyndir}/fcntl.so
599 %attr(755,root,root) %{py_dyndir}/gdbm.so
600 %attr(755,root,root) %{py_dyndir}/grp.so
601 %attr(755,root,root) %{py_dyndir}/itertools.so
602 %attr(755,root,root) %{py_dyndir}/linuxaudiodev.so
603 %attr(755,root,root) %{py_dyndir}/math.so
604 %attr(755,root,root) %{py_dyndir}/md5.so
605 %attr(755,root,root) %{py_dyndir}/mmap.so
606 %attr(755,root,root) %{py_dyndir}/mpz.so
607 %attr(755,root,root) %{py_dyndir}/nis.so
608 %attr(755,root,root) %{py_dyndir}/operator.so
609 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
610 %attr(755,root,root) %{py_dyndir}/parser.so
611 %attr(755,root,root) %{py_dyndir}/pcre.so
612 %attr(755,root,root) %{py_dyndir}/pwd.so
613 %attr(755,root,root) %{py_dyndir}/pyexpat.so
614 %attr(755,root,root) %{py_dyndir}/regex.so
615 %attr(755,root,root) %{py_dyndir}/resource.so
616 %attr(755,root,root) %{py_dyndir}/rotor.so
617 %attr(755,root,root) %{py_dyndir}/select.so
618 %attr(755,root,root) %{py_dyndir}/sha.so
619 %attr(755,root,root) %{py_dyndir}/strop.so
620 %attr(755,root,root) %{py_dyndir}/syslog.so
621 %attr(755,root,root) %{py_dyndir}/termios.so
622 %attr(755,root,root) %{py_dyndir}/time.so
623 %attr(755,root,root) %{py_dyndir}/timing.so
624 %attr(755,root,root) %{py_dyndir}/unicodedata.so
625 %attr(755,root,root) %{py_dyndir}/xreadlines.so
626 %attr(755,root,root) %{py_dyndir}/zlib.so
627
628 %dir %{py_scriptdir}/plat-*
629 %attr(755,root,root) %{py_scriptdir}/plat-*/regen
630 %{py_scriptdir}/plat-*/*.py[co]
631
632 %dir %{py_scriptdir}/bsddb
633 %{py_scriptdir}/bsddb/*.py[co]
634
635 %dir %{py_scriptdir}/compiler
636 %{py_scriptdir}/compiler/*.py[co]
637
638 %dir %{py_scriptdir}/curses
639 %{py_scriptdir}/curses/*.py[co]
640
641 %dir %{py_scriptdir}/distutils
642 %{py_scriptdir}/distutils/*.py[co]
643
644 %dir %{py_scriptdir}/distutils/command
645 %{py_scriptdir}/distutils/command/*.py[co]
646
647 %dir %{py_scriptdir}/email
648 %{py_scriptdir}/email/*.py[co]
649
650 %dir %{py_scriptdir}/logging
651 %{py_scriptdir}/logging/*.py[co]
652
653 %dir %{py_scriptdir}/xml
654 %{py_scriptdir}/xml/*.py[co]
655
656 %dir %{py_scriptdir}/xml/parsers
657 %{py_scriptdir}/xml/parsers/*.py[co]
658
659 %dir %{py_scriptdir}/xml/sax
660 %{py_scriptdir}/xml/sax/*.py[co]
661
662 %dir %{py_scriptdir}/xml/dom
663 %{py_scriptdir}/xml/dom/*.py[co]
664
665 %files libs
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_libdir}/libpython*so.*
668
669 %dir %{py_dyndir}
670 %dir %{py_scriptdir}
671 %dir %{py_libdir}
672 %dir %{py_sitescriptdir}
673 %dir %{py_sitedir}
674
675 # required shared modules by python library
676 %attr(755,root,root) %{py_dyndir}/struct.so
677
678 # required modules by python library
679 %{py_scriptdir}/UserDict.py[co]
680 %{py_scriptdir}/codecs.py[co]
681 %{py_scriptdir}/copy_reg.py[co]
682 %{py_scriptdir}/locale.py[co]
683 %{py_scriptdir}/posixpath.py[co]
684 %{py_scriptdir}/site.py[co]
685 %{py_scriptdir}/stat.py[co]
686 %{py_scriptdir}/os.py[co]
687
688 # required encodings by python library
689 %dir %{py_scriptdir}/encodings
690 %{py_scriptdir}/encodings/*.py[co]
691
692 %files -n pydoc
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_bindir}/pydoc
695 %{py_scriptdir}/pydoc.py[co]
696
697 %files -n idle
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_bindir}/idle
700 %dir %{py_scriptdir}/idlelib
701 %dir %{py_scriptdir}/idlelib/Icons
702 %{py_scriptdir}/idlelib/*.py[co]
703 %{py_scriptdir}/idlelib/Icons/*
704 %{py_scriptdir}/idlelib/*.def
705
706 %files devel
707 %defattr(644,root,root,755)
708 %doc Misc/{ACKS,NEWS,README}
709 %attr(755,root,root) %{_libdir}/lib*.so
710 %dir %{py_incdir}
711 %{py_incdir}/*.h
712
713 %dir %{py_libdir}/config
714 %attr(755,root,root) %{py_libdir}/config/makesetup
715 %attr(755,root,root) %{py_libdir}/config/install-sh
716 %{py_libdir}/config/Makefile
717 %{py_libdir}/config/Makefile.pre.in
718 %{py_libdir}/config/Setup
719 %{py_libdir}/config/Setup.config
720 %{py_libdir}/config/Setup.local
721 %{py_libdir}/config/config.c
722 %{py_libdir}/config/config.c.in
723 %{py_libdir}/config/python.o
724
725 %files devel-src
726 %defattr(644,root,root,755)
727 %attr(-,root,root) %{py_scriptdir}/*.py
728 %{py_scriptdir}/plat-*/*.py
729 %{py_scriptdir}/bsddb/*.py
730 %{py_scriptdir}/compiler/*.py
731 %{py_scriptdir}/curses/*.py
732 %{py_scriptdir}/distutils/*.py
733 %{py_scriptdir}/distutils/command/*.py
734 %{py_scriptdir}/email/*.py
735 %{py_scriptdir}/hotshot/*.py
736 %{py_scriptdir}/logging/*.py
737 %{py_scriptdir}/xml/*.py
738 %{py_scriptdir}/xml/parsers/*.py
739 %{py_scriptdir}/xml/sax/*.py
740 %{py_scriptdir}/xml/dom/*.py
741 %{py_scriptdir}/encodings/*.py
742 %{py_scriptdir}/idlelib/*.py
743
744 %files devel-tools
745 %defattr(644,root,root,755)
746 %doc Lib/profile.doc Lib/pdb.doc
747 %attr(755,root,root) %{_bindir}/timeit.py
748 %attr(755,root,root) %{_bindir}/profile.py
749 %attr(755,root,root) %{_bindir}/pdb.py
750 %attr(755,root,root) %{_bindir}/pstats.py
751 %attr(755,root,root) %{_bindir}/pygettext.py
752
753 %attr(755,root,root) %{py_dyndir}/_hotshot.so
754 %dir %{py_scriptdir}/hotshot
755 %{py_scriptdir}/hotshot/*.py[co]
756 %{py_scriptdir}/pdb.py[co]
757 %{py_scriptdir}/profile.py[co]
758 %{py_scriptdir}/pstats.py[co]
759 %{py_scriptdir}/timeit.py[co]
760
761 %files static
762 %defattr(644,root,root,755)
763 %{_libdir}/lib*.a
764
765 %files examples
766 %defattr(644,root,root,755)
767 %{_examplesdir}/%{name}-%{version}
768
769 %files doc
770 %defattr(644,root,root,755)
771 %doc Python-Docs-%{version}/*
772 %dir %{py_scriptdir}/test
773 %attr(-,root,root) %{py_scriptdir}/test/*
774 %attr(-,root,root) %{py_scriptdir}/email/test/*
775 %attr(-,root,root) %{py_scriptdir}/bsddb/test/*
776
777 %if %{with tkinter}
778 %files tkinter
779 %defattr(644,root,root,755)
780 %{py_scriptdir}/lib-tk
781 %attr(755,root,root) %{py_dyndir}/_tkinter.so
782 %endif
783
784 %files old
785 %defattr(644,root,root,755)
786 %dir %{py_scriptdir}/lib-old
787 %{py_scriptdir}/lib-old/*.py[co]
This page took 0.107481 seconds and 4 git commands to generate.