]> git.pld-linux.org Git - packages/python.git/blob - python.spec
- security note
[packages/python.git] / python.spec
1 #
2 # TODO
3 # - test_distutils fails for unknown reason: (does it still do with new lib64 patch?)
4 #   AssertionError: '/tmp/tmpaomC0l/installation/share/python' != '/tmp/tmpaomC0l/installation/lib/python'
5 # - change searchpath order so /usr/lib* is before /usr/share
6 # - kill lib-tk from searchpath
7 # - kill BR: file requirement from lib64 patch
8 # - security(CVE-2008-4108)
9 #   http://securitytracker.com/alerts/2008/Sep/1020904.html
10 #
11 # Conditional build:
12 %bcond_with     info                    # build info pages (requires emacs, fails in python-2.5.0)
13 %bcond_without  tkinter                 # disables tkinter module building
14 %bcond_without  tests                   # disables Python testing
15 %bcond_with     verbose_tests           # runs tests in verbose mode
16 %bcond_with     openssl097
17 #
18 # tests which will not work on 64-bit platforms
19 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
20 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
21 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
22 # tests which fail because of some unknown/unresolved reason (this list should be empty)
23 %define         broken_tests test_anydbm test_bsddb test_re test_shelve test_whichdb test_zipimport test_distutils
24
25 %define beta            %{nil}
26
27 %define py_ver          2.5
28 %define py_prefix       %{_prefix}
29 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
30 %define py_incdir       %{_includedir}/python%{py_ver}
31 %define py_sitedir      %{py_libdir}/site-packages
32 %define py_dyndir       %{py_libdir}/lib-dynload
33
34 Summary:        Very high level scripting language with X interface
35 Summary(es.UTF-8):      Lenguaje script de alto nivel con interfaz X
36 Summary(fr.UTF-8):      Langage de script de très haut niveau avec interface X
37 Summary(pl.UTF-8):      Python - język obiektowy wysokiego poziomu
38 Summary(pt_BR.UTF-8):   Linguagem de programação interpretada de alto nível
39 Summary(ru.UTF-8):      Язык программирования очень высокого уровня с X-интерфейсом
40 Summary(tr.UTF-8):      X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
41 Summary(uk.UTF-8):      Мова програмування дуже високого рівня з X-інтерфейсом
42 Name:           python
43 Version:        %{py_ver}.2
44 Release:        5
45 Epoch:          1
46 License:        PSF
47 Group:          Applications
48 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}%{beta}.tar.bz2
49 # Source0-md5:  afb5451049eda91fbde10bd5a4b7fadc
50 Source1:        http://www.python.org/ftp/python/doc/%{version}%{beta}/html-%{version}%{beta}.tar.bz2
51 # Source1-md5:  b264d979f7b3e4c0243bec3a039a6464
52 Patch0:         %{name}-readline.patch
53 Patch1:         %{name}-%{name}path.patch
54 Patch2:         %{name}-no_ndbm.patch
55 Patch3:         %{name}-ac_fixes.patch
56 Patch4:         %{name}-noarch_to_datadir.patch
57 Patch5:         %{name}-lib64.patch
58 Patch6:         %{name}-doc_path.patch
59 Patch7:         %{name}-db.patch
60 Patch8:         %{name}-bug-216503.patch
61 URL:            http://www.python.org/
62 BuildRequires:  autoconf
63 BuildRequires:  bzip2-devel
64 BuildRequires:  db-devel >= 4
65 %{?with_info:BuildRequires:     emacs >= 21}
66 BuildRequires:  expat-devel >= 1:1.95.7
67 BuildRequires:  file
68 BuildRequires:  gdbm-devel >= 1.8.3
69 BuildRequires:  gmp-devel >= 4.0
70 BuildRequires:  libstdc++-devel
71 BuildRequires:  ncurses-ext-devel >= 5.2
72 %if %{with openssl097}
73 BuildRequires:  openssl-devel < 0.9.8
74 %else
75 BuildRequires:  openssl-devel >= 0.9.8
76 %endif
77 BuildRequires:  readline-devel >= 5.0
78 BuildRequires:  rpm-pythonprov
79 BuildRequires:  sed >= 4.0
80 BuildRequires:  sqlite3-devel >= 3.3.5
81 %{?with_info:BuildRequires:     tetex-makeindex}
82 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
83 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
84 BuildRequires:  zlib-devel
85 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
86 Obsoletes:      python-curses
87 Obsoletes:      python-gdbm
88 Obsoletes:      python-intl
89 Obsoletes:      python-xml
90 Obsoletes:      python-zlib
91 Obsoletes:      python2
92 Obsoletes:      python2-devel
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %if %{with verbose_tests}
96 %define test_flags -v -l -x
97 %else
98 %define test_flags -l -x
99 %endif
100
101 %ifarch alpha ia64 ppc64 ppc64 %{x8664}
102 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
103 %else
104 %define test_list %{nobuilder_tests} %{broken_tests}
105 %endif
106
107 %ifarch sparc
108 %define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
109 %endif
110
111 %ifarch sparc64
112 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests} test_fcntl test_ioctl
113 %endif
114
115 %description
116 Python is an interpreted, interactive, object-oriented programming
117 language. It incorporates modules, exceptions, dynamic typing, very
118 high level dynamic data types, and classes. Python combines remarkable
119 power with very clear syntax. It has interfaces to many system calls
120 and libraries, as well as to various window systems, and is extensible
121 in C or C++. It is also usable as an extension language for
122 applications that need a programmable interface. Finally, Python is
123 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
124 MS-DOS, Windows, Windows NT, and OS/2.
125
126 This package contains the Python binary.
127
128 %description -l de.UTF-8
129 Python ist eine interpretierte, interaktive, objektorientierte
130 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
131 Python enthält Module, Klassen, Exceptions, High-Level dynamische
132 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
133 zu vielen Systemaufrufen und Libraries, sowie verschiedene
134 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
135
136 Programmierer können neue built-in-Module für Python in C oder C++
137 schreiben. Python kann auch als Erweiterungssprache für Applikationen
138 benutzt werden, die ein programmierbares Interface brauchen. Dieses
139 Paket enthält die meisten Standard-Python-Module, und Module zum
140 Ansprechen von Tix (Tk-widget set) und RPM.
141
142 %description -l es.UTF-8
143 Python es un lenguaje de scripts interpretado orientado a objetos.
144 Contiene soporte para carga dinámica de objetos, clases, módulos y
145 excepciones.
146
147 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
148 través de código C, tornando Python fácil de usar en ambientes
149 particulares/personalizados. Este paquete Python incluye la mayoría de
150 los módulos padrón Python, junto con módulos para crear interfaces
151 para el conjunto de componentes Tix para Tk y RPM.
152
153 %description -l fr.UTF-8
154 Python est un langage de script interprété et orienté objet. Il gère
155 le chargement dynamique des objets, les classes, les modules et les
156 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
157 avec du code C est simple, ce qui rend Python facile à utiliser dans
158 des configs personnalisées.
159
160 Ce paquetage Python contient la plupart des modules Python standards,
161 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
162 et RPM.
163
164 %description -l pl.UTF-8
165 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
166 językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
167 typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
168 sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
169 wielu wywołań systemowych i bibliotek, w tym również do różnych
170 bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
171 poprzez odpowiednie moduły pisane w C lub C++. Python może być również
172 użyty jako element aplikacji, którym potrzebny jest interpreter do
173 skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
174 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
175 OS/2.
176
177 Ten pakiet zawiera binarkę Pythona.
178
179 %description -l pt_BR.UTF-8
180 Python é uma linguagem de scripts interpretada orientada a objetos.
181 Contém suporte para carga dinâmica de objetos, classes, módulos e
182 exceções. Adicionar interfaces para novos sistemas de biblioteca
183 através de código C é simples, tornando Python fácil de usar em
184 ambientes particulares/personalizados.
185
186 Este pacote Python inclui a maioria do módulos padrão Python, junto
187 com módulos para interfaceamento para o conjunto de componentes Tix
188 para Tk e RPM.
189
190 %description -l ru.UTF-8
191 Python - это интерпретируемый, объектно-ориентированный язык
192 программирования. Он поддерживает динамическую загрузку объектов,
193 классы, модули и обработку исключительных ситуаций (exceptions).
194 Простота добавления интерфейсов к новым системным библиотекам через
195 код на языке C делает Python хорошим выбором для использования в
196 специальных конфигурациях.
197
198 %description -l tr.UTF-8
199 Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
200 sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
201 destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
202 paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
203 arayüz birimlerini de içerir.
204
205 %description -l uk.UTF-8
206 Python - це інтерпретована, об'єктно-орієнтована мова програмування.
207 Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
208 виключних ситуацій (exceptions). Простота додавання інтерфейсів для
209 нових системних бібліотек через код на мові C робить Python добрим
210 вибором для використання в спеціальних конфігураціях.
211
212 %package libs
213 Summary:        Python library
214 Summary(pl.UTF-8):      Biblioteka języka Python
215 Group:          Libraries/Python
216 # broken detection in rpm/pythondeps.sh
217 Provides:       python(abi) = %{py_ver}
218 # for compatibility with existing Ac packages
219 Provides:       python(bytecode) = %{py_ver}
220 %{!?with_info:Obsoletes:        python-doc-info}
221
222 %description libs
223 Python shared library and very essental modules for Python binary.
224
225 %description libs -l pl.UTF-8
226 Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
227 dla Pythona.
228
229 %package modules
230 Summary:        Python modules
231 Summary(pl.UTF-8):      Moduły języka Python
232 Group:          Libraries/Python
233 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
234 Provides:       python-cElementTree
235 Provides:       python-elementtree
236 Obsoletes:      python-cElementTree
237 Obsoletes:      python-ctypes
238 Obsoletes:      python-elementtree
239 Obsoletes:      python-logging
240 Obsoletes:      python-old
241 Obsoletes:      python-optik
242 Obsoletes:      python-xmlrpc <= 1.0.1
243
244 %description modules
245 Python officially distributed modules.
246
247 %description modules -l pl.UTF-8
248 Oficjalnie rozprowadzane moduły języka Python.
249
250 %package modules-sqlite
251 Summary:        Python SQLite modules
252 Summary(pl.UTF-8):      Moduły SQLite języka Python
253 Group:          Libraries/Python
254 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
255
256 %description modules-sqlite
257 Python officially distributed sqlite module.
258
259 %description modules-sqlite -l pl.UTF-8
260 Oficjalnie rozprowadzany moduł sqlite języka Python.
261
262 %package -n pydoc
263 Summary:        Python interactive module documentation access support
264 Summary(pl.UTF-8):      Interaktywne korzystanie z dokumentacji modułów języka Python
265 Group:          Applications
266 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
267 Obsoletes:      python-pydoc
268
269 %description -n pydoc
270 Python interactive module documentation access support.
271
272 %description -n pydoc -l pl.UTF-8
273 Interaktywne korzystanie z dokumentacji modułów języka Python.
274
275 %package -n idle
276 Summary:        IDE for Python language
277 Summary(pl.UTF-8):      IDE dla języka Python
278 Group:          Applications
279 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
280 Obsoletes:      python-idle
281
282 %description -n idle
283 IDE for Python language.
284
285 %description -n idle -l pl.UTF-8
286 IDE dla języka Python.
287
288 %package devel
289 Summary:        Libraries and header files for building python code
290 Summary(de.UTF-8):      Libraries und Header-Dateien zum Erstellen von Python-Code
291 Summary(es.UTF-8):      Bibliotecas y archivos de inclusión para construir programas en python
292 Summary(fr.UTF-8):      Bibliothèques et en-têtes pour construire du code python
293 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki Pythona
294 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para o Python
295 Summary(ru.UTF-8):      Библиотеки и хедеры для построения кода на языке Python
296 Summary(tr.UTF-8):      Python ile geliştirme yapmak için gerekli dosyalar
297 Summary(uk.UTF-8):      Бібліотеки та хедери для програмування на мові Python
298 Group:          Development/Languages/Python
299 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
300
301 %description devel
302 The Python interpreter is relatively easy to extend with dynamically
303 loaded extensions and to embed in other programs. This package
304 contains the header files and libraries which are needed to do both of
305 these tasks.
306
307 %description devel -l de.UTF-8
308 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
309 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
310 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
311 die für beide Aufgaben erforderlich sind.
312
313 %description devel -l es.UTF-8
314 El interpretador Python permite incluir con facilidad extensiones
315 cargadas dinámicamente. Python es también fácil de ser empotrado en
316 otros programas. Este paquete contiene los archivos de inclusión y
317 bibliotecas necesarios para estas dos tareas.
318
319 %description devel -l fr.UTF-8
320 L'interpréteur Python est relativement facile à étendre avec des
321 extensions chargées dynamiquement et à insérer dans d'autres
322 programmes. Ce paquetage contient les en-têtes et les bibliothèques
323 nécessaires à ces deux tâches.
324
325 %description devel -l pl.UTF-8
326 Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
327 dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
328 osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
329 wszystko inne co potrzebne do tych celów.
330
331 %description devel -l pt_BR.UTF-8
332 O interpretador Python permite incluir com facilidade extensões
333 carregadas dinamicamente. Python é também fácil de ser embutido em
334 outros programas. Este pacote contém os arquivos de inclusão e
335 bibliotecas necessários para estas duas tarefas.
336
337 %description devel -l ru.UTF-8
338 Интерпретатор Python относительно легко расширяется при помощи
339 динамически загружаемых расширений и встраивается в другие программы.
340 Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
341 задач.
342
343 %description devel -l tr.UTF-8
344 Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
345 dosyalarını ve kitaplıkları içerir.
346
347 %description devel -l uk.UTF-8
348 Інтерпретатор Python відносно легко розширюється за допомогою
349 розширень з динамічною загрузкою та вбудовується в інші програми. Цей
350 пакет містить хедери та бібліотеки, необхідні для обох цих задач.
351
352 %package devel-src
353 Summary:        Python module sources
354 Summary(pl.UTF-8):      Pliki źródłowe modułów Pythona
355 Group:          Development/Languages/Python
356 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
357
358 %description devel-src
359 Python module sources.
360
361 %description devel-src -l pl.UTF-8
362 Pliki źródłowe modułów Pythona.
363
364 %package devel-tools
365 Summary:        Python development tools
366 Summary(pl.UTF-8):      Narzędzia programistyczne języka Python
367 Group:          Development/Languages/Python
368 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
369
370 %description devel-tools
371 Python development tools such as profilers and debugger.
372
373 %description devel-tools -l pl.UTF-8
374 Narzędzia programistyczne języka Python takie jak profiler oraz
375 debugger.
376
377 %package static
378 Summary:        Static python library
379 Summary(pl.UTF-8):      Statyczna biblioteka Pythona
380 Group:          Development/Languages/Python
381 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
382
383 %description static
384 Static python library.
385
386 %description static -l pl.UTF-8
387 Statyczna biblioteka Pythona.
388
389 %package doc
390 Summary:        Documentation on Python
391 Summary(de.UTF-8):      Dokumentation zu Python
392 Summary(es.UTF-8):      Documentación para Python
393 Summary(fr.UTF-8):      Documentation sur Python
394 Summary(pl.UTF-8):      Dokumentacja do Pythona
395 Summary(pt_BR.UTF-8):   Documentação para a linguagem de programação Python
396 Summary(ru.UTF-8):      Документация по языку Python
397 Summary(tr.UTF-8):      Python belgeleri
398 Summary(uk.UTF-8):      Документація по мові Python
399 Group:          Documentation
400 Obsoletes:      python-docs
401
402 %description doc
403 This package contains documentation on the Python language and
404 interpretor as a mix of plain ASCII files and LaTeX sources.
405
406 %description doc -l de.UTF-8
407 Dieses Paket enthält Dokumentationen zu Python (Sprache und
408 Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
409
410 %description doc -l es.UTF-8
411 Documentación para Python. Contiene archivos en texto y PostScript.
412
413 %description doc -l fr.UTF-8
414 Ce paquetage contient la documentation sur le langage python et sur
415 son interpréteur sous forme de fichiers ASCII et LaTeX.
416
417 %description doc -l pl.UTF-8
418 Oficjalna dokumentacja do Pythona. Zawiera przykładowe programy,
419 narzędzia i dokumentację. Strony podręcznika man znajdują się w
420 głównym pakiecie. Ten pakiet nie zawiera źródeł dokumentacji
421 napisanych w LaTeXu, tylko gotowe do wykorzystania pliki postscriptowe
422 i HTML.
423
424 %description doc -l pt_BR.UTF-8
425 O pacote python-doc contém documentação para a linguagem de
426 programação e para o interpretador Python. Fornecida em arquivos texto
427 e Postcript.
428
429 %description doc -l ru.UTF-8
430 Этот пакет содержит документацию по собственно языку Python и по
431 исполняющему его интерпретатору в виде набора текстовых файлов и
432 исходных текстов в формате LaTeX.
433
434 %description doc -l tr.UTF-8
435 Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyaları ve
436 LaTeX kaynaklarının bir karışımı olan yorumlayıcıyı içerir.
437
438 %description doc -l uk.UTF-8
439 Цей пакет містить документацію по власне мові Python та по виконуючому
440 її інтерпретатору у вигляді набора текстових файлів та вихідних
441 текстів у форматі LaTeX.
442
443 %package doc-info
444 Summary:        Documentation on Python in texinfo format
445 Summary(pl.UTF-8):      Dokumentacja do Pythona w formacie texinfo
446 Group:          Documentation
447
448 %description doc-info
449 Documentation on Python in texinfo format.
450
451 %description doc-info -l pl.UTF-8
452 Dokumentacja do Pythona w formacie texinfo.
453
454 %package tkinter
455 Summary:        Standard Python interface to the Tk GUI toolkit
456 Summary(de.UTF-8):      Grafische Tk-Schnittstelle für Python
457 Summary(es.UTF-8):      Interfaz de GUI Tk para Python
458 Summary(fr.UTF-8):      Interface graphique Tk pour Python
459 Summary(pl.UTF-8):      Standardowy interfejs Pythona do biblioteki Tk
460 Summary(pt_BR.UTF-8):   Interface GUI Tk para Phyton
461 Summary(tr.UTF-8):      Python için grafik kullanıcı arayüzü
462 Group:          Libraries/Python
463 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
464 Requires:       tcl >= 8.4.3
465 Requires:       tix >= 1:8.1.4-4
466 Requires:       tk >= 8.4.3
467 Obsoletes:      tkinter
468
469 %description tkinter
470 Standard Python interface to the Tk GUI toolkit.
471
472 %description tkinter -l de.UTF-8
473 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
474 vielen Konfigurations-Tools genutzt.
475
476 %description tkinter -l es.UTF-8
477 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
478 herramientas de configuración.
479
480 %description tkinter -l fr.UTF-8
481 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
482 beaucoup des outils de configuration.
483
484 %description tkinter -l pl.UTF-8
485 Standardowy interfejs Pythona do biblioteki Tk.
486
487 %description tkinter -l pt_BR.UTF-8
488 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
489 muitas ferramentas de configuração.
490
491 %description tkinter -l ru.UTF-8
492 Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
493
494 %description tkinter -l tr.UTF-8
495 Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
496 kullanılan grafik bir arayüzdür.
497
498 %description tkinter -l uk.UTF-8
499 Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
500
501 %package examples
502 Summary:        Example programs in Python
503 Summary(pl.UTF-8):      Przykładowe programy w Pythonie
504 Group:          Development/Languages/Python
505 Obsoletes:      python-tools
506
507 %description examples
508 Example programs in Python.
509
510 These are for Python 2.3.4, not %{version}.
511
512 %description examples -l pl.UTF-8
513 Przykładowe programy w Pythonie.
514
515 Przykłady te są dla Pythona 2.3.4, nie %{version}.
516
517 %prep
518 %setup -q -n Python-%{version}%{beta}
519 %patch0 -p1
520 %patch1 -p1
521 %patch2 -p1
522 %patch3 -p1
523 %patch5 -p1
524 %patch4 -p1
525 %patch6 -p1
526 %patch7 -p1
527 %patch8 -p2
528
529 tar xjf %{SOURCE1}
530
531 %build
532 sed -i -e 's#-ltermcap#-ltinfo#g' configure*
533 %{__autoconf}
534 CPPFLAGS="-I/usr/include/ncurses"; export CPPFLAGS
535 %configure \
536         --with-threads \
537         --with-cxx="%{__cxx}" \
538         --enable-unicode=ucs4 \
539         --enable-shared \
540         LINKCC='$(PURIFY) $(CXX)' \
541         LDSHARED='$(CC) $(CFLAGS) -shared' \
542         BLDSHARED='$(CC) $(CFLAGS) -shared' \
543         LDFLAGS="%{rpmcflags} %{rpmldflags}"
544
545 ./Doc/tools/getversioninfo
546
547 %{__make} \
548         OPT="%{rpmcflags}" 2>&1 | awk '
549 BEGIN { fail = 0; logmsg = ""; }
550 {
551                 if ($0 ~ /\*\*\* WARNING:/) {
552                                 fail = 1;
553                                 logmsg = logmsg $0;
554                 }
555                 print $0;
556 }
557 END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
558
559 LC_ALL=C
560 export LC_ALL
561 %if %{with tests}
562 binlibdir=`echo build/lib.*`
563 %{__make} test \
564         TESTOPTS="%{test_flags} %{test_list}" \
565         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
566 %endif
567
568 %install
569 rm -rf $RPM_BUILD_ROOT
570 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
571         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
572         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
573         $RPM_BUILD_ROOT%{_infodir} \
574         $RPM_BUILD_ROOT/etc/shrc.d
575
576 %{__make} install \
577         DESTDIR=$RPM_BUILD_ROOT
578
579 %if %{with info}
580 %{__make} -C Doc/info
581 install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
582 %endif
583
584 install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
585
586 mv $RPM_BUILD_ROOT{%{py_libdir}/config,%{_libdir}}/libpython%{py_ver}.a
587 ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
588 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython.so
589 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{py_ver}.so
590
591 rm -f $RPM_BUILD_ROOT%{_bindir}/python%{py_ver}
592
593 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
594 cp -a Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
595
596 #
597 # create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
598 #
599
600 # for python devel tools
601 for script in timeit profile pdb pstats; do
602     echo alias $script.py=\"python -m ${script}\"
603 done > $RPM_BUILD_ROOT/etc/shrc.d/python-devel.sh
604
605 sed 's/=/ /' \
606         < $RPM_BUILD_ROOT/etc/shrc.d/python-devel.sh \
607         > $RPM_BUILD_ROOT/etc/shrc.d/python-devel.csh
608
609 # for python modules
610 for script in smtpd webbrowser; do
611     echo alias $script.py=\"python -m ${script}\"
612 done > $RPM_BUILD_ROOT/etc/shrc.d/python-modules.sh
613
614 sed 's/=/ /' \
615         < $RPM_BUILD_ROOT/etc/shrc.d/python-modules.sh \
616         > $RPM_BUILD_ROOT/etc/shrc.d/python-modules.csh
617
618 # just to cut the noise, as they are not packaged (now)
619 # first tests
620 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/test
621 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/bsddb/test
622 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
623 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
624 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/email/test
625 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
626
627 # other files
628 rm -rf $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
629 find $RPM_BUILD_ROOT%{py_scriptdir} -name \*.egg-info -exec rm {} \;
630 find $RPM_BUILD_ROOT%{py_scriptdir} -name \*.bat -exec rm {} \;
631 find $RPM_BUILD_ROOT%{py_scriptdir} -name \*.txt -exec rm {} \;
632 find $RPM_BUILD_ROOT%{py_scriptdir} -name README\* -exec rm {} \;
633
634 %clean
635 rm -rf $RPM_BUILD_ROOT
636
637 %post   libs -p /sbin/ldconfig
638 %postun libs -p /sbin/ldconfig
639
640 %post doc-info  -p      /sbin/postshell
641 -/usr/sbin/fix-info-dir -c %{_infodir}
642
643 %postun doc-info        -p      /sbin/postshell
644 -/usr/sbin/fix-info-dir -c %{_infodir}
645
646 %files
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_bindir}/python
649 %{_mandir}/man1/*
650
651 %files modules
652 %defattr(644,root,root,755)
653 /etc/shrc.d/python-modules*
654 %exclude %{py_scriptdir}/UserDict.py[co]
655 %exclude %{py_scriptdir}/codecs.py[co]
656 %exclude %{py_scriptdir}/copy_reg.py[co]
657 %exclude %{py_scriptdir}/locale.py[co]
658 %exclude %{py_scriptdir}/posixpath.py[co]
659 %exclude %{py_scriptdir}/pdb.py[co]
660 %exclude %{py_scriptdir}/profile.py[co]
661 %exclude %{py_scriptdir}/pstats.py[co]
662 %exclude %{py_scriptdir}/pydoc.py[co]
663 %exclude %{py_scriptdir}/site.py[co]
664 %exclude %{py_scriptdir}/stat.py[co]
665 %exclude %{py_scriptdir}/timeit.py[co]
666 %exclude %{py_scriptdir}/os.py[co]
667 %exclude %{py_scriptdir}/encodings/*.py[co]
668 %exclude %{py_scriptdir}/types.py[co]
669
670 %{py_scriptdir}/*.py[co]
671
672 %{py_dyndir}/*.egg-info
673
674 #
675 # list .so modules to be sure that all of them are built
676 #
677
678 # three modules below do not work on 64-bit architectures
679 # see Python README file for explanation
680 %ifnarch alpha ia64 ppc64 sparc64 %{x8664}
681 %attr(755,root,root) %{py_dyndir}/audioop.so
682 %attr(755,root,root) %{py_dyndir}/rgbimg.so
683 %attr(755,root,root) %{py_dyndir}/imageop.so
684 # sizeof(long) != sizeof(int), so dl module will not be built on 64-bit
685 # platforms
686 %attr(755,root,root) %{py_dyndir}/dl.so
687 %endif
688
689 %attr(755,root,root) %{py_dyndir}/array.so
690 %attr(755,root,root) %{py_dyndir}/binascii.so
691 %attr(755,root,root) %{py_dyndir}/_bisect.so
692 %attr(755,root,root) %{py_dyndir}/_bsddb.so
693 %attr(755,root,root) %{py_dyndir}/bz2.so
694 %attr(755,root,root) %{py_dyndir}/cmath.so
695 %attr(755,root,root) %{py_dyndir}/_codecs_cn.so
696 %attr(755,root,root) %{py_dyndir}/_codecs_hk.so
697 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
698 %attr(755,root,root) %{py_dyndir}/_codecs_jp.so
699 %attr(755,root,root) %{py_dyndir}/_codecs_kr.so
700 %attr(755,root,root) %{py_dyndir}/_codecs_tw.so
701 %attr(755,root,root) %{py_dyndir}/collections.so
702 %attr(755,root,root) %{py_dyndir}/cPickle.so
703 %attr(755,root,root) %{py_dyndir}/crypt.so
704 %attr(755,root,root) %{py_dyndir}/cStringIO.so
705 %attr(755,root,root) %{py_dyndir}/_csv.so
706 %attr(755,root,root) %{py_dyndir}/_ctypes*.so
707 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
708 %attr(755,root,root) %{py_dyndir}/_curses.so
709 %attr(755,root,root) %{py_dyndir}/datetime.so
710 %attr(755,root,root) %{py_dyndir}/_elementtree.so
711 %attr(755,root,root) %{py_dyndir}/_functools.so
712 %attr(755,root,root) %{py_dyndir}/_hashlib.so
713 %attr(755,root,root) %{py_dyndir}/_heapq.so
714 %attr(755,root,root) %{py_dyndir}/_locale.so
715 %attr(755,root,root) %{py_dyndir}/_lsprof.so
716 %attr(755,root,root) %{py_dyndir}/_multibytecodec.so
717 %attr(755,root,root) %{py_dyndir}/_random.so
718 %{?with_openssl097:%attr(755,root,root) %{py_dyndir}/_sha*.so}
719 %attr(755,root,root) %{py_dyndir}/_socket.so
720 %attr(755,root,root) %{py_dyndir}/_ssl.so
721 %attr(755,root,root) %{py_dyndir}/_testcapi.so
722 %attr(755,root,root) %{py_dyndir}/_weakref.so
723 %ifnarch sparc64
724 %attr(755,root,root) %{py_dyndir}/dbm.so
725 %endif
726 %attr(755,root,root) %{py_dyndir}/fcntl.so
727 %attr(755,root,root) %{py_dyndir}/gdbm.so
728 %attr(755,root,root) %{py_dyndir}/grp.so
729 %attr(755,root,root) %{py_dyndir}/itertools.so
730 %attr(755,root,root) %{py_dyndir}/linuxaudiodev.so
731 %attr(755,root,root) %{py_dyndir}/math.so
732 %attr(755,root,root) %{py_dyndir}/mmap.so
733 %attr(755,root,root) %{py_dyndir}/nis.so
734 %attr(755,root,root) %{py_dyndir}/operator.so
735 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
736 %attr(755,root,root) %{py_dyndir}/parser.so
737 %attr(755,root,root) %{py_dyndir}/pyexpat.so
738 %attr(755,root,root) %{py_dyndir}/readline.so
739 %attr(755,root,root) %{py_dyndir}/resource.so
740 %attr(755,root,root) %{py_dyndir}/select.so
741 %attr(755,root,root) %{py_dyndir}/strop.so
742 %attr(755,root,root) %{py_dyndir}/syslog.so
743 %attr(755,root,root) %{py_dyndir}/termios.so
744 %attr(755,root,root) %{py_dyndir}/time.so
745 %attr(755,root,root) %{py_dyndir}/spwd.so
746 %attr(755,root,root) %{py_dyndir}/unicodedata.so
747 %attr(755,root,root) %{py_dyndir}/zlib.so
748
749 %dir %{py_scriptdir}/plat-*
750 %{py_scriptdir}/plat-*/*.py[co]
751
752 %dir %{py_scriptdir}/bsddb
753 %{py_scriptdir}/bsddb/*.py[co]
754
755 %dir %{py_scriptdir}/compiler
756 %{py_scriptdir}/compiler/*.py[co]
757
758 %dir %{py_scriptdir}/ctypes
759 %dir %{py_scriptdir}/ctypes/macholib
760 %{py_scriptdir}/ctypes/*.py[co]
761 %{py_scriptdir}/ctypes/macholib/*.py[co]
762
763 %dir %{py_scriptdir}/curses
764 %{py_scriptdir}/curses/*.py[co]
765
766 %dir %{py_scriptdir}/distutils
767 %dir %{py_scriptdir}/distutils/command
768 %{py_scriptdir}/distutils/*.py[co]
769 %{py_scriptdir}/distutils/command/*.py[co]
770
771 %dir %{py_scriptdir}/email
772 %dir %{py_scriptdir}/email/mime
773 %{py_scriptdir}/email/*.py[co]
774 %{py_scriptdir}/email/mime/*.py[co]
775
776 %dir %{py_scriptdir}/logging
777 %{py_scriptdir}/logging/*.py[co]
778
779 %dir %{py_scriptdir}/wsgiref
780 %{py_scriptdir}/wsgiref/*.py[co]
781
782 %dir %{py_scriptdir}/xml
783 %dir %{py_scriptdir}/xml/dom
784 %dir %{py_scriptdir}/xml/etree
785 %dir %{py_scriptdir}/xml/parsers
786 %dir %{py_scriptdir}/xml/sax
787 %{py_scriptdir}/xml/*.py[co]
788 %{py_scriptdir}/xml/dom/*.py[co]
789 %{py_scriptdir}/xml/etree/*.py[co]
790 %{py_scriptdir}/xml/parsers/*.py[co]
791 %{py_scriptdir}/xml/sax/*.py[co]
792
793 %files modules-sqlite
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{py_dyndir}/_sqlite3.so
796 %dir %{py_scriptdir}/sqlite3
797 %{py_scriptdir}/sqlite3/*.py[co]
798
799 %files libs
800 %defattr(644,root,root,755)
801 %attr(755,root,root) %{_libdir}/libpython*.so.*
802
803 %dir %{py_dyndir}
804 %dir %{py_scriptdir}
805 %dir %{py_libdir}
806 %dir %{py_sitescriptdir}
807 %dir %{py_sitedir}
808
809 # shared modules required by python library
810 %attr(755,root,root) %{py_dyndir}/_struct.so
811
812 # modules required by python library
813 %{py_scriptdir}/UserDict.py[co]
814 %{py_scriptdir}/codecs.py[co]
815 %{py_scriptdir}/copy_reg.py[co]
816 %{py_scriptdir}/locale.py[co]
817 %{py_scriptdir}/posixpath.py[co]
818 %{py_scriptdir}/site.py[co]
819 %{py_scriptdir}/stat.py[co]
820 %{py_scriptdir}/os.py[co]
821 # needed by the dynamic sys.lib patch
822 %{py_scriptdir}/types.py[co]
823
824 # encodings required by python library
825 %dir %{py_scriptdir}/encodings
826 %{py_scriptdir}/encodings/*.py[co]
827
828 %files -n pydoc
829 %defattr(644,root,root,755)
830 %attr(755,root,root) %{_bindir}/pydoc
831 %{py_scriptdir}/pydoc.py[co]
832
833 %files -n idle
834 %defattr(644,root,root,755)
835 %attr(755,root,root) %{_bindir}/idle
836 %dir %{py_scriptdir}/idlelib
837 %dir %{py_scriptdir}/idlelib/Icons
838 %{py_scriptdir}/idlelib/*.py[co]
839 %{py_scriptdir}/idlelib/Icons/*
840 %{py_scriptdir}/idlelib/*.def
841
842 %files devel
843 %defattr(644,root,root,755)
844 %doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
845 %attr(755,root,root) %{_bindir}/python-config
846 %attr(755,root,root) %{_bindir}/python%{py_ver}-config
847 %attr(755,root,root) %{_libdir}/lib*.so
848 %dir %{py_incdir}
849 %{py_incdir}/*.h
850
851 %dir %{py_libdir}/config
852 %attr(755,root,root) %{py_libdir}/config/makesetup
853 %attr(755,root,root) %{py_libdir}/config/install-sh
854 %{py_libdir}/config/Makefile
855 %{py_libdir}/config/Makefile.pre.in
856 %{py_libdir}/config/Setup
857 %{py_libdir}/config/Setup.config
858 %{py_libdir}/config/Setup.local
859 %{py_libdir}/config/config.c
860 %{py_libdir}/config/config.c.in
861 %{py_libdir}/config/python.o
862
863 %files devel-src
864 %defattr(644,root,root,755)
865 %attr(-,root,root) %{py_scriptdir}/*.py
866 %{py_scriptdir}/plat-*/*.py
867 %{py_scriptdir}/bsddb/*.py
868 %{py_scriptdir}/ctypes/*.py
869 %{py_scriptdir}/ctypes/macholib/*.py
870 %{py_scriptdir}/compiler/*.py
871 %{py_scriptdir}/curses/*.py
872 %{py_scriptdir}/distutils/*.py
873 %{py_scriptdir}/distutils/command/*.py
874 %{py_scriptdir}/email/*.py
875 %{py_scriptdir}/email/mime/*.py
876 %{py_scriptdir}/hotshot/*.py
877 %{py_scriptdir}/logging/*.py
878 %{py_scriptdir}/sqlite3/*.py
879 %{py_scriptdir}/wsgiref/*.py
880 %{py_scriptdir}/xml/*.py
881 %{py_scriptdir}/xml/dom/*.py
882 %{py_scriptdir}/xml/etree/*.py
883 %{py_scriptdir}/xml/parsers/*.py
884 %{py_scriptdir}/xml/sax/*.py
885 %{py_scriptdir}/encodings/*.py
886 %{py_scriptdir}/idlelib/*.py
887
888 %files devel-tools
889 %defattr(644,root,root,755)
890 %doc Lib/pdb.doc
891 /etc/shrc.d/python-devel*
892
893 %attr(755,root,root) %{py_dyndir}/_hotshot.so
894 %dir %{py_scriptdir}/hotshot
895 %{py_scriptdir}/hotshot/*.py[co]
896 %{py_scriptdir}/pdb.py[co]
897 %{py_scriptdir}/profile.py[co]
898 %{py_scriptdir}/pstats.py[co]
899 %{py_scriptdir}/timeit.py[co]
900
901 %files static
902 %defattr(644,root,root,755)
903 %{_libdir}/lib*.a
904
905 %files examples
906 %defattr(644,root,root,755)
907 %{_examplesdir}/%{name}-%{version}
908
909
910 %files doc
911 %defattr(644,root,root,755)
912 %doc Python-Docs-%{version}%{beta}/*
913
914 %if %{with info}
915 %files doc-info
916 %defattr(644,root,root,755)
917 %{_infodir}/*.info*
918 %endif
919
920 %if %{with tkinter}
921 %files tkinter
922 %defattr(644,root,root,755)
923 %{py_scriptdir}/lib-tk
924 %attr(755,root,root) %{py_dyndir}/_tkinter.so
925 %endif
This page took 0.183002 seconds and 4 git commands to generate.