]> git.pld-linux.org Git - packages/python.git/blob - python.spec
- missing BR
[packages/python.git] / python.spec
1 #
2 # Conditional build:
3 %bcond_without  tkinter                 # disables tkinter module building
4 %bcond_without  tests                   # disables Python testing
5 %bcond_with     verbose_tests           # runs tests in verbose mode
6 #
7 # tests which will not work on 64-bit platforms
8 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
9 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
10 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
11 # tests which fail because of some unknown/unresolved reason (this list should be empty)
12 %define         broken_tests test_anydbm test_bsddb test_re test_shelve test_whichdb test_zipimport test_distutils
13 # test_distutils fails for unknown reason:
14 # AssertionError: '/tmp/tmpaomC0l/installation/share/python' != '/tmp/tmpaomC0l/installation/lib/python'
15
16 %define py_ver          2.4
17 %define py_prefix       %{_prefix}
18 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
19 %define py_incdir       %{_includedir}/python%{py_ver}
20 %define py_sitedir      %{py_libdir}/site-packages
21 %define py_dyndir       %{py_libdir}/lib-dynload
22
23 Summary:        Very high level scripting language with X interface
24 Summary(es):    Lenguaje script de alto nivel con interfaz X
25 Summary(fr):    Langage de script de très haut niveau avec interface X
26 Summary(pl):    Python - jêzyk obiektowy wysokiego poziomu
27 Summary(pt_BR): Linguagem de programação interpretada de alto nível
28 Summary(ru):    ñÚÙË ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ ÏÞÅÎØ ×ÙÓÏËÏÇÏ ÕÒÏ×ÎÑ Ó X-ÉÎÔÅÒÆÅÊÓÏÍ
29 Summary(tr):    X arayüzlü, yüksek düzeyli, kabuk yorumlayýcý dili
30 Summary(uk):    íÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÄÕÖÅ ×ÉÓÏËÏÇÏ Ò¦×ÎÑ Ú X-¦ÎÔÅÒÆÅÊÓÏÍ
31 Name:           python
32 Version:        %{py_ver}
33 Release:        1
34 Epoch:          1
35 License:        PSF
36 Group:          Applications
37 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
38 # Source0-md5:  44c2226eff0f3fc1f2fedaa1ce596533
39 Source1:        http://www.python.org/ftp/python/doc/%{version}/html-%{version}.tar.bz2
40 # Source1-md5:  10cca09fcdf1b5ad269bc9edb652d76f
41 Patch0:         %{name}-readline.patch
42 Patch1:         %{name}-%{name}path.patch
43 Patch2:         %{name}-default_encoding.patch
44 Patch3:         %{name}-no_ndbm.patch
45 Patch4:         %{name}-ac_fixes.patch
46 Patch5:         %{name}-noarch_to_datadir.patch
47 Patch6:         %{name}-lib64.patch
48 Patch7:         %{name}-doc_path.patch
49 URL:            http://www.python.org/
50 BuildRequires:  autoconf
51 BuildRequires:  bzip2-devel
52 BuildRequires:  db-devel >= 4
53 BuildRequires:  expat-devel >= 1:1.95.7
54 BuildRequires:  gdbm-devel >= 1.8.3
55 BuildRequires:  gmp-devel >= 4.0
56 BuildRequires:  ncurses-ext-devel >= 5.2
57 BuildRequires:  libstdc++-devel
58 BuildRequires:  openssl-devel >= 0.9.7d
59 BuildRequires:  readline-devel >= 4.2
60 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
61 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
62 BuildRequires:  zlib-devel
63 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
64 Provides:       %{name} = %{py_ver}
65 Obsoletes:      python-xml
66 Obsoletes:      python-intl
67 Obsoletes:      python-curses
68 Obsoletes:      python-gdbm
69 Obsoletes:      python-zlib
70 Obsoletes:      python2
71 Obsoletes:      python2-devel
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %if %{with verbose_tests}
75 %define test_flags -v -l -x 
76 %else
77 %define test_flags -l -x 
78 %endif
79
80 %ifarch alpha amd64 ia64 ppc64 sparc64 ppc64
81 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
82 %else
83 %define test_list %{nobuilder_tests} %{broken_tests}
84 %endif
85
86 %description
87 Python is an interpreted, interactive, object-oriented programming
88 language. It incorporates modules, exceptions, dynamic typing, very
89 high level dynamic data types, and classes. Python combines remarkable
90 power with very clear syntax. It has interfaces to many system calls
91 and libraries, as well as to various window systems, and is extensible
92 in C or C++. It is also usable as an extension language for
93 applications that need a programmable interface. Finally, Python is
94 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
95 MS-DOS, Windows, Windows NT, and OS/2.
96
97 %description -l de
98 Python ist eine interpretierte, interaktive, objektorientierte
99 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
100 Python enthält Module, Klassen, Exceptions, High-Level dynamische
101 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
102 zu vielen Systemaufrufen und Libraries, sowie verschiedene
103 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
104
105 Programmierer können neue built-in-Module für Python in C oder C++
106 schreiben. Python kann auch als Erweiterungssprache für Applikationen
107 benutzt werden, die ein programmierbares Interface brauchen. Dieses
108 Paket enthält die meisten Standard-Python-Module, und Module zum
109 Ansprechen von Tix (Tk-widget set) und RPM.
110
111 %description -l es
112 Python es un lenguaje de scripts interpretado orientado a objetos.
113 Contiene soporte para carga dinámica de objetos, clases, módulos y
114 excepciones.
115
116 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
117 través de código C, tornando Python fácil de usar en ambientes
118 particulares/personalizados. Este paquete Python incluye la mayoría de
119 los módulos padrón Python, junto con módulos para crear interfaces
120 para el conjunto de componentes Tix para Tk y RPM.
121
122 %description -l fr
123 Python est un langage de script interprété et orienté objet. Il gère
124 le chargement dynamique des objets, les classes, les modules et les
125 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
126 avec du code C est simple, ce qui rend Python facile à utiliser dans
127 des configs personnalisées.
128
129 Ce paquetage Python contient la plupart des modules Python standards,
130 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
131 et RPM.
132
133 %description -l pl
134 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
135 jêzykiem programowania. Jest modularny, obs³uguje wyj±tki, dynamiczne
136 typy, zaawansowane dynamiczne struktury danych i klasy. Python ³±czy w
137 sobie du¿e mo¿liwo¶ci i przejrzyst± sk³adniê. Posiada interfejsy do
138 wielu wywo³añ systemowych i bibliotek, w tym równie¿ do ró¿nych
139 bibliotek okienkowych. Mo¿liwo¶ci jego mo¿na jeszcze rozszerzaæ
140 poprzez odpowiednie modu³y pisane w C lub C++. Python mo¿e byæ równie¿
141 u¿yty jako element aplikacji, którym potrzebny jest interpreter do
142 skryptów. I wreszcie, Python jest wieloplatformowy, dzia³a na wielu
143 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
144 OS/2.
145
146 %description -l pt_BR
147 Python é uma linguagem de scripts interpretada orientada a objetos.
148 Contém suporte para carga dinâmica de objetos, classes, módulos e
149 exceções. Adicionar interfaces para novos sistemas de biblioteca
150 através de código C é simples, tornando Python fácil de usar em
151 ambientes particulares/personalizados.
152
153 Este pacote Python inclui a maioria do módulos padrão Python, junto
154 com módulos para interfaceamento para o conjunto de componentes Tix
155 para Tk e RPM.
156
157 %description -l ru
158 Python - ÜÔÏ ÉÎÔÅÒÐÒÅÔÉÒÕÅÍÙÊ, ÏÂßÅËÔÎÏ-ÏÒÉÅÎÔÉÒÏ×ÁÎÎÙÊ ÑÚÙË
159 ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ. ïΠÐÏÄÄÅÒÖÉ×ÁÅÔ ÄÉÎÁÍÉÞÅÓËÕÀ ÚÁÇÒÕÚËÕ ÏÂßÅËÔÏ×,
160 ËÌÁÓÓÙ, ÍÏÄÕÌÉ É ÏÂÒÁÂÏÔËÕ ÉÓËÌÀÞÉÔÅÌØÎÙÈ ÓÉÔÕÁÃÉÊ (exceptions).
161 ðÒÏÓÔÏÔÁ ÄÏÂÁ×ÌÅÎÉÑ ÉÎÔÅÒÆÅÊÓÏ× Ë ÎÏ×ÙÍ ÓÉÓÔÅÍÎÙÍ ÂÉÂÌÉÏÔÅËÁÍ ÞÅÒÅÚ
162 ËÏÄ ÎÁ ÑÚÙËÅ C ÄÅÌÁÅÔ Python ÈÏÒÏÛÉÍ ×ÙÂÏÒÏÍ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ×
163 ÓÐÅÃÉÁÌØÎÙÈ ËÏÎÆÉÇÕÒÁÃÉÑÈ.
164
165 %description -l tr
166 Python, nesneye yönelik bir kabuk yorumlayýcýdýr. Nesnelerin,
167 sýnýflarýn, modüllerin ve aykýrý durumlarýn dinamik yüklenmelerine
168 destek verir. C koduyla birlikte kullanýmý son derece kolaydýr. Bu
169 paket, standart Python birimlerinin çoðunun yanýsýra Tk ve RPM için
170 arayüz birimlerini de içerir.
171
172 %description -l uk
173 Python - ÃÅ ¦ÎÔÅÒÐÒÅÔÏ×ÁÎÁ, ÏÂ'¤ËÔÎÏ-ÏÒ¦¤ÎÔÏ×ÁÎÁ ÍÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ.
174 ÷¦Î Ð¦ÄÔÒÉÍÕ¤ ÄÉÎÁͦÞÎÕ ÚÁÇÒÕÚËÕ ÏÂ'¤ËÔ¦×, ËÌÁÓÉ, ÍÏÄÕ̦ ÔÁ ÏÂÒÏÂËÕ
175 ×ÉËÌÀÞÎÉÈ ÓÉÔÕÁæʠ(exceptions). ðÒÏÓÔÏÔÁ ÄÏÄÁ×ÁÎÎÑ ¦ÎÔÅÒÆÅÊӦנÄÌÑ
176 ÎÏ×ÉÈ ÓÉÓÔÅÍÎÉȠ¦Â̦ÏÔÅË ÞÅÒÅÚ ËÏÄ ÎÁ ÍÏצ C ÒÏÂÉÔØ Python ÄÏÂÒÉÍ
177 ×ÉÂÏÒÏÍ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎÑ × ÓÐÅæÁÌØÎÉÈ ËÏÎƦÇÕÒÁæÑÈ.
178
179 %package libs
180 Summary:        Python library
181 Summary(pl):    Biblioteka jêzyka Python
182 Group:          Libraries/Python
183 Provides:       %{name}-libs = %{py_ver}
184
185 %description libs
186 Python library.
187
188 %description libs -l pl
189 Biblioteka jêzyka Python.
190
191 %package modules
192 Summary:        Python modules
193 Summary(pl):    Modu³y jêzyka Python
194 Group:          Libraries/Python
195 Requires:       %{name} = %{epoch}:%{version}-%{release}
196 Provides:       %{name}-modules = %{py_ver}
197 Obsoletes:      python-logging
198 Obsoletes:      python-optik
199 Obsoletes:      python-xmlrpc <= 1.0.1
200
201 %description modules
202 Python modules.
203
204 %description modules -l pl
205 Modu³y jêzyka Python.
206
207 %package -n pydoc
208 Summary:        Python interactive module documentation access support
209 Summary(pl):    Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python
210 Group:          Applications
211 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
212 Obsoletes:      python-pydoc
213
214 %description -n pydoc
215 Python interactive module documentation access support.
216
217 %description -n pydoc -l pl
218 Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python.
219
220 %package -n idle
221 Summary:        IDE for Python language
222 Summary(pl):    IDE dla jêzyka Python
223 Group:          Applications
224 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
225 Obsoletes:      python-idle
226
227 %description -n idle
228 IDE for Python language.
229
230 %description -n idle -l pl
231 IDE dla jêzyka Python.
232
233 %package devel
234 Summary:        Libraries and header files for building python code
235 Summary(de):    Libraries und Header-Dateien zum Erstellen von Python-Code
236 Summary(es):    Bibliotecas y archivos de inclusión para construir programas en python
237 Summary(fr):    Bibliothèques et en-têtes pour construire du code python
238 Summary(pl):    Pliki nag³ówkowe i biblioteki Pythona
239 Summary(pt_BR): Bibliotecas e arquivos de inclusão para o Python
240 Summary(ru):    âÉÂÌÉÏÔÅËÉ É ÈÅÄÅÒÙ ÄÌÑ ÐÏÓÔÒÏÅÎÉÑ ËÏÄÁ ÎÁ ÑÚÙËÅ Python
241 Summary(tr):    Python ile geliþtirme yapmak için gerekli dosyalar
242 Summary(uk):    â¦Â̦ÏÔÅËÉ ÔÁ ÈÅÄÅÒÉ ÄÌÑ ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÎÁ ÍÏצ Python
243 Group:          Development/Languages/Python
244 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
245
246 %description devel
247 The Python interpreter is relatively easy to extend with dynamically
248 loaded extensions and to embed in other programs. This package
249 contains the header files and libraries which are needed to do both of
250 these tasks.
251
252 %description devel -l de
253 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
254 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
255 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
256 die für beide Aufgaben erforderlich sind.
257
258 %description devel -l es
259 El interpretador Python permite incluir con facilidad extensiones
260 cargadas dinámicamente. Python es también fácil de ser empotrado en
261 otros programas. Este paquete contiene los archivos de inclusión y
262 bibliotecas necesarios para estas dos tareas.
263
264 %description devel -l fr
265 L'interpréteur Python est relativement facile à étendre avec des
266 extensions chargées dynamiquement et à insérer dans d'autres
267 programmes. Ce paquetage contient les en-têtes et les bibliothèques
268 nécessaires à ces deux tâches.
269
270 %description devel -l pl
271 Interpreter Pythona jest w miarê ³atwy do rozszerzania przy pomocy
272 dynamicznie ³adowanych rozszerzeñ napisanych w C lub C++ oraz
273 osadzania w innych programach. Ten pakiet zawiera pliki nag³ówkowe i
274 wszystko inne co potrzebne do tych celów.
275
276 %description devel -l pt_BR
277 O interpretador Python permite incluir com facilidade extensões
278 carregadas dinamicamente. Python é também fácil de ser embutido em
279 outros programas. Este pacote contém os arquivos de inclusão e
280 bibliotecas necessários para estas duas tarefas.
281
282 %description devel -l ru
283 éÎÔÅÒÐÒÅÔÁÔÏÒ Python ÏÔÎÏÓÉÔÅÌØÎÏ ÌÅÇËÏ ÒÁÓÛÉÒÑÅÔÓÑ ÐÒÉ ÐÏÍÏÝÉ
284 ÄÉÎÁÍÉÞÅÓËÉ ÚÁÇÒÕÖÁÅÍÙÈ ÒÁÓÛÉÒÅÎÉÊ É ×ÓÔÒÁÉ×ÁÅÔÓÑ × ÄÒÕÇÉÅ ÐÒÏÇÒÁÍÍÙ.
285 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÈÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÏÂÅÉÈ ÜÔÉÈ
286 ÚÁÄÁÞ.
287
288 %description devel -l tr
289 Bu paket, Python ile geliþtirme yapýlabilmesi için gerekli baþlýk
290 dosyalarýný ve kitaplýklarý içerir.
291
292 %description devel -l uk
293 ¶ÎÔÅÒÐÒÅÔÁÔÏÒ Python ×¦ÄÎÏÓÎÏ ÌÅÇËÏ ÒÏÚÛÉÒÀ¤ÔØÓÑ ÚÁ ÄÏÐÏÍÏÇÏÀ
294 ÒÏÚÛÉÒÅÎØ Ú ÄÉÎÁͦÞÎÏÀ ÚÁÇÒÕÚËÏÀ ÔÁ ×ÂÕÄÏ×Õ¤ÔØÓÑ × ¦ÎÛ¦ ÐÒÏÇÒÁÍÉ. ãÅÊ
295 ÐÁËÅԠͦÓÔÉÔØ ÈÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÏÂÏÈ ÃÉÈ ÚÁÄÁÞ.
296
297 %package devel-src
298 Summary:        Python module sources
299 Summary(pl):    Pliki ¼ród³owe modu³ów Pythona
300 Group:          Development/Languages/Python
301 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
302
303 %description devel-src
304 Python module sources.
305
306 %description devel-src -l pl
307 Pliki ¼ród³owe modu³ów Pythona.
308
309 %package devel-tools
310 Summary:        Python development tools
311 Summary(pl):    Narzêdzia programistyczne jêzyka Python
312 Group:          Development/Languages/Python
313 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
314
315 %description devel-tools
316 Python development tools such as profilers and debugger.
317
318 %description devel-tools -l pl
319 Narzêdzia programistyczne jêzyka Python takie jak profiler oraz debugger.
320
321 %package static
322 Summary:        Static python library
323 Summary(pl):    Statyczna biblioteka Pythona
324 Group:          Development/Languages/Python
325 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
326 Provides:       %{name}-static = %{py_ver}
327
328 %description static
329 Static python library.
330
331 %description static -l pl
332 Statyczna biblioteka Pythona.
333
334 %package doc
335 Summary:        Documentation on Python
336 Summary(de):    Dokumentation zu Python
337 Summary(es):    Documentación para Python
338 Summary(fr):    Documentation sur Python
339 Summary(pl):    Dokumentacja do Pythona
340 Summary(pt_BR): Documentação para a linguagem de programação Python
341 Summary(ru):    äÏËÕÍÅÎÔÁÃÉÑ ÐÏ ÑÚÙËÕ Python
342 Summary(tr):    Python belgeleri
343 Summary(uk):    äÏËÕÍÅÎÔÁæѠÐÏ ÍÏצ Python
344 Group:          Documentation
345 Requires:       %{name} = %{epoch}:%{version}-%{release}
346 Obsoletes:      python-docs
347
348 %description doc
349 This package contains documentation on the Python language and
350 interpretor as a mix of plain ASCII files and LaTeX sources.
351
352 %description doc -l de
353 Dieses Paket enthält Dokumentationen zu Python (Sprache und
354 Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
355
356 %description doc -l es
357 Documentación para Python. Contiene archivos en texto y PostScript.
358
359 %description doc -l fr
360 Ce paquetage contient la documentation sur le langage python et sur
361 son interpréteur sous forme de fichiers ASCII et LaTeX.
362
363 %description doc -l pl
364 Oficjalna dokumentacja do Pythona. Zawiera przyk³adowe programy,
365 narzêdzia i dokumentacjê. Strony podrêcznika man znajduj± siê w
366 g³ównym pakiecie. Ten pakiet nie zawiera ¼róde³ dokumentacji
367 napisanych w LaTeXu, tylko gotowe do wykorzystania pliki
368 postscriptowe i HTML.
369
370 %description doc -l pt_BR
371 O pacote python-doc contém documentação para a linguagem de
372 programação e para o interpretador Python. Fornecida em arquivos texto
373 e Postcript.
374
375 %description doc -l ru
376 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÏËÕÍÅÎÔÁÃÉÀ ÐÏ ÓÏÂÓÔ×ÅÎÎÏ ÑÚÙËÕ Python É ÐÏ
377 ÉÓÐÏÌÎÑÀÝÅÍÕ ÅÇÏ ÉÎÔÅÒÐÒÅÔÁÔÏÒÕ × ×ÉÄÅ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÙÈ ÆÁÊÌÏ× É
378 ÉÓÈÏÄÎÙÈ ÔÅËÓÔÏ× × ÆÏÒÍÁÔÅ LaTeX.
379
380 %description doc -l tr
381 Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyalarý ve
382 LaTeX kaynaklarýnýn bir karýþýmý olan yorumlayýcýyý içerir.
383
384 %description doc -l uk
385 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÄÏËÕÍÅÎÔÁæÀ ÐÏ ×ÌÁÓÎÅ ÍÏצ Python ÔÁ ÐÏ ×ÉËÏÎÕÀÞÏÍÕ
386 §§ ¦ÎÔÅÒÐÒÅÔÁÔÏÒÕ Õ ×ÉÇÌÑĦ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÉÈ ÆÁÊ̦נÔÁ ×ÉȦÄÎÉÈ
387 ÔÅËÓԦנՠÆÏÒÍÁÔ¦ LaTeX.
388
389 %package tkinter
390 Summary:        Standard Python interface to the Tk GUI toolkit
391 Summary(de):    Grafische Tk-Schnittstelle für Python
392 Summary(es):    Interfaz de GUI Tk para Python
393 Summary(fr):    Interface graphique Tk pour Python
394 Summary(pl):    Standardowy interfejs Pythona do biblioteki Tk
395 Summary(pt_BR): Interface GUI Tk para Phyton
396 Summary(tr):    Python için grafik kullanýcý arayüzü
397 Group:          Libraries/Python
398 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
399 Requires:       tcl >= 8.4.3
400 Requires:       tix >= 1:8.1.4-4
401 Requires:       tk >= 8.4.3
402 Obsoletes:      tkinter
403
404 %description tkinter
405 Standard Python interface to the Tk GUI toolkit.
406
407 %description tkinter -l de
408 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
409 vielen Konfigurations-Tools genutzt.
410
411 %description tkinter -l es
412 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por
413 muchas herramientas de configuración.
414
415 %description tkinter -l fr
416 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
417 beaucoup des outils de configuration.
418
419 %description tkinter -l pl
420 Standardowy interfejs Pythona do biblioteki Tk.
421
422 %description tkinter -l pt_BR
423 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
424 muitas ferramentas de configuração.
425
426 %description tkinter -l ru
427 çÒÁÆÉÞÅÓËÉÊ ÉÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÓÔÒÏÅÎÎÙÊ ÎÁ Tcl/Tk.
428
429 %description tkinter -l tr
430 Python için Tcl/Tk'ye dayalý ve pek çok ayarlama aracý tarafýndan
431 kullanýlan grafik bir arayüzdür.
432
433 %description tkinter -l uk
434 çÒÁƦÞÎÉÊ ¦ÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÂÕÄÏ×ÁÎÉÊ ÎÁ Tcl/Tk.
435
436 %package old
437 Summary:        Deprecated Python modules
438 Summary(pl):    Nieaktualne modu³y jêzyka Python
439 Group:          Libraries/Python
440 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
441
442 %description old
443 Install this package when one of your program written in Python is old
444 as Miss Universum of 1918, who only you want to see... ooops, which
445 only you want to run.
446
447 %description old -l pl
448 Zainstaluj ten pakiet, wtedy kiedy jeden z Twoich programów napisanych
449 w jêzyku Python jest tak stary jak Miss Universum z roku 1918, któr±
450 tylko ty chcesz zobaczyæ... przepraszam, który tylko ty chcesz
451 uruchomiæ.
452
453 %package examples
454 Summary:        Example programs in Python
455 Summary(pl):    Przyk³adowe programy w Pythonie
456 Group:          Development/Languages/Python
457 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
458 Obsoletes:      python-tools
459
460 %description examples
461 Example programs in Python.
462
463 These are for Python 2.3.4, not %{version}.
464
465 %description examples -l pl
466 Przyk³adowe programy w Pythonie.
467
468 Przyk³ady te s± dla Pythona 2.3.4, nie %{version}.
469
470 %prep
471 %setup -q -n Python-%{version}
472 %patch0 -p1
473 %patch1 -p1
474 # should be already fixed in the source but seems not to be:
475 %patch2 -p1
476 %patch3 -p1
477 %patch4 -p1
478 %patch5 -p1
479 %if "%{_lib}" == "lib64"
480 %patch6 -p1
481 %endif
482 %patch7 -p1
483
484 tar -xf %{SOURCE1} --use=bzip2
485
486 %build
487 sed -i -e 's#-ltermcap#-ltinfo#g' configure*
488 %{__autoconf}
489 CPPFLAGS="-I%{_includedir}/ncurses"; export CPPFLAGS
490 %configure \
491         --with-threads \
492         --with-cxx=%{__cxx} \
493         --enable-unicode=ucs4 \
494         --enable-shared
495
496 %{__make} \
497         OPT="%{rpmcflags}"
498
499 LC_ALL=C
500 export LC_ALL
501 %if %{with tests}
502 binlibdir=`echo build/lib.*`
503 %{__make} test \
504         TESTOPTS="%{test_flags} %{test_list}" \
505         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
506 %endif
507
508 %install
509 rm -rf $RPM_BUILD_ROOT
510 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
511         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
512         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
513
514 %{__make} install \
515         DESTDIR=$RPM_BUILD_ROOT
516
517 install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
518
519 install libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}
520 ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
521 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython.so
522 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{py_ver}.so
523
524 rm -f $RPM_BUILD_ROOT%{_bindir}/python%{py_ver}
525
526 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
527 cp -ar Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
528
529 SCRIPT_EXT=".py"
530 export SCRIPT_EXT
531
532 # create several useful scripts, such as timeit.py, profile.py, pdb.py, smtpd.py
533 for script in timeit profile pdb pstats smtpd; do
534     cat <<END > $RPM_BUILD_ROOT%{_bindir}/${script}$SCRIPT_EXT
535 #!/bin/sh
536 exec python %{py_scriptdir}/${script}.pyc "\$@"
537 END
538 done
539
540 # xgettext specific for Python code
541 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext$SCRIPT_EXT
542
543 %clean
544 rm -rf $RPM_BUILD_ROOT
545
546 %post   libs -p /sbin/ldconfig
547 %postun libs -p /sbin/ldconfig
548
549 %files
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{_bindir}/python
552 %{_mandir}/man1/*
553
554 # readline support for python binary
555 %attr(755,root,root) %{py_dyndir}/readline.so
556
557 %files modules
558 %defattr(644,root,root,755)
559 %exclude %{py_scriptdir}/UserDict.py[co]
560 %exclude %{py_scriptdir}/codecs.py[co]
561 %exclude %{py_scriptdir}/copy_reg.py[co]
562 %exclude %{py_scriptdir}/locale.py[co]
563 %exclude %{py_scriptdir}/posixpath.py[co]
564 %exclude %{py_scriptdir}/pdb.py[co]
565 %exclude %{py_scriptdir}/profile.py[co]
566 %exclude %{py_scriptdir}/pstats.py[co]
567 %exclude %{py_scriptdir}/pydoc.py[co]
568 %exclude %{py_scriptdir}/site.py[co]
569 %exclude %{py_scriptdir}/smtpd.py[co]
570 %exclude %{py_scriptdir}/stat.py[co]
571 %exclude %{py_scriptdir}/timeit.py[co]
572 %exclude %{py_scriptdir}/os.py[co]
573 %exclude %{py_scriptdir}/encodings/*.py[co]
574
575 %{py_scriptdir}/*.py[co]
576
577 #
578 # list .so modules to be sure that all of them are built
579 #
580
581 # three modules below does not work on 64-bit architectures
582 # see Python README file for explanation
583 %ifnarch alpha amd64 ia64 ppc64 sparc64
584 %attr(755,root,root) %{py_dyndir}/audioop.so
585 %attr(755,root,root) %{py_dyndir}/rgbimg.so
586 %attr(755,root,root) %{py_dyndir}/imageop.so
587 # sizeof(long) != sizeof(int), so dl module will not be built on 64-bit
588 # platforms
589 %attr(755,root,root) %{py_dyndir}/dl.so
590 %endif
591
592 %attr(755,root,root) %{py_dyndir}/_bisect.so
593 %attr(755,root,root) %{py_dyndir}/_bsddb.so
594 %attr(755,root,root) %{py_dyndir}/_codecs_cn.so
595 %attr(755,root,root) %{py_dyndir}/_codecs_hk.so
596 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
597 %attr(755,root,root) %{py_dyndir}/_codecs_jp.so
598 %attr(755,root,root) %{py_dyndir}/_codecs_kr.so
599 %attr(755,root,root) %{py_dyndir}/_codecs_tw.so
600 %attr(755,root,root) %{py_dyndir}/_csv.so
601 %attr(755,root,root) %{py_dyndir}/_curses.so
602 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
603 %attr(755,root,root) %{py_dyndir}/_heapq.so
604 %attr(755,root,root) %{py_dyndir}/_locale.so
605 %attr(755,root,root) %{py_dyndir}/_multibytecodec.so
606 %attr(755,root,root) %{py_dyndir}/_random.so
607 %attr(755,root,root) %{py_dyndir}/_socket.so
608 %attr(755,root,root) %{py_dyndir}/_ssl.so
609 %attr(755,root,root) %{py_dyndir}/_testcapi.so
610 %attr(755,root,root) %{py_dyndir}/_weakref.so
611 %attr(755,root,root) %{py_dyndir}/array.so
612 %attr(755,root,root) %{py_dyndir}/binascii.so
613 %attr(755,root,root) %{py_dyndir}/bz2.so
614 %attr(755,root,root) %{py_dyndir}/cPickle.so
615 %attr(755,root,root) %{py_dyndir}/cStringIO.so
616 %attr(755,root,root) %{py_dyndir}/cmath.so
617 %attr(755,root,root) %{py_dyndir}/collections.so
618 %attr(755,root,root) %{py_dyndir}/crypt.so
619 %attr(755,root,root) %{py_dyndir}/datetime.so
620 %ifnarch sparc64
621 %attr(755,root,root) %{py_dyndir}/dbm.so
622 %endif
623 %attr(755,root,root) %{py_dyndir}/fcntl.so
624 %attr(755,root,root) %{py_dyndir}/gdbm.so
625 %attr(755,root,root) %{py_dyndir}/grp.so
626 %attr(755,root,root) %{py_dyndir}/itertools.so
627 %attr(755,root,root) %{py_dyndir}/linuxaudiodev.so
628 %attr(755,root,root) %{py_dyndir}/math.so
629 %attr(755,root,root) %{py_dyndir}/md5.so
630 %attr(755,root,root) %{py_dyndir}/mmap.so
631 %attr(755,root,root) %{py_dyndir}/nis.so
632 %attr(755,root,root) %{py_dyndir}/operator.so
633 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
634 %attr(755,root,root) %{py_dyndir}/parser.so
635 %attr(755,root,root) %{py_dyndir}/pwd.so
636 %attr(755,root,root) %{py_dyndir}/pyexpat.so
637 %attr(755,root,root) %{py_dyndir}/regex.so
638 %attr(755,root,root) %{py_dyndir}/resource.so
639 %attr(755,root,root) %{py_dyndir}/select.so
640 %attr(755,root,root) %{py_dyndir}/sha.so
641 %attr(755,root,root) %{py_dyndir}/strop.so
642 %attr(755,root,root) %{py_dyndir}/syslog.so
643 %attr(755,root,root) %{py_dyndir}/termios.so
644 %attr(755,root,root) %{py_dyndir}/time.so
645 %attr(755,root,root) %{py_dyndir}/timing.so
646 %attr(755,root,root) %{py_dyndir}/unicodedata.so
647 %attr(755,root,root) %{py_dyndir}/zlib.so
648
649 %dir %{py_scriptdir}/plat-*
650 %attr(755,root,root) %{py_scriptdir}/plat-*/regen
651 %{py_scriptdir}/plat-*/*.py[co]
652
653 %dir %{py_scriptdir}/bsddb
654 %{py_scriptdir}/bsddb/*.py[co]
655
656 %dir %{py_scriptdir}/compiler
657 %{py_scriptdir}/compiler/*.py[co]
658
659 %dir %{py_scriptdir}/curses
660 %{py_scriptdir}/curses/*.py[co]
661
662 %dir %{py_scriptdir}/distutils
663 %{py_scriptdir}/distutils/*.py[co]
664
665 %dir %{py_scriptdir}/distutils/command
666 %{py_scriptdir}/distutils/command/*.py[co]
667
668 %dir %{py_scriptdir}/email
669 %{py_scriptdir}/email/*.py[co]
670
671 %dir %{py_scriptdir}/logging
672 %{py_scriptdir}/logging/*.py[co]
673
674 %dir %{py_scriptdir}/xml
675 %{py_scriptdir}/xml/*.py[co]
676
677 %dir %{py_scriptdir}/xml/parsers
678 %{py_scriptdir}/xml/parsers/*.py[co]
679
680 %dir %{py_scriptdir}/xml/sax
681 %{py_scriptdir}/xml/sax/*.py[co]
682
683 %dir %{py_scriptdir}/xml/dom
684 %{py_scriptdir}/xml/dom/*.py[co]
685
686 %files libs
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_libdir}/libpython*.so.*
689
690 %dir %{py_dyndir}
691 %dir %{py_scriptdir}
692 %dir %{py_libdir}
693 %dir %{py_sitescriptdir}
694 %dir %{py_sitedir}
695
696 # shared modules required by python library
697 %attr(755,root,root) %{py_dyndir}/struct.so
698
699 # modules required by python library
700 %{py_scriptdir}/UserDict.py[co]
701 %{py_scriptdir}/codecs.py[co]
702 %{py_scriptdir}/copy_reg.py[co]
703 %{py_scriptdir}/locale.py[co]
704 %{py_scriptdir}/posixpath.py[co]
705 %{py_scriptdir}/site.py[co]
706 %{py_scriptdir}/stat.py[co]
707 %{py_scriptdir}/os.py[co]
708
709 # encodings required by python library
710 %dir %{py_scriptdir}/encodings
711 %{py_scriptdir}/encodings/*.py[co]
712
713 %files -n pydoc
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_bindir}/pydoc
716 %{py_scriptdir}/pydoc.py[co]
717
718 %files -n idle
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_bindir}/idle
721 %dir %{py_scriptdir}/idlelib
722 %dir %{py_scriptdir}/idlelib/Icons
723 %{py_scriptdir}/idlelib/*.py[co]
724 %{py_scriptdir}/idlelib/Icons/*
725 %{py_scriptdir}/idlelib/*.def
726
727 %files devel
728 %defattr(644,root,root,755)
729 %doc Misc/{ACKS,NEWS,README}
730 %attr(755,root,root) %{_libdir}/lib*.so
731 %dir %{py_incdir}
732 %{py_incdir}/*.h
733
734 %dir %{py_libdir}/config
735 %attr(755,root,root) %{py_libdir}/config/makesetup
736 %attr(755,root,root) %{py_libdir}/config/install-sh
737 %{py_libdir}/config/Makefile
738 %{py_libdir}/config/Makefile.pre.in
739 %{py_libdir}/config/Setup
740 %{py_libdir}/config/Setup.config
741 %{py_libdir}/config/Setup.local
742 %{py_libdir}/config/config.c
743 %{py_libdir}/config/config.c.in
744 %{py_libdir}/config/ccpython.o
745 %{py_libdir}/config/libpython2.4.a
746
747 %files devel-src
748 %defattr(644,root,root,755)
749 %attr(-,root,root) %{py_scriptdir}/*.py
750 %{py_scriptdir}/plat-*/*.py
751 %{py_scriptdir}/bsddb/*.py
752 %{py_scriptdir}/compiler/*.py
753 %{py_scriptdir}/curses/*.py
754 %{py_scriptdir}/distutils/*.py
755 %{py_scriptdir}/distutils/command/*.py
756 %{py_scriptdir}/email/*.py
757 %{py_scriptdir}/hotshot/*.py
758 %{py_scriptdir}/logging/*.py
759 %{py_scriptdir}/xml/*.py
760 %{py_scriptdir}/xml/parsers/*.py
761 %{py_scriptdir}/xml/sax/*.py
762 %{py_scriptdir}/xml/dom/*.py
763 %{py_scriptdir}/encodings/*.py
764 %{py_scriptdir}/idlelib/*.py
765
766 %files devel-tools
767 %defattr(644,root,root,755)
768 %doc Lib/profile.doc Lib/pdb.doc
769 %attr(755,root,root) %{_bindir}/timeit*
770 %attr(755,root,root) %{_bindir}/profile*
771 %attr(755,root,root) %{_bindir}/pdb*
772 %attr(755,root,root) %{_bindir}/pstats*
773 %attr(755,root,root) %{_bindir}/pygettext*
774 %attr(755,root,root) %{_bindir}/smtpd*
775
776 %attr(755,root,root) %{py_dyndir}/_hotshot.so
777 %dir %{py_scriptdir}/hotshot
778 %{py_scriptdir}/hotshot/*.py[co]
779 %{py_scriptdir}/pdb.py[co]
780 %{py_scriptdir}/profile.py[co]
781 %{py_scriptdir}/pstats.py[co]
782 %{py_scriptdir}/smtpd.py[co]
783 %{py_scriptdir}/timeit.py[co]
784
785 %files static
786 %defattr(644,root,root,755)
787 %{_libdir}/lib*.a
788
789 %files examples
790 %defattr(644,root,root,755)
791 %{_examplesdir}/%{name}-%{version}
792
793 %files doc
794 %defattr(644,root,root,755)
795 # FIXME
796 %doc Python-Docs-%{version}
797 %dir %{py_scriptdir}/test
798 %attr(-,root,root) %{py_scriptdir}/test/*
799 %attr(-,root,root) %{py_scriptdir}/email/test/*
800 %attr(-,root,root) %{py_scriptdir}/bsddb/test/*
801
802 %if %{with tkinter}
803 %files tkinter
804 %defattr(644,root,root,755)
805 %{py_scriptdir}/lib-tk
806 %attr(755,root,root) %{py_dyndir}/_tkinter.so
807 %endif
808
809 %files old
810 %defattr(644,root,root,755)
811 %dir %{py_scriptdir}/lib-old
812 %{py_scriptdir}/lib-old/*.py[co]
This page took 0.141408 seconds and 4 git commands to generate.