]> git.pld-linux.org Git - packages/python.git/blob - python.spec
- test_pty added to obuilder_tests
[packages/python.git] / python.spec
1 #
2 # Conditional build:
3 %bcond_without  tkinter                 # disables tkinter module building
4 %bcond_without  tests                   # disables Python testing
5 %bcond_with     verbose_tests           # runs tests in verbose mode
6 %bcond_with     noautosys               # do not put sys.argv[0] directory in sys.path
7 #
8 # tests which will not work on 64-bit platforms
9 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
10 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
11 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
12 # tests which fail because of some unknown/unresolved reason (this list should be empty)
13 %define         broken_tests test_anydbm test_bsddb test_re test_shelve test_whichdb test_zipimport
14
15 %define py_ver         2.3
16 %define py_prefix      %{_prefix}
17 %define py_libdir      %{py_prefix}/%{_lib}/python%{py_ver}
18 %define py_scriptdir   %{py_prefix}/share/python%{py_ver}
19 %define py_incdir      %{_includedir}/python%{py_ver}
20 %define py_sitedir     %{py_libdir}/site-packages
21 %define py_sitescriptdir %{py_scriptdir}/site-packages
22 %define py_dyndir      %{py_libdir}/lib-dynload
23 %define py_comp        ./python -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
24 %define py_ocomp       ./python -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
25
26 Summary:        Very high level scripting language with X interface
27 Summary(de):    Very High-Level-Script-Sprache mit X-Oberfläche
28 Summary(es):    Lenguaje script de alto nivel con interface X
29 Summary(fr):    Langage de script de tés haut niveau avec interface X
30 Summary(pl):    Python - jêzyk obiektowy wysokiego poziomu
31 Summary(pt_BR): Linguagem de programação interpretada, orientada a objeto de alto nível
32 Summary(ru):    ñÚÙË ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ ÏÞÅÎØ ×ÙÓÏËÏÇÏ ÕÒÏ×ÎÑ Ó X-ÉÎÔÅÒÆÅÊÓÏÍ
33 Summary(tr):    X arayüzlü, yüksek düzeyli, kabuk yorumlayýcý dili
34 Summary(uk):    íÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÄÕÖÅ ×ÉÓÏËÏÇÏ Ò¦×ÎÑ Ú X-¦ÎÔÅÒÆÅÊÓÏÍ
35 Name:           python
36 Version:        %{py_ver}.4
37 Release:        3
38 Epoch:          1
39 License:        PSF
40 Group:          Applications
41 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
42 # Source0-md5:  a2c089faa2726c142419c03472fc4063
43 Source1:        http://www.python.org/ftp/python/doc/%{version}/html-%{version}.tar.bz2
44 # Source1-md5:  599abc498714de055814d4542de4f2fc
45 Patch0:         %{name}-readline.patch
46 Patch1:         %{name}-%{name}path.patch
47 Patch2:         %{name}-default_encoding.patch
48 Patch3:         %{name}-no_ndbm.patch
49 Patch4:         %{name}-ac_fixes.patch
50 Patch5:         %{name}-noarch_to_datadir.patch
51 Patch6:         %{name}-lib64.patch
52 Patch7:         %{name}-doc_path.patch
53 Patch8:         %{name}-noautosys.patch
54 URL:            http://www.python.org/
55 BuildRequires:  autoconf
56 BuildRequires:  bzip2-devel
57 BuildRequires:  db-devel >= 4
58 BuildRequires:  expat-devel >= 1:1.95.7
59 BuildRequires:  gdbm-devel >= 1.8.3
60 BuildRequires:  gmp-devel >= 4.0
61 BuildRequires:  ncurses-ext-devel >= 5.2
62 BuildRequires:  openssl-devel >= 0.9.7d
63 BuildRequires:  readline-devel >= 4.2
64 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
65 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
66 BuildRequires:  zlib-devel
67 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
68 Provides:       %{name} = %{py_ver}
69 Obsoletes:      python-xml
70 Obsoletes:      python-intl
71 Obsoletes:      python-curses
72 Obsoletes:      python-gdbm
73 Obsoletes:      python-zlib
74 Obsoletes:      python2
75 Obsoletes:      python2-devel
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %if %{with verbose_tests}
79 %define test_flags -v -l -x 
80 %else
81 %define test_flags -l -x 
82 %endif
83
84 %ifarch alpha amd64 ia64 ppc64 sparc64 ppc64
85 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
86 %else
87 %define test_list %{nobuilder_tests} %{broken_tests}
88 %endif
89
90 %description
91 Python is an interpreted, interactive, object-oriented programming
92 language. It incorporates modules, exceptions, dynamic typing, very
93 high level dynamic data types, and classes. Python combines remarkable
94 power with very clear syntax. It has interfaces to many system calls
95 and libraries, as well as to various window systems, and is extensible
96 in C or C++. It is also usable as an extension language for
97 applications that need a programmable interface. Finally, Python is
98 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
99 MS-DOS, Windows, Windows NT, and OS/2.
100
101 %description -l de
102 Python ist eine interpretierte, interaktive, objektorientierte
103 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
104 Python enthält Module, Klassen, Exceptions, High-Level dynamische
105 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
106 zu vielen Systemaufrufen und Libraries, sowie verschiedene
107 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
108
109 Programmierer können neue built-in-Module für Python in C oder C++
110 schreiben. Python kann auch als Erweiterungssprache für Applikationen
111 benutzt werden, die ein programmierbares Interface brauchen. Dieses
112 Paket enthält die meisten Standard-Python-Module, und Module zum
113 Ansprechen von Tix (Tk-widget set) und RPM.
114
115 %description -l es
116 Python es un lenguaje de scripts interpretado orientado a objetos.
117 Contiene soporte para carga dinámica de objetos, clases, módulos y
118 excepciones.
119
120 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
121 través de código C, tornando Python fácil de usar en ambientes
122 articulares/ personalizados. Este paquete Python incluye la mayoría de
123 los módulos padrón Python, junto con módulos para crear interfaces
124 para el conjunto de componentes Tix para Tk y RPM.
125
126 %description -l fr
127 Python est un langage de script interprété et orienté objet. Il gère
128 le chargement dynamique des objets, les classes, les modules et les
129 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
130 avec du code C est simple, ce qui rend Python facile à utiliser dans
131 des configs personnalisées.
132
133 Ce paquetage Python contient la plupart des modules Python standards,
134 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
135 et RPM.
136
137 %description -l pl
138 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
139 jêzykiem programowania. Jest modularny, obs³uguje wyj±tki, dynamiczne
140 typy, zaawansowane dynamiczne struktury danych i klasy. Python ³±czy w
141 sobie du¿e mo¿liwo¶ci i przejrzyst± sk³adniê. Posiada interfejsy do
142 wielu wywo³añ systemowych i bibliotek, w tym równie¿ do ró¿nych
143 bibliotek okienkowych. Mo¿liwo¶ci jego mo¿na jeszcze rozszerzaæ
144 poprzez odpowiednie modu³y pisane w C lub C++. Python mo¿e byæ równie¿
145 u¿yty jako element aplikacji, którym potrzebny jest interpreter do
146 skryptów. I wreszcie, Python jest wieloplatformowy, dzia³a na wielu
147 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
148 OS/2.
149
150 %description -l pt_BR
151 Python é uma linguagem de scripts interpretada orientada a objetos.
152 Contém suporte para carga dinâmica de objetos, classes, módulos e
153 exceções. Adicionar interfaces para novos sistemas de biblioteca
154 através de código C é simples, tornando Python fácil de usar em
155 ambientes particulares/personalizados.
156
157 Este pacote Python inclui a maioria do módulos padrão Python, junto
158 com módulos para interfaceamento para o conjunto de componentes Tix
159 para Tk e RPM.
160
161 %description -l ru
162 Python - ÜÔÏ ÉÎÔÅÒÐÒÅÔÉÒÕÅÍÙÊ, ÏÂßÅËÔÎÏ-ÏÒÉÅÎÔÉÒÏ×ÁÎÎÙÊ ÑÚÙË
163 ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ. ïΠÐÏÄÄÅÒÖÉ×ÁÅÔ ÄÉÎÁÍÉÞÅÓËÕÀ ÚÁÇÒÕÚËÕ ÏÂßÅËÔÏ×,
164 ËÌÁÓÓÙ, ÍÏÄÕÌÉ É ÏÂÒÁÂÏÔËÕ ÉÓËÌÀÞÉÔÅÌØÎÙÈ ÓÉÔÕÁÃÉÊ (exceptions).
165 ðÒÏÓÔÏÔÁ ÄÏÂÁ×ÌÅÎÉÑ ÉÎÔÅÒÆÅÊÓÏ× Ë ÎÏ×ÙÍ ÓÉÓÔÅÍÎÙÍ ÂÉÂÌÉÏÔÅËÁÍ ÞÅÒÅÚ
166 ËÏÄ ÎÁ ÑÚÙËÅ C ÄÅÌÁÅÔ Python ÈÏÒÏÛÉÍ ×ÙÂÏÒÏÍ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ×
167 ÓÐÅÃÉÁÌØÎÙÈ ËÏÎÆÉÇÕÒÁÃÉÑÈ.
168
169 %description -l tr
170 Python, nesneye yönelik bir kabuk yorumlayýcýdýr. Nesnelerin,
171 sýnýflarýn, modüllerin ve aykýrý durumlarýn dinamik yüklenmelerine
172 destek verir. C koduyla birlikte kullanýmý son derece kolaydýr. Bu
173 paket, standart Python birimlerinin çoðunun yanýsýra Tk ve RPM için
174 arayüz birimlerini de içerir.
175
176 %description -l uk
177 Python - ÃÅ ¦ÎÔÅÒÐÒÅÔÏ×ÁÎÁ, ÏÂ'¤ËÔÎÏ-ÏÒ¦¤ÎÔÏ×ÁÎÁ ÍÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ.
178 ÷¦Î Ð¦ÄÔÒÉÍÕ¤ ÄÉÎÁͦÞÎÕ ÚÁÇÒÕÚËÕ ÏÂ'¤ËÔ¦×, ËÌÁÓÉ, ÍÏÄÕ̦ ÔÁ ÏÂÒÏÂËÕ
179 ×ÉËÌÀÞÎÉÈ ÓÉÔÕÁæʠ(exceptions). ðÒÏÓÔÏÔÁ ÄÏÄÁ×ÁÎÎÑ ¦ÎÔÅÒÆÅÊӦנÄÌÑ
180 ÎÏ×ÉÈ ÓÉÓÔÅÍÎÉȠ¦Â̦ÏÔÅË ÞÅÒÅÚ ËÏÄ ÎÁ ÍÏצ C ÒÏÂÉÔØ Python ÄÏÂÒÉÍ
181 ×ÉÂÏÒÏÍ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎÑ × ÓÐÅæÁÌØÎÉÈ ËÏÎƦÇÕÒÁæÑÈ.
182
183 %package libs
184 Summary:        Python library
185 Summary(pl):    Biblioteka jêzyka Python
186 Group:          Libraries/Python
187 Provides:       %{name}-libs = %{py_ver}
188
189 %description libs
190 Python library.
191
192 %description libs -l pl
193 Biblioteka jêzyka Python.
194
195 %package modules
196 Summary:        Python modules
197 Summary(pl):    Modu³y jêzyka Python
198 Group:          Libraries/Python
199 Requires:       %{name} = %{epoch}:%{version}-%{release}
200 Provides:       %{name}-modules = %{py_ver}
201 Obsoletes:      python-logging
202 Obsoletes:      python-optik
203 Obsoletes:      python-xmlrpc <= 1.0.1
204
205 %description modules
206 Python modules.
207
208 %description modules -l pl
209 Modu³y jêzyka Python.
210
211 %package -n pydoc
212 Summary:        Python interactive module documentation access support
213 Summary(pl):    Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python
214 Group:          Applications
215 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
216 Obsoletes:      python-pydoc
217
218 %description -n pydoc
219 Python interactive module documentation access support.
220
221 %description -n pydoc -l pl
222 Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python.
223
224 %package -n idle
225 Summary:        IDE for Python language
226 Summary(pl):    IDE dla jêzyka Python
227 Group:          Applications
228 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
229 Obsoletes:      python-idle
230
231 %description -n idle
232 IDE for Python language.
233
234 %description -n idle -l pl
235 IDE dla jêzyka Python.
236
237 %package devel
238 Summary:        Libraries and header files for building python code
239 Summary(de):    Libraries und Header-Dateien zum Erstellen von Python-Code
240 Summary(es):    Bibliotecas y archivos de inclusión para construir programas en python
241 Summary(fr):    Bibliothèques et en-têtes pour construire du code python
242 Summary(pl):    Pliki nag³ówkowe i biblioteki Pythona
243 Summary(pt_BR): Bibliotecas e arquivos de inclusão para o Python
244 Summary(ru):    âÉÂÌÉÏÔÅËÉ É ÈÅÄÅÒÙ ÄÌÑ ÐÏÓÔÒÏÅÎÉÑ ËÏÄÁ ÎÁ ÑÚÙËÅ Python
245 Summary(tr):    Python ile geliþtirme yapmak için gerekli dosyalar
246 Summary(uk):    â¦Â̦ÏÔÅËÉ ÔÁ ÈÅÄÅÒÉ ÄÌÑ ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÎÁ ÍÏצ Python
247 Group:          Development/Languages/Python
248 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
249
250 %description devel
251 The Python interpreter is relatively easy to extend with dynamically
252 loaded extensions and to embed in other programs. This package
253 contains the header files and libraries which are needed to do both of
254 these tasks.
255
256 %description devel -l de
257 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
258 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
259 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
260 die für beide Aufgaben erforderlich sind.
261
262 %description devel -l es
263 El interpretador Python permite incluir con facilidad extensiones
264 cargadas dinámicamente. Python es también fácil de ser empotrado en
265 otros programas. Este paquete contiene los archivos de inclusión y
266 bibliotecas necesarios para estas dos tareas.
267
268 %description devel -l fr
269 L'interpréteur Python est relativement facile à étendre avec des
270 extensions chargées dynamiquement et à insérer dans d'autres
271 programmes. Ce paquetage contient les en-têtes et les bibliothèques
272 nécessaires à ces deux tâches.
273
274 %description devel -l pl
275 Interpreter Pythona jest w miarê ³atwy do rozszerzania przy pomocy
276 dynamicznie ³adowanych rozszerzeñ napisanych w C lub C++ oraz
277 osadzania w innych programach. Ten pakiet zawiera pliki nag³ówkowe i
278 wszystko inne co potrzebne do tych celów.
279
280 %description devel -l pt_BR
281 O interpretador Python permite incluir com facilidade extensões
282 carregadas dinamicamente. Python é também fácil de ser embutido em
283 outros programas. Este pacote contém os arquivos de inclusão e
284 bibliotecas necessários para estas duas tarefas.
285
286 %description devel -l ru
287 éÎÔÅÒÐÒÅÔÁÔÏÒ Python ÏÔÎÏÓÉÔÅÌØÎÏ ÌÅÇËÏ ÒÁÓÛÉÒÑÅÔÓÑ ÐÒÉ ÐÏÍÏÝÉ
288 ÄÉÎÁÍÉÞÅÓËÉ ÚÁÇÒÕÖÁÅÍÙÈ ÒÁÓÛÉÒÅÎÉÊ É ×ÓÔÒÁÉ×ÁÅÔÓÑ × ÄÒÕÇÉÅ ÐÒÏÇÒÁÍÍÙ.
289 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÈÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÏÂÅÉÈ ÜÔÉÈ
290 ÚÁÄÁÞ.
291
292 %description devel -l tr
293 Bu paket, Python ile geliþtirme yapýlabilmesi için gerekli baþlýk
294 dosyalarýný ve kitaplýklarý içerir.
295
296 %description devel -l uk
297 ¶ÎÔÅÒÐÒÅÔÁÔÏÒ Python ×¦ÄÎÏÓÎÏ ÌÅÇËÏ ÒÏÚÛÉÒÀ¤ÔØÓÑ ÚÁ ÄÏÐÏÍÏÇÏÀ
298 ÒÏÚÛÉÒÅÎØ Ú ÄÉÎÁͦÞÎÏÀ ÚÁÇÒÕÚËÏÀ ÔÁ ×ÂÕÄÏ×Õ¤ÔØÓÑ × ¦ÎÛ¦ ÐÒÏÇÒÁÍÉ. ãÅÊ
299 ÐÁËÅԠͦÓÔÉÔØ ÈÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÏÂÏÈ ÃÉÈ ÚÁÄÁÞ.
300
301 %package devel-src
302 Summary:        Python module sources
303 Summary(pl):    Pliki ¼ród³owe modu³ów Pythona
304 Group:          Development/Languages/Python
305 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
306
307 %description devel-src
308 Python module sources.
309
310 %description devel-src -l pl
311 Pliki ¼ród³owe modu³ów Pythona.
312
313 %package devel-tools
314 Summary:        Python development tools
315 Summary(pl):    Narzêdzia programistyczne jêzyka Python
316 Group:          Development/Languages/Python
317 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
318
319 %description devel-tools
320 Python development tools such as profilers and debugger.
321
322 %description devel-tools -l pl
323 Narzêdzia programistyczne jêzyka Python takie jak profiler oraz debugger.
324
325 %package static
326 Summary:        Static python library
327 Summary(pl):    Statyczna biblioteka Pythona
328 Group:          Development/Languages/Python
329 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
330 Provides:       %{name}-static = %{py_ver}
331
332 %description static
333 Static python library.
334
335 %description static -l pl
336 Statyczna biblioteka Pythona.
337
338 %package doc
339 Summary:        Documentation on Python
340 Summary(de):    Dokumentation zu Python
341 Summary(es):    Documentación para Python
342 Summary(fr):    Documentation sur Python
343 Summary(pl):    Dokumentacja do Pythona
344 Summary(pt_BR): Documentação para a linguagem de programação Python
345 Summary(ru):    äÏËÕÍÅÎÔÁÃÉÑ ÐÏ ÑÚÙËÕ Python
346 Summary(tr):    Python belgeleri
347 Summary(uk):    äÏËÕÍÅÎÔÁæѠÐÏ ÍÏצ Python
348 Group:          Documentation
349 Requires:       %{name} = %{epoch}:%{version}-%{release}
350 Obsoletes:      python-docs
351
352 %description doc
353 This package contains documentation on the Python language and
354 interpretor as a mix of plain ASCII files and LaTeX sources.
355
356 %description doc -l de
357 Dieses Paket enthält Dokumentationen zu Python (Sprache und
358 Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
359
360 %description doc -l es
361 Documentación para Python. Contiene archivos en texto y PostScript.
362
363 %description doc -l fr
364 Ce paquetage contient la documentation sur le langage python et sur
365 son interpréteur sous forme de fichiers ASCII et LaTeX.
366
367 %description doc -l pl
368 Oficjalna dokumentacja do Pythona. Zawiera przyk³adowe programy,
369 narzêdzia i dokumentacjê. Strony podrêcznika man znajduj± siê w
370 g³ównym pakiecie. Ten pakiet nie zawiera ¼róde³ dokumentacji
371 napisanych w LaTeXu, tylko gotowe do wykorzystania pliki
372 postscriptowe i HTML.
373
374 %description doc -l pt_BR
375 O pacote python-doc contém documentação para a linguagem de
376 programação e para o interpretador Python. Fornecida em arquivos texto
377 e Postcript.
378
379 %description doc -l ru
380 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÏËÕÍÅÎÔÁÃÉÀ ÐÏ ÓÏÂÓÔ×ÅÎÎÏ ÑÚÙËÕ Python É ÐÏ
381 ÉÓÐÏÌÎÑÀÝÅÍÕ ÅÇÏ ÉÎÔÅÒÐÒÅÔÁÔÏÒÕ × ×ÉÄÅ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÙÈ ÆÁÊÌÏ× É
382 ÉÓÈÏÄÎÙÈ ÔÅËÓÔÏ× × ÆÏÒÍÁÔÅ LaTeX.
383
384 %description doc -l tr
385 Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyalarý ve
386 LaTeX kaynaklarýnýn bir karýþýmý olan yorumlayýcýyý içerir.
387
388 %description doc -l uk
389 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÄÏËÕÍÅÎÔÁæÀ ÐÏ ×ÌÁÓÎÅ ÍÏצ Python ÔÁ ÐÏ ×ÉËÏÎÕÀÞÏÍÕ
390 §§ ¦ÎÔÅÒÐÒÅÔÁÔÏÒÕ Õ ×ÉÇÌÑĦ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÉÈ ÆÁÊ̦נÔÁ ×ÉȦÄÎÉÈ
391 ÔÅËÓԦנՠÆÏÒÍÁÔ¦ LaTeX.
392
393 %package tkinter
394 Summary:        Standard Python interface to the Tk GUI toolkit
395 Summary(de):    Grafischer Oberfläche für Python
396 Summary(es):    Interface GUI para Phyton
397 Summary(fr):    Interface graphique pour python
398 Summary(pl):    Standardowy interfejs Pythona do biblioteki Tk
399 Summary(pt_BR): Interface GUI para Phyton
400 Summary(tr):    Python için grafik kullanýcý arayüzü
401 Group:          Libraries/Python
402 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
403 Requires:       tcl >= 8.4.3
404 Requires:       tix >= 1:8.1.4-4
405 Requires:       tk  >= 8.4.3
406 Obsoletes:      tkinter
407
408 %description tkinter
409 Standard Python interface to the Tk GUI toolkit.
410
411 %description tkinter -l de
412 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
413 vielen Konfigurations-Tools genutzt.
414
415 %description tkinter -l es
416 Una interface gráfica para Python, basada en Tcl/Tk, y usada por
417 muchas herramientas de configuración.
418
419 %description tkinter -l fr
420 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
421 beaucoup des outils de configuration.
422
423 %description tkinter -l pl
424 Standardowy interfejs Pythona do biblioteki Tk.
425
426 %description tkinter -l pt_BR
427 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
428 muitas ferramentas de configuração.
429
430 %description tkinter -l ru
431 çÒÁÆÉÞÅÓËÉÊ ÉÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÓÔÒÏÅÎÎÙÊ ÎÁ Tcl/Tk.
432
433 %description tkinter -l tr
434 Python için Tcl/Tk'ye dayalý ve pek çok ayarlama aracý tarafýndan
435 kullanýlan grafik bir arayüzdür.
436
437 %description tkinter -l uk
438 çÒÁƦÞÎÉÊ ¦ÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÂÕÄÏ×ÁÎÉÊ ÎÁ Tcl/Tk.
439
440 %package old
441 Summary:        Depreciated Python modules
442 Summary(pl):    Nieaktualne modu³y jêzyka Python
443 Group:          Libraries/Python
444 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
445
446 %description old
447 Install this package when one of your program written in Python is old
448 as Miss Universum of 1918, who only you want to see... ooops, which
449 only you want to run.
450
451 %description old -l pl
452 Zainstaluj ten pakiet, wtedy kiedy jeden z Twoich programów napisanych
453 w jêzyku Python jest tak stary jak Miss Universum z roku 1918, któr±
454 tylko ty chcesz zobaczyæ... przepraszam, który tylko ty chcesz
455 uruchomiæ.
456
457 %package examples
458 Summary:        Example programs in Python
459 Summary(pl):    Przyk³adowe programy w Pythonie
460 Group:          Development/Languages/Python
461 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
462 Obsoletes:      python-tools
463
464 %description examples
465 Example programs in Python.
466
467 %description examples -l pl
468 Przyk³adowe programy w Pythonie.
469
470 %prep
471 %setup -q -n Python-%{version}
472 %patch0 -p1
473 %patch1 -p1
474 %patch2 -p1
475 %patch3 -p1
476 %patch4 -p1
477 %patch5 -p1
478 %if "%{_lib}" == "lib64"
479 %patch6 -p1
480 %endif
481 %patch7 -p1
482 %{?with_noautosys:%patch8 -p1}
483
484 tar -xf %{SOURCE1} --use=bzip2
485
486 %build
487 %{__autoconf}
488
489 CPPFLAGS="-I%{_includedir}/ncurses"; export CPPFLAGS
490 %configure \
491         --with-threads \
492         --enable-unicode=ucs4 \
493         --enable-shared
494
495 %{__make} \
496         OPT="%{rpmcflags}"
497
498 LC_ALL=C
499 export LC_ALL
500 %if %{with tests}
501 binlibdir=`echo build/lib.*`
502 %{__make} test \
503         TESTOPTS="%{test_flags} %{test_list}" \
504         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
505 %endif
506
507 %install
508 rm -rf $RPM_BUILD_ROOT
509 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
510         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1}
511
512 %{__make} install \
513         DESTDIR=$RPM_BUILD_ROOT
514
515 install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
516
517 install libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}
518 ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
519 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython.so
520 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{py_ver}.so
521
522 rm -f $RPM_BUILD_ROOT%{_bindir}/python%{py_ver}
523
524 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
525 cp -ar Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
526
527 SCRIPT_EXT="_py"
528 %if %{with noautosys}
529     SCRIPT_EXT=".py"
530 %endif
531 export SCRIPT_EXT
532
533 # create several useful scripts, such as timeit.py, profile.py, pdb.py
534 for script in timeit profile pdb pstats; do
535     cat <<END > $RPM_BUILD_ROOT%{_bindir}/${script}$SCRIPT_EXT
536 #!/bin/sh
537 exec python %{py_scriptdir}/${script}.pyc "\$@"
538 END
539 done
540
541 # xgettext specific for Python code
542 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext$SCRIPT_EXT
543
544 %clean
545 rm -rf $RPM_BUILD_ROOT
546
547 %post   libs -p /sbin/ldconfig
548 %postun libs -p /sbin/ldconfig
549
550 %files
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{_bindir}/python
553 %{_mandir}/man1/*
554
555 # readline support for python binary
556 %attr(755,root,root) %{py_dyndir}/readline.so
557
558 %files modules
559 %defattr(644,root,root,755)
560 %exclude %{py_scriptdir}/UserDict.py[co]
561 %exclude %{py_scriptdir}/codecs.py[co]
562 %exclude %{py_scriptdir}/copy_reg.py[co]
563 %exclude %{py_scriptdir}/locale.py[co]
564 %exclude %{py_scriptdir}/posixpath.py[co]
565 %exclude %{py_scriptdir}/pdb.py[co]
566 %exclude %{py_scriptdir}/profile.py[co]
567 %exclude %{py_scriptdir}/pstats.py[co]
568 %exclude %{py_scriptdir}/pydoc.py[co]
569 %exclude %{py_scriptdir}/site.py[co]
570 %exclude %{py_scriptdir}/stat.py[co]
571 %exclude %{py_scriptdir}/timeit.py[co]
572 %exclude %{py_scriptdir}/os.py[co]
573 %exclude %{py_scriptdir}/encodings/*.py[co]
574
575 %{py_scriptdir}/*.py[co]
576
577 #
578 # list .so modules to be sure that all of them are built
579 #
580
581 # three modules below does not work on 64-bit architectures
582 # see Python README file for explanation
583 %ifnarch alpha amd64 ia64 ppc64 sparc64
584 %attr(755,root,root) %{py_dyndir}/audioop.so
585 %attr(755,root,root) %{py_dyndir}/rgbimg.so
586 %attr(755,root,root) %{py_dyndir}/imageop.so
587 # sizeof(long) != sizeof(int), so dl module will not be built on 64-bit
588 # platforms
589 %attr(755,root,root) %{py_dyndir}/dl.so
590 %endif
591
592 %attr(755,root,root) %{py_dyndir}/_bsddb.so
593 %attr(755,root,root) %{py_dyndir}/_csv.so
594 %attr(755,root,root) %{py_dyndir}/_curses.so
595 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
596 %attr(755,root,root) %{py_dyndir}/_locale.so
597 %attr(755,root,root) %{py_dyndir}/_random.so
598 %attr(755,root,root) %{py_dyndir}/_socket.so
599 %attr(755,root,root) %{py_dyndir}/_ssl.so
600 %attr(755,root,root) %{py_dyndir}/_testcapi.so
601 %attr(755,root,root) %{py_dyndir}/_weakref.so
602 %attr(755,root,root) %{py_dyndir}/array.so
603 %attr(755,root,root) %{py_dyndir}/binascii.so
604 %attr(755,root,root) %{py_dyndir}/bz2.so
605 %attr(755,root,root) %{py_dyndir}/cPickle.so
606 %attr(755,root,root) %{py_dyndir}/cStringIO.so
607 %attr(755,root,root) %{py_dyndir}/cmath.so
608 %attr(755,root,root) %{py_dyndir}/crypt.so
609 %attr(755,root,root) %{py_dyndir}/datetime.so
610 %attr(755,root,root) %{py_dyndir}/dbm.so
611 %attr(755,root,root) %{py_dyndir}/fcntl.so
612 %attr(755,root,root) %{py_dyndir}/gdbm.so
613 %attr(755,root,root) %{py_dyndir}/grp.so
614 %attr(755,root,root) %{py_dyndir}/itertools.so
615 %attr(755,root,root) %{py_dyndir}/linuxaudiodev.so
616 %attr(755,root,root) %{py_dyndir}/math.so
617 %attr(755,root,root) %{py_dyndir}/md5.so
618 %attr(755,root,root) %{py_dyndir}/mmap.so
619 %attr(755,root,root) %{py_dyndir}/mpz.so
620 %attr(755,root,root) %{py_dyndir}/nis.so
621 %attr(755,root,root) %{py_dyndir}/operator.so
622 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
623 %attr(755,root,root) %{py_dyndir}/parser.so
624 %attr(755,root,root) %{py_dyndir}/pcre.so
625 %attr(755,root,root) %{py_dyndir}/pwd.so
626 %attr(755,root,root) %{py_dyndir}/pyexpat.so
627 %attr(755,root,root) %{py_dyndir}/regex.so
628 %attr(755,root,root) %{py_dyndir}/resource.so
629 %attr(755,root,root) %{py_dyndir}/rotor.so
630 %attr(755,root,root) %{py_dyndir}/select.so
631 %attr(755,root,root) %{py_dyndir}/sha.so
632 %attr(755,root,root) %{py_dyndir}/strop.so
633 %attr(755,root,root) %{py_dyndir}/syslog.so
634 %attr(755,root,root) %{py_dyndir}/termios.so
635 %attr(755,root,root) %{py_dyndir}/time.so
636 %attr(755,root,root) %{py_dyndir}/timing.so
637 %attr(755,root,root) %{py_dyndir}/unicodedata.so
638 %attr(755,root,root) %{py_dyndir}/xreadlines.so
639 %attr(755,root,root) %{py_dyndir}/zlib.so
640
641 %dir %{py_scriptdir}/plat-*
642 %attr(755,root,root) %{py_scriptdir}/plat-*/regen
643 %{py_scriptdir}/plat-*/*.py[co]
644
645 %dir %{py_scriptdir}/bsddb
646 %{py_scriptdir}/bsddb/*.py[co]
647
648 %dir %{py_scriptdir}/compiler
649 %{py_scriptdir}/compiler/*.py[co]
650
651 %dir %{py_scriptdir}/curses
652 %{py_scriptdir}/curses/*.py[co]
653
654 %dir %{py_scriptdir}/distutils
655 %{py_scriptdir}/distutils/*.py[co]
656
657 %dir %{py_scriptdir}/distutils/command
658 %{py_scriptdir}/distutils/command/*.py[co]
659
660 %dir %{py_scriptdir}/email
661 %{py_scriptdir}/email/*.py[co]
662
663 %dir %{py_scriptdir}/logging
664 %{py_scriptdir}/logging/*.py[co]
665
666 %dir %{py_scriptdir}/xml
667 %{py_scriptdir}/xml/*.py[co]
668
669 %dir %{py_scriptdir}/xml/parsers
670 %{py_scriptdir}/xml/parsers/*.py[co]
671
672 %dir %{py_scriptdir}/xml/sax
673 %{py_scriptdir}/xml/sax/*.py[co]
674
675 %dir %{py_scriptdir}/xml/dom
676 %{py_scriptdir}/xml/dom/*.py[co]
677
678 %files libs
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_libdir}/libpython*.so.*
681
682 %dir %{py_dyndir}
683 %dir %{py_scriptdir}
684 %dir %{py_libdir}
685 %dir %{py_sitescriptdir}
686 %dir %{py_sitedir}
687
688 # shared modules required by python library
689 %attr(755,root,root) %{py_dyndir}/struct.so
690
691 # modules required by python library
692 %{py_scriptdir}/UserDict.py[co]
693 %{py_scriptdir}/codecs.py[co]
694 %{py_scriptdir}/copy_reg.py[co]
695 %{py_scriptdir}/locale.py[co]
696 %{py_scriptdir}/posixpath.py[co]
697 %{py_scriptdir}/site.py[co]
698 %{py_scriptdir}/stat.py[co]
699 %{py_scriptdir}/os.py[co]
700
701 # encodings required by python library
702 %dir %{py_scriptdir}/encodings
703 %{py_scriptdir}/encodings/*.py[co]
704
705 %files -n pydoc
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_bindir}/pydoc
708 %{py_scriptdir}/pydoc.py[co]
709
710 %files -n idle
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{_bindir}/idle
713 %dir %{py_scriptdir}/idlelib
714 %dir %{py_scriptdir}/idlelib/Icons
715 %{py_scriptdir}/idlelib/*.py[co]
716 %{py_scriptdir}/idlelib/Icons/*
717 %{py_scriptdir}/idlelib/*.def
718
719 %files devel
720 %defattr(644,root,root,755)
721 %doc Misc/{ACKS,NEWS,README}
722 %attr(755,root,root) %{_libdir}/lib*.so
723 %dir %{py_incdir}
724 %{py_incdir}/*.h
725
726 %dir %{py_libdir}/config
727 %attr(755,root,root) %{py_libdir}/config/makesetup
728 %attr(755,root,root) %{py_libdir}/config/install-sh
729 %{py_libdir}/config/Makefile
730 %{py_libdir}/config/Makefile.pre.in
731 %{py_libdir}/config/Setup
732 %{py_libdir}/config/Setup.config
733 %{py_libdir}/config/Setup.local
734 %{py_libdir}/config/config.c
735 %{py_libdir}/config/config.c.in
736 %{py_libdir}/config/python.o
737
738 %files devel-src
739 %defattr(644,root,root,755)
740 %attr(-,root,root) %{py_scriptdir}/*.py
741 %{py_scriptdir}/plat-*/*.py
742 %{py_scriptdir}/bsddb/*.py
743 %{py_scriptdir}/compiler/*.py
744 %{py_scriptdir}/curses/*.py
745 %{py_scriptdir}/distutils/*.py
746 %{py_scriptdir}/distutils/command/*.py
747 %{py_scriptdir}/email/*.py
748 %{py_scriptdir}/hotshot/*.py
749 %{py_scriptdir}/logging/*.py
750 %{py_scriptdir}/xml/*.py
751 %{py_scriptdir}/xml/parsers/*.py
752 %{py_scriptdir}/xml/sax/*.py
753 %{py_scriptdir}/xml/dom/*.py
754 %{py_scriptdir}/encodings/*.py
755 %{py_scriptdir}/idlelib/*.py
756
757 %files devel-tools
758 %defattr(644,root,root,755)
759 %doc Lib/profile.doc Lib/pdb.doc
760 %attr(755,root,root) %{_bindir}/timeit*
761 %attr(755,root,root) %{_bindir}/profile*
762 %attr(755,root,root) %{_bindir}/pdb*
763 %attr(755,root,root) %{_bindir}/pstats*
764 %attr(755,root,root) %{_bindir}/pygettext*
765
766 %attr(755,root,root) %{py_dyndir}/_hotshot.so
767 %dir %{py_scriptdir}/hotshot
768 %{py_scriptdir}/hotshot/*.py[co]
769 %{py_scriptdir}/pdb.py[co]
770 %{py_scriptdir}/profile.py[co]
771 %{py_scriptdir}/pstats.py[co]
772 %{py_scriptdir}/timeit.py[co]
773
774 %files static
775 %defattr(644,root,root,755)
776 %{_libdir}/lib*.a
777
778 %files examples
779 %defattr(644,root,root,755)
780 %{_examplesdir}/%{name}-%{version}
781
782 %files doc
783 %defattr(644,root,root,755)
784 %doc Python-Docs-%{version}/*
785 %dir %{py_scriptdir}/test
786 %attr(-,root,root) %{py_scriptdir}/test/*
787 %attr(-,root,root) %{py_scriptdir}/email/test/*
788 %attr(-,root,root) %{py_scriptdir}/bsddb/test/*
789
790 %if %{with tkinter}
791 %files tkinter
792 %defattr(644,root,root,755)
793 %{py_scriptdir}/lib-tk
794 %attr(755,root,root) %{py_dyndir}/_tkinter.so
795 %endif
796
797 %files old
798 %defattr(644,root,root,755)
799 %dir %{py_scriptdir}/lib-old
800 %{py_scriptdir}/lib-old/*.py[co]
This page took 0.085377 seconds and 4 git commands to generate.