]> git.pld-linux.org Git - packages/python.git/blob - python.spec
- release 8,
[packages/python.git] / python.spec
1 %define py_ver         2.2
2 %define py_prefix      %{_prefix}
3 %define py_libdir      %{py_prefix}/lib/python%{py_ver}
4 %define py_incdir      %{_includedir}/python%{py_ver}
5 %define py_sitedir     %{py_libdir}/site-packages
6 %define py_dyndir      %{py_libdir}/lib-dynload
7 %define py_comp        ./python -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
8 %define py_ocomp       ./python -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
9  
10 Summary:        Very high level scripting language with X interface
11 Summary(de):    Very High-Level-Script-Sprache mit X-Oberfläche
12 Summary(es):    Lenguaje script de alto nivel con interface X
13 Summary(fr):    Langage de script de tés haut niveau avec interface X
14 Summary(pl):    Python - jêzyk obiektowy wysokiego poziomu
15 Summary(pt_BR): Linguagem de programação interpretada, orientada a objeto de alto nível
16 Summary(tr):    X arayüzlü, yüksek düzeyli, kabuk yorumlayýcý dili
17 Name:           python
18 Version:        %{py_ver}
19 Release:        8
20 License:        PSF
21 Group:          Development/Languages/Python
22 Group(de):      Entwicklung/Sprachen/Python
23 Group(pl):      Programowanie/Jêzyki/Python
24 URL:            http://www.python.org/
25 Source0:        http://prdownloads.sourceforge.net/python/Python-%{version}.tgz
26 Source1:        http://www.python.org/ftp/python/doc/%{version}/html-%{version}.tar.bz2
27 Source2:        %{name}-setup.dist
28 Patch0:         %{name}-shared-lib.patch
29 Patch1:         %{name}-readline.patch
30 Patch2:         %{name}-%{name}path.patch
31 Patch3:         %{name}-ac25x.patch
32 Patch4:         %{name}-default_encoding.patch
33 Patch5:         %{name}-no_ndbm.patch
34 BuildRequires:  XFree86-devel
35 BuildRequires:  autoconf
36 BuildRequires:  db3-devel
37 BuildRequires:  expat-devel
38 BuildRequires:  gdbm-devel >= 1.0.8-7
39 BuildRequires:  gmp-devel => 4.0
40 BuildRequires:  ncurses-devel >= 5.2
41 BuildRequires:  openssl-devel >= 0.9.6b
42 BuildRequires:  readline-devel >= 4.2
43 BuildRequires:  tcl-devel >= 8.3.2
44 BuildRequires:  tix-devel
45 BuildRequires:  tk-devel >= 8.3.2
46 BuildRequires:  zlib-devel
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48 Obsoletes:      python-xml
49 Obsoletes:      python-intl
50 Obsoletes:      python-curses
51 Obsoletes:      python-gdbm
52 Obsoletes:      python-zlib
53 Obsoletes:      python2
54 Obsoletes:      python2-devel
55
56 %description
57 Python is an interpreted, interactive, object-oriented programming
58 language. It incorporates modules, exceptions, dynamic typing, very
59 high level dynamic data types, and classes. Python combines remarkable
60 power with very clear syntax. It has interfaces to many system calls
61 and libraries, as well as to various window systems, and is extensible
62 in C or C++. It is also usable as an extension language for
63 applications that need a programmable interface. Finally, Python is
64 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
65 MS-DOS, Windows, Windows NT, and OS/2.
66
67 %description -l de
68 Python ist eine interpretierte, interaktive, objektorientierte
69 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
70 Python enthält Module, Klassen, Exceptions, High-Level dynamische
71 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
72 zu vielen Systemaufrufen und Libraries, sowie verschiedene
73 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
74
75 Programmierer können neue built-in-Module für Python in C oder C++
76 schreiben. Python kann auch als Erweiterungssprache für Applikationen
77 benutzt werden, die ein programmierbares Interface brauchen. Dieses
78 Paket enthält die meisten Standard-Python-Module, und Module zum
79 Ansprechen von Tix (Tk-widget set) und RPM.
80
81 Dokumentationen zu Python sind in python-doc enthalten.
82
83 %description -l es
84 Python es un lenguaje de scripts interpretado orientado a objetos.
85 Contiene soporte para carga dinámica de objetos, clases, módulos y
86 excepciones.
87
88 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
89 través de código C, tornando Python fácil de usar en ambientes
90 articulares/ personalizados. Este paquete Python incluye la mayoría de
91 los módulos padrón Python, junto con módulos para crear interfaces
92 para el conjunto de componentes Tix para Tk y RPM.
93
94 %description -l fr
95 Python est un langage de script interprété et orienté objet. Il gère
96 le chargement dynamique des objets, les classes, les modules et les
97 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
98 avec du code C est simple, ce qui rend Python facile à utiliser dans
99 des configs personnalisées.
100
101 Ce paquetage Python contient la plupart des modules Python standards,
102 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
103 et RPM.
104
105 %description -l pl
106 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
107 jêzykiem programowania. Jest modularny, obs³uguje wyj±tki, dynamiczne
108 typy, zaawansowane dynamiczne struktury danych i klasy. Python ³±czy w
109 sobie du¿e mo¿liwo¶ci i przejrzyst± sk³adniê. Posiada interfejsy do
110 wielu wywo³añ systemowych i bibliotek, w tym równie¿ do ró¿nych
111 bibliotek okienkowych. Mo¿liwo¶ci jego mo¿na jeszcze rozszerzaæ
112 poprzez odpowiednie modu³y pisane w C lub C++. Python mo¿e byæ równie¿
113 u¿yty jako element aplikacji, którym potrzebny jest interpreter do
114 skryptów. I wreszcie, Python jest wieloplatformowy, dzia³a na wielu
115 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
116 OS/2.
117
118 %description -l pt_BR
119 Python é uma linguagem de scripts interpretada orientada a objetos.
120 Contém suporte para carga dinâmica de objetos, classes, módulos e
121 exceções. Adicionar interfaces para novos sistemas de biblioteca
122 através de código C é simples, tornando Python fácil de usar em
123 ambientes particulares/personalizados.
124
125 Este pacote Python inclui a maioria do módulos padrão Python, junto
126 com módulos para interfaceamento para o conjunto de componentes Tix
127 para Tk e RPM.
128
129 %description -l tr
130 Python, nesneye yönelik bir kabuk yorumlayýcýdýr. Nesnelerin,
131 sýnýflarýn, modüllerin ve aykýrý durumlarýn dinamik yüklenmelerine
132 destek verir. C koduyla birlikte kullanýmý son derece kolaydýr. Bu
133 paket, standart Python birimlerinin çoðunun yanýsýra Tk ve RPM için
134 arayüz birimlerini de içerir.
135
136 %package libs
137 Summary:        Python library
138 Summary(pl):    Biblioteka jêzyka Python
139 Group:          Development/Languages/Python
140 Group(de):      Entwicklung/Sprachen/Python
141 Group(pl):      Programowanie/Jêzyki/Python
142
143 %description libs
144 Python library.
145
146 %description libs -l pl
147 Biblioteka jêzyka Python.
148
149 %package modules
150 Summary:        Python modules
151 Summary(pl):    Modu³y jêzyka Python
152 Group:          Development/Languages/Python
153 Group(de):      Entwicklung/Sprachen/Python
154 Group(pl):      Programowanie/Jêzyki/Python
155 Requires:       %{name} = %{version}
156
157 %description modules
158 Python modules.
159
160 %description modules -l pl
161 Modu³y jêzyka Python.
162
163 %package pydoc
164 Summary:        Python interactive module documentation access support
165 Summary(pl):    Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python
166 Group:          Development/Languages/Python
167 Group(de):      Entwicklung/Sprachen/Python
168 Group(pl):      Programowanie/Jêzyki/Python
169 Requires:       %{name}-modules = %{version}
170
171 %description pydoc
172 Python interactive module documentation access support.
173
174 %description pydoc -l pl
175 Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python.
176
177 %package devel
178 Summary:        Libraries and header files for building python code
179 Summary(de):    Libraries und Header-Dateien zum Erstellen von Python-Code
180 Summary(es):    Bibliotecas y archivos de inclusión para construir programas en python
181 Summary(fr):    Bibliothèques et en-têtes pour construire du code python
182 Summary(pl):    Pliki nag³ówkowe i biblioteki Pythona
183 Summary(pt_BR): Bibliotecas e arquivos de inclusão para o Python
184 Summary(tr):    Python ile geliþtirme yapmak için gerekli dosyalar
185 Group:          Development/Languages/Python
186 Group(de):      Entwicklung/Sprachen/Python
187 Group(pl):      Programowanie/Jêzyki/Python
188 Requires:       %{name}-libs = %{version}
189
190 %description devel
191 The Python interpreter is relatively easy to extend with dynamically
192 loaded extensions and to embed in other programs. This packages
193 contains the header files and libraries which are needed to do both of
194 these tasks.
195
196 %description devel -l de
197 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
198 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
199 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
200 die für beide Aufgaben erforderlich sind.
201
202 %description devel -l es
203 El interpretador Python permite incluir con facilidad extensiones
204 cargadas dinámicamente. Python es también fácil de ser empotrado en
205 otros programas. Este paquete contiene los archivos de inclusión y
206 bibliotecas necesarios para estas dos tareas.
207
208 %description devel -l fr
209 L'interpréteur Python est relativement facile à étendre avec des
210 extensions chargées dynamiquement et à insérer dans d'autres
211 programmes. Ce paquetage contient les en-têtes et les bibliothèques
212 nécessaires à ces deux tâches.
213
214 %description devel -l pl
215 Wszystko co potrzebne, aby napisaæ w C/C++ modu³ rozszerzaj±cy
216 mo¿liwo¶ci Pythona. S± tu równie¿ wersje ¼ród³owe modu³ów ze
217 standardowej biblioteki.
218
219 %description devel -l pt_BR
220 O interpretador Python permite incluir com facilidade extensões
221 carregadas dinamicamente. Python é também fácil de ser embutido em
222 outros programas. Este pacote contém os arquivos de inclusão e
223 bibliotecas necessários para estas duas tarefas.
224
225 %description devel -l tr
226 Bu paket, Python ile geliþtirme yapýlabilmesi için gerekli baþlýk
227 dosyalarýný ve kitaplýklarý içerir.
228
229 %package devel-src
230 Summary:        Python module sources
231 Summary(pl):    Pliki ¼ród³owe modu³ów Pythona
232 Group:          Development/Languages/Python
233 Group(de):      Entwicklung/Sprachen/Python
234 Group(pl):      Programowanie/Jêzyki/Python
235 Requires:       %{name}-modules = %{version}
236
237 %description devel-src
238 Python module sources.
239
240 %description devel-src -l pl
241 Pliki ¼ród³owe modu³ów Pythona.
242
243 %package static
244 Summary:        Static python library
245 Summary(pl):    Statyczna biblioteka Pythona
246 Group:          Development/Languages/Python
247 Group(de):      Entwicklung/Sprachen/Python
248 Group(pl):      Programowanie/Jêzyki/Python
249 Requires:       %{name}-devel = %{version}
250
251 %description static
252 Static python library.
253
254 %description static -l pl
255 Statyczna biblioteka Pythona.
256
257 %package doc
258 Summary:        Documentation on Python
259 Summary(de):    Dokumentation zu Python 
260 Summary(es):    Documentación para Python
261 Summary(fr):    Documentation sur Python
262 Summary(pl):    Dokumentacja do Pythona 
263 Summary(pt_BR): Documentação para a linguagem de programação Python.
264 Summary(tr):    Python belgeleri
265 Group:          Development/Languages
266 Group(de):      Entwicklung/Sprachen
267 Group(pl):      Programowanie/Jêzyki
268 Requires:       %{name} = %{version}
269 Obsoletes:      python-docs
270
271 %description doc
272 This package contains documentation on the Python language and
273 interpretor as a mix of plain ASCII files and LaTeX sources.
274
275 %description doc -l de
276 Dieses Paket enthält Dokumentationen zu Python (Sprache und
277 Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
278
279 %description doc -l es
280 Documentación para Python. Contiene archivos en texto y PostScript.
281
282 %description doc -l fr
283 Ce paquetage contient la documentation sur le langage python et sur
284 son interpréteur sous forme de fichiers ASCII et LaTeX.
285
286 %description doc -l pl
287 Oficjalna dokumentacja do Pythona. Zawiera przyk³adowe programy,
288 narzêdzia i dokumentacjê. Strony podrêcznika man znajduj± siê w
289 g³ównym pakiecie. Ten pakiet nie zawiera ¼róde³ dokumentacji
290 napisanych w LaTeX'u, tylko gotowe do wykorzystania pliki
291 postscript'owe i HTML.
292
293 %description doc -l pt_BR
294 O pacote python-doc contém documentação para a linguagem de
295 programação e para o interpretador Python. Fornecida em arquivos texto
296 e Postcript.
297
298 %description doc -l tr
299 Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyalarý ve
300 LaTeX kaynaklarýnýn bir karýþýmý olan yorumlayýcýyý içerir.
301
302 %package without-thread
303 Summary:        Python without threads
304 Summary(pl):    Pyton bez w±tków
305 Group:          Development/Languages
306 Group(de):      Entwicklung/Sprachen
307 Group(pl):      Programowanie/Jêzyki
308 Requires:       %{name} = %{version}
309 Obsoletes:      python-without-thread
310
311 %description without-thread
312 This package is rather needed for apache-mod_python module. Other ways
313 of use are unknown.
314
315 %description without-thread -l pl
316 Pyton bez w±tków jest w³a¶ciwie potrzebny tylko modu³owi
317 apache-mod_python, bo apache nie ich na razie nie wspiera.
318
319 %package -n tkinter
320 Summary:        Lowlevel Python -> Tk Interface
321 Summary(de):    Grafischer Oberfläche für Python
322 Summary(es):    Interface GUI para Phyton
323 Summary(fr):    Interface graphique pour python.
324 Summary(pl):    Modu³y niskiego poziomu dla pakietu Python-tkinter
325 Summary(pt_BR): Interface GUI para Phyton
326 Summary(tr):    Python için grafik kullanýcý arayüzü
327 Group:          Development/Languages/Python
328 Group(de):      Entwicklung/Sprachen/Python
329 Group(pl):      Programowanie/Jêzyki/Python
330 Requires:       %{name}-modules = %{version}
331 Requires:       tcl >= 8.0.3 
332 Requires:       tk  >= 8.0.3
333 Requires:       tix >= 4.1.0.6
334
335 %description -n tkinter
336 This is the lowlevel C module that interfaces Tk and which is the
337 basis for the Tkinter, Python's OO interface to Tk, which is included
338 in the package python-tkinter.
339
340 The only reason this file is removed from python-tkinter, is to make
341 it more easy to replay _tkinter with a PIL (Python Imaging Libary)
342 aware version of it. Look at my PIL distribution.
343
344 %description -n tkinter -l de
345 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
346 vielen Konfigurations-Tools genutzt.
347
348 %description -n tkinter -l es
349 Una interface gráfica para Python, basada en Tcl/Tk, y usada por
350 muchas herramientas de configuración.
351
352 %description -n tkinter -l fr
353 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
354 beaucoup des outils de configuration.
355
356 %description -n tkinter -l pl
357 Ten pakiet zawiera modu³y w C, które po¶rednicz± w wywo³aniach
358 pomiêdzy samym Tk a modu³em Tkinter bêd±cym g³ównym interfejsem Tk dla
359 Pythona.
360
361 Jedynym powodem wydzielenia tego pakietu jest u³atwienie wymiany go na
362 PIL (Python Imaging Library).
363
364 %description -n tkinter -l pt_BR
365 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
366 muitas ferramentas de configuração.
367
368 %description -n tkinter -l tr
369 Python için Tcl/Tk'ye dayalý ve pek çok ayarlama aracý tarafýndan
370 kullanýlan grafik bir arayüzdür.
371
372 %package old
373 Summary:        Depreciated Python modules
374 Summary(pl):    Nieaktualne modu³y jêzyka Python
375 Group:          Development/Languages/Python
376 Group(de):      Entwicklung/Sprachen/Python
377 Group(pl):      Programowanie/Jêzyki/Python
378 Requires:       %{name}-modules = %{version}
379
380 %description old
381 Install this package when one of your program written in Python is old
382 as Miss Universum of 1918, who only you want to see... ooops, which
383 only you want to run.
384
385 %description old -l pl
386 Zainstaluj ten pakiet, wtedy kiedy jeden z Twoich programów napisanych
387 w jêzyku Python jest tak stary jak Miss Universum z roku 1918, któr±
388 tylko ty chcesz zobaczyæ... przepraszam, który tylko ty chcesz
389 uruchomiæ.
390
391 %package examples
392 Summary:        Example programs in Python
393 Summary(pl):    Przyk³adowe programy w Pythonie
394 Group:          Development/Languages/Python
395 Group(de):      Entwicklung/Sprachen/Python
396 Group(pl):      Programowanie/Jêzyki/Python
397 Requires:       %{name}-devel = %{version}
398 Obsoletes:      python-tools
399
400 %description examples
401 Example programs in Python.
402
403 %description examples -l pl
404 Przyk³adowe programy w Pythonie.
405
406 %prep
407 %setup -q -n Python-%{version}
408 %patch0 -p1
409 %patch1 -p1
410 %patch2 -p1
411 %patch3 -p1
412 %patch4 -p1
413 %patch5 -p1
414
415 install -d html-doc
416 tar -xf %{SOURCE1} --use=bzip2 -C html-doc
417
418 install %{SOURCE2} Modules/Setup
419
420 %build
421 export POSIXLY_CORRECT=TRUE
422
423 echo ': ${LDSHARED='gcc -shared'}' > config.cache
424 echo ': ${LINKFORSHARED='-rdynamic'}' >> config.cache
425 echo ': ${CCSHARED='-fPIC'}' >> config.cache
426
427 autoconf
428
429 CPPFLAGS="-I%{_includedir}/ncurses -I%{_includedir}/db3"; export CPPFLAGS
430 %configure \
431         --with-threads 
432
433 %{__make} OPT="%{rpmcflags} -D_REENTRANT"
434
435 %install
436 rm -rf $RPM_BUILD_ROOT
437 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_mandir}}
438
439 LD_LIBRARY_PATH=$(pwd)
440 export LD_LIBRARY_PATH
441 %{__make} install \
442         BINDIR=$RPM_BUILD_ROOT%{_bindir} \
443         SCRIPTDIR=$RPM_BUILD_ROOT%{_libdir} \
444         LIBDIR=$RPM_BUILD_ROOT%{_libdir} \
445         MANDIR=$RPM_BUILD_ROOT%{_mandir} \
446         INCLUDEDIR=$RPM_BUILD_ROOT%{_includedir} \
447         CONFINCLUDEDIR=$RPM_BUILD_ROOT%{_includedir}
448
449 install libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}
450
451 %py_comp $RPM_BUILD_ROOT%{py_libdir}
452 %py_ocomp $RPM_BUILD_ROOT%{py_libdir}
453
454 rm -f $RPM_BUILD_ROOT%{_bindir}/python%{py_ver}
455 ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
456
457 install -d $RPM_BUILD_ROOT%{_examplesdir}/python
458 cp -ar Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/python
459
460 install Tools/scripts/pydoc $RPM_BUILD_ROOT%{_bindir}
461
462 gzip -9nf Misc/{ACKS,NEWS,README,unicode.txt}
463
464 echo "%defattr(644,root,root,755)" > modules.filelist
465
466 find $RPM_BUILD_ROOT%{py_libdir} \
467         -type f \
468         -maxdepth 1 \
469         -printf %{py_libdir}/%f\\n \
470         | grep '\.py[co]$' \
471         | grep -v -e 'UserDict\.py[oc]$'\
472         | grep -v -e 'codecs\.py[oc]$' \
473         | grep -v -e 'locale\.py[oc]$' \
474         | grep -v -e 'posixpath\.py[oc]$' \
475         | grep -v -e 'pydoc\.py[oc]$' \
476         | grep -v -e 'site\.py[oc]$' \
477         | grep -v -e 'stat\.py[oc]$' \
478         | grep -v -e 'os\.py[oc]$' \
479         | grep -v -e 'encodings\/.*\.py[oc]$' >> modules.filelist
480  
481 find $RPM_BUILD_ROOT%{py_dyndir} \
482         -type f \
483         -maxdepth 1 \
484         -printf "%%%%attr(755,root,root) %{py_dyndir}/%f\\n" \
485         | grep '\.so$' \
486         | grep -v -e 'codecsmodule\.so$' \
487         | grep -v -e 'readline\.so$' \
488         | grep -v -e 'structmodule\.so$' \
489         | grep -v -e '_tkinter\.so$' >> modules.filelist
490
491 %clean
492 rm -rf $RPM_BUILD_ROOT
493
494 %post   -p /sbin/ldconfig
495 %postun -p /sbin/ldconfig
496
497 %files 
498 %defattr(644,root,root,755)
499 %attr(755,root,root) %{_bindir}/python
500 %{_mandir}/man1/*
501
502 %dir %{py_dyndir}
503
504 # required modules by python core
505 %attr(755,root,root) %{py_dyndir}/_codecsmodule.so
506 %attr(755,root,root) %{py_dyndir}/structmodule.so
507 # readline support for python binary
508 %attr(755,root,root) %{py_dyndir}/readline.so
509
510 # required modules by python core
511 %{py_libdir}/UserDict.py?
512 %{py_libdir}/codecs.py?
513 %{py_libdir}/locale.py?
514 %{py_libdir}/posixpath.py?
515 %{py_libdir}/site.py?
516 %{py_libdir}/stat.py?
517 %{py_libdir}/os.py?
518
519 %dir %{py_libdir}/encodings
520 %{py_libdir}/encodings/*.py?
521
522 %files modules -f modules.filelist
523 %defattr(644,root,root,755)
524
525 %dir %{py_sitedir}
526 %dir %{py_libdir}
527
528 %dir %{py_libdir}/plat-*
529 %attr(755,root,root) %{py_libdir}/plat-*/regen
530 %{py_libdir}/plat-*/*.py?
531
532 %dir %{py_libdir}/curses
533 %{py_libdir}/curses/*.py?
534
535 %dir %{py_libdir}/distutils
536 %{py_libdir}/distutils/*.py?
537
538 %dir %{py_libdir}/distutils/command
539 %{py_libdir}/distutils/command/*.py?
540
541 %dir %{py_libdir}/xml
542 %{py_libdir}/xml/*.py?
543
544 %dir %{py_libdir}/xml/parsers
545 %{py_libdir}/xml/parsers/*.py?
546
547 %dir %{py_libdir}/xml/sax
548 %{py_libdir}/xml/sax/*.py?
549
550 %dir %{py_libdir}/xml/dom
551 %{py_libdir}/xml/dom/*.py?
552
553 %files libs
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_libdir}/libpython*so.*
556
557 %files pydoc
558 %defattr(644,root,root,755)
559 %attr(755,root,root) %{_bindir}/pydoc
560 %{py_libdir}/pydoc.py?
561
562 %files devel
563 %defattr(644,root,root,755)
564 %doc Misc/*.gz
565 %attr(755,root,root) %{_libdir}/lib*.so
566 %dir %{py_incdir}
567 %{py_incdir}/*.h
568
569 %dir %{py_libdir}/config
570 %attr(755,root,root) %{py_libdir}/config/makesetup
571 %attr(755,root,root) %{py_libdir}/config/install-sh
572 %{py_libdir}/config/Makefile
573 %{py_libdir}/config/Setup
574 %{py_libdir}/config/Setup.config
575 %{py_libdir}/config/Setup.local
576 %{py_libdir}/config/config.c
577 %{py_libdir}/config/config.c.in
578 %{py_libdir}/config/python.o
579
580 %files devel-src
581 %defattr(644,root,root,755)
582 %attr(-,root,root) %{py_libdir}/*.py
583 %{py_libdir}/plat-*/*.py
584 %{py_libdir}/curses/*.py
585 %{py_libdir}/distutils/*.py
586 %{py_libdir}/distutils/command/*.py
587 %{py_libdir}/xml/*.py
588 %{py_libdir}/xml/parsers/*.py
589 %{py_libdir}/xml/sax/*.py
590 %{py_libdir}/xml/dom/*.py
591 %{py_libdir}/encodings/*.py
592
593 %files static
594 %defattr(644,root,root,755)
595 %{_libdir}/lib*.a
596
597 %files examples
598 %defattr(644,root,root,755)
599 %{_examplesdir}/python/Tools
600 %{_examplesdir}/python/Demo
601
602 %files doc
603 %defattr(644,root,root,755)
604 %doc html-doc/*
605 %dir %{py_libdir}/test
606 %attr(-,root,root) %{py_libdir}/test/*
607
608 %files -n tkinter
609 %defattr(644,root,root,755)
610
611 %{py_libdir}/lib-tk
612 %attr(755,root,root) %{py_dyndir}/_tkinter.so
613
614 %files old
615 %defattr(644,root,root,755)
616
617 %dir %{py_libdir}/lib-old
618 %{py_libdir}/lib-old/*.py?
This page took 0.105987 seconds and 3 git commands to generate.