]> git.pld-linux.org Git - packages/python.git/blob - python.spec
- obsoletes separated python-xmlrpc (included in main distribution)
[packages/python.git] / python.spec
1
2 %define py_ver         2.3
3 %define py_prefix      %{_prefix}
4 %define py_libdir      %{py_prefix}/lib/python%{py_ver}
5 %define py_incdir      %{_includedir}/python%{py_ver}
6 %define py_sitedir     %{py_libdir}/site-packages
7 %define py_dyndir      %{py_libdir}/lib-dynload
8 %define py_comp        ./python -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
9 %define py_ocomp       ./python -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
10
11 Summary:        Very high level scripting language with X interface
12 Summary(de):    Very High-Level-Script-Sprache mit X-Oberfläche
13 Summary(es):    Lenguaje script de alto nivel con interface X
14 Summary(fr):    Langage de script de tés haut niveau avec interface X
15 Summary(pl):    Python - jêzyk obiektowy wysokiego poziomu
16 Summary(pt_BR): Linguagem de programação interpretada, orientada a objeto de alto nível
17 Summary(ru):    ñÚÙË ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ ÏÞÅÎØ ×ÙÓÏËÏÇÏ ÕÒÏ×ÎÑ Ó X-ÉÎÔÅÒÆÅÊÓÏÍ
18 Summary(tr):    X arayüzlü, yüksek düzeyli, kabuk yorumlayýcý dili
19 Summary(uk):    íÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÄÕÖÅ ×ÉÓÏËÏÇÏ Ò¦×ÎÑ Ú X-¦ÎÔÅÒÆÅÊÓÏÍ
20 Name:           python
21 Version:        %{py_ver}c1
22 Release:        0.2
23 License:        PSF
24 Group:          Applications
25 URL:            http://www.python.org/
26 Source0:        http://www.python.org/ftp/python/%{py_ver}/Python-%{version}.tgz
27 # Source0-md5:  167327b762b305d72b1cce3a5d78ccdf
28 Source1:        http://www.python.org/ftp/python/doc/%{version}/html-%{version}.tar.bz2
29 # Source1-md5:  e52227f258c2d7405f9ecf33175f8987
30 Patch0:         %{name}-readline.patch
31 Patch1:         %{name}-%{name}path.patch
32 Patch2:         %{name}-default_encoding.patch
33 Patch3:         %{name}-no_ndbm.patch
34 Patch4:         %{name}-ac_fixes.patch
35 BuildRequires:  XFree86-devel
36 BuildRequires:  autoconf
37 BuildRequires:  db-devel >= 4
38 BuildRequires:  gdbm-devel >= 1.8.3
39 BuildRequires:  expat-devel
40 BuildRequires:  gmp-devel => 4.0
41 BuildRequires:  ncurses-devel >= 5.2
42 BuildRequires:  openssl-devel >= 0.9.7
43 BuildRequires:  readline-devel >= 4.2
44 BuildRequires:  tcl-devel >= 8.4.3
45 BuildRequires:  tix-devel >= 1:8.1.4-4
46 BuildRequires:  tk-devel >= 8.4.3
47 BuildRequires:  zlib-devel
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49 Provides:       %{name} = %{py_ver}
50 Obsoletes:      python-xml
51 Obsoletes:      python-intl
52 Obsoletes:      python-curses
53 Obsoletes:      python-gdbm
54 Obsoletes:      python-zlib
55 Obsoletes:      python2
56 Obsoletes:      python2-devel
57
58 %description
59 Python is an interpreted, interactive, object-oriented programming
60 language. It incorporates modules, exceptions, dynamic typing, very
61 high level dynamic data types, and classes. Python combines remarkable
62 power with very clear syntax. It has interfaces to many system calls
63 and libraries, as well as to various window systems, and is extensible
64 in C or C++. It is also usable as an extension language for
65 applications that need a programmable interface. Finally, Python is
66 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
67 MS-DOS, Windows, Windows NT, and OS/2.
68
69 %description -l de
70 Python ist eine interpretierte, interaktive, objektorientierte
71 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
72 Python enthält Module, Klassen, Exceptions, High-Level dynamische
73 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
74 zu vielen Systemaufrufen und Libraries, sowie verschiedene
75 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
76
77 Programmierer können neue built-in-Module für Python in C oder C++
78 schreiben. Python kann auch als Erweiterungssprache für Applikationen
79 benutzt werden, die ein programmierbares Interface brauchen. Dieses
80 Paket enthält die meisten Standard-Python-Module, und Module zum
81 Ansprechen von Tix (Tk-widget set) und RPM.
82
83 %description -l es
84 Python es un lenguaje de scripts interpretado orientado a objetos.
85 Contiene soporte para carga dinámica de objetos, clases, módulos y
86 excepciones.
87
88 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
89 través de código C, tornando Python fácil de usar en ambientes
90 articulares/ personalizados. Este paquete Python incluye la mayoría de
91 los módulos padrón Python, junto con módulos para crear interfaces
92 para el conjunto de componentes Tix para Tk y RPM.
93
94 %description -l fr
95 Python est un langage de script interprété et orienté objet. Il gère
96 le chargement dynamique des objets, les classes, les modules et les
97 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
98 avec du code C est simple, ce qui rend Python facile à utiliser dans
99 des configs personnalisées.
100
101 Ce paquetage Python contient la plupart des modules Python standards,
102 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
103 et RPM.
104
105 %description -l pl
106 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
107 jêzykiem programowania. Jest modularny, obs³uguje wyj±tki, dynamiczne
108 typy, zaawansowane dynamiczne struktury danych i klasy. Python ³±czy w
109 sobie du¿e mo¿liwo¶ci i przejrzyst± sk³adniê. Posiada interfejsy do
110 wielu wywo³añ systemowych i bibliotek, w tym równie¿ do ró¿nych
111 bibliotek okienkowych. Mo¿liwo¶ci jego mo¿na jeszcze rozszerzaæ
112 poprzez odpowiednie modu³y pisane w C lub C++. Python mo¿e byæ równie¿
113 u¿yty jako element aplikacji, którym potrzebny jest interpreter do
114 skryptów. I wreszcie, Python jest wieloplatformowy, dzia³a na wielu
115 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
116 OS/2.
117
118 %description -l pt_BR
119 Python é uma linguagem de scripts interpretada orientada a objetos.
120 Contém suporte para carga dinâmica de objetos, classes, módulos e
121 exceções. Adicionar interfaces para novos sistemas de biblioteca
122 através de código C é simples, tornando Python fácil de usar em
123 ambientes particulares/personalizados.
124
125 Este pacote Python inclui a maioria do módulos padrão Python, junto
126 com módulos para interfaceamento para o conjunto de componentes Tix
127 para Tk e RPM.
128
129 %description -l ru
130 Python - ÜÔÏ ÉÎÔÅÒÐÒÅÔÉÒÕÅÍÙÊ, ÏÂßÅËÔÎÏ-ÏÒÉÅÎÔÉÒÏ×ÁÎÎÙÊ ÑÚÙË
131 ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ. ïΠÐÏÄÄÅÒÖÉ×ÁÅÔ ÄÉÎÁÍÉÞÅÓËÕÀ ÚÁÇÒÕÚËÕ ÏÂßÅËÔÏ×,
132 ËÌÁÓÓÙ, ÍÏÄÕÌÉ É ÏÂÒÁÂÏÔËÕ ÉÓËÌÀÞÉÔÅÌØÎÙÈ ÓÉÔÕÁÃÉÊ (exceptions).
133 ðÒÏÓÔÏÔÁ ÄÏÂÁ×ÌÅÎÉÑ ÉÎÔÅÒÆÅÊÓÏ× Ë ÎÏ×ÙÍ ÓÉÓÔÅÍÎÙÍ ÂÉÂÌÉÏÔÅËÁÍ ÞÅÒÅÚ
134 ËÏÄ ÎÁ ÑÚÙËÅ C ÄÅÌÁÅÔ Python ÈÏÒÏÛÉÍ ×ÙÂÏÒÏÍ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ×
135 ÓÐÅÃÉÁÌØÎÙÈ ËÏÎÆÉÇÕÒÁÃÉÑÈ.
136
137 %description -l tr
138 Python, nesneye yönelik bir kabuk yorumlayýcýdýr. Nesnelerin,
139 sýnýflarýn, modüllerin ve aykýrý durumlarýn dinamik yüklenmelerine
140 destek verir. C koduyla birlikte kullanýmý son derece kolaydýr. Bu
141 paket, standart Python birimlerinin çoðunun yanýsýra Tk ve RPM için
142 arayüz birimlerini de içerir.
143
144 %description -l uk
145 Python - ÃÅ ¦ÎÔÅÒÐÒÅÔÏ×ÁÎÁ, ÏÂ'¤ËÔÎÏ-ÏÒ¦¤ÎÔÏ×ÁÎÁ ÍÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ.
146 ÷¦Î Ð¦ÄÔÒÉÍÕ¤ ÄÉÎÁͦÞÎÕ ÚÁÇÒÕÚËÕ ÏÂ'¤ËÔ¦×, ËÌÁÓÉ, ÍÏÄÕ̦ ÔÁ ÏÂÒÏÂËÕ
147 ×ÉËÌÀÞÎÉÈ ÓÉÔÕÁæʠ(exceptions). ðÒÏÓÔÏÔÁ ÄÏÄÁ×ÁÎÎÑ ¦ÎÔÅÒÆÅÊӦנÄÌÑ
148 ÎÏ×ÉÈ ÓÉÓÔÅÍÎÉȠ¦Â̦ÏÔÅË ÞÅÒÅÚ ËÏÄ ÎÁ ÍÏצ C ÒÏÂÉÔØ Python ÄÏÂÒÉÍ
149 ×ÉÂÏÒÏÍ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎÑ × ÓÐÅæÁÌØÎÉÈ ËÏÎƦÇÕÒÁæÑÈ.
150
151 %package libs
152 Summary:        Python library
153 Summary(pl):    Biblioteka jêzyka Python
154 Group:          Libraries/Python
155 Provides:       %{name}-libs = %{py_ver}
156
157 %description libs
158 Python library.
159
160 %description libs -l pl
161 Biblioteka jêzyka Python.
162
163 %package modules
164 Summary:        Python modules
165 Summary(pl):    Modu³y jêzyka Python
166 Group:          Libraries/Python
167 Provides:       %{name}-modules = %{py_ver}
168 Requires:       %{name} = %{version}
169 Obsoletes:      python-logging
170 Obsoletes:      python-xmlrpc <= 1.0.1
171
172 %description modules
173 Python modules.
174
175 %description modules -l pl
176 Modu³y jêzyka Python.
177
178 %package pydoc
179 Summary:        Python interactive module documentation access support
180 Summary(pl):    Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python
181 Group:          Applications
182 Requires:       %{name}-modules = %{version}
183
184 %description pydoc
185 Python interactive module documentation access support.
186
187 %description pydoc -l pl
188 Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python.
189
190 %package idle
191 Summary:        IDE for Python language
192 Summary(pl):    IDE dla jêzyka Python
193 Group:          Applications
194 Requires:       %{name}-modules = %{version}
195
196 %description idle
197 IDE for Python language.
198
199 %description idle -l pl
200 IDE dla jêzyka Python.
201
202 %package devel
203 Summary:        Libraries and header files for building python code
204 Summary(de):    Libraries und Header-Dateien zum Erstellen von Python-Code
205 Summary(es):    Bibliotecas y archivos de inclusión para construir programas en python
206 Summary(fr):    Bibliothèques et en-têtes pour construire du code python
207 Summary(pl):    Pliki nag³ówkowe i biblioteki Pythona
208 Summary(pt_BR): Bibliotecas e arquivos de inclusão para o Python
209 Summary(ru):    âÉÂÌÉÏÔÅËÉ É ÈÅÄÅÒÙ ÄÌÑ ÐÏÓÔÒÏÅÎÉÑ ËÏÄÁ ÎÁ ÑÚÙËÅ Python
210 Summary(tr):    Python ile geliþtirme yapmak için gerekli dosyalar
211 Summary(uk):    â¦Â̦ÏÔÅËÉ ÔÁ ÈÅÄÅÒÉ ÄÌÑ ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÎÁ ÍÏצ Python
212 Group:          Development/Languages/Python
213 Requires:       %{name}-libs = %{version}
214
215 %description devel
216 The Python interpreter is relatively easy to extend with dynamically
217 loaded extensions and to embed in other programs. This packages
218 contains the header files and libraries which are needed to do both of
219 these tasks.
220
221 %description devel -l de
222 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
223 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
224 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
225 die für beide Aufgaben erforderlich sind.
226
227 %description devel -l es
228 El interpretador Python permite incluir con facilidad extensiones
229 cargadas dinámicamente. Python es también fácil de ser empotrado en
230 otros programas. Este paquete contiene los archivos de inclusión y
231 bibliotecas necesarios para estas dos tareas.
232
233 %description devel -l fr
234 L'interpréteur Python est relativement facile à étendre avec des
235 extensions chargées dynamiquement et à insérer dans d'autres
236 programmes. Ce paquetage contient les en-têtes et les bibliothèques
237 nécessaires à ces deux tâches.
238
239 %description devel -l pl
240 Wszystko co potrzebne, aby napisaæ w C/C++ modu³ rozszerzaj±cy
241 mo¿liwo¶ci Pythona. S± tu równie¿ wersje ¼ród³owe modu³ów ze
242 standardowej biblioteki.
243
244 %description devel -l pt_BR
245 O interpretador Python permite incluir com facilidade extensões
246 carregadas dinamicamente. Python é também fácil de ser embutido em
247 outros programas. Este pacote contém os arquivos de inclusão e
248 bibliotecas necessários para estas duas tarefas.
249
250 %description devel -l ru
251 éÎÔÅÒÐÒÅÔÁÔÏÒ Python ÏÔÎÏÓÉÔÅÌØÎÏ ÌÅÇËÏ ÒÁÓÛÉÒÑÅÔÓÑ ÐÒÉ ÐÏÍÏÝÉ
252 ÄÉÎÁÍÉÞÅÓËÉ ÚÁÇÒÕÖÁÅÍÙÈ ÒÁÓÛÉÒÅÎÉÊ É ×ÓÔÒÁÉ×ÁÅÔÓÑ × ÄÒÕÇÉÅ ÐÒÏÇÒÁÍÍÙ.
253 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÈÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÏÂÅÉÈ ÜÔÉÈ
254 ÚÁÄÁÞ.
255
256 %description devel -l tr
257 Bu paket, Python ile geliþtirme yapýlabilmesi için gerekli baþlýk
258 dosyalarýný ve kitaplýklarý içerir.
259
260 %description devel -l uk
261 ¶ÎÔÅÒÐÒÅÔÁÔÏÒ Python ×¦ÄÎÏÓÎÏ ÌÅÇËÏ ÒÏÚÛÉÒÀ¤ÔØÓÑ ÚÁ ÄÏÐÏÍÏÇÏÀ
262 ÒÏÚÛÉÒÅÎØ Ú ÄÉÎÁͦÞÎÏÀ ÚÁÇÒÕÚËÏÀ ÔÁ ×ÂÕÄÏ×Õ¤ÔØÓÑ × ¦ÎÛ¦ ÐÒÏÇÒÁÍÉ. ãÅÊ
263 ÐÁËÅԠͦÓÔÉÔØ ÈÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÏÂÏÈ ÃÉÈ ÚÁÄÁÞ.
264
265 %package devel-src
266 Summary:        Python module sources
267 Summary(pl):    Pliki ¼ród³owe modu³ów Pythona
268 Group:          Development/Languages/Python
269 Requires:       %{name}-modules = %{version}
270
271 %description devel-src
272 Python module sources.
273
274 %description devel-src -l pl
275 Pliki ¼ród³owe modu³ów Pythona.
276
277 %package static
278 Summary:        Static python library
279 Summary(pl):    Statyczna biblioteka Pythona
280 Group:          Development/Languages/Python
281 Provides:       %{name}-static = %{py_ver}
282 Requires:       %{name}-devel = %{version}
283
284 %description static
285 Static python library.
286
287 %description static -l pl
288 Statyczna biblioteka Pythona.
289
290 %package doc
291 Summary:        Documentation on Python
292 Summary(de):    Dokumentation zu Python
293 Summary(es):    Documentación para Python
294 Summary(fr):    Documentation sur Python
295 Summary(pl):    Dokumentacja do Pythona
296 Summary(pt_BR): Documentação para a linguagem de programação Python
297 Summary(ru):    äÏËÕÍÅÎÔÁÃÉÑ ÐÏ ÑÚÙËÕ Python
298 Summary(tr):    Python belgeleri
299 Summary(uk):    äÏËÕÍÅÎÔÁæѠÐÏ ÍÏצ Python
300 Group:          Documentation
301 Requires:       %{name} = %{version}
302 Obsoletes:      python-docs
303
304 %description doc
305 This package contains documentation on the Python language and
306 interpretor as a mix of plain ASCII files and LaTeX sources.
307
308 %description doc -l de
309 Dieses Paket enthält Dokumentationen zu Python (Sprache und
310 Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
311
312 %description doc -l es
313 Documentación para Python. Contiene archivos en texto y PostScript.
314
315 %description doc -l fr
316 Ce paquetage contient la documentation sur le langage python et sur
317 son interpréteur sous forme de fichiers ASCII et LaTeX.
318
319 %description doc -l pl
320 Oficjalna dokumentacja do Pythona. Zawiera przyk³adowe programy,
321 narzêdzia i dokumentacjê. Strony podrêcznika man znajduj± siê w
322 g³ównym pakiecie. Ten pakiet nie zawiera ¼róde³ dokumentacji
323 napisanych w LaTeX'u, tylko gotowe do wykorzystania pliki
324 postscript'owe i HTML.
325
326 %description doc -l pt_BR
327 O pacote python-doc contém documentação para a linguagem de
328 programação e para o interpretador Python. Fornecida em arquivos texto
329 e Postcript.
330
331 %description doc -l ru
332 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÏËÕÍÅÎÔÁÃÉÀ ÐÏ ÓÏÂÓÔ×ÅÎÎÏ ÑÚÙËÕ Python É ÐÏ
333 ÉÓÐÏÌÎÑÀÝÅÍÕ ÅÇÏ ÉÎÔÅÒÐÒÅÔÁÔÏÒÕ × ×ÉÄÅ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÙÈ ÆÁÊÌÏ× É
334 ÉÓÈÏÄÎÙÈ ÔÅËÓÔÏ× × ÆÏÒÍÁÔÅ LaTeX.
335
336 %description doc -l tr
337 Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyalarý ve
338 LaTeX kaynaklarýnýn bir karýþýmý olan yorumlayýcýyý içerir.
339
340 %description doc -l uk
341 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÄÏËÕÍÅÎÔÁæÀ ÐÏ ×ÌÁÓÎÅ ÍÏצ Python ÔÁ ÐÏ ×ÉËÏÎÕÀÞÏÍÕ
342 §§ ¦ÎÔÅÒÐÒÅÔÁÔÏÒÕ Õ ×ÉÇÌÑĦ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÉÈ ÆÁÊ̦נÔÁ ×ÉȦÄÎÉÈ
343 ÔÅËÓԦנՠÆÏÒÍÁÔ¦ LaTeX.
344
345 %package without-thread
346 Summary:        Python without threads
347 Summary(pl):    Pyton bez w±tków
348 Summary(ru):    ÷ÉÚÕÁÌØÎÙÊ ÉÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python
349 Summary(uk):    ÷¦ÚÕÁÌØÎÉÊ ¦ÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python
350 Group:          Libraries/Python
351 Provides:       %{name}-without-thread = %{py_ver}
352 Requires:       %{name} = %{version}
353 Obsoletes:      python-without-thread
354
355 %description without-thread
356 This package is rather needed for apache-mod_python module. Other ways
357 of use are unknown.
358
359 %description without-thread -l pl
360 Pyton bez w±tków jest w³a¶ciwie potrzebny tylko modu³owi
361 apache-mod_python, bo apache nie ich na razie nie wspiera.
362
363 %package -n tkinter
364 Summary:        Standard Python interface to the Tk GUI toolkit
365 Summary(de):    Grafischer Oberfläche für Python
366 Summary(es):    Interface GUI para Phyton
367 Summary(fr):    Interface graphique pour python
368 Summary(pl):    Standardowy interfejs Pythona do biblioteki Tk
369 Summary(pt_BR): Interface GUI para Phyton
370 Summary(tr):    Python için grafik kullanýcý arayüzü
371 Group:          Libraries/Python
372 Requires:       %{name}-modules = %{version}
373 Requires:       tcl >= 8.0.3
374 Requires:       tk  >= 8.0.3
375 Requires:       tix >= 4.1.0.6
376
377 %description -n tkinter
378 Standard Python interface to the Tk GUI toolkit.
379
380 %description -n tkinter -l de
381 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
382 vielen Konfigurations-Tools genutzt.
383
384 %description -n tkinter -l es
385 Una interface gráfica para Python, basada en Tcl/Tk, y usada por
386 muchas herramientas de configuración.
387
388 %description -n tkinter -l fr
389 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
390 beaucoup des outils de configuration.
391
392 %description -n tkinter -l pl
393 Standardowy interfejs Pythona do biblioteki Tk.
394
395 %description -n tkinter -l pt_BR
396 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
397 muitas ferramentas de configuração.
398
399 %description -n tkinter -l ru
400 çÒÁÆÉÞÅÓËÉÊ ÉÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÓÔÒÏÅÎÎÙÊ ÎÁ Tcl/Tk.
401
402 %description -n tkinter -l tr
403 Python için Tcl/Tk'ye dayalý ve pek çok ayarlama aracý tarafýndan
404 kullanýlan grafik bir arayüzdür.
405
406 %description -n tkinter -l uk
407 çÒÁƦÞÎÉÊ ¦ÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÂÕÄÏ×ÁÎÉÊ ÎÁ Tcl/Tk.
408
409 %package old
410 Summary:        Depreciated Python modules
411 Summary(pl):    Nieaktualne modu³y jêzyka Python
412 Group:          Libraries/Python
413 Requires:       %{name}-modules = %{version}
414
415 %description old
416 Install this package when one of your program written in Python is old
417 as Miss Universum of 1918, who only you want to see... ooops, which
418 only you want to run.
419
420 %description old -l pl
421 Zainstaluj ten pakiet, wtedy kiedy jeden z Twoich programów napisanych
422 w jêzyku Python jest tak stary jak Miss Universum z roku 1918, któr±
423 tylko ty chcesz zobaczyæ... przepraszam, który tylko ty chcesz
424 uruchomiæ.
425
426 %package examples
427 Summary:        Example programs in Python
428 Summary(pl):    Przyk³adowe programy w Pythonie
429 Group:          Development/Languages/Python
430 Requires:       %{name}-devel = %{version}
431 Obsoletes:      python-tools
432
433 %description examples
434 Example programs in Python.
435
436 %description examples -l pl
437 Przyk³adowe programy w Pythonie.
438
439 %prep
440 %setup -q -n Python-%{version}
441 %patch0 -p1
442 %patch1 -p1
443 %patch2 -p1
444 %patch3 -p1
445 %patch4 -p1
446
447 install -d html-doc
448 tar -xf %{SOURCE1} --use=bzip2 -C html-doc
449
450 %build
451 %{__autoconf}
452
453 POSIXLY_CORRECT=TRUE; export POSIXLY_CORRECT
454
455 CPPFLAGS="-I%{_includedir}/ncurses"; export CPPFLAGS
456 %configure \
457         --with-threads \
458         --enable-shared
459
460 %{__make} OPT="%{rpmcflags}"
461
462 %install
463 rm -rf $RPM_BUILD_ROOT
464 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} $RPM_BUILD_ROOT%{_mandir}/man1
465
466 %{__make} install DESTDIR=$RPM_BUILD_ROOT
467
468 install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
469
470 install libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}
471 ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
472 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython.so
473
474 rm -f $RPM_BUILD_ROOT%{_bindir}/python%{py_ver}
475
476 install -d $RPM_BUILD_ROOT%{_examplesdir}/python
477 cp -ar Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/python
478
479 echo "%defattr(644,root,root,755)" > modules.filelist
480
481 find $RPM_BUILD_ROOT%{py_libdir} \
482         -type f \
483         -maxdepth 1 \
484         -printf %{py_libdir}/%f\\n \
485         | grep '\.py[co]$' \
486         | grep -v -e 'UserDict\.py[oc]$'\
487         | grep -v -e 'codecs\.py[oc]$' \
488         | grep -v -e 'copy_reg\.py[oc]$' \
489         | grep -v -e 'locale\.py[oc]$' \
490         | grep -v -e 'posixpath\.py[oc]$' \
491         | grep -v -e 'pydoc\.py[oc]$' \
492         | grep -v -e 'site\.py[oc]$' \
493         | grep -v -e 'stat\.py[oc]$' \
494         | grep -v -e 'os\.py[oc]$' \
495         | grep -v -e 'encodings\/.*\.py[oc]$' >> modules.filelist
496
497 find $RPM_BUILD_ROOT%{py_dyndir} \
498         -type f \
499         -maxdepth 1 \
500         -printf "%%%%attr(755,root,root) %{py_dyndir}/%f\\n" \
501         | grep '\.so$' \
502         | grep -v -e '_iconv_codec\.so$' \
503         | grep -v -e 'readline\.so$' \
504         | grep -v -e 'struct\.so$' \
505         | grep -v -e '_tkinter\.so$' >> modules.filelist
506
507 %clean
508 rm -rf $RPM_BUILD_ROOT
509
510 %post   libs -p /sbin/ldconfig
511 %postun libs -p /sbin/ldconfig
512
513 %files
514 %defattr(644,root,root,755)
515 %attr(755,root,root) %{_bindir}/python
516 %{_mandir}/man1/*
517
518 # readline support for python binary
519 %attr(755,root,root) %{py_dyndir}/readline.so
520
521 %files modules -f modules.filelist
522 %defattr(644,root,root,755)
523
524 %dir %{py_libdir}/plat-*
525 %attr(755,root,root) %{py_libdir}/plat-*/regen
526 %{py_libdir}/plat-*/*.py[co]
527
528 %dir %{py_libdir}/bsddb
529 %{py_libdir}/bsddb/*.py[co]
530
531 %dir %{py_libdir}/compiler
532 %{py_libdir}/compiler/*.py[co]
533
534 %dir %{py_libdir}/curses
535 %{py_libdir}/curses/*.py[co]
536
537 %dir %{py_libdir}/distutils
538 %{py_libdir}/distutils/*.py[co]
539
540 %dir %{py_libdir}/distutils/command
541 %{py_libdir}/distutils/command/*.py[co]
542
543 %dir %{py_libdir}/email
544 %{py_libdir}/email/*.py[co]
545
546 %dir %{py_libdir}/hotshot
547 %{py_libdir}/hotshot/*.py[co]
548
549 %dir %{py_libdir}/logging
550 %{py_libdir}/logging/*.py[co]
551
552 %dir %{py_libdir}/xml
553 %{py_libdir}/xml/*.py[co]
554
555 %dir %{py_libdir}/xml/parsers
556 %{py_libdir}/xml/parsers/*.py[co]
557
558 %dir %{py_libdir}/xml/sax
559 %{py_libdir}/xml/sax/*.py[co]
560
561 %dir %{py_libdir}/xml/dom
562 %{py_libdir}/xml/dom/*.py[co]
563
564 %files libs
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_libdir}/libpython*so.*
567
568 %dir %{py_dyndir}
569 %dir %{py_libdir}
570 %dir %{py_sitedir}
571
572 # required shared modules by python library
573 #%attr(755,root,root) %{py_dyndir}/_iconv_codec.so
574 %attr(755,root,root) %{py_dyndir}/struct.so
575
576 # required modules by python library
577 %{py_libdir}/UserDict.py[co]
578 %{py_libdir}/codecs.py[co]
579 %{py_libdir}/copy_reg.py[co]
580 %{py_libdir}/locale.py[co]
581 %{py_libdir}/posixpath.py[co]
582 %{py_libdir}/site.py[co]
583 %{py_libdir}/stat.py[co]
584 %{py_libdir}/os.py[co]
585
586 # required encodings by python library
587 %dir %{py_libdir}/encodings
588 %{py_libdir}/encodings/*.py[co]
589
590 %files pydoc
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_bindir}/pydoc
593 %{py_libdir}/pydoc.py[co]
594
595 %files idle
596 %defattr(644,root,root,755)
597 %attr(755,root,root) %{_bindir}/idle
598 %dir %{py_libdir}/idlelib
599 %dir %{py_libdir}/idlelib/Icons
600 %{py_libdir}/idlelib/*.py[co]
601 %{py_libdir}/idlelib/Icons/*
602
603 %files devel
604 %defattr(644,root,root,755)
605 %doc Misc/{ACKS,NEWS,README}
606 %attr(755,root,root) %{_libdir}/lib*.so
607 %dir %{py_incdir}
608 %{py_incdir}/*.h
609
610 %dir %{py_libdir}/config
611 %attr(755,root,root) %{py_libdir}/config/makesetup
612 %attr(755,root,root) %{py_libdir}/config/install-sh
613 %{py_libdir}/config/Makefile
614 %{py_libdir}/config/Makefile.pre.in
615 %{py_libdir}/config/Setup
616 %{py_libdir}/config/Setup.config
617 %{py_libdir}/config/Setup.local
618 %{py_libdir}/config/config.c
619 %{py_libdir}/config/config.c.in
620 %{py_libdir}/config/python.o
621
622 %files devel-src
623 %defattr(644,root,root,755)
624 %attr(-,root,root) %{py_libdir}/*.py
625 %{py_libdir}/plat-*/*.py
626 %{py_libdir}/bsddb/*.py
627 %{py_libdir}/compiler/*.py
628 %{py_libdir}/curses/*.py
629 %{py_libdir}/distutils/*.py
630 %{py_libdir}/distutils/command/*.py
631 %{py_libdir}/email/*.py
632 %{py_libdir}/hotshot/*.py
633 %{py_libdir}/logging/*.py
634 %{py_libdir}/xml/*.py
635 %{py_libdir}/xml/parsers/*.py
636 %{py_libdir}/xml/sax/*.py
637 %{py_libdir}/xml/dom/*.py
638 %{py_libdir}/encodings/*.py
639 %{py_libdir}/idlelib/*.py
640
641 %files static
642 %defattr(644,root,root,755)
643 %{_libdir}/lib*.a
644
645 %files examples
646 %defattr(644,root,root,755)
647 %{_examplesdir}/python/Tools
648 %{_examplesdir}/python/Demo
649
650 %files doc
651 %defattr(644,root,root,755)
652 %doc html-doc/*
653 %dir %{py_libdir}/test
654 %attr(-,root,root) %{py_libdir}/test/*
655
656 %files -n tkinter
657 %defattr(644,root,root,755)
658
659 %{py_libdir}/lib-tk
660 %attr(755,root,root) %{py_dyndir}/_tkinter.so
661
662 %files old
663 %defattr(644,root,root,755)
664
665 %dir %{py_libdir}/lib-old
666 %{py_libdir}/lib-old/*.py[co]
This page took 0.097896 seconds and 3 git commands to generate.