]> git.pld-linux.org Git - packages/python.git/blob - python.spec
- rebuild with readline 5.0
[packages/python.git] / python.spec
1 #
2 # Conditional build:
3 %bcond_without  tkinter                 # disables tkinter module building
4 %bcond_without  tests                   # disables Python testing
5 %bcond_with     verbose_tests           # runs tests in verbose mode
6 #
7 # tests which will not work on 64-bit platforms
8 %define         no64bit_tests   test_audioop test_rgbimg test_imageop
9 # tests which may fail because of builder environment limitations (no /proc or /dev/pts)
10 %define         nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
11 # tests which fail because of some unknown/unresolved reason (this list should be empty)
12 %define         broken_tests test_anydbm test_bsddb test_re test_shelve test_whichdb test_zipimport test_distutils
13 # test_distutils fails for unknown reason:
14 # AssertionError: '/tmp/tmpaomC0l/installation/share/python' != '/tmp/tmpaomC0l/installation/lib/python'
15
16 %define py_ver          2.4
17 %define py_prefix       %{_prefix}
18 %define py_libdir       %{py_prefix}/%{_lib}/python%{py_ver}
19 %define py_incdir       %{_includedir}/python%{py_ver}
20 %define py_sitedir      %{py_libdir}/site-packages
21 %define py_dyndir       %{py_libdir}/lib-dynload
22
23 Summary:        Very high level scripting language with X interface
24 Summary(es):    Lenguaje script de alto nivel con interfaz X
25 Summary(fr):    Langage de script de très haut niveau avec interface X
26 Summary(pl):    Python - jêzyk obiektowy wysokiego poziomu
27 Summary(pt_BR): Linguagem de programação interpretada de alto nível
28 Summary(ru):    ñÚÙË ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ ÏÞÅÎØ ×ÙÓÏËÏÇÏ ÕÒÏ×ÎÑ Ó X-ÉÎÔÅÒÆÅÊÓÏÍ
29 Summary(tr):    X arayüzlü, yüksek düzeyli, kabuk yorumlayýcý dili
30 Summary(uk):    íÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÄÕÖÅ ×ÉÓÏËÏÇÏ Ò¦×ÎÑ Ú X-¦ÎÔÅÒÆÅÊÓÏÍ
31 Name:           python
32 Version:        %{py_ver}.1
33 Release:        3
34 Epoch:          1
35 License:        PSF
36 Group:          Applications
37 Source0:        http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
38 # Source0-md5:  de3e9a8836fab6df7c7ce545331afeb3
39 Source1:        http://www.python.org/ftp/python/doc/%{version}/html-%{version}.tar.bz2
40 # Source1-md5:  00fb0aee372eae2d9cef649853dfc5d8
41 Patch0:         %{name}-readline.patch
42 Patch1:         %{name}-%{name}path.patch
43 Patch2:         %{name}-no_ndbm.patch
44 Patch3:         %{name}-ac_fixes.patch
45 Patch4:         %{name}-noarch_to_datadir.patch
46 Patch5:         %{name}-lib64.patch
47 Patch6:         %{name}-doc_path.patch
48 Patch7:         %{name}-smtplib.patch
49 URL:            http://www.python.org/
50 BuildRequires:  autoconf
51 BuildRequires:  bzip2-devel
52 BuildRequires:  db-devel >= 4
53 BuildRequires:  expat-devel >= 1:1.95.7
54 BuildRequires:  gdbm-devel >= 1.8.3
55 BuildRequires:  gmp-devel >= 4.0
56 BuildRequires:  ncurses-ext-devel >= 5.2
57 BuildRequires:  libstdc++-devel
58 BuildRequires:  openssl-devel >= 0.9.7d
59 BuildRequires:  readline-devel >= 5.0
60 BuildRequires:  sed >= 4.0
61 %{?with_tkinter:BuildRequires:  tix-devel >= 1:8.1.4-4}
62 %{?with_tkinter:BuildRequires:  tk-devel >= 8.4.3}
63 BuildRequires:  zlib-devel
64 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
65 Obsoletes:      python-xml
66 Obsoletes:      python-intl
67 Obsoletes:      python-curses
68 Obsoletes:      python-gdbm
69 Obsoletes:      python-zlib
70 Obsoletes:      python2
71 Obsoletes:      python2-devel
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %if %{with verbose_tests}
75 %define test_flags -v -l -x 
76 %else
77 %define test_flags -l -x 
78 %endif
79
80 %ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
81 %define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
82 %else
83 %define test_list %{nobuilder_tests} %{broken_tests}
84 %endif
85
86 %description
87 Python is an interpreted, interactive, object-oriented programming
88 language. It incorporates modules, exceptions, dynamic typing, very
89 high level dynamic data types, and classes. Python combines remarkable
90 power with very clear syntax. It has interfaces to many system calls
91 and libraries, as well as to various window systems, and is extensible
92 in C or C++. It is also usable as an extension language for
93 applications that need a programmable interface. Finally, Python is
94 portable: it runs on many brands of UNIX, on the Mac, and on PCs under
95 MS-DOS, Windows, Windows NT, and OS/2.
96
97 %description -l de
98 Python ist eine interpretierte, interaktive, objektorientierte
99 Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
100 Python enthält Module, Klassen, Exceptions, High-Level dynamische
101 Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
102 zu vielen Systemaufrufen und Libraries, sowie verschiedene
103 Fenstersysteme (X11, Motif, Tk, Mac und MFC)
104
105 Programmierer können neue built-in-Module für Python in C oder C++
106 schreiben. Python kann auch als Erweiterungssprache für Applikationen
107 benutzt werden, die ein programmierbares Interface brauchen. Dieses
108 Paket enthält die meisten Standard-Python-Module, und Module zum
109 Ansprechen von Tix (Tk-widget set) und RPM.
110
111 %description -l es
112 Python es un lenguaje de scripts interpretado orientado a objetos.
113 Contiene soporte para carga dinámica de objetos, clases, módulos y
114 excepciones.
115
116 Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
117 través de código C, tornando Python fácil de usar en ambientes
118 particulares/personalizados. Este paquete Python incluye la mayoría de
119 los módulos padrón Python, junto con módulos para crear interfaces
120 para el conjunto de componentes Tix para Tk y RPM.
121
122 %description -l fr
123 Python est un langage de script interprété et orienté objet. Il gère
124 le chargement dynamique des objets, les classes, les modules et les
125 exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
126 avec du code C est simple, ce qui rend Python facile à utiliser dans
127 des configs personnalisées.
128
129 Ce paquetage Python contient la plupart des modules Python standards,
130 ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
131 et RPM.
132
133 %description -l pl
134 Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
135 jêzykiem programowania. Jest modularny, obs³uguje wyj±tki, dynamiczne
136 typy, zaawansowane dynamiczne struktury danych i klasy. Python ³±czy w
137 sobie du¿e mo¿liwo¶ci i przejrzyst± sk³adniê. Posiada interfejsy do
138 wielu wywo³añ systemowych i bibliotek, w tym równie¿ do ró¿nych
139 bibliotek okienkowych. Mo¿liwo¶ci jego mo¿na jeszcze rozszerzaæ
140 poprzez odpowiednie modu³y pisane w C lub C++. Python mo¿e byæ równie¿
141 u¿yty jako element aplikacji, którym potrzebny jest interpreter do
142 skryptów. I wreszcie, Python jest wieloplatformowy, dzia³a na wielu
143 odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
144 OS/2.
145
146 %description -l pt_BR
147 Python é uma linguagem de scripts interpretada orientada a objetos.
148 Contém suporte para carga dinâmica de objetos, classes, módulos e
149 exceções. Adicionar interfaces para novos sistemas de biblioteca
150 através de código C é simples, tornando Python fácil de usar em
151 ambientes particulares/personalizados.
152
153 Este pacote Python inclui a maioria do módulos padrão Python, junto
154 com módulos para interfaceamento para o conjunto de componentes Tix
155 para Tk e RPM.
156
157 %description -l ru
158 Python - ÜÔÏ ÉÎÔÅÒÐÒÅÔÉÒÕÅÍÙÊ, ÏÂßÅËÔÎÏ-ÏÒÉÅÎÔÉÒÏ×ÁÎÎÙÊ ÑÚÙË
159 ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ. ïΠÐÏÄÄÅÒÖÉ×ÁÅÔ ÄÉÎÁÍÉÞÅÓËÕÀ ÚÁÇÒÕÚËÕ ÏÂßÅËÔÏ×,
160 ËÌÁÓÓÙ, ÍÏÄÕÌÉ É ÏÂÒÁÂÏÔËÕ ÉÓËÌÀÞÉÔÅÌØÎÙÈ ÓÉÔÕÁÃÉÊ (exceptions).
161 ðÒÏÓÔÏÔÁ ÄÏÂÁ×ÌÅÎÉÑ ÉÎÔÅÒÆÅÊÓÏ× Ë ÎÏ×ÙÍ ÓÉÓÔÅÍÎÙÍ ÂÉÂÌÉÏÔÅËÁÍ ÞÅÒÅÚ
162 ËÏÄ ÎÁ ÑÚÙËÅ C ÄÅÌÁÅÔ Python ÈÏÒÏÛÉÍ ×ÙÂÏÒÏÍ ÄÌÑ ÉÓÐÏÌØÚÏ×ÁÎÉÑ ×
163 ÓÐÅÃÉÁÌØÎÙÈ ËÏÎÆÉÇÕÒÁÃÉÑÈ.
164
165 %description -l tr
166 Python, nesneye yönelik bir kabuk yorumlayýcýdýr. Nesnelerin,
167 sýnýflarýn, modüllerin ve aykýrý durumlarýn dinamik yüklenmelerine
168 destek verir. C koduyla birlikte kullanýmý son derece kolaydýr. Bu
169 paket, standart Python birimlerinin çoðunun yanýsýra Tk ve RPM için
170 arayüz birimlerini de içerir.
171
172 %description -l uk
173 Python - ÃÅ ¦ÎÔÅÒÐÒÅÔÏ×ÁÎÁ, ÏÂ'¤ËÔÎÏ-ÏÒ¦¤ÎÔÏ×ÁÎÁ ÍÏ×Á ÐÒÏÇÒÁÍÕ×ÁÎÎÑ.
174 ÷¦Î Ð¦ÄÔÒÉÍÕ¤ ÄÉÎÁͦÞÎÕ ÚÁÇÒÕÚËÕ ÏÂ'¤ËÔ¦×, ËÌÁÓÉ, ÍÏÄÕ̦ ÔÁ ÏÂÒÏÂËÕ
175 ×ÉËÌÀÞÎÉÈ ÓÉÔÕÁæʠ(exceptions). ðÒÏÓÔÏÔÁ ÄÏÄÁ×ÁÎÎÑ ¦ÎÔÅÒÆÅÊӦנÄÌÑ
176 ÎÏ×ÉÈ ÓÉÓÔÅÍÎÉȠ¦Â̦ÏÔÅË ÞÅÒÅÚ ËÏÄ ÎÁ ÍÏצ C ÒÏÂÉÔØ Python ÄÏÂÒÉÍ
177 ×ÉÂÏÒÏÍ ÄÌÑ ×ÉËÏÒÉÓÔÁÎÎÑ × ÓÐÅæÁÌØÎÉÈ ËÏÎƦÇÕÒÁæÑÈ.
178
179 %package libs
180 Summary:        Python library
181 Summary(pl):    Biblioteka jêzyka Python
182 Group:          Libraries/Python
183 # broken detection in rpm/pythondeps.sh
184 Provides:       python(abi) = %{py_ver}
185 # for compatibility with existing Ac packages
186 Provides:       python(bytecode) = %{py_ver}
187
188 %description libs
189 Python library.
190
191 %description libs -l pl
192 Biblioteka jêzyka Python.
193
194 %package modules
195 Summary:        Python modules
196 Summary(pl):    Modu³y jêzyka Python
197 Group:          Libraries/Python
198 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
199 Obsoletes:      python-logging
200 Obsoletes:      python-optik
201 Obsoletes:      python-xmlrpc <= 1.0.1
202
203 %description modules
204 Python modules.
205
206 %description modules -l pl
207 Modu³y jêzyka Python.
208
209 %package -n pydoc
210 Summary:        Python interactive module documentation access support
211 Summary(pl):    Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python
212 Group:          Applications
213 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
214 Obsoletes:      python-pydoc
215
216 %description -n pydoc
217 Python interactive module documentation access support.
218
219 %description -n pydoc -l pl
220 Interaktywne korzystanie z dokumentacji modu³ów jêzyka Python.
221
222 %package -n idle
223 Summary:        IDE for Python language
224 Summary(pl):    IDE dla jêzyka Python
225 Group:          Applications
226 Requires:       %{name}-tkinter = %{epoch}:%{version}-%{release}
227 Obsoletes:      python-idle
228
229 %description -n idle
230 IDE for Python language.
231
232 %description -n idle -l pl
233 IDE dla jêzyka Python.
234
235 %package devel
236 Summary:        Libraries and header files for building python code
237 Summary(de):    Libraries und Header-Dateien zum Erstellen von Python-Code
238 Summary(es):    Bibliotecas y archivos de inclusión para construir programas en python
239 Summary(fr):    Bibliothèques et en-têtes pour construire du code python
240 Summary(pl):    Pliki nag³ówkowe i biblioteki Pythona
241 Summary(pt_BR): Bibliotecas e arquivos de inclusão para o Python
242 Summary(ru):    âÉÂÌÉÏÔÅËÉ É ÈÅÄÅÒÙ ÄÌÑ ÐÏÓÔÒÏÅÎÉÑ ËÏÄÁ ÎÁ ÑÚÙËÅ Python
243 Summary(tr):    Python ile geliþtirme yapmak için gerekli dosyalar
244 Summary(uk):    â¦Â̦ÏÔÅËÉ ÔÁ ÈÅÄÅÒÉ ÄÌÑ ÐÒÏÇÒÁÍÕ×ÁÎÎÑ ÎÁ ÍÏצ Python
245 Group:          Development/Languages/Python
246 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
247
248 %description devel
249 The Python interpreter is relatively easy to extend with dynamically
250 loaded extensions and to embed in other programs. This package
251 contains the header files and libraries which are needed to do both of
252 these tasks.
253
254 %description devel -l de
255 Der Python-Interpretierer ist relativ einfach anhand von dynamisch
256 ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
257 integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
258 die für beide Aufgaben erforderlich sind.
259
260 %description devel -l es
261 El interpretador Python permite incluir con facilidad extensiones
262 cargadas dinámicamente. Python es también fácil de ser empotrado en
263 otros programas. Este paquete contiene los archivos de inclusión y
264 bibliotecas necesarios para estas dos tareas.
265
266 %description devel -l fr
267 L'interpréteur Python est relativement facile à étendre avec des
268 extensions chargées dynamiquement et à insérer dans d'autres
269 programmes. Ce paquetage contient les en-têtes et les bibliothèques
270 nécessaires à ces deux tâches.
271
272 %description devel -l pl
273 Interpreter Pythona jest w miarê ³atwy do rozszerzania przy pomocy
274 dynamicznie ³adowanych rozszerzeñ napisanych w C lub C++ oraz
275 osadzania w innych programach. Ten pakiet zawiera pliki nag³ówkowe i
276 wszystko inne co potrzebne do tych celów.
277
278 %description devel -l pt_BR
279 O interpretador Python permite incluir com facilidade extensões
280 carregadas dinamicamente. Python é também fácil de ser embutido em
281 outros programas. Este pacote contém os arquivos de inclusão e
282 bibliotecas necessários para estas duas tarefas.
283
284 %description devel -l ru
285 éÎÔÅÒÐÒÅÔÁÔÏÒ Python ÏÔÎÏÓÉÔÅÌØÎÏ ÌÅÇËÏ ÒÁÓÛÉÒÑÅÔÓÑ ÐÒÉ ÐÏÍÏÝÉ
286 ÄÉÎÁÍÉÞÅÓËÉ ÚÁÇÒÕÖÁÅÍÙÈ ÒÁÓÛÉÒÅÎÉÊ É ×ÓÔÒÁÉ×ÁÅÔÓÑ × ÄÒÕÇÉÅ ÐÒÏÇÒÁÍÍÙ.
287 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÈÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÏÂÅÉÈ ÜÔÉÈ
288 ÚÁÄÁÞ.
289
290 %description devel -l tr
291 Bu paket, Python ile geliþtirme yapýlabilmesi için gerekli baþlýk
292 dosyalarýný ve kitaplýklarý içerir.
293
294 %description devel -l uk
295 ¶ÎÔÅÒÐÒÅÔÁÔÏÒ Python ×¦ÄÎÏÓÎÏ ÌÅÇËÏ ÒÏÚÛÉÒÀ¤ÔØÓÑ ÚÁ ÄÏÐÏÍÏÇÏÀ
296 ÒÏÚÛÉÒÅÎØ Ú ÄÉÎÁͦÞÎÏÀ ÚÁÇÒÕÚËÏÀ ÔÁ ×ÂÕÄÏ×Õ¤ÔØÓÑ × ¦ÎÛ¦ ÐÒÏÇÒÁÍÉ. ãÅÊ
297 ÐÁËÅԠͦÓÔÉÔØ ÈÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÏÂÏÈ ÃÉÈ ÚÁÄÁÞ.
298
299 %package devel-src
300 Summary:        Python module sources
301 Summary(pl):    Pliki ¼ród³owe modu³ów Pythona
302 Group:          Development/Languages/Python
303 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
304
305 %description devel-src
306 Python module sources.
307
308 %description devel-src -l pl
309 Pliki ¼ród³owe modu³ów Pythona.
310
311 %package devel-tools
312 Summary:        Python development tools
313 Summary(pl):    Narzêdzia programistyczne jêzyka Python
314 Group:          Development/Languages/Python
315 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
316
317 %description devel-tools
318 Python development tools such as profilers and debugger.
319
320 %description devel-tools -l pl
321 Narzêdzia programistyczne jêzyka Python takie jak profiler oraz debugger.
322
323 %package static
324 Summary:        Static python library
325 Summary(pl):    Statyczna biblioteka Pythona
326 Group:          Development/Languages/Python
327 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
328
329 %description static
330 Static python library.
331
332 %description static -l pl
333 Statyczna biblioteka Pythona.
334
335 %package doc
336 Summary:        Documentation on Python
337 Summary(de):    Dokumentation zu Python
338 Summary(es):    Documentación para Python
339 Summary(fr):    Documentation sur Python
340 Summary(pl):    Dokumentacja do Pythona
341 Summary(pt_BR): Documentação para a linguagem de programação Python
342 Summary(ru):    äÏËÕÍÅÎÔÁÃÉÑ ÐÏ ÑÚÙËÕ Python
343 Summary(tr):    Python belgeleri
344 Summary(uk):    äÏËÕÍÅÎÔÁæѠÐÏ ÍÏצ Python
345 Group:          Documentation
346 Requires:       %{name} = %{epoch}:%{version}-%{release}
347 Obsoletes:      python-docs
348
349 %description doc
350 This package contains documentation on the Python language and
351 interpretor as a mix of plain ASCII files and LaTeX sources.
352
353 %description doc -l de
354 Dieses Paket enthält Dokumentationen zu Python (Sprache und
355 Interpreter) in Form von einfachen ASCII-Dateien und LaTeX-Quellen.
356
357 %description doc -l es
358 Documentación para Python. Contiene archivos en texto y PostScript.
359
360 %description doc -l fr
361 Ce paquetage contient la documentation sur le langage python et sur
362 son interpréteur sous forme de fichiers ASCII et LaTeX.
363
364 %description doc -l pl
365 Oficjalna dokumentacja do Pythona. Zawiera przyk³adowe programy,
366 narzêdzia i dokumentacjê. Strony podrêcznika man znajduj± siê w
367 g³ównym pakiecie. Ten pakiet nie zawiera ¼róde³ dokumentacji
368 napisanych w LaTeXu, tylko gotowe do wykorzystania pliki
369 postscriptowe i HTML.
370
371 %description doc -l pt_BR
372 O pacote python-doc contém documentação para a linguagem de
373 programação e para o interpretador Python. Fornecida em arquivos texto
374 e Postcript.
375
376 %description doc -l ru
377 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÄÏËÕÍÅÎÔÁÃÉÀ ÐÏ ÓÏÂÓÔ×ÅÎÎÏ ÑÚÙËÕ Python É ÐÏ
378 ÉÓÐÏÌÎÑÀÝÅÍÕ ÅÇÏ ÉÎÔÅÒÐÒÅÔÁÔÏÒÕ × ×ÉÄÅ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÙÈ ÆÁÊÌÏ× É
379 ÉÓÈÏÄÎÙÈ ÔÅËÓÔÏ× × ÆÏÒÍÁÔÅ LaTeX.
380
381 %description doc -l tr
382 Bu paket, Python dili ile ilgili belgeleri ve düz ASCII dosyalarý ve
383 LaTeX kaynaklarýnýn bir karýþýmý olan yorumlayýcýyý içerir.
384
385 %description doc -l uk
386 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÄÏËÕÍÅÎÔÁæÀ ÐÏ ×ÌÁÓÎÅ ÍÏצ Python ÔÁ ÐÏ ×ÉËÏÎÕÀÞÏÍÕ
387 §§ ¦ÎÔÅÒÐÒÅÔÁÔÏÒÕ Õ ×ÉÇÌÑĦ ÎÁÂÏÒÁ ÔÅËÓÔÏ×ÉÈ ÆÁÊ̦נÔÁ ×ÉȦÄÎÉÈ
388 ÔÅËÓԦנՠÆÏÒÍÁÔ¦ LaTeX.
389
390 %package tkinter
391 Summary:        Standard Python interface to the Tk GUI toolkit
392 Summary(de):    Grafische Tk-Schnittstelle für Python
393 Summary(es):    Interfaz de GUI Tk para Python
394 Summary(fr):    Interface graphique Tk pour Python
395 Summary(pl):    Standardowy interfejs Pythona do biblioteki Tk
396 Summary(pt_BR): Interface GUI Tk para Phyton
397 Summary(tr):    Python için grafik kullanýcý arayüzü
398 Group:          Libraries/Python
399 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
400 Requires:       tcl >= 8.4.3
401 Requires:       tix >= 1:8.1.4-4
402 Requires:       tk >= 8.4.3
403 Obsoletes:      tkinter
404
405 %description tkinter
406 Standard Python interface to the Tk GUI toolkit.
407
408 %description tkinter -l de
409 Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
410 vielen Konfigurations-Tools genutzt.
411
412 %description tkinter -l es
413 Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por
414 muchas herramientas de configuración.
415
416 %description tkinter -l fr
417 Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
418 beaucoup des outils de configuration.
419
420 %description tkinter -l pl
421 Standardowy interfejs Pythona do biblioteki Tk.
422
423 %description tkinter -l pt_BR
424 Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
425 muitas ferramentas de configuração.
426
427 %description tkinter -l ru
428 çÒÁÆÉÞÅÓËÉÊ ÉÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÓÔÒÏÅÎÎÙÊ ÎÁ Tcl/Tk.
429
430 %description tkinter -l tr
431 Python için Tcl/Tk'ye dayalý ve pek çok ayarlama aracý tarafýndan
432 kullanýlan grafik bir arayüzdür.
433
434 %description tkinter -l uk
435 çÒÁƦÞÎÉÊ ¦ÎÔÅÒÆÅÊÓ (GUI) ÄÌÑ Python, ÐÏÂÕÄÏ×ÁÎÉÊ ÎÁ Tcl/Tk.
436
437 %package old
438 Summary:        Deprecated Python modules
439 Summary(pl):    Nieaktualne modu³y jêzyka Python
440 Group:          Libraries/Python
441 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
442
443 %description old
444 Install this package when one of your program written in Python is old
445 as Miss Universum of 1918, who only you want to see... ooops, which
446 only you want to run.
447
448 %description old -l pl
449 Zainstaluj ten pakiet, wtedy kiedy jeden z Twoich programów napisanych
450 w jêzyku Python jest tak stary jak Miss Universum z roku 1918, któr±
451 tylko ty chcesz zobaczyæ... przepraszam, który tylko ty chcesz
452 uruchomiæ.
453
454 %package examples
455 Summary:        Example programs in Python
456 Summary(pl):    Przyk³adowe programy w Pythonie
457 Group:          Development/Languages/Python
458 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
459 Obsoletes:      python-tools
460
461 %description examples
462 Example programs in Python.
463
464 These are for Python 2.3.4, not %{version}.
465
466 %description examples -l pl
467 Przyk³adowe programy w Pythonie.
468
469 Przyk³ady te s± dla Pythona 2.3.4, nie %{version}.
470
471 %prep
472 %setup -q -n Python-%{version}
473 %patch0 -p1
474 %patch1 -p1
475 %patch2 -p1
476 %patch3 -p1
477 %patch4 -p1
478 %if "%{_lib}" == "lib64"
479 %patch5 -p1
480 %endif
481 %patch6 -p1
482 %patch7 -p1
483
484 tar -xf %{SOURCE1} --use=bzip2
485
486 %build
487 sed -i -e 's#-ltermcap#-ltinfo#g' configure*
488 %{__autoconf}
489 CPPFLAGS="-I%{_includedir}/ncurses"; export CPPFLAGS
490 %configure \
491         --with-threads \
492         --with-cxx="%{__cxx}" \
493         --enable-unicode=ucs4 \
494         --enable-shared \
495         LINKCC='$(PURIFY) $(CXX)'
496
497 %{__make} \
498         OPT="%{rpmcflags}"
499
500 LC_ALL=C
501 export LC_ALL
502 %if %{with tests}
503 binlibdir=`echo build/lib.*`
504 %{__make} test \
505         TESTOPTS="%{test_flags} %{test_list}" \
506         TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:$binlibdir ./python -tt"
507 %endif
508
509 %install
510 rm -rf $RPM_BUILD_ROOT
511 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
512         $RPM_BUILD_ROOT{%{py_sitedir},%{_mandir}/man1} \
513         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
514
515 %{__make} install \
516         DESTDIR=$RPM_BUILD_ROOT
517
518 install Makefile.pre.in $RPM_BUILD_ROOT%{py_libdir}/config
519
520 install libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}
521 ln -sf libpython%{py_ver}.a $RPM_BUILD_ROOT%{_libdir}/libpython.a
522 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython.so
523 ln -sf libpython%{py_ver}.so.1.0 $RPM_BUILD_ROOT%{_libdir}/libpython%{py_ver}.so
524
525 rm -f $RPM_BUILD_ROOT%{_bindir}/python%{py_ver}
526
527 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
528 cp -ar Tools Demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
529
530 SCRIPT_EXT=".py"
531 export SCRIPT_EXT
532
533 # create several useful scripts, such as timeit.py, profile.py, pdb.py, smtpd.py
534 for script in timeit profile pdb pstats smtpd; do
535     cat <<END > $RPM_BUILD_ROOT%{_bindir}/${script}$SCRIPT_EXT
536 #!/bin/sh
537 exec python %{py_scriptdir}/${script}.pyc "\$@"
538 END
539 done
540
541 # xgettext specific for Python code
542 install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext$SCRIPT_EXT
543
544 %clean
545 rm -rf $RPM_BUILD_ROOT
546
547 %post   libs -p /sbin/ldconfig
548 %postun libs -p /sbin/ldconfig
549
550 %files
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{_bindir}/python
553 %{_mandir}/man1/*
554
555 %files modules
556 %defattr(644,root,root,755)
557 %exclude %{py_scriptdir}/UserDict.py[co]
558 %exclude %{py_scriptdir}/codecs.py[co]
559 %exclude %{py_scriptdir}/copy_reg.py[co]
560 %exclude %{py_scriptdir}/locale.py[co]
561 %exclude %{py_scriptdir}/posixpath.py[co]
562 %exclude %{py_scriptdir}/pdb.py[co]
563 %exclude %{py_scriptdir}/profile.py[co]
564 %exclude %{py_scriptdir}/pstats.py[co]
565 %exclude %{py_scriptdir}/pydoc.py[co]
566 %exclude %{py_scriptdir}/site.py[co]
567 %exclude %{py_scriptdir}/stat.py[co]
568 %exclude %{py_scriptdir}/timeit.py[co]
569 %exclude %{py_scriptdir}/os.py[co]
570 %exclude %{py_scriptdir}/encodings/*.py[co]
571
572 %{py_scriptdir}/*.py[co]
573
574 #
575 # list .so modules to be sure that all of them are built
576 #
577
578 # three modules below does not work on 64-bit architectures
579 # see Python README file for explanation
580 %ifnarch alpha ia64 ppc64 sparc64 %{x8664}
581 %attr(755,root,root) %{py_dyndir}/audioop.so
582 %attr(755,root,root) %{py_dyndir}/rgbimg.so
583 %attr(755,root,root) %{py_dyndir}/imageop.so
584 # sizeof(long) != sizeof(int), so dl module will not be built on 64-bit
585 # platforms
586 %attr(755,root,root) %{py_dyndir}/dl.so
587 %endif
588
589 %attr(755,root,root) %{py_dyndir}/_bisect.so
590 %attr(755,root,root) %{py_dyndir}/_bsddb.so
591 %attr(755,root,root) %{py_dyndir}/_codecs_cn.so
592 %attr(755,root,root) %{py_dyndir}/_codecs_hk.so
593 %attr(755,root,root) %{py_dyndir}/_codecs_iso2022.so
594 %attr(755,root,root) %{py_dyndir}/_codecs_jp.so
595 %attr(755,root,root) %{py_dyndir}/_codecs_kr.so
596 %attr(755,root,root) %{py_dyndir}/_codecs_tw.so
597 %attr(755,root,root) %{py_dyndir}/_csv.so
598 %attr(755,root,root) %{py_dyndir}/_curses.so
599 %attr(755,root,root) %{py_dyndir}/_curses_panel.so
600 %attr(755,root,root) %{py_dyndir}/_heapq.so
601 %attr(755,root,root) %{py_dyndir}/_locale.so
602 %attr(755,root,root) %{py_dyndir}/_multibytecodec.so
603 %attr(755,root,root) %{py_dyndir}/_random.so
604 %attr(755,root,root) %{py_dyndir}/_socket.so
605 %attr(755,root,root) %{py_dyndir}/_ssl.so
606 %attr(755,root,root) %{py_dyndir}/_testcapi.so
607 %attr(755,root,root) %{py_dyndir}/_weakref.so
608 %attr(755,root,root) %{py_dyndir}/array.so
609 %attr(755,root,root) %{py_dyndir}/binascii.so
610 %attr(755,root,root) %{py_dyndir}/bz2.so
611 %attr(755,root,root) %{py_dyndir}/cPickle.so
612 %attr(755,root,root) %{py_dyndir}/cStringIO.so
613 %attr(755,root,root) %{py_dyndir}/cmath.so
614 %attr(755,root,root) %{py_dyndir}/collections.so
615 %attr(755,root,root) %{py_dyndir}/crypt.so
616 %attr(755,root,root) %{py_dyndir}/datetime.so
617 %ifnarch sparc64
618 %attr(755,root,root) %{py_dyndir}/dbm.so
619 %endif
620 %attr(755,root,root) %{py_dyndir}/fcntl.so
621 %attr(755,root,root) %{py_dyndir}/gdbm.so
622 %attr(755,root,root) %{py_dyndir}/grp.so
623 %attr(755,root,root) %{py_dyndir}/itertools.so
624 %attr(755,root,root) %{py_dyndir}/linuxaudiodev.so
625 %attr(755,root,root) %{py_dyndir}/math.so
626 %attr(755,root,root) %{py_dyndir}/md5.so
627 %attr(755,root,root) %{py_dyndir}/mmap.so
628 %attr(755,root,root) %{py_dyndir}/nis.so
629 %attr(755,root,root) %{py_dyndir}/operator.so
630 %attr(755,root,root) %{py_dyndir}/ossaudiodev.so
631 %attr(755,root,root) %{py_dyndir}/parser.so
632 %attr(755,root,root) %{py_dyndir}/pwd.so
633 %attr(755,root,root) %{py_dyndir}/pyexpat.so
634 %attr(755,root,root) %{py_dyndir}/readline.so
635 %attr(755,root,root) %{py_dyndir}/regex.so
636 %attr(755,root,root) %{py_dyndir}/resource.so
637 %attr(755,root,root) %{py_dyndir}/select.so
638 %attr(755,root,root) %{py_dyndir}/sha.so
639 %attr(755,root,root) %{py_dyndir}/strop.so
640 %attr(755,root,root) %{py_dyndir}/syslog.so
641 %attr(755,root,root) %{py_dyndir}/termios.so
642 %attr(755,root,root) %{py_dyndir}/time.so
643 %attr(755,root,root) %{py_dyndir}/timing.so
644 %attr(755,root,root) %{py_dyndir}/unicodedata.so
645 %attr(755,root,root) %{py_dyndir}/zlib.so
646
647 %dir %{py_scriptdir}/plat-*
648 %attr(755,root,root) %{py_scriptdir}/plat-*/regen
649 %{py_scriptdir}/plat-*/*.py[co]
650
651 %dir %{py_scriptdir}/bsddb
652 %{py_scriptdir}/bsddb/*.py[co]
653
654 %dir %{py_scriptdir}/compiler
655 %{py_scriptdir}/compiler/*.py[co]
656
657 %dir %{py_scriptdir}/curses
658 %{py_scriptdir}/curses/*.py[co]
659
660 %dir %{py_scriptdir}/distutils
661 %{py_scriptdir}/distutils/*.py[co]
662
663 %dir %{py_scriptdir}/distutils/command
664 %{py_scriptdir}/distutils/command/*.py[co]
665
666 %dir %{py_scriptdir}/email
667 %{py_scriptdir}/email/*.py[co]
668
669 %dir %{py_scriptdir}/logging
670 %{py_scriptdir}/logging/*.py[co]
671
672 %dir %{py_scriptdir}/xml
673 %{py_scriptdir}/xml/*.py[co]
674
675 %dir %{py_scriptdir}/xml/parsers
676 %{py_scriptdir}/xml/parsers/*.py[co]
677
678 %dir %{py_scriptdir}/xml/sax
679 %{py_scriptdir}/xml/sax/*.py[co]
680
681 %dir %{py_scriptdir}/xml/dom
682 %{py_scriptdir}/xml/dom/*.py[co]
683
684 %files libs
685 %defattr(644,root,root,755)
686 %attr(755,root,root) %{_libdir}/libpython*.so.*
687
688 %dir %{py_dyndir}
689 %dir %{py_scriptdir}
690 %dir %{py_libdir}
691 %dir %{py_sitescriptdir}
692 %dir %{py_sitedir}
693
694 # shared modules required by python library
695 %attr(755,root,root) %{py_dyndir}/struct.so
696
697 # modules required by python library
698 %{py_scriptdir}/UserDict.py[co]
699 %{py_scriptdir}/codecs.py[co]
700 %{py_scriptdir}/copy_reg.py[co]
701 %{py_scriptdir}/locale.py[co]
702 %{py_scriptdir}/posixpath.py[co]
703 %{py_scriptdir}/site.py[co]
704 %{py_scriptdir}/stat.py[co]
705 %{py_scriptdir}/os.py[co]
706
707 # encodings required by python library
708 %dir %{py_scriptdir}/encodings
709 %{py_scriptdir}/encodings/*.py[co]
710
711 %files -n pydoc
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_bindir}/pydoc
714 %{py_scriptdir}/pydoc.py[co]
715
716 %files -n idle
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_bindir}/idle
719 %dir %{py_scriptdir}/idlelib
720 %dir %{py_scriptdir}/idlelib/Icons
721 %{py_scriptdir}/idlelib/*.py[co]
722 %{py_scriptdir}/idlelib/Icons/*
723 %{py_scriptdir}/idlelib/*.def
724
725 %files devel
726 %defattr(644,root,root,755)
727 %doc Misc/{ACKS,NEWS,README}
728 %attr(755,root,root) %{_libdir}/lib*.so
729 %dir %{py_incdir}
730 %{py_incdir}/*.h
731
732 %dir %{py_libdir}/config
733 %attr(755,root,root) %{py_libdir}/config/makesetup
734 %attr(755,root,root) %{py_libdir}/config/install-sh
735 %{py_libdir}/config/Makefile
736 %{py_libdir}/config/Makefile.pre.in
737 %{py_libdir}/config/Setup
738 %{py_libdir}/config/Setup.config
739 %{py_libdir}/config/Setup.local
740 %{py_libdir}/config/config.c
741 %{py_libdir}/config/config.c.in
742 %{py_libdir}/config/ccpython.o
743 %{py_libdir}/config/libpython2.4.a
744
745 %files devel-src
746 %defattr(644,root,root,755)
747 %attr(-,root,root) %{py_scriptdir}/*.py
748 %{py_scriptdir}/plat-*/*.py
749 %{py_scriptdir}/bsddb/*.py
750 %{py_scriptdir}/compiler/*.py
751 %{py_scriptdir}/curses/*.py
752 %{py_scriptdir}/distutils/*.py
753 %{py_scriptdir}/distutils/command/*.py
754 %{py_scriptdir}/email/*.py
755 %{py_scriptdir}/hotshot/*.py
756 %{py_scriptdir}/logging/*.py
757 %{py_scriptdir}/xml/*.py
758 %{py_scriptdir}/xml/parsers/*.py
759 %{py_scriptdir}/xml/sax/*.py
760 %{py_scriptdir}/xml/dom/*.py
761 %{py_scriptdir}/encodings/*.py
762 %{py_scriptdir}/idlelib/*.py
763
764 %files devel-tools
765 %defattr(644,root,root,755)
766 %doc Lib/profile.doc Lib/pdb.doc
767 %attr(755,root,root) %{_bindir}/timeit*
768 %attr(755,root,root) %{_bindir}/profile*
769 %attr(755,root,root) %{_bindir}/pdb*
770 %attr(755,root,root) %{_bindir}/pstats*
771 %attr(755,root,root) %{_bindir}/pygettext*
772 %attr(755,root,root) %{_bindir}/smtpd*
773
774 %attr(755,root,root) %{py_dyndir}/_hotshot.so
775 %dir %{py_scriptdir}/hotshot
776 %{py_scriptdir}/hotshot/*.py[co]
777 %{py_scriptdir}/pdb.py[co]
778 %{py_scriptdir}/profile.py[co]
779 %{py_scriptdir}/pstats.py[co]
780 %{py_scriptdir}/timeit.py[co]
781
782 %files static
783 %defattr(644,root,root,755)
784 %{_libdir}/lib*.a
785
786 %files examples
787 %defattr(644,root,root,755)
788 %{_examplesdir}/%{name}-%{version}
789
790 %files doc
791 %defattr(644,root,root,755)
792 # FIXME
793 %doc Python-Docs-%{version}
794 %dir %{py_scriptdir}/test
795 %attr(-,root,root) %{py_scriptdir}/test/*
796 %attr(-,root,root) %{py_scriptdir}/email/test/*
797 %attr(-,root,root) %{py_scriptdir}/bsddb/test/*
798
799 %if %{with tkinter}
800 %files tkinter
801 %defattr(644,root,root,755)
802 %{py_scriptdir}/lib-tk
803 %attr(755,root,root) %{py_dyndir}/_tkinter.so
804 %endif
805
806 %files old
807 %defattr(644,root,root,755)
808 %dir %{py_scriptdir}/lib-old
809 %{py_scriptdir}/lib-old/*.py[co]
This page took 0.207701 seconds and 3 git commands to generate.