]> git.pld-linux.org Git - packages/python-setuptools.git/blob - python-setuptools.spec
- new
[packages/python-setuptools.git] / python-setuptools.spec
1
2 %define module  setuptools
3
4 Summary:        A collection of enhancements to the Python distutils
5 Name:           python-setuptools
6 Version:        0.6a8
7 Release:        1
8 License:        GPL
9 Group:          Development/Languages/Python
10 Source0:        http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-%{version}.zip
11 # Source0-md5:  3eecdf66c1a2cf8a6556bc00b69d572a
12 URL:            http://peak.telecommunity.com/DevCenter/setuptools
13 %pyrequires_eq  python
14 BuildRequires:  python-devel
15 BuildRequires:  unzip
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 setuptools is a collection of enhancements to the Python distutils
21 (for Python 2.3.5 and up on most platforms; 64-bit platforms require a
22 minimum of Python 2.4) that allow you to more easily build and
23 distribute Python packages, especially ones that have dependencies on
24 other packages.
25
26 %prep
27 %setup  -q -n %{module}-%{version}
28
29 %build
30 python ./setup.py build
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34
35 python ./setup.py install \
36         --optimize 2 \
37         --root=$RPM_BUILD_ROOT
38
39 %py_postclean
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc *.txt
47 %attr(755,root,root) %{_bindir}/*
48 %{py_sitescriptdir}/%{module}*
This page took 0.074629 seconds and 4 git commands to generate.