]> git.pld-linux.org Git - packages/python-setuptools.git/blob - python-setuptools.spec
- rel .2
[packages/python-setuptools.git] / python-setuptools.spec
1
2 %define module  setuptools
3 %define sub     c3
4
5 Summary:        A collection of enhancements to the Python distutils
6 Summary(pl):    Zestaw rozszerzeñ dla pythonowych distutils
7 Name:           python-setuptools
8 Version:        0.6
9 Release:        0.%{sub}.2
10 Epoch:          1
11 License:        GPL
12 Group:          Development/Languages/Python
13 Source0:        http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-%{version}%{sub}.tar.gz
14 # Source0-md5:  76cb98b779d356c64323125490f88d17
15 URL:            http://peak.telecommunity.com/DevCenter/setuptools
16 BuildRequires:  findutils
17 %pyrequires_eq  python
18 BuildRequires:  python-devel
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 setuptools is a collection of enhancements to the Python distutils
24 (for Python 2.3.5 and up on most platforms; 64-bit platforms require a
25 minimum of Python 2.4) that allow you to more easily build and
26 distribute Python packages, especially ones that have dependencies on
27 other packages.
28
29 %description -l pl
30 setuptools to zestaw rozszerzeñ do pythonowych distutils (dla Pythona
31 2.3.5 i nowszego na wiêkszo¶ci platform; platformy 64-bitowe wymagaj±
32 co najmniej Pythona 2.4) umo¿liwiaj±cy ³atwiejsze budowanie i
33 rozprowadzanie pakietów Pythona, szczególnie tych maj±cych zale¿no¶ci
34 od innych pakietów.
35
36 %prep
37 %setup  -q -n %{module}-%{version}%{sub}
38
39 %build
40 python ./setup.py build
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 python ./setup.py install \
46         --single-version-externally-managed \
47         --optimize 2 \
48         --root=$RPM_BUILD_ROOT
49
50 rm -f $RPM_BUILD_ROOT%{py_sitescriptdir}/*/*.exe
51
52 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
53 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
54 %py_postclean
55 install site.py $RPM_BUILD_ROOT%{py_sitescriptdir}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc *.txt
63 %attr(755,root,root) %{_bindir}/*
64 %{py_sitescriptdir}/%{module}*
65 %{py_sitescriptdir}/*.py[co]
66 %{py_sitescriptdir}/site.py
This page took 0.064285 seconds and 4 git commands to generate.