]> git.pld-linux.org Git - packages/python-setuptools.git/blob - python-setuptools.spec
- fix
[packages/python-setuptools.git] / python-setuptools.spec
1
2 %define module  setuptools
3
4 Summary:        A collection of enhancements to the Python distutils
5 Name:           python-setuptools
6 Version:        0.6a8
7 Release:        1
8 License:        GPL
9 Group:          Development/Languages/Python
10 Source0:        http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-%{version}.zip
11 # Source0-md5:  3eecdf66c1a2cf8a6556bc00b69d572a
12 URL:            http://peak.telecommunity.com/DevCenter/setuptools
13 BuildRequires:  findutils
14 %pyrequires_eq  python
15 BuildRequires:  python-devel
16 BuildRequires:  unzip
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 setuptools is a collection of enhancements to the Python distutils
22 (for Python 2.3.5 and up on most platforms; 64-bit platforms require a
23 minimum of Python 2.4) that allow you to more easily build and
24 distribute Python packages, especially ones that have dependencies on
25 other packages.
26
27 %prep
28 %setup  -q -n %{module}-%{version}
29
30 %build
31 python ./setup.py build
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35
36 python ./setup.py install \
37         --optimize 2 \
38         --root=$RPM_BUILD_ROOT
39
40 find $RPM_BUILD_ROOT -type f -name '*.pyc' -exec rm "{}" ";"
41 find $RPM_BUILD_ROOT -type f -name '*.pyo' -exec rm "{}" ";"
42 find $RPM_BUILD_ROOT -type f -exec sed -i -e "s#$RPM_BUILD_ROOT##g" "{}" ";"
43
44 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
45 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
46 %py_postclean
47
48 echo '%{module}-%{version}-py%{py_ver}.egg' > $RPM_BUILD_ROOT%{py_sitescriptdir}/%{module}.pth
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc *.txt
56 %attr(755,root,root) %{_bindir}/*
57 %{py_sitescriptdir}/%{module}*
This page took 0.048056 seconds and 4 git commands to generate.