]> git.pld-linux.org Git - packages/python-setuptools.git/blob - python-setuptools.spec
- missing epoch in -devel deps; rel 3
[packages/python-setuptools.git] / python-setuptools.spec
1 # TODO:
2 # - sync -pl
3 %define         module  setuptools
4 %define         subver  c8
5 %define         rel             3
6 Summary:        A collection of enhancements to the Python distutils
7 Summary(pl.UTF-8):      Zestaw rozszerzeń dla pythonowych distutils
8 Name:           python-setuptools
9 Version:        0.6
10 Release:        1.%{subver}.%{rel}
11 Epoch:          1
12 License:        GPL
13 Group:          Development/Languages/Python
14 Source0:        http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-%{version}%{subver}.tar.gz
15 # Source0-md5:  0e9bbe1466f3ee29588cc09d3211a010
16 URL:            http://peak.telecommunity.com/DevCenter/setuptools
17 BuildRequires:  python-devel
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 setuptools is a collection of enhancements to the Python distutils
23 that allow you to more easily build and distribute Python packages,
24 especially ones that have dependencies on other packages.
25
26 This package contains the runtime components of setuptools, necessary
27 to execute the software that requires pkg_resources.py.
28
29 %description -l pl.UTF-8
30 setuptools to zestaw rozszerzeń do pythonowych distutils (dla Pythona
31 2.3.5 i nowszego na większości platform; platformy 64-bitowe wymagają
32 co najmniej Pythona 2.4) umożliwiający łatwiejsze budowanie i
33 rozprowadzanie pakietów Pythona, szczególnie tych mających zależności
34 od innych pakietów.
35
36 %package devel
37 Summary:        Download, install, upgrade, and uninstall Python packages
38 Group:          Development/Languages
39 Requires:       %{name} = %{epoch}:%{version}-%{release}
40 Requires:       python-devel
41
42 %description devel
43 setuptools is a collection of enhancements to the Python distutils
44 that allow you to more easily build and distribute Python packages,
45 especially ones that have dependencies on other packages.
46
47 This package contains the components necessary to build and install
48 software requiring setuptools.
49
50 %prep
51 %setup -q -n %{module}-%{version}%{subver}
52
53 %build
54 %{__python} ./setup.py build
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 python ./setup.py install \
60         --single-version-externally-managed \
61         --optimize 2 \
62         --root=$RPM_BUILD_ROOT
63
64 rm -f $RPM_BUILD_ROOT%{py_sitescriptdir}/*/*.exe
65
66 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
67 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
68 %py_postclean
69 install site.py $RPM_BUILD_ROOT%{py_sitescriptdir}
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc pkg_resources.txt setuptools.txt
77 %{py_sitescriptdir}/%{module}*
78 %{py_sitescriptdir}/pkg_resources.py[co]
79 %{py_sitescriptdir}/site.py[co]
80 %{py_sitescriptdir}/site.py
81
82 %files devel
83 %defattr(644,root,root,755)
84 %doc EasyInstall.txt README.txt api_tests.txt
85 %attr(755,root,root) %{_bindir}/easy_install*
86 %{py_sitescriptdir}/easy_install.py[co]
This page took 0.047567 seconds and 4 git commands to generate.