]> git.pld-linux.org Git - packages/python-setuptools.git/blob - python-setuptools.spec
- cool trunk version with setup for --single-version-externally-managed
[packages/python-setuptools.git] / python-setuptools.spec
1
2 %define module  setuptools
3 %define snap    20051219
4
5 Summary:        A collection of enhancements to the Python distutils
6 Summary(pl):    Zestaw rozszerzeñ dla pythonowych distutils
7 Name:           python-setuptools
8 Version:        0.6a9
9 Release:        0.%{snap}.1
10 License:        GPL
11 Group:          Development/Languages/Python
12 # Source0:      http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-%{version}.zip
13 Source0:        setuptools-%{snap}.tar.gz
14 # Source0-md5:  594f178498539c14f646bb00fb382a98
15 URL:            http://peak.telecommunity.com/DevCenter/setuptools
16 BuildRequires:  findutils
17 %pyrequires_eq  python
18 BuildRequires:  python-devel
19 BuildRequires:  unzip
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 setuptools is a collection of enhancements to the Python distutils
25 (for Python 2.3.5 and up on most platforms; 64-bit platforms require a
26 minimum of Python 2.4) that allow you to more easily build and
27 distribute Python packages, especially ones that have dependencies on
28 other packages.
29
30 %description -l pl
31 setuptools to zestaw rozszerzeñ do pythonowych distutils (dla Pythona
32 2.3.5 i nowszego na wiêkszo¶ci platform; platformy 64-bitowe wymagaj±
33 co najmniej Pythona 2.4) umo¿liwiaj±cy ³atwiejsze budowanie i
34 rozprowadzanie pakietów Pythona, szczególnie tych maj±cych zale¿no¶ci
35 od innych pakietów.
36
37 %prep
38 %setup  -q -n %{module}
39
40 %build
41 python ./setup.py build
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 python ./setup.py install \
47         --single-version-externally-managed \
48         --optimize 2 \
49         --root=$RPM_BUILD_ROOT
50
51 rm -f $RPM_BUILD_ROOT%{py_sitescriptdir}/*/*.exe
52
53 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
54 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
55 %py_postclean
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc *.txt
63 %attr(755,root,root) %{_bindir}/*
64 %{py_sitescriptdir}/%{module}*
65 %{py_sitescriptdir}/*.py[co]
This page took 0.248953 seconds and 4 git commands to generate.