]> git.pld-linux.org Git - packages/python-setuptools.git/blob - python-setuptools.spec
- up to 0.6c11
[packages/python-setuptools.git] / python-setuptools.spec
1 %define         module  setuptools
2 %define         subver  c11
3 %define         rel     1
4 Summary:        A collection of enhancements to the Python distutils
5 Summary(pl.UTF-8):      Zestaw rozszerzeń dla pythonowych distutils
6 Name:           python-setuptools
7 Version:        0.6
8 Release:        2.%{subver}.%{rel}
9 Epoch:          1
10 License:        GPL
11 Group:          Development/Languages/Python
12 Source0:        http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-%{version}%{subver}.tar.gz
13 # Source0-md5:  7df2a529a074f613b509fb44feefe74e
14 URL:            http://peak.telecommunity.com/DevCenter/setuptools
15 BuildRequires:  python-devel
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 setuptools is a collection of enhancements to the Python distutils
21 that allow you to more easily build and distribute Python packages,
22 especially ones that have dependencies on other packages.
23
24 This package contains the runtime components of setuptools, necessary
25 to execute the software that requires pkg_resources.py.
26
27 %description -l pl.UTF-8
28 setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
29 łatwiejsze budowanie i rozprowadzanie pakietów Pythona, szczególnie
30 tych mających zależności od innych pakietów.
31
32 Ten pakiet zawiera składniki uruchomieniowe setuptools, potrzebne do
33 uruchamiania kodu wymagającego pkg_resources.py.
34
35 %package devel
36 Summary:        Download, install, upgrade, and uninstall Python packages
37 Summary(pl.UTF-8):      Ściąganie, instalacja, uaktualnianie i usuwanie pakietów Pythona
38 Group:          Development/Languages
39 Requires:       %{name} = %{epoch}:%{version}-%{release}
40 Requires:       python-devel
41
42 %description devel
43 setuptools is a collection of enhancements to the Python distutils
44 that allow you to more easily build and distribute Python packages,
45 especially ones that have dependencies on other packages.
46
47 This package contains the components necessary to build and install
48 software requiring setuptools.
49
50 %description devel -l pl.UTF-8
51 setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
52 łatwiejsze budowanie i rozprowadzanie pakietów Pythona, szczególnie
53 tych mających zależności od innych pakietów.
54
55 Ten pakiet zawiera składniki potrzebne do budowania i instalacji
56 oprogramowania wymagającego setuptools.
57
58 %prep
59 %setup -q -n %{module}-%{version}%{subver}
60
61 %build
62 %{__python} ./setup.py build
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__python} ./setup.py install \
68         --single-version-externally-managed \
69         --optimize 2 \
70         --root=$RPM_BUILD_ROOT
71
72 rm -f $RPM_BUILD_ROOT%{py_sitescriptdir}/*/*.exe
73
74 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
75 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
76 %py_postclean
77 install site.py $RPM_BUILD_ROOT%{py_sitescriptdir}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc pkg_resources.txt setuptools.txt
85 %{py_sitescriptdir}/%{module}*
86 %{py_sitescriptdir}/pkg_resources.py[co]
87 %{py_sitescriptdir}/site.py[co]
88 %{py_sitescriptdir}/site.py
89
90 %files devel
91 %defattr(644,root,root,755)
92 %doc EasyInstall.txt README.txt api_tests.txt
93 %attr(755,root,root) %{_bindir}/easy_install*
94 %{py_sitescriptdir}/easy_install.py[co]
This page took 0.059676 seconds and 3 git commands to generate.