]> git.pld-linux.org Git - packages/python-requests.git/blob - python-requests.spec
build python3 module
[packages/python-requests.git] / python-requests.spec
1 # TODO
2 # - bundled external libs? packages/ contains:
3 #   chardet/
4 #   chardet2/
5 #   oauthlib/
6 %define         module  requests
7 Summary:        HTTP library for Python
8 Name:           python-%{module}
9 Version:        0.13.3
10 Release:        2
11 License:        ISC
12 Group:          Development/Languages/Python
13 Source0:        https://github.com/kennethreitz/requests/tarball/v%{version}-11-g52b55cc/%{name}-%{version}.tgz
14 # Source0-md5:  d4e0de0ecfc14128c3a878d9f82328a0
15 URL:            https://github.com/kennethreitz/requests
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.219
18 BuildRequires:  sed >= 4.0
19 Requires:       python-modules
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Requests is an ISC Licensed HTTP library, written in Python, for human
25 beings.
26
27 Most existing Python modules for sending HTTP requests are extremely
28 verbose and cumbersome. Python's builtin urllib2 module provides most
29 of the HTTP capabilities you should need, but the api is thoroughly
30 broken. It requires an enormous amount of work (even method overrides)
31 to perform the simplest of tasks.
32
33 Things shouldn't be this way. Not in Python.
34
35 %package -n python3-requests
36 Summary:        HTTP library, written in Python, for human beings
37 License:        ISC
38 Group:          Development/Languages/Python
39
40 %description -n python3-requests
41 Requests is an ISC Licensed HTTP library, written in Python, for human
42 beings.
43
44 Most existing Python modules for sending HTTP requests are extremely
45 verbose and cumbersome. Python's builtin urllib2 module provides most
46 of the HTTP capabilities you should need, but the api is thoroughly
47 broken. It requires an enormous amount of work (even method overrides)
48 to perform the simplest of tasks.
49
50 Things shouldn't be this way. Not in Python.
51
52 %prep
53 %setup -qc
54 mv *-%{module}-*/* .
55
56 # fix version in module
57 # tarball for 0.13.3 contains 0.13.2:
58 #./HISTORY.rst:0.13.2 (2012-06-28)
59 #./requests/__init__.py:__version__ = '0.13.2'
60 #./requests/__init__.py:__build__ = 0x001302
61 %{__sed} -i -e 's/0\.13\.2/0.13.3/; s/0x001302/0x001302/' requests/__init__.py
62
63 %build
64 ver=$(%{__python} -c "import requests; print requests.__version__")
65 test "$ver" = %{version}
66
67 mkdir py2-egg py3-egg
68 %{__python} setup.py build --build-base py2 egg_info --egg-base py2-egg
69 %{__python3} setup.py build --build-base py3 egg_info --egg-base py3-egg
70
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %{__python} setup.py \
75         build --build-base py2 \
76         egg_info --egg-base py2-egg \
77         install \
78         --skip-build \
79         --optimize=2 \
80         --root=$RPM_BUILD_ROOT
81
82 %{__python3} setup.py  \
83         build --build-base py3 \
84         egg_info --egg-base py3-egg \
85         install \
86         --skip-build \
87         --optimize=2 \
88         --root=$RPM_BUILD_ROOT
89
90
91 %py_postclean
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS.rst README.rst LICENSE  docs
99 %{py_sitescriptdir}/%{module}
100 %if "%{py_ver}" > "2.4"
101 %{py_sitescriptdir}/%{module}-*.egg-info
102 %endif
103
104 %files -n python3-requests
105 %defattr(644,root,root,755)
106 %{py3_sitescriptdir}/%{module}
107 %{py3_sitescriptdir}/%{module}-*.egg-info
This page took 0.0621 seconds and 4 git commands to generate.