]> git.pld-linux.org Git - packages/python3-requests.git/blob - python-requests.spec
f36c1a21f5fea5a960c6a75aa0e6dd540547c9bc
[packages/python3-requests.git] / python-requests.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # test target (tests not included in dist tarball as of 2.13.0)
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define         urllib3ver      1.21.1
8 %define         module          requests
9 %define         egg_name        requests
10 %define         pypi_name       requests
11 Summary:        HTTP library for Python 2
12 Summary(pl.UTF-8):      Biblioteka HTTP dla Pythona 2
13 Name:           python-%{module}
14 Version:        2.18.3
15 Release:        1
16 License:        Apache v2.0
17 Group:          Development/Languages/Python
18 Source0:        https://files.pythonhosted.org/packages/source/r/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
19 # Source0-md5:  c8f60cf816a35c0c3fef0a40d0e407a6
20 Patch0:         system-cert.patch
21 URL:            http://python-requests.org/
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.713
24 %if %{with python2}
25 BuildRequires:  python-modules >= 1:2.6
26 BuildRequires:  python-setuptools
27 %if %{with tests}
28 BuildRequires:  python-certifi >= 2017.4.17
29 BuildRequires:  python-chardet >= 3.0.2
30 BuildRequires:  python-idna >= 2.5
31 BuildRequires:  python-pytest >= 2.8.0
32 BuildRequires:  python-pytest-cov
33 BuildRequires:  python-pytest-httpbin >= 0.0.7
34 BuildRequires:  python-pytest-mock
35 BuildRequires:  python-urllib3 >= %{urllib3ver}
36 %endif
37 %endif
38 %if %{with python3}
39 BuildRequires:  python3-modules >= 1:3.2
40 %if %{with tests}
41 BuildRequires:  python3-certifi >= 2017.4.17
42 BuildRequires:  python3-chardet >= 3.0.2
43 BuildRequires:  python3-idna >= 2.5
44 BuildRequires:  python3-pytest >= 2.8.0
45 BuildRequires:  python3-pytest-cov
46 BuildRequires:  python3-pytest-httpbin >= 0.0.7
47 BuildRequires:  python3-pytest-mock
48 BuildRequires:  python3-urllib3 >= %{urllib3ver}
49 %endif
50 %endif
51 Suggests:       ca-certificates
52 # for python2 only to get SNI working. python3 doesn't need this
53 Requires:       python-ndg-httpsclient
54 Requires:       python-pyOpenSSL >= 0.14
55 Requires:       python-pyasn1
56 Requires:       python-urllib3 >= 1.22-2
57 BuildArch:      noarch
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 Requests is a HTTP library, written in Python, for human beings.
62
63 Most existing Python modules for sending HTTP requests are extremely
64 verbose and cumbersome. Python's builtin urllib2 module provides most
65 of the HTTP capabilities you should need, but the API is thoroughly
66 broken. It requires an enormous amount of work (even method overrides)
67 to perform the simplest of tasks. Things shouldn't be this way. Not in
68 Python.
69
70 This package contains Python 2.x module.
71
72 %description -l pl.UTF-8
73 Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
74
75 Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
76 zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
77 zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
78 wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
79 najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
80
81 Ten pakiet zawiera moduł dla Pythona 2.x.
82
83 %package -n python3-requests
84 Summary:        HTTP library for Python 3
85 Summary(pl.UTF-8):      Biblioteka HTTP dla Pythona 3
86 Group:          Development/Languages/Python
87 Requires:       python3-urllib3 >= 1.22-2
88 Suggests:       ca-certificates
89
90 %description -n python3-requests
91 Requests is a HTTP library, written in Python, for human beings.
92
93 Most existing Python modules for sending HTTP requests are extremely
94 verbose and cumbersome. Python's builtin urllib2 module provides most
95 of the HTTP capabilities you should need, but the api is thoroughly
96 broken. It requires an enormous amount of work (even method overrides)
97 to perform the simplest of tasks. Things shouldn't be this way. Not in
98 Python.
99
100 This package contains Python 3.x module.
101
102 %description -n python3-requests -l pl.UTF-8
103 Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
104
105 Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
106 zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
107 zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
108 wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
109 najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
110
111 Ten pakiet zawiera moduł dla Pythona 3.x.
112
113 %prep
114 %setup -q -n %{module}-%{version}
115 %patch0 -p1
116
117 %build
118 %if %{with python2}
119 %py_build %{?with_tests:test}
120 %endif
121
122 %if %{with python3}
123 %py3_build %{?with_tests:test}
124 %endif
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %if %{with python2}
130 %py_install
131 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
132 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
133 %py_postclean
134 %endif
135
136 %if %{with python3}
137 %py3_install
138 %endif
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %if %{with python2}
144 %files
145 %defattr(644,root,root,755)
146 %doc HISTORY.rst README.rst
147 %{py_sitescriptdir}/%{module}
148 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
149 %endif
150
151 %if %{with python3}
152 %files -n python3-requests
153 %defattr(644,root,root,755)
154 %doc HISTORY.rst README.rst
155 %{py3_sitescriptdir}/%{module}
156 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
157 %endif
This page took 0.029248 seconds and 3 git commands to generate.