]> git.pld-linux.org Git - packages/python-recommonmark.git/blob - python-recommonmark.spec
new (version: 0.5.0 snapshot)
[packages/python-recommonmark.git] / python-recommonmark.spec
1 # TODO:
2 # - package tools
3 #
4 # Conditional build:
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 %define         commit  33b5c2a4ec50d18d3f659aa119d3bd11452327da
9 %define         commit_date 20180907
10
11 Summary:        docutils-compatibility bridge to CommonMark
12 Name:           python-recommonmark
13 Version:        0.5.0
14 Release:        0.%{commit_date}.1
15 License:        MIT
16 Group:          Libraries/Python
17 Source0:        https://github.com/rtfd/recommonmark/archive/%{commit}/recommonmark-%{commit}.tar.gz
18 # Source0-md5:  64cc2f674a76bf740594055a3be32a2d
19 URL:            https://recommonmark.readthedocs.io/en/latest/
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.7
22 BuildRequires:  python-setuptools
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3-modules >= 1:3.3
26 BuildRequires:  python3-setuptools
27 %endif
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.714
30 Requires:       python-modules >= 1:2.7
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 This allows you to write CommonMark inside of Docutils & Sphinx
36 projects.
37
38 %package -n python3-recommonmark
39 Summary:        docutils-compatibility bridge to CommonMark
40 Group:          Libraries/Python
41 Requires:       python3-modules >= 1:3.3
42
43 %description -n python3-recommonmark
44 This allows you to write CommonMark inside of Docutils & Sphinx
45 projects.
46
47 %prep
48 %setup -q -n recommonmark-%{commit}
49
50 %build
51 %if %{with python2}
52 %py_build
53 %endif
54
55 %if %{with python3}
56 %py3_build
57 %endif
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %if %{with python2}
63 %py_install
64
65 %py_postclean
66 %endif
67
68 %if %{with python3}
69 %py3_install
70 %endif
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %if %{with python2}
76 %files
77 %defattr(644,root,root,755)
78 %{py_sitescriptdir}/recommonmark
79 %{py_sitescriptdir}/recommonmark-%{version}.dev0-py*.egg-info
80 %endif
81
82 %if %{with python3}
83 %files -n python3-recommonmark
84 %defattr(644,root,root,755)
85 %{py3_sitescriptdir}/recommonmark
86 %{py3_sitescriptdir}/recommonmark-%{version}.dev0-py*.egg-info
87 %endif
This page took 0.067433 seconds and 4 git commands to generate.