]> git.pld-linux.org Git - packages/python-pycairo.git/blob - python-pycairo.spec
c6c93854672325e947200ace933c72466ce69be8
[packages/python-pycairo.git] / python-pycairo.spec
1 %define         pname pycairo
2 Summary:        Python Cairo bindings
3 Summary:        Dowi±zania Pythona dla Cairo
4 Name:           python-%{pname}
5 Version:        1.2.0
6 Release:        1
7 License:        LGPL v2.1 or MPL v1.1
8 Group:          Libraries
9 Source0:        http://cairographics.org/releases/%{pname}-%{version}.tar.gz
10 # Source0-md5:  ab531e02fda56a9d6b2b65153fda65f6
11 URL:            http://cairographics.org/
12 BuildRequires:  autoconf >= 2.54
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  cairo-devel >= 1.2.0
15 BuildRequires:  gtk+2-devel >= 2:2.2.0
16 BuildRequires:  libsvg-cairo-devel >= 0.1.6
17 BuildRequires:  libtool
18 BuildRequires:  python >= 1:2.3
19 BuildRequires:  python-numpy-devel
20 BuildRequires:  rpm-pythonprov
21 %pyrequires_eq  python-libs
22 Requires:       cairo >= 1.2.0
23 Requires:       libsvg-cairo >= 0.1.6
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Python Cairo bindings.
28
29 %description -l pl
30 Dowi±zania Pythona dla Cairo.
31
32 %package devel
33 Summary:        Development files for pycairo
34 Summary(pl):    Pliki programistyczne pycairo
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Development files for pycairo.
40
41 %description devel -l pl
42 Pliki programistyczne pycairo.
43
44 %package examples
45 Summary:        Example programs using Python Cairo bindings
46 Summary(pl):    Przyk³adowe programy w Pythonie u¿ywaj±ce Cairo
47 Group:          Libraries/Python
48 Requires:       %{name} = %{version}-%{release}
49
50 %description examples
51 Example programs using Python Cairo bindings.
52
53 %description examples -l pl
54 Przyk³adowe programy w Pythonie u¿ywaj±ce Cairo.
55
56 %prep
57 %setup -q -n %{pname}-%{version}
58
59 %build
60 %{__libtoolize}
61 %{__aclocal}
62 %{__autoconf}
63 %{__autoheader}
64 %{__automake}
65 %configure \
66         --without-pygtk
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT%{_examplesdir}
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 cp -ar examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
77
78 rm $RPM_BUILD_ROOT%{py_sitedir}/cairo/*.{la,py}
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS COPYING ChangeLog NEWS NOTES README
89 %dir %{py_sitedir}/cairo
90 %attr(755,root,root) %{py_sitedir}/cairo/*.so
91 %{py_sitedir}/cairo/*.py[oc]
92
93 %files devel
94 %defattr(644,root,root,755)
95 %{_includedir}/pycairo
96 %{_pkgconfigdir}/pycairo.pc
97
98 %files examples
99 %defattr(644,root,root,755)
100 %{_examplesdir}/%{name}-%{version}
This page took 0.047061 seconds and 3 git commands to generate.