]> git.pld-linux.org Git - packages/python-py.git/blob - python-py.spec
- updated to 1.4.32
[packages/python-py.git] / python-py.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # HTML documentation build
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define         module  py
8 Summary:        Library with cross-python path, ini-parsing, io, code, log facilities
9 Summary(pl.UTF-8):      Biblioteka wspierająca obsługę ścieżek, ini, we/wy, kodowania i logowania w wielu Pythonach
10 Name:           python-%{module}
11 Version:        1.4.32
12 Release:        1
13 License:        MIT
14 Group:          Development/Languages/Python
15 #Source0Download: https://pypi.python.org/simple/py
16 Source0:        https://files.pythonhosted.org/packages/source/p/py/py-%{version}.tar.gz
17 # Source0-md5:  68ee0b5867282595d0b410a7f3c03ab3
18 Source1:        http://docs.python.org/objects.inv?/python-objects.inv
19 # Source1-md5:  3d3c0b594b2e91d559418c107d973633
20 Patch0:         %{name}-offline.patch
21 URL:            https://pypi.python.org/pypi/py
22 %if %{with python2}
23 BuildRequires:  python-devel >= 1:2.5
24 BuildRequires:  python-setuptools >= 7.0
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-devel >= 1:3.2
28 BuildRequires:  python3-modules >= 1:3.2
29 BuildRequires:  python3-setuptools >= 7.0
30 %endif
31 BuildRequires:  rpm-pythonprov
32 BuildRequires:  rpmbuild(macros) >= 1.710
33 %{?with_doc:BuildRequires:      sphinx-pdg >= 1.0}
34 %{?with_doc:BuildRequires:      python-devel-tools}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 The py lib is a Python development support library featuring the
39 following tools and modules:
40  - py.path: uniform local and svn path objects
41  - py.apipkg: explicit API control and lazy-importing
42  - py.iniconfig: easy parsing of .ini files
43  - py.code: dynamic code generation and introspection
44
45 %description -l pl.UTF-8
46 Biblioteka py to biblioteka wpierająca tworzenie oprogramowania w
47 Pythonie. Zawiera następujące narzędzia i moduły:
48  - py.path - jednolite obiekty ścieżek lokalnych i svn
49  - py.apipkg - bezpośrednia kontrola API i leniwego importowania
50  - py.iniconfig - łatwa analiza plików .ini
51  - py.code - dynamiczne generowanie kodu i introspekcji
52
53 %package -n python3-py
54 Summary:        Library with cross-python path, ini-parsing, io, code, log facilities
55 Summary(pl.UTF-8):      Biblioteka wspierająca obsługę ścieżek, ini, we/wy, kodowania i logowania w wielu Pythonach
56 Group:          Development/Languages/Python
57
58 %description -n python3-py
59 The py lib is a Python development support library featuring the
60 following tools and modules:
61 - py.path: uniform local and svn path objects
62 - py.apipkg: explicit API control and lazy-importing
63 - py.iniconfig: easy parsing of .ini files
64 - py.code: dynamic code generation and introspection
65
66 %description -n python3-py -l pl.UTF-8
67 Biblioteka py to biblioteka wpierająca tworzenie oprogramowania w
68 Pythonie. Zawiera następujące narzędzia i moduły:
69  - py.path - jednolite obiekty ścieżek lokalnych i svn
70  - py.apipkg - bezpośrednia kontrola API i leniwego importowania
71  - py.iniconfig - łatwa analiza plików .ini
72  - py.code - dynamiczne generowanie kodu i introspekcji
73
74 %package apidocs
75 Summary:        Documentation for Python py library
76 Summary(pl.UTF-8):      Dokumentacja do biblioteki Pythona py
77 Group:          Documentation
78
79 %description apidocs
80 Documentation for Python py library.
81
82 %description apidocs -l pl.UTF-8
83 Dokumentacja do biblioteki Pythona py.
84
85 %prep
86 %setup -q -n %{module}-%{version}
87 %patch0 -p1
88
89 cp -p %{SOURCE1} doc
90
91 %build
92 %if %{with python2}
93 %py_build
94 %endif
95
96 %if %{with python3}
97 %py3_build
98 %endif
99
100 %if %{with doc}
101 PYTHONPATH=$(pwd) \
102 %{__make} -C doc html
103 %endif
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %if %{with python2}
109 %py_install
110
111 %py_postclean
112 %endif
113
114 %if %{with python3}
115 %py3_install
116 %endif
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %if %{with python2}
122 %files
123 %defattr(644,root,root,755)
124 %doc AUTHORS CHANGELOG LICENSE README.rst
125 %{py_sitescriptdir}/%{module}
126 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
127 %endif
128
129 %if %{with python3}
130 %files -n python3-py
131 %defattr(644,root,root,755)
132 %doc AUTHORS CHANGELOG LICENSE README.rst
133 %{py3_sitescriptdir}/%{module}
134 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
135 %endif
136
137 %if %{with doc}
138 %files apidocs
139 %defattr(644,root,root,755)
140 %doc doc/_build/html/{_modules,_static,announce,*.html,*.js}
141 %endif
This page took 0.114387 seconds and 3 git commands to generate.