]> git.pld-linux.org Git - packages/python-pluggy.git/blob - python-pluggy.spec
- release 3 (by relup.sh)
[packages/python-pluggy.git] / python-pluggy.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define         module  pluggy
8 Summary:        Plugin and hook calling mechanisms for Python
9 Summary(pl.UTF-8):      Mechanizmy wtyczek dla Pythona
10 Name:           python-%{module}
11 Version:        0.3.1
12 Release:        3
13 License:        MIT
14 Group:          Libraries/Python
15 Source0:        https://pypi.python.org/packages/1b/a9/6f5f80b75a8d84d21a8a13486fe26a2da9f043f93b464b2e3928be256dc4/pluggy-%{version}.tar.gz
16 # Source0-md5:  ecdd791e309f60668b66fec97c2ee7db
17 URL:            https://pypi.python.org/pypi/pluggy
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules
22 BuildRequires:  python-pytest
23 BuildRequires:  python-setuptools
24 %endif
25 %if %{with python3}
26 BuildRequires:  python3-modules
27 BuildRequires:  python3-pytest
28 BuildRequires:  python3-setuptools
29 %endif
30 Requires:       python-modules
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Plugin manager as used by pytest but stripped of pytest specific
36 details.
37
38 %description -l pl.UTF-8
39 Zarządca wtyczek tak jak używany przez pytest, ale pozbawiony detali
40 specyficznych dla pytest.
41
42 %package -n python3-%{module}
43 Summary:        Plugin and hook calling mechanisms for Python
44 Summary(pl.UTF-8):      Mechanizmy wtyczek dla Pythona
45 Group:          Libraries/Python
46 Requires:       python3-modules
47
48 %description -n python3-%{module}
49 Plugin manager as used by pytest but stripped of pytest specific
50 details.
51
52 %description -n python3-%{module} -l pl.UTF-8
53 Zarządca wtyczek tak jak używany przez pytest, ale pozbawiony detali
54 specyficznych dla pytest.
55
56 %package apidocs
57 Summary:        %{module} API documentation
58 Summary(pl.UTF-8):      Dokumentacja API %{module}
59 Group:          Documentation
60
61 %description apidocs
62 API documentation for %{module}.
63
64 %description apidocs -l pl.UTF-8
65 Dokumentacja API %{module}.
66
67 %prep
68 %setup -q -n %{module}-%{version}
69
70 %build
71 %if %{with python2}
72 %py_build %{?with_tests:test}
73 %endif
74
75 %if %{with python3}
76 %py3_build %{?with_tests:test}
77 %endif
78
79 %if %{with doc}
80 cd docs
81 %{__make} -j1 html
82 rm -rf _build/html/_sources
83 %endif
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 %if %{with python2}
88 %py_install
89 %py_postclean
90 %endif
91
92 %if %{with python3}
93 %py3_install
94 %endif
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %if %{with python2}
100 %files
101 %defattr(644,root,root,755)
102 %doc CHANGELOG README.rst
103 %{py_sitescriptdir}/%{module}.py[co]
104 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
105 %endif
106
107 %if %{with python3}
108 %files -n python3-%{module}
109 %defattr(644,root,root,755)
110 %doc CHANGELOG README.rst
111 %{py3_sitescriptdir}/%{module}.py
112 %{py3_sitescriptdir}/__pycache__/%{module}.*.pyc
113 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
114 %endif
115
116 %if %{with doc}
117 %files apidocs
118 %defattr(644,root,root,755)
119 %doc docs/_build/html/*
120 %endif
This page took 0.031298 seconds and 3 git commands to generate.