]> git.pld-linux.org Git - packages/python-networkx.git/blob - python-networkx.spec
9a6206468c8671e56a2039e409beb4e71a68132d
[packages/python-networkx.git] / python-networkx.spec
1 # TODO:
2 # Add docs
3 %define         module  networkx
4 Summary:        High-productivity software for complex networks
5 Summary(pl.UTF-8):      Efektywne operacje na skompliwkoanych grafach.
6 Name:           python-%{module}
7 Version:        1.7
8 Release:        0.1
9 License:        BSD
10 Group:          Libraries/Python
11 Source0:        https://pypi.python.org/packages/source/n/networkx/%{module}-%{version}.tar.gz#md5=1a73da9d571a206aa40f6ef69254f7b4
12 # Source0-md5:  1a73da9d571a206aa40f6ef69254f7b4
13 URL:            http://networkx.github.io/index.html
14 BuildRequires:  python-distribute
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.219
17 Requires:       python-modules
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Python language software package for the creation, manipulation, and
23 study of the structure, dynamics, and functions of complex networks.
24
25 %description -l pl.UTF-8
26 Pakiet oprogramowania do tworzenia, manipulacji i badania struktury
27 dynamiki i funkcji zlozonych sieci.
28
29 %prep
30 %setup -q -n %{module}-%{version}
31
32 %build
33 %{__python} setup.py build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 %{__python} setup.py install \
38         --skip-build \
39         --optimize=2 \
40         --root=$RPM_BUILD_ROOT
41
42 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
43 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
44
45 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
46 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
47 %py_postclean
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 # %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
55 %{py_sitescriptdir}/%{module}
56 %if "%{py_ver}" > "2.4"
57 %{py_sitescriptdir}/%{module}-*.egg-info
58 %endif
59 %{_examplesdir}/%{name}-%{version}
This page took 0.07906 seconds and 2 git commands to generate.