]> git.pld-linux.org Git - packages/python-libvirt.git/blob - python-libvirt.spec
- finished packaging
[packages/python-libvirt.git] / python-libvirt.spec
1 #
2 # Conditional build:
3 %bcond_without  lxc             # LXC support
4 %bcond_without  qemu            # Qemu support
5
6 # qemu available only on x86 and ppc
7 %ifnarch %{ix86} %{x8664} ppc
8 %undefine       with_qemu
9 %endif
10
11 %define         origname        libvirt-python
12 Summary:        Python bindings to interact with virtualization capabilities
13 Summary(pl.UTF-8):      Wiązania Pythona do współpracy z funkcjami wirtualizacji
14 Name:           python-libvirt
15 Version:        1.2.0
16 Release:        1
17 License:        LGPL v2.1+
18 Group:          Development/Languages/Python
19 Source0:        ftp://ftp.libvirt.org/libvirt/python/%{origname}-%{version}.tar.gz
20 # Source0-md5:  38158e5740be65f17eef9f99ffa5dadf
21 URL:            http://www.libvirt.org/
22 BuildRequires:  libvirt-devel >= 1.0.2
23 BuildRequires:  pkgconfig
24 BuildRequires:  python >= 2
25 BuildRequires:  python-devel >= 2
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.627
28 Requires:       libvirt >= 1.0.2
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Libvirt is a C toolkit to interact with the virtualization
33 capabilities of recent versions of Linux.
34
35 This package contains the Python bindings for the libvirt library.
36
37 %description -l pl.UTF-8
38 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
39 obecnych wersji Linuksa.
40
41 Ten pakiet zawiera wiązania Pythona do biblioteki libvirt.
42
43 %prep
44 %setup -q -n %{origname}-%{version}
45
46 %build
47 CC="%{__cc}" \
48 CFLAGS="%{rpmcflags}" \
49 %{__python} setup.py build
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 %{__python} setup.py install \
54         --root=$RPM_BUILD_ROOT
55
56 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
57 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
58 %py_postclean
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc AUTHORS ChangeLog README NEWS
66 %attr(755,root,root) %{py_sitedir}/libvirtmod.so
67 %{py_sitedir}/libvirt.py[co]
68 %if %{with lxc}
69 %attr(755,root,root) %{py_sitedir}/libvirtmod_lxc.so
70 %{py_sitedir}/libvirt_lxc.py[co]
71 %endif
72 %if %{with qemu}
73 %attr(755,root,root) %{py_sitedir}/libvirtmod_qemu.so
74 %{py_sitedir}/libvirt_qemu.py[co]
75 %endif
76 %{py_sitedir}/libvirt_python-%{version}-py*.egg-info
This page took 0.07854 seconds and 3 git commands to generate.