]> git.pld-linux.org Git - packages/python-jinja2.git/blob - python-jinja2.spec
- release 5
[packages/python-jinja2.git] / python-jinja2.spec
1 %bcond_without  doc
2 %define module jinja2
3 Summary:        Template engine
4 Summary(pl.UTF-8):      Silnik szablonów
5 Name:           python-%{module}
6 Version:        2.3.1
7 Release:        5
8 License:        BSD
9 Group:          Development/Languages/Python
10 Source0:        http://pypi.python.org/packages/source/J/Jinja2/Jinja2-%{version}.tar.gz
11 # Source0-md5:  391c7dd06c62dfe7e30ebaad7af0a401
12 URL:            http://pypi.python.org/pypi/Jinja2
13 BuildRequires:  python-devel
14 BuildRequires:  python-setuptools
15 BuildRequires:  rpm-pythonprov
16 %if %{with doc}
17 BuildRequires:  sphinx-pdg
18 %endif
19 %pyrequires_eq  python-modules
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 A small but fast and easy to use stand-alone template engine written
24 in pure python. Provides a Django inspired non-XML syntax but supports
25 inline expressions and an optional sandboxed environment.
26
27
28 %description -l pl.UTF-8
29 Mały ale szybkie i łatwy w użyciu samodzielny silnik szablonów
30 napisany w czystym Pythonie. Dostarcza podobne do Django, o odmiennej
31 od XMLa składni i kompliowane do kodu Pythona szablony w opcjonalnie
32 ograniczonym środowisku.
33
34 %prep
35 %setup -q -n Jinja2-%{version}
36
37 %build
38 %{__python} setup.py build
39 %if %{with doc}
40 cd docs
41 %{__make} -j1 html
42 rm -rf _build/html/_sources
43 %endif
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__python} setup.py install \
49                 --optimize=2 \
50                 --root=$RPM_BUILD_ROOT
51
52 %py_postclean
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc PKG-INFO AUTHORS CHANGES
60 %if %{with doc}
61 %doc docs/_build/html
62 %endif
63 %{py_sitescriptdir}/%{module}
64 %{py_sitescriptdir}/*Jinja*.egg*
This page took 0.082369 seconds and 3 git commands to generate.