]> git.pld-linux.org Git - packages/python-gnome.git/blob - python-gnome.spec
- fixed gobject version
[packages/python-gnome.git] / python-gnome.spec
1 %define         module          gnome-python
2 %define         pygtk_req       2:2.9.0
3 %define         pyorbit_req     2.14.0
4 Summary:        GNOME bindings for Python
5 Summary(pl):    Wi±zania Pythona do bibliotek GNOME
6 Name:           python-gnome
7 Version:        2.15.1
8 Release:        1
9 License:        GPL v2+/LGPL v2.1+
10 Group:          Libraries/Python
11 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-python/2.15/%{module}-%{version}.tar.bz2
12 # Source0-md5:  f55f0d8a5c66363d4d9893a6481b1b85
13 BuildRequires:  GConf2-devel >= 2.14.0
14 BuildRequires:  automake
15 BuildRequires:  autoconf
16 BuildRequires:  gnome-common >= 2.12.0
17 BuildRequires:  gnome-vfs2-devel >= 2.15.1
18 BuildRequires:  gtk+2-devel >= 2:2.9.2
19 BuildRequires:  libbonobo-devel >= 2.14.0
20 BuildRequires:  libgnomeui-devel >= 2.15.1
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 BuildRequires:  python-devel >= 1:2.3.2
24 BuildRequires:  python-pyorbit-devel >= %{pyorbit_req}
25 BuildRequires:  python-pygtk-devel >= %{pygtk_req}
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.197
28 %pyrequires_eq  python-modules
29 Requires:       %{name}-bonobo = %{version}-%{release}
30 Requires:       %{name}-gconf = %{version}-%{release}
31 Requires:       %{name}-vfs = %{version}-%{release}
32 Requires:       libgnomeui >= 2.15.1
33 Obsoletes:      gnome-python
34 Obsoletes:      gnome-python-nautilus
35 Obsoletes:      python-gnome-nautilus
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define pydefsdir %(pkg-config --variable=defsdir pygtk-2.0)
39
40 %description
41 GNOME bindings for Python.
42
43 %description -l pl
44 Wi±zania Pythona do bibliotek GNOME.
45
46 %package bonobo
47 Summary:        Bonobo bindings for Python
48 Summary(pl):    Wi±zania Pythona do biblioteki Bonobo
49 Group:          Libraries/Python
50 Requires:       python-pygobject >= 2.10.0
51 Requires:       python-pyorbit >= %{pyorbit_req}
52
53 %description bonobo
54 Bonobo bindings for Python.
55
56 %description bonobo -l pl
57 Wi±zania Pythona do biblioteki Bonobo.
58
59 %package bonobo-ui
60 Summary:        Bonobo User Interface bindings for Python
61 Summary(pl):    Wi±zania Pythona do biblioteki interfejsu u¿ytkownika Bonobo
62 Group:          Libraries/Python
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       %{name}-bonobo = %{version}-%{release}
65 Requires:       %{name}-canvas = %{version}-%{release}
66 Requires:       %{name}-gconf = %{version}-%{release}
67 Requires:       %{name}-vfs = %{version}-%{release}
68
69 %description bonobo-ui
70 Bonobo User Interface bindings for Python.
71
72 %description bonobo-ui -l pl
73 Wi±zania Pythona do biblioteki interfejsu u¿ytkownika Bonobo.
74
75 %package canvas
76 Summary:        GNOME Canvas bindings for Python
77 Summary(pl):    Wi±zania Pythona do biblioteki GNOME Canvas
78 Group:          Libraries/Python
79 Requires:       python-pygtk-gtk >= %{pygtk_req}
80
81 %description canvas
82 GNOME Canvas bindings for Python.
83
84 %description canvas -l pl
85 Wi±zania Pythona do biblioteki GNOME Canvas.
86
87 %package gconf
88 Summary:        GConf bindings for Python
89 Summary(pl):    Wi±zania Pythona do biblioteki GConf
90 Group:          Libraries/Python
91 Requires:       python-pygobject >= 2.10.0
92 Requires:       python-pyorbit >= %{pyorbit_req}
93
94 %description gconf
95 GConf bindings for Python.
96
97 %description gconf -l pl
98 Wi±zania Pythona do biblioteki GConf.
99
100 %package ui
101 Summary:        GNOME User Interface bindings for Python
102 Summary(pl):    Wi±zania Pythona do biblioteki interfejsu u¿ytkownika GNOME
103 Group:          Libraries/Python
104 Requires:       %{name}-bonobo-ui = %{version}-%{release}
105
106 %description ui
107 GNOME User Interface bindings for Python.
108
109 %description ui -l pl
110 Wi±zania Pythona do biblioteki interfejsu u¿ytkownika GNOME.
111
112 %package vfs
113 Summary:        GNOME VFS bindings for Python
114 Summary(pl):    Wi±zania Pythona do biblioteki GNOME VFS
115 Group:          Libraries/Python
116 Requires:       %{name}-bonobo = %{version}-%{release}
117 Requires:       %{name}-gconf = %{version}-%{release}
118
119 %description vfs
120 GNOME VFS bindings for Python.
121
122 %description vfs -l pl
123 Wi±zania Pythona do biblioteki GNOME VFS.
124
125 %package devel
126 Summary:        Development files for GNOME bindings for Python
127 Summary(pl):    Pliki programistyczne wi±zañ Pythona do GNOME
128 Group:          Libraries/Python
129 Requires:       %{name}-ui = %{version}-%{release}
130 Requires:       python-pygtk-devel >= %{pygtk_req}
131
132 %description devel
133 Development files for GNOME bindings for Python.
134
135 %description devel -l pl
136 Pliki programistyczne wi±zañ Pythona do GNOME.
137
138 %package examples
139 Summary:        Example programs for python-gnome
140 Summary(pl):    Przyk³adowe programy do python-gnome
141 Group:          Libraries/Python
142 Requires:       %{name}-devel = %{version}-%{release}
143
144 %description examples
145 This package contains example programs for python-gnome.
146
147 %description examples -l pl
148 Ten pakiet zawiera przyk³adowe programy dla python-gnome.
149
150 %prep
151 %setup -q -n %{module}-%{version}
152
153 %build
154 %{__libtoolize}
155 %{__aclocal}
156 %{__autoconf}
157 %{__autoheader}
158 %{__automake}
159 %configure
160 %{__make}
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164
165 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
166
167 %{__make} install \
168         DESTDIR=$RPM_BUILD_ROOT
169
170 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
171
172 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/{*.la,*/{*.la,*.py}}
173 rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/*.la
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %post   -p /sbin/ldconfig
179 %postun -p /sbin/ldconfig
180
181 %files
182 %defattr(644,root,root,755)
183 %doc ChangeLog AUTHORS
184 %dir %{py_sitedir}/gtk-2.0/gnome
185 %{py_sitedir}/gtk-2.0/gnome/__init__.py?
186 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnome/_gnome*.so
187 %dir %{_datadir}/pygtk/2.0/argtypes
188
189 %files devel
190 %defattr(644,root,root,755)
191 %{_includedir}/%{module}-2.0
192 %{pydefsdir}/*
193 %{_pkgconfigdir}/*
194
195 %files examples
196 %defattr(644,root,root,755)
197 %{_examplesdir}/%{name}-%{version}
198
199 %files bonobo
200 %defattr(644,root,root,755)
201 %dir %{py_sitedir}/gtk-2.0/bonobo
202 %{py_sitedir}/gtk-2.0/bonobo/__init__.py?
203 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/_bonobo*.so
204 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/activation*.so
205 %{_datadir}/pygtk/2.0/argtypes/bonobo-arg-types.py*
206
207 %files bonobo-ui
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/ui*.so
210
211 %files canvas
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomecanvas*.so
214 %{py_sitedir}/gtk-2.0/gnome/canvas.py[co]
215
216 %files gconf
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gconf*.so
219 %{_datadir}/pygtk/2.0/argtypes/gconf-arg-types.py*
220
221 %files ui
222 %defattr(644,root,root,755)
223 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnome/ui*.so
224
225 %files vfs
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomevfs*.so
228 %attr(755,root,root) %{_libdir}/gnome-vfs-2.0/modules/*.so
229 %{py_sitedir}/gtk-2.0/gnome/vfs.py[co]
This page took 0.048958 seconds and 3 git commands to generate.