]> git.pld-linux.org Git - packages/python-gnome.git/blob - python-gnome.spec
- merged from DEVEL
[packages/python-gnome.git] / python-gnome.spec
1 %define         module          gnome-python
2 %define         pygtk_req       2:2.6.0
3 %define         pyorbit_req     2.0.1
4 Summary:        GNOME bindings for Python
5 Summary(pl):    Wi±zania Pythona do bibliotek GNOME
6 Name:           python-gnome
7 Version:        2.10.0
8 Release:        1
9 License:        GPL v2+/LGPL v2.1+
10 Group:          Libraries/Python
11 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-python/2.10/%{module}-%{version}.tar.bz2
12 # Source0-md5:  018c210bc5e2e9be36791bede9dbdc73
13 BuildRequires:  GConf2-devel >= 2.9.90
14 BuildRequires:  automake
15 BuildRequires:  autoconf
16 BuildRequires:  gnome-common >= 2.8.0
17 BuildRequires:  gnome-vfs2-devel >= 2.9.90
18 BuildRequires:  gtk+2-devel >= 2:2.6.2
19 BuildRequires:  libbonobo-devel >= 2.8.1
20 BuildRequires:  libgnomeui-devel >= 2.9.1
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 BuildRequires:  python-devel >= 1:2.3.2
24 BuildRequires:  python-pyorbit-devel >= %{pyorbit_req}
25 BuildRequires:  python-pygtk-devel >= %{pygtk_req}
26 %pyrequires_eq  python-modules
27 Requires:       python-pygtk-gobject >= %{pygtk_req}
28 Obsoletes:      gnome-python
29 Obsoletes:      gnome-python-nautilus
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define pydefsdir %(pkg-config --variable=defsdir pygtk-2.0)
33
34 %description
35 GNOME bindings for Python.
36
37 %description -l pl
38 Wi±zania Pythona do bibliotek GNOME.
39
40 %package bonobo
41 Summary:        Bonobo bindings for Python
42 Summary(pl):    Wi±zania Pythona do biblioteki Bonobo
43 Group:          Libraries/Python
44 Requires:       python-pygtk-gobject >= %{pygtk_req}
45 Requires:       python-pyorbit >= %{pyorbit_req}
46
47 %description bonobo
48 Bonobo bindings for Python.
49
50 %description bonobo -l pl
51 Wi±zania Pythona do biblioteki Bonobo.
52
53 %package bonobo-ui
54 Summary:        Bonobo User Interface bindings for Python
55 Summary(pl):    Wi±zania Pythona do biblioteki interfejsu u¿ytkownika Bonobo
56 Group:          Libraries/Python
57 Requires:       %{name}-bonobo = %{version}-%{release}
58 Requires:       %{name}-canvas = %{version}-%{release}
59
60 %description bonobo-ui
61 Bonobo User Interface bindings for Python.
62
63 %description bonobo-ui -l pl
64 Wi±zania Pythona do biblioteki interfejsu u¿ytkownika Bonobo.
65
66 %package canvas
67 Summary:        GNOME Canvas bindings for Python
68 Summary(pl):    Wi±zania Pythona do biblioteki GNOME Canvas
69 Group:          Libraries/Python
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       python-pygtk-gtk >= %{pygtk_req}
72
73 %description canvas
74 GNOME Canvas bindings for Python.
75
76 %description canvas -l pl
77 Wi±zania Pythona do biblioteki GNOME Canvas.
78
79 %package gconf
80 Summary:        GConf bindings for Python
81 Summary(pl):    Wi±zania Pythona do biblioteki GConf
82 Group:          Libraries/Python
83 Requires:       python-pygtk-gobject >= %{pygtk_req}
84
85 %description gconf
86 GConf bindings for Python.
87
88 %description gconf -l pl
89 Wi±zania Pythona do biblioteki GConf.
90
91 %package ui
92 Summary:        GNOME User Interface bindings for Python
93 Summary(pl):    Wi±zania Pythona do biblioteki interfejsu u¿ytkownika GNOME
94 Group:          Libraries/Python
95 Requires:       %{name}-bonobo-ui = %{version}-%{release}
96
97 %description ui
98 GNOME User Interface bindings for Python.
99
100 %description ui -l pl
101 Wi±zania Pythona do biblioteki interfejsu u¿ytkownika GNOME.
102
103 %package vfs
104 Summary:        GNOME VFS bindings for Python
105 Summary(pl):    Wi±zania Pythona do biblioteki GNOME VFS
106 Group:          Libraries/Python
107 Requires:       %{name} = %{version}-%{release}
108
109 %description vfs
110 GNOME VFS bindings for Python.
111
112 %description vfs -l pl
113 Wi±zania Pythona do biblioteki GNOME VFS.
114
115 %package devel
116 Summary:        Development files for GNOME bindings for Python
117 Summary(pl):    Pliki programistyczne wi±zañ Pythona do GNOME
118 Group:          Libraries/Python
119 Requires:       %{name}-bonobo = %{version}-%{release}
120 Requires:       %{name}-bonobo-ui = %{version}-%{release}
121 Requires:       %{name}-canvas = %{version}-%{release}
122 Requires:       %{name}-gconf = %{version}-%{release}
123 Requires:       %{name}-ui = %{version}-%{release}
124 Requires:       %{name}-vfs = %{version}-%{release}
125 Requires:       python-pygtk-devel >= %{pygtk_req}
126
127 %description devel
128 Development files for GNOME bindings for Python.
129
130 %description devel -l pl
131 Pliki programistyczne wi±zañ Pythona do GNOME.
132
133 %prep
134 %setup -q -n %{module}-%{version}
135
136 %build
137 %{__libtoolize}
138 %{__aclocal}
139 %{__autoconf}
140 %{__autoheader}
141 %{__automake}
142 %configure
143 %{__make}
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147
148 %{__make} install \
149         DESTDIR=$RPM_BUILD_ROOT
150
151 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/{*.la,*/{*.la,*.py}}
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post   -p /sbin/ldconfig
157 %postun -p /sbin/ldconfig
158
159 %files
160 %defattr(644,root,root,755)
161 %doc ChangeLog AUTHORS
162 %dir %{py_sitedir}/gtk-2.0/gnome
163 %{py_sitedir}/gtk-2.0/gnome/__init__.py?
164 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnome/_gnome*.so
165 %dir %{_datadir}/pygtk/2.0/argtypes
166
167 %files bonobo
168 %defattr(644,root,root,755)
169 %dir %{py_sitedir}/gtk-2.0/bonobo
170 %{py_sitedir}/gtk-2.0/bonobo/__init__.py?
171 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/_bonobo*.so
172 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/activation*.so
173 %{_datadir}/pygtk/2.0/argtypes/bonobo-arg-types.py*
174
175 %files bonobo-ui
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/ui*.so
178
179 %files canvas
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomecanvas*.so
182 %{py_sitedir}/gtk-2.0/gnome/canvas.py[co]
183
184 %files gconf
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gconf*.so
187 %{_datadir}/pygtk/2.0/argtypes/gconf-arg-types.py*
188
189 %files ui
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnome/ui*.so
192
193 %files vfs
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomevfs*.so
196 %{py_sitedir}/gtk-2.0/gnome/vfs.py[co]
197
198 %files devel
199 %defattr(644,root,root,755)
200 %{pydefsdir}/*
201 %{_pkgconfigdir}/*
This page took 0.072793 seconds and 3 git commands to generate.