]> git.pld-linux.org Git - packages/python-gnome.git/blob - python-gnome.spec
- examples subpackage, rel. 2
[packages/python-gnome.git] / python-gnome.spec
1 %define         module          gnome-python
2 %define         pygtk_req       2:2.8.0
3 %define         pyorbit_req     2.0.1
4 Summary:        GNOME bindings for Python
5 Summary(pl):    Wi±zania Pythona do bibliotek GNOME
6 Name:           python-gnome
7 Version:        2.12.1
8 Release:        2
9 License:        GPL v2+/LGPL v2.1+
10 Group:          Libraries/Python
11 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-python/2.12/%{module}-%{version}.tar.bz2
12 # Source0-md5:  7f772bd8a209c1f1f42d9e52e12aed5b
13 BuildRequires:  GConf2-devel >= 2.9.90
14 BuildRequires:  automake
15 BuildRequires:  autoconf
16 BuildRequires:  gnome-common >= 2.8.0
17 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
18 BuildRequires:  gtk+2-devel >= 2:2.8.0
19 BuildRequires:  libbonobo-devel >= 2.8.1
20 BuildRequires:  libgnomeui-devel >= 2.10.0-2
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 BuildRequires:  python-devel >= 1:2.3.2
24 BuildRequires:  python-pyorbit-devel >= %{pyorbit_req}
25 BuildRequires:  python-pygtk-devel >= %{pygtk_req}
26 BuildRequires:  rpmbuild(macros) >= 1.197
27 %pyrequires_eq  python-modules
28 Requires:       python-pygtk-gobject >= %{pygtk_req}
29 Obsoletes:      gnome-python
30 Obsoletes:      gnome-python-nautilus
31 Obsoletes:      python-gnome-nautilus
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define pydefsdir %(pkg-config --variable=defsdir pygtk-2.0)
35
36 %description
37 GNOME bindings for Python.
38
39 %description -l pl
40 Wi±zania Pythona do bibliotek GNOME.
41
42 %package bonobo
43 Summary:        Bonobo bindings for Python
44 Summary(pl):    Wi±zania Pythona do biblioteki Bonobo
45 Group:          Libraries/Python
46 Requires:       python-pygtk-gobject >= %{pygtk_req}
47 Requires:       python-pyorbit >= %{pyorbit_req}
48
49 %description bonobo
50 Bonobo bindings for Python.
51
52 %description bonobo -l pl
53 Wi±zania Pythona do biblioteki Bonobo.
54
55 %package bonobo-ui
56 Summary:        Bonobo User Interface bindings for Python
57 Summary(pl):    Wi±zania Pythona do biblioteki interfejsu u¿ytkownika Bonobo
58 Group:          Libraries/Python
59 Requires:       %{name}-bonobo = %{version}-%{release}
60 Requires:       %{name}-canvas = %{version}-%{release}
61
62 %description bonobo-ui
63 Bonobo User Interface bindings for Python.
64
65 %description bonobo-ui -l pl
66 Wi±zania Pythona do biblioteki interfejsu u¿ytkownika Bonobo.
67
68 %package canvas
69 Summary:        GNOME Canvas bindings for Python
70 Summary(pl):    Wi±zania Pythona do biblioteki GNOME Canvas
71 Group:          Libraries/Python
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       python-pygtk-gtk >= %{pygtk_req}
74
75 %description canvas
76 GNOME Canvas bindings for Python.
77
78 %description canvas -l pl
79 Wi±zania Pythona do biblioteki GNOME Canvas.
80
81 %package gconf
82 Summary:        GConf bindings for Python
83 Summary(pl):    Wi±zania Pythona do biblioteki GConf
84 Group:          Libraries/Python
85 Requires:       python-pygtk-gobject >= %{pygtk_req}
86
87 %description gconf
88 GConf bindings for Python.
89
90 %description gconf -l pl
91 Wi±zania Pythona do biblioteki GConf.
92
93 %package ui
94 Summary:        GNOME User Interface bindings for Python
95 Summary(pl):    Wi±zania Pythona do biblioteki interfejsu u¿ytkownika GNOME
96 Group:          Libraries/Python
97 Requires:       %{name}-bonobo-ui = %{version}-%{release}
98
99 %description ui
100 GNOME User Interface bindings for Python.
101
102 %description ui -l pl
103 Wi±zania Pythona do biblioteki interfejsu u¿ytkownika GNOME.
104
105 %package vfs
106 Summary:        GNOME VFS bindings for Python
107 Summary(pl):    Wi±zania Pythona do biblioteki GNOME VFS
108 Group:          Libraries/Python
109 Requires:       %{name} = %{version}-%{release}
110 Requires:       gnome-vfs2
111
112 %description vfs
113 GNOME VFS bindings for Python.
114
115 %description vfs -l pl
116 Wi±zania Pythona do biblioteki GNOME VFS.
117
118 %package devel
119 Summary:        Development files for GNOME bindings for Python
120 Summary(pl):    Pliki programistyczne wi±zañ Pythona do GNOME
121 Group:          Libraries/Python
122 Requires:       %{name}-bonobo = %{version}-%{release}
123 Requires:       %{name}-bonobo-ui = %{version}-%{release}
124 Requires:       %{name}-canvas = %{version}-%{release}
125 Requires:       %{name}-gconf = %{version}-%{release}
126 Requires:       %{name}-ui = %{version}-%{release}
127 Requires:       %{name}-vfs = %{version}-%{release}
128 Requires:       python-pygtk-devel >= %{pygtk_req}
129
130 %description devel
131 Development files for GNOME bindings for Python.
132
133 %description devel -l pl
134 Pliki programistyczne wi±zañ Pythona do GNOME.
135
136 %package examples
137 Summary:        Example programs for python-gnome
138 Summary(pl):    Przyk³adowe programy do python-gnome
139 Group:          Libraries/Python
140 Requires:       %{name}-devel = %{version}-%{release}
141
142 %description examples
143 This package contains example programs for python-gnome.
144
145 %description -l pl examples
146 Ten pakiet zawiera przyk³adowe programy dla python-gnome.
147
148 %prep
149 %setup -q -n %{module}-%{version}
150
151 %build
152 %{__libtoolize}
153 %{__aclocal}
154 %{__autoconf}
155 %{__autoheader}
156 %{__automake}
157 %configure
158 %{__make}
159
160 %install
161 rm -rf $RPM_BUILD_ROOT
162
163 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
164
165 %{__make} install \
166         DESTDIR=$RPM_BUILD_ROOT
167
168 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
169
170 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/{*.la,*/{*.la,*.py}}
171 rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/*.la
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post   -p /sbin/ldconfig
177 %postun -p /sbin/ldconfig
178
179 %files
180 %defattr(644,root,root,755)
181 %doc ChangeLog AUTHORS
182 %dir %{py_sitedir}/gtk-2.0/gnome
183 %{py_sitedir}/gtk-2.0/gnome/__init__.py?
184 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnome/_gnome*.so
185 %dir %{_datadir}/pygtk/2.0/argtypes
186
187 %files devel
188 %defattr(644,root,root,755)
189 %{_includedir}/%{module}-2.0
190 %{pydefsdir}/*
191 %{_pkgconfigdir}/*
192
193 %files examples
194 %defattr(644,root,root,755)
195 %{_examplesdir}/%{name}-%{version}
196
197 %files bonobo
198 %defattr(644,root,root,755)
199 %dir %{py_sitedir}/gtk-2.0/bonobo
200 %{py_sitedir}/gtk-2.0/bonobo/__init__.py?
201 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/_bonobo*.so
202 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/activation*.so
203 %{_datadir}/pygtk/2.0/argtypes/bonobo-arg-types.py*
204
205 %files bonobo-ui
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/ui*.so
208
209 %files canvas
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomecanvas*.so
212 %{py_sitedir}/gtk-2.0/gnome/canvas.py[co]
213
214 %files gconf
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gconf*.so
217 %{_datadir}/pygtk/2.0/argtypes/gconf-arg-types.py*
218
219 %files ui
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnome/ui*.so
222
223 %files vfs
224 %defattr(644,root,root,755)
225 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomevfs*.so
226 %attr(755,root,root) %{_libdir}/gnome-vfs-2.0/modules/*.so
227 %{py_sitedir}/gtk-2.0/gnome/vfs.py[co]
This page took 0.038725 seconds and 3 git commands to generate.