]> git.pld-linux.org Git - packages/python-gnome.git/blob - python-gnome.spec
- 2.12.2
[packages/python-gnome.git] / python-gnome.spec
1 %define         module          gnome-python
2 %define         pygtk_req       2:2.8.0
3 %define         pyorbit_req     2.0.1
4 Summary:        GNOME bindings for Python
5 Summary(pl):    Wi±zania Pythona do bibliotek GNOME
6 Name:           python-gnome
7 Version:        2.12.2
8 Release:        1
9 License:        GPL v2+/LGPL v2.1+
10 Group:          Libraries/Python
11 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-python/2.12/%{module}-%{version}.tar.bz2
12 # Source0-md5:  411e5bbeb5f777ee8774be4d21499b11
13 BuildRequires:  GConf2-devel >= 2.9.90
14 BuildRequires:  automake
15 BuildRequires:  autoconf
16 BuildRequires:  gnome-common >= 2.8.0
17 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
18 BuildRequires:  gtk+2-devel >= 2:2.8.0
19 BuildRequires:  libbonobo-devel >= 2.8.1
20 BuildRequires:  libgnomeui-devel >= 2.10.0-2
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 BuildRequires:  python-devel >= 1:2.3.2
24 BuildRequires:  python-pyorbit-devel >= %{pyorbit_req}
25 BuildRequires:  python-pygtk-devel >= %{pygtk_req}
26 BuildRequires:  rpmbuild(macros) >= 1.197
27 %pyrequires_eq  python-modules
28 Requires:       %{name}-bonobo = %{version}-%{release}
29 Requires:       %{name}-gconf = %{version}-%{release}
30 Requires:       %{name}-vfs = %{version}-%{release}
31 Obsoletes:      gnome-python
32 Obsoletes:      gnome-python-nautilus
33 Obsoletes:      python-gnome-nautilus
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define pydefsdir %(pkg-config --variable=defsdir pygtk-2.0)
37
38 %description
39 GNOME bindings for Python.
40
41 %description -l pl
42 Wi±zania Pythona do bibliotek GNOME.
43
44 %package bonobo
45 Summary:        Bonobo bindings for Python
46 Summary(pl):    Wi±zania Pythona do biblioteki Bonobo
47 Group:          Libraries/Python
48 Requires:       python-pygtk-gobject >= %{pygtk_req}
49 Requires:       python-pyorbit >= %{pyorbit_req}
50
51 %description bonobo
52 Bonobo bindings for Python.
53
54 %description bonobo -l pl
55 Wi±zania Pythona do biblioteki Bonobo.
56
57 %package bonobo-ui
58 Summary:        Bonobo User Interface bindings for Python
59 Summary(pl):    Wi±zania Pythona do biblioteki interfejsu u¿ytkownika Bonobo
60 Group:          Libraries/Python
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       %{name}-bonobo = %{version}-%{release}
63 Requires:       %{name}-canvas = %{version}-%{release}
64 Requires:       %{name}-gconf = %{version}-%{release}
65
66 %description bonobo-ui
67 Bonobo User Interface bindings for Python.
68
69 %description bonobo-ui -l pl
70 Wi±zania Pythona do biblioteki interfejsu u¿ytkownika Bonobo.
71
72 %package canvas
73 Summary:        GNOME Canvas bindings for Python
74 Summary(pl):    Wi±zania Pythona do biblioteki GNOME Canvas
75 Group:          Libraries/Python
76 Requires:       python-pygtk-gtk >= %{pygtk_req}
77
78 %description canvas
79 GNOME Canvas bindings for Python.
80
81 %description canvas -l pl
82 Wi±zania Pythona do biblioteki GNOME Canvas.
83
84 %package gconf
85 Summary:        GConf bindings for Python
86 Summary(pl):    Wi±zania Pythona do biblioteki GConf
87 Group:          Libraries/Python
88 Requires:       python-pygtk-gobject >= %{pygtk_req}
89 Requires:       python-pyorbit >= %{pyorbit_req}
90
91 %description gconf
92 GConf bindings for Python.
93
94 %description gconf -l pl
95 Wi±zania Pythona do biblioteki GConf.
96
97 %package ui
98 Summary:        GNOME User Interface bindings for Python
99 Summary(pl):    Wi±zania Pythona do biblioteki interfejsu u¿ytkownika GNOME
100 Group:          Libraries/Python
101 Requires:       %{name}-bonobo-ui = %{version}-%{release}
102
103 %description ui
104 GNOME User Interface bindings for Python.
105
106 %description ui -l pl
107 Wi±zania Pythona do biblioteki interfejsu u¿ytkownika GNOME.
108
109 %package vfs
110 Summary:        GNOME VFS bindings for Python
111 Summary(pl):    Wi±zania Pythona do biblioteki GNOME VFS
112 Group:          Libraries/Python
113 Requires:       %{name}-bonobo = %{version}-%{release}
114 Requires:       %{name}-gconf = %{version}-%{release}
115 Requires:       gnome-vfs2
116
117 %description vfs
118 GNOME VFS bindings for Python.
119
120 %description vfs -l pl
121 Wi±zania Pythona do biblioteki GNOME VFS.
122
123 %package devel
124 Summary:        Development files for GNOME bindings for Python
125 Summary(pl):    Pliki programistyczne wi±zañ Pythona do GNOME
126 Group:          Libraries/Python
127 Requires:       %{name}-ui = %{version}-%{release}
128 Requires:       python-pygtk-devel >= %{pygtk_req}
129
130 %description devel
131 Development files for GNOME bindings for Python.
132
133 %description devel -l pl
134 Pliki programistyczne wi±zañ Pythona do GNOME.
135
136 %package examples
137 Summary:        Example programs for python-gnome
138 Summary(pl):    Przyk³adowe programy do python-gnome
139 Group:          Libraries/Python
140 Requires:       %{name}-devel = %{version}-%{release}
141
142 %description examples
143 This package contains example programs for python-gnome.
144
145 %description -l pl examples
146 Ten pakiet zawiera przyk³adowe programy dla python-gnome.
147
148 %prep
149 %setup -q -n %{module}-%{version}
150
151 %build
152 %{__libtoolize}
153 %{__aclocal}
154 %{__autoconf}
155 %{__autoheader}
156 %{__automake}
157 %configure
158 %{__make}
159
160 %install
161 rm -rf $RPM_BUILD_ROOT
162
163 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
164
165 %{__make} install \
166         DESTDIR=$RPM_BUILD_ROOT
167
168 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
169
170 rm -f $RPM_BUILD_ROOT%{py_sitedir}/gtk-2.0/{*.la,*/{*.la,*.py}}
171 rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/*.la
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post   -p /sbin/ldconfig
177 %postun -p /sbin/ldconfig
178
179 %files
180 %defattr(644,root,root,755)
181 %doc ChangeLog AUTHORS
182 %dir %{py_sitedir}/gtk-2.0/gnome
183 %{py_sitedir}/gtk-2.0/gnome/__init__.py?
184 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnome/_gnome*.so
185 %dir %{_datadir}/pygtk/2.0/argtypes
186
187 %files devel
188 %defattr(644,root,root,755)
189 %{_includedir}/%{module}-2.0
190 %{pydefsdir}/*
191 %{_pkgconfigdir}/*
192
193 %files examples
194 %defattr(644,root,root,755)
195 %{_examplesdir}/%{name}-%{version}
196
197 %files bonobo
198 %defattr(644,root,root,755)
199 %dir %{py_sitedir}/gtk-2.0/bonobo
200 %{py_sitedir}/gtk-2.0/bonobo/__init__.py?
201 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/_bonobo*.so
202 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/activation*.so
203 %{_datadir}/pygtk/2.0/argtypes/bonobo-arg-types.py*
204
205 %files bonobo-ui
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/ui*.so
208
209 %files canvas
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomecanvas*.so
212 %{py_sitedir}/gtk-2.0/gnome/canvas.py[co]
213
214 %files gconf
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gconf*.so
217 %{_datadir}/pygtk/2.0/argtypes/gconf-arg-types.py*
218
219 %files ui
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnome/ui*.so
222
223 %files vfs
224 %defattr(644,root,root,755)
225 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomevfs*.so
226 %attr(755,root,root) %{_libdir}/gnome-vfs-2.0/modules/*.so
227 %{py_sitedir}/gtk-2.0/gnome/vfs.py[co]
This page took 0.054102 seconds and 3 git commands to generate.