]> git.pld-linux.org Git - packages/python-gnome.git/blob - python-gnome.spec
- removed unnecessary ldconfig, updated source URL
[packages/python-gnome.git] / python-gnome.spec
1 %define         module          gnome-python
2 %define         pygobject_ver   2.17.0
3 %define         pygtk_ver       2:2.16.0
4 %define         pyorbit_ver     2.14.2
5 Summary:        GNOME bindings for Python
6 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek GNOME
7 Name:           python-gnome
8 Version:        2.28.1
9 Release:        12
10 License:        LGPL v2.1+
11 Group:          Libraries/Python
12 Source0:        https://download.gnome.org/sources/gnome-python/2.28/%{module}-%{version}.tar.bz2
13 # Source0-md5:  a17ad952813ed86f520de8e07194a2bf
14 URL:            https://www.gnome.org/
15 BuildRequires:  GConf2-devel >= 2.22.0
16 BuildRequires:  glib2-devel >= 1:2.16.0
17 BuildRequires:  gnome-common >= 2.20.0
18 BuildRequires:  gnome-vfs2-devel >= 2.22.0
19 BuildRequires:  gtk+2-devel >= 2:2.12.0
20 BuildRequires:  libbonobo-devel >= 2.22.0
21 BuildRequires:  libbonoboui-devel >= 2.22.0
22 BuildRequires:  libgnome-devel >= 2.22.0
23 BuildRequires:  libgnomecanvas-devel >= 2.8.0
24 BuildRequires:  libgnomeui-devel >= 2.22.0
25 BuildRequires:  libxslt-progs
26 BuildRequires:  pkgconfig
27 BuildRequires:  popt-devel
28 BuildRequires:  python-devel >= 1:2.3.2
29 BuildRequires:  python-pygobject-devel >= %{pygobject_ver}
30 BuildRequires:  python-pygtk-devel >= %{pygtk_ver}
31 BuildRequires:  python-pyorbit-devel >= %{pyorbit_ver}
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.219
34 BuildRequires:  sed >= 4.0
35 Requires:       %{name}-common = %{version}-%{release}
36 Requires:       libgnome-libs >= 2.22.0
37 Requires:       python-pygobject >= %{pygobject_ver}
38 Obsoletes:      gnome-python
39 Obsoletes:      gnome-python-nautilus
40 Obsoletes:      python-gnome-nautilus
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define pydefsdir %(pkg-config --variable=defsdir pygtk-2.0)
44
45 %description
46 GNOME bindings for Python.
47
48 %description -l pl.UTF-8
49 Wiązania Pythona do bibliotek GNOME.
50
51 %package bonobo
52 Summary:        Bonobo bindings for Python
53 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Bonobo
54 Group:          Libraries/Python
55 Requires:       libbonobo >= 2.22.0
56 Requires:       python-pygobject >= %{pygobject_ver}
57 Requires:       python-pyorbit >= %{pyorbit_ver}
58
59 %description bonobo
60 Bonobo bindings for Python.
61
62 %description bonobo -l pl.UTF-8
63 Wiązania Pythona do biblioteki Bonobo.
64
65 %package bonobo-ui
66 Summary:        Bonobo User Interface bindings for Python
67 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki interfejsu użytkownika Bonobo
68 Group:          Libraries/Python
69 Requires:       %{name}-bonobo = %{version}-%{release}
70 Requires:       %{name}-canvas = %{version}-%{release}
71 Requires:       libbonoboui >= 2.22.0
72 Requires:       libgnome-libs >= 2.22.0
73 Requires:       python-pygobject >= %{pygobject_ver}
74 Requires:       python-pygtk-gtk >= %{pygtk_ver}
75
76 %description bonobo-ui
77 Bonobo User Interface bindings for Python.
78
79 %description bonobo-ui -l pl.UTF-8
80 Wiązania Pythona do biblioteki interfejsu użytkownika Bonobo.
81
82 %package canvas
83 Summary:        GNOME Canvas bindings for Python
84 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GNOME Canvas
85 Group:          Libraries/Python
86 Requires:       %{name}-common = %{version}-%{release}
87 Requires:       libgnomecanvas >= 2.8.0
88 Requires:       python-pygobject >= %{pygobject_ver}
89 Requires:       python-pygtk-gtk >= %{pygtk_ver}
90
91 %description canvas
92 GNOME Canvas bindings for Python.
93
94 %description canvas -l pl.UTF-8
95 Wiązania Pythona do biblioteki GNOME Canvas.
96
97 %package gconf
98 Summary:        GConf bindings for Python
99 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GConf
100 Group:          Libraries/Python
101 Requires:       %{name}-common = %{version}-%{release}
102 Requires:       GConf2-libs >= 2.22.0
103 Requires:       python-pygobject >= %{pygobject_ver}
104
105 %description gconf
106 GConf bindings for Python.
107
108 %description gconf -l pl.UTF-8
109 Wiązania Pythona do biblioteki GConf.
110
111 %package ui
112 Summary:        GNOME User Interface bindings for Python
113 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki interfejsu użytkownika GNOME
114 Group:          Libraries/Python
115 Requires:       %{name}-bonobo-ui = %{version}-%{release}
116 Requires:       %{name}-canvas = %{version}-%{release}
117 Requires:       libgnomeui >= 2.22.0
118 Requires:       python-pygobject >= %{pygobject_ver}
119 Requires:       python-pygtk-gtk >= %{pygtk_ver}
120
121 %description ui
122 GNOME User Interface bindings for Python.
123
124 %description ui -l pl.UTF-8
125 Wiązania Pythona do biblioteki interfejsu użytkownika GNOME.
126
127 %package vfs
128 Summary:        GNOME VFS bindings for Python
129 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GNOME VFS
130 Group:          Libraries/Python
131 Requires:       %{name}-common = %{version}-%{release}
132 Requires:       gnome-vfs2-libs >= 2.22.0
133 Requires:       libbonobo >= 2.22.0
134 Requires:       python-pygobject >= %{pygobject_ver}
135 Requires:       python-pyorbit >= %{pyorbit_ver}
136
137 %description vfs
138 GNOME VFS bindings for Python.
139
140 %description vfs -l pl.UTF-8
141 Wiązania Pythona do biblioteki GNOME VFS.
142
143 %package common
144 Summary:        Common files for Python GNOME bindings
145 Summary(pl.UTF-8):      Pliki wspólne wiązań Pythona do GNOME
146 Group:          Libraries/Python
147 Requires:       python-libs >= 1:2.3.2
148 Requires:       python-pygobject >= %{pygobject_ver}
149
150 %description common
151 Common files for Python GNOME bindings.
152
153 %description common -l pl.UTF-8
154 Pliki wspólne wiązań Pythona do GNOME.
155
156 %package devel
157 Summary:        Development files for Python GNOME bindings
158 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do GNOME
159 Group:          Development/Libraries
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       %{name}-bonobo = %{version}-%{release}
162 Requires:       %{name}-bonobo-ui = %{version}-%{release}
163 Requires:       %{name}-canvas = %{version}-%{release}
164 Requires:       %{name}-gconf = %{version}-%{release}
165 Requires:       %{name}-ui = %{version}-%{release}
166 Requires:       %{name}-vfs = %{version}-%{release}
167 Requires:       gnome-vfs2-devel >= 2.22.0
168 Requires:       python-pygtk-devel >= %{pygtk_ver}
169
170 %description devel
171 Development files for Python GNOME bindings.
172
173 %description devel -l pl.UTF-8
174 Pliki programistyczne wiązań Pythona do GNOME.
175
176 %package apidocs
177 Summary:        API documentation for Python GNOME bindings
178 Summary(pl.UTF-8):      Dokumentacja API wiązań Pythona do GNOME
179 Group:          Documentation
180 BuildArch:      noarch
181
182 %description apidocs
183 API documentation for Python GNOME bindings.
184
185 %description apidocs -l pl.UTF-8
186 Dokumentacja API wiązań Pythona do GNOME.
187
188 %package examples
189 Summary:        Example programs for python-gnome
190 Summary(pl.UTF-8):      Przykładowe programy do python-gnome
191 Group:          Libraries/Python
192 Requires:       %{name}-devel = %{version}-%{release}
193
194 %description examples
195 This package contains example programs for python-gnome.
196
197 %description examples -l pl.UTF-8
198 Ten pakiet zawiera przykładowe programy dla python-gnome.
199
200 %prep
201 %setup -q -n %{module}-%{version}
202
203 %{__sed} -i -e 's,${DATADIR}/gtk-doc/html/,%{_gtkdocdir}/,' docs/gnomevfs/wscript
204
205 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' \
206       examples/*/*.py \
207       examples/*/*/*.py
208
209 %build
210 CC="%{__cc}" \
211 CFLAGS="%{rpmcflags}" \
212 ./waf configure \
213         --prefix %{_prefix} \
214         --libdir %{_libdir}
215 ./waf build \
216         --verbose
217
218 %install
219 rm -rf $RPM_BUILD_ROOT
220
221 ./waf install \
222         --destdir $RPM_BUILD_ROOT
223
224 # waf is sucker, and does not +x executables
225 find $RPM_BUILD_ROOT -name '*.so' | xargs chmod a+rx
226
227 %py_postclean
228
229 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
230 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
231
232 %clean
233 rm -rf $RPM_BUILD_ROOT
234
235 %files
236 %defattr(644,root,root,755)
237 %{py_sitedir}/gtk-2.0/gnome/__init__.py[co]
238 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnome/_gnome.so
239
240 %files bonobo
241 %defattr(644,root,root,755)
242 %dir %{py_sitedir}/gtk-2.0/bonobo
243 %{py_sitedir}/gtk-2.0/bonobo/__init__.py[co]
244 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/_bonobo.so
245 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/activation.so
246
247 %files bonobo-ui
248 %defattr(644,root,root,755)
249 %attr(755,root,root) %{py_sitedir}/gtk-2.0/bonobo/ui.so
250
251 %files canvas
252 %defattr(644,root,root,755)
253 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomecanvas.so
254 %{py_sitedir}/gtk-2.0/gnome/canvas.py[co]
255
256 %files gconf
257 %defattr(644,root,root,755)
258 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gconf.so
259
260 %files ui
261 %defattr(644,root,root,755)
262 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnome/ui.so
263
264 %files vfs
265 %defattr(644,root,root,755)
266 %dir %{py_sitedir}/gtk-2.0/gnomevfs
267 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomevfs/_gnomevfs.so
268 %attr(755,root,root) %{py_sitedir}/gtk-2.0/gnomevfs/gnomevfsbonobo.so
269 %{py_sitedir}/gtk-2.0/gnomevfs/__init__.py[co]
270 %{py_sitedir}/gtk-2.0/gnome/vfs.py[co]
271 %attr(755,root,root) %{_libdir}/gnome-vfs-2.0/modules/libpythonmethod.so
272
273 %files common
274 %defattr(644,root,root,755)
275 %doc AUTHORS ChangeLog NEWS README
276 %dir %{py_sitedir}/gtk-2.0/gnome
277
278 %files devel
279 %defattr(644,root,root,755)
280 %{_includedir}/gnome-python-2.0
281 %dir %{_datadir}/pygtk/2.0/argtypes
282 %{_datadir}/pygtk/2.0/argtypes/bonobo-arg-types.py*
283 %{_datadir}/pygtk/2.0/argtypes/gconf-arg-types.py*
284 %{pydefsdir}/bonobo.defs
285 %{pydefsdir}/bonobo-types.defs
286 %{pydefsdir}/bonoboui.defs
287 %{pydefsdir}/bonoboui-types.defs
288 %{pydefsdir}/canvas.defs
289 %{pydefsdir}/gconf.defs
290 %{pydefsdir}/gnome.defs
291 %{pydefsdir}/gnome-types.defs
292 %{pydefsdir}/ui.defs
293 %{_pkgconfigdir}/gnome-python-2.0.pc
294
295 %files apidocs
296 %defattr(644,root,root,755)
297 %{_gtkdocdir}/pygnomevfs
298
299 %files examples
300 %defattr(644,root,root,755)
301 %{_examplesdir}/%{name}-%{version}
This page took 0.070051 seconds and 3 git commands to generate.