]> git.pld-linux.org Git - packages/python-gitdb.git/blob - python-gitdb.spec
New
[packages/python-gitdb.git] / python-gitdb.spec
1 %define         module  gitdb
2 Summary:        Python git object database
3 Name:           python-%{module}
4 Version:        0.5.4
5 Release:        1
6 License:        BSD
7 Group:          Development/Languages/Python
8 Source0:        http://pypi.python.org/packages/source/g/gitdb/%{module}-%{version}.tar.gz
9 # Source0-md5:  25353bb8d3ea527ba443dd88cd4e8a1c
10 URL:            http://pypi.python.org/pypi/gitdb
11 BuildRequires:  python-distribute
12 BuildRequires:  rpm-pythonprov
13 BuildRequires:  rpmbuild(macros) >= 1.219
14 Requires:       python-modules
15 Requires:       python-async >= 0.6.1
16 Requires:       python-smmap >= 0.8.0
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 GitDB is a pure-Python git object database
21
22 %prep
23 %setup -q -n %{module}-%{version}
24
25 %build
26 CC="%{__cc}" \
27 CFLAGS="%{rpmcflags}" \
28 %{__python} setup.py build
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 %{__python} setup.py install \
33         --skip-build \
34         --optimize=2 \
35         --root=$RPM_BUILD_ROOT
36
37 %py_postclean
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(644,root,root,755)
44 %doc AUTHORS LICENSE
45 %dir %{py_sitedir}/gitdb
46 %dir %{py_sitedir}/gitdb/db
47 %{py_sitedir}/gitdb/*.py[co]
48 %attr(755,root,root) %{py_sitedir}/gitdb/*.so
49 %{py_sitedir}/gitdb/db/*.py[co]
50 %{py_sitedir}/gitdb-*.egg-info
This page took 0.070458 seconds and 4 git commands to generate.