]> git.pld-linux.org Git - packages/python-dbus.git/blob - python-dbus.spec
- up to 1.0.0
[packages/python-dbus.git] / python-dbus.spec
1 #
2 # TODO:
3 # - package documentation
4 #
5 %define         rname           dbus-python
6 #
7 Summary:        Python library for using D-BUS
8 Summary(pl.UTF-8):      Biblioteka do używania D-BUS oparta o Pythona
9 Name:           python-dbus
10 Version:        1.0.0
11 Release:        1
12 License:        MIT
13 Group:          Libraries/Python
14 Source0:        http://dbus.freedesktop.org/releases/dbus-python/%{rname}-%{version}.tar.gz
15 # Source0-md5:  775a8235736bf760cdd96e2d76546469
16 URL:            http://www.freedesktop.org/Software/DBusBindings
17 BuildRequires:  autoconf >= 2.59c
18 BuildRequires:  automake >= 1:1.9
19 BuildRequires:  cpp
20 BuildRequires:  dbus-devel >= 1.0
21 BuildRequires:  dbus-glib-devel >= 0.73
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig
24 BuildRequires:  python-devel >= 1:2.5
25 BuildRequires:  rpmbuild(macros) >= 1.268
26 BuildRequires:  rpm-pythonprov
27 %pyrequires_eq  python-modules
28 Requires:       dbus-glib >= 0.73
29 Requires:       dbus-libs >= 1.0
30 Requires:       python-libxml2 >= 1:2.6.26
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 D-BUS add-on library to integrate the standard D-BUS library with
35 Python.
36
37 %description -l pl.UTF-8
38 Dodatkowa biblioteka D-BUS do integracji standardowej biblioteki D-BUS
39 z Pythonem.
40
41 %package devel
42 Summary:        C API for _dbus_bindings module
43 Summary(pl.UTF-8):      API C dla modułu _dbus_bindings
44 License:        AFL v2.1 or LGPL v2.1
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       dbus-devel >= 0.93
48 Requires:       python-devel >= 1:2.5
49
50 %description devel
51 C API for _dbus_bindings module.
52
53 %description devel -l pl.UTF-8
54 API C dla modułu _dbus_bindings.
55
56 %prep
57 %setup -qn %{rname}-%{version}
58
59 %build
60 %configure
61 %{__make}
62         
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 # use sitedir instead of sitescriptdir to match PyQt4 dbus/mainloop dir
67
68 %{__make} install \
69         pythondir=%{py_sitedir} \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
73 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
74 %py_postclean
75
76 rm -f $RPM_BUILD_ROOT%{py_sitedir}/_dbus*.la    
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc AUTHORS COPYING ChangeLog NEWS README
84 %dir %{py_sitedir}/dbus
85 %dir %{py_sitedir}/dbus/mainloop
86 %{py_sitedir}/dbus/*.py[co]
87 %{py_sitedir}/dbus/mainloop/*.py[co]
88 %attr(755,root,root) %{py_sitedir}/_dbus*.so
89 #%{py_sitedir}/dbus_python-*.egg-info
90
91 %files devel
92 %defattr(644,root,root,755)
93 %{_includedir}/dbus-1.0/dbus/dbus-python.h
94 %{_pkgconfigdir}/dbus-python.pc
This page took 0.504875 seconds and 3 git commands to generate.