]> git.pld-linux.org Git - packages/python-chardet.git/blob - python-chardet.spec
- initial revision
[packages/python-chardet.git] / python-chardet.spec
1 %define         module  chardet
2
3 Summary:        Character encoding auto-detection in Python
4 Summary(pl.UTF-8):      Automatyczne wykrywanie kodowania znaków w pythonie
5 Name:           python-%{module}
6 Version:        1.0
7 Release:        1
8 License:        LGPL
9 Group:          Development/Languages/Python
10 Source0:        http://chardet.feedparser.org/download/%{module}-%{version}.tgz
11 # Source0-md5:  29f69d097052a4eae3774382c234cf2b
12 URL:            http://chardet.feedparser.org/
13 BuildRequires:  python >= 1:2.5
14 BuildRequires:  python-devel >= 1:2.5
15 %pyrequires_eq  python-modules
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Character encoding auto-detection in Python.
20 As smart as your browser.
21
22 %description -l pl.UTF-8
23 Automatyczne wykrywanie kodowania znaków w pythonie.
24 Tak zmyślne jak w twojej przeglądarce.
25
26 %prep
27 %setup -q -n %{module}-%{version}
28
29 %build
30 python setup.py build
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34
35 python setup.py install \
36         --root=$RPM_BUILD_ROOT \
37         --optimize=2
38
39 %py_postclean
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc docs/*
47 %dir %{py_sitescriptdir}/chardet
48 %{py_sitescriptdir}/chardet/*.py[co]
49 %{py_sitescriptdir}/*.egg-info
This page took 0.06618 seconds and 4 git commands to generate.