]> git.pld-linux.org Git - packages/python-cffi.git/blob - python-cffi.spec
rebuild with separate debuginfo build-ids
[packages/python-cffi.git] / python-cffi.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5 %bcond_without  doc     # Sphinx based documentation
6 %bcond_without  tests   # unit tests
7 #
8 Summary:        Foreign Function Interface for Python 2 calling C code
9 Summary(pl.UTF-8):      Interfejs funkcji obcych (FFI) dla Pythona 2 wywołującego kod w C
10 Name:           python-cffi
11 Version:        1.14.4
12 Release:        4
13 License:        MIT
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.org/simple/cffi/
16 Source0:        https://files.pythonhosted.org/packages/source/c/cffi/cffi-%{version}.tar.gz
17 # Source0-md5:  ad3d8537b1516bad6bcdc36c458788be
18 URL:            http://cffi.readthedocs.org/
19 BuildRequires:  libffi-devel >= 3
20 BuildRequires:  pkgconfig
21 %if %{with python2}
22 BuildRequires:  python >= 1:2.6
23 BuildRequires:  python-devel >= 1:2.6
24 %if %{with tests}
25 BuildRequires:  python-pycparser
26 BuildRequires:  python-pytest
27 %endif
28 %endif
29 %if %{with python3}
30 BuildRequires:  python3 >= 1:3.2
31 BuildRequires:  python3-devel >= 1:3.2
32 %if %{with tests}
33 BuildRequires:  python3-pycparser
34 BuildRequires:  python3-pytest
35 %endif
36 %endif
37 BuildRequires:  rpm-pythonprov
38 BuildRequires:  rpmbuild(macros) >= 1.714
39 %{?with_doc:BuildRequires:      sphinx-pdg}
40 Requires:       python-modules >= 1:2.6
41 Requires:       python-pycparser
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Foreign Function Interface for Python calling C code. The aim of this
46 project is to provide a convenient and reliable way of calling C code
47 from Python without learning additional language or API.
48
49 This package contains Python 2 module.
50
51 %description -l pl.UTF-8
52 CFFI to interfejs funkcji obcych (FFI - foreign Function Interface) do
53 wywoływania kodu w C z Pythona. Celem projektu jest dostarczenie
54 wygodnego i wiarygodnego sposobu wywoływania kodu w C z Pythona bez
55 potrzeby nauki dodatkowego języka lub API.
56
57 Ten pakiet zawiera moduł Pythona 2.
58
59 %package -n python3-cffi
60 Summary:        Foreign Function Interface for Python 3 calling C code
61 Summary(pl.UTF-8):      Interfejs funkcji obcych (FFI) dla Pythona 3 wywołującego kod w C
62 Group:          Libraries/Python
63 Requires:       python3-modules >= 1:3.2
64 Requires:       python3-pycparser
65
66 %description -n python3-cffi
67 Foreign Function Interface for Python calling C code. The aim of this
68 project is to provide a convenient and reliable way of calling C code
69 from Python without learning additional language or API.
70
71 This package contains Python 3 module.
72
73 %description -n python3-cffi -l pl.UTF-8
74 CFFI to interfejs funkcji obcych (FFI - foreign Function Interface) do
75 wywoływania kodu w C z Pythona. Celem projektu jest dostarczenie
76 wygodnego i wiarygodnego sposobu wywoływania kodu w C z Pythona bez
77 potrzeby nauki dodatkowego języka lub API.
78
79 Ten pakiet zawiera moduł Pythona 3.
80
81 %package apidocs
82 Summary:        API documentation for Python CFFI module
83 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona CFFI
84 Group:          Documentation
85 BuildArch:      noarch
86
87 %description apidocs
88 API documentation for Python CFFI module.
89
90 %description apidocs -l pl.UTF-8
91 Dokumentacja API modułu Pythona CFFI.
92
93 %prep
94 %setup -q -n cffi-%{version}
95
96 %build
97 %if %{with python2}
98 %py_build
99
100 %if %{with tests}
101 PYTHONPATH=$(pwd):$(echo $(pwd)/build-2/lib.linux-*) \
102 py.test-2 c testing
103 %endif
104 %endif
105
106 %if %{with python3}
107 %py3_build
108
109 %if %{with tests}
110 PYTHONPATH=$(pwd):$(echo $(pwd)/build-3/lib.linux-*) \
111 py.test-3 c testing
112 %endif
113 %endif
114
115 %if %{with doc}
116 %{__make} -C doc html
117 %endif
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %if %{with python2}
123 %py_install
124
125 %py_postclean
126 %endif
127
128 %if %{with python3}
129 %py3_install
130 %endif
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %if %{with python2}
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS LICENSE README.md
139 %attr(755,root,root) %{py_sitedir}/_cffi_backend.so
140 %dir %{py_sitedir}/cffi
141 %{py_sitedir}/cffi/_cffi_errors.h
142 %{py_sitedir}/cffi/_cffi_include.h
143 %{py_sitedir}/cffi/_embedding.h
144 %{py_sitedir}/cffi/parse_c_type.h
145 %{py_sitedir}/cffi/*.py[co]
146 %{py_sitedir}/cffi-%{version}-py*.egg-info
147 %endif
148
149 %if %{with python3}
150 %files -n python3-cffi
151 %defattr(644,root,root,755)
152 %doc AUTHORS LICENSE README.md
153 %attr(755,root,root) %{py3_sitedir}/_cffi_backend.cpython-*.so
154 %dir %{py3_sitedir}/cffi
155 %{py3_sitedir}/cffi/_cffi_errors.h
156 %{py3_sitedir}/cffi/_cffi_include.h
157 %{py3_sitedir}/cffi/_embedding.h
158 %{py3_sitedir}/cffi/parse_c_type.h
159 %{py3_sitedir}/cffi/*.py
160 %{py3_sitedir}/cffi/__pycache__
161 %{py3_sitedir}/cffi-%{version}-py*.egg-info
162 %endif
163
164 %if %{with doc}
165 %files apidocs
166 %defattr(644,root,root,755)
167 %doc doc/build/html/{_static,*.html,*.js}
168 %endif
This page took 0.051473 seconds and 4 git commands to generate.