]> git.pld-linux.org Git - packages/python-cffi.git/blob - python-cffi.spec
- release 2 (libffi 3.4.x)
[packages/python-cffi.git] / python-cffi.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5 %bcond_without  doc     # Sphinx based documentation
6 %bcond_without  tests   # unit tests
7 #
8 Summary:        Foreign Function Interface for Python 2 calling C code
9 Summary(pl.UTF-8):      Interfejs funkcji obcych (FFI) dla Pythona 2 wywołującego kod w C
10 Name:           python-cffi
11 Version:        1.15.1
12 Release:        2
13 License:        MIT
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.org/simple/cffi/
16 Source0:        https://files.pythonhosted.org/packages/source/c/cffi/cffi-%{version}.tar.gz
17 # Source0-md5:  f493860a6e98cd0c4178149568a6b4f6
18 URL:            http://cffi.readthedocs.org/
19 BuildRequires:  libffi-devel >= 3
20 BuildRequires:  pkgconfig
21 %if %{with python2}
22 BuildRequires:  python >= 1:2.6
23 BuildRequires:  python-devel >= 1:2.6
24 BuildRequires:  python-setuptools
25 %if %{with tests}
26 BuildRequires:  python-pycparser
27 BuildRequires:  python-pytest
28 BuildRequires:  rpm-build >= 4.6
29 BuildRequires:  virtualenv
30 %endif
31 %endif
32 %if %{with python3}
33 BuildRequires:  python3 >= 1:3.2
34 BuildRequires:  python3-devel >= 1:3.2
35 BuildRequires:  python3-setuptools
36 %if %{with tests}
37 BuildRequires:  python3-pycparser
38 BuildRequires:  python3-pytest
39 BuildRequires:  virtualenv
40 %endif
41 %endif
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  rpmbuild(macros) >= 1.714
44 %{?with_doc:BuildRequires:      sphinx-pdg}
45 Requires:       python-modules >= 1:2.6
46 Requires:       python-pycparser
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Foreign Function Interface for Python calling C code. The aim of this
51 project is to provide a convenient and reliable way of calling C code
52 from Python without learning additional language or API.
53
54 This package contains Python 2 module.
55
56 %description -l pl.UTF-8
57 CFFI to interfejs funkcji obcych (FFI - foreign Function Interface) do
58 wywoływania kodu w C z Pythona. Celem projektu jest dostarczenie
59 wygodnego i wiarygodnego sposobu wywoływania kodu w C z Pythona bez
60 potrzeby nauki dodatkowego języka lub API.
61
62 Ten pakiet zawiera moduł Pythona 2.
63
64 %package -n python3-cffi
65 Summary:        Foreign Function Interface for Python 3 calling C code
66 Summary(pl.UTF-8):      Interfejs funkcji obcych (FFI) dla Pythona 3 wywołującego kod w C
67 Group:          Libraries/Python
68 Requires:       python3-modules >= 1:3.2
69 Requires:       python3-pycparser
70
71 %description -n python3-cffi
72 Foreign Function Interface for Python calling C code. The aim of this
73 project is to provide a convenient and reliable way of calling C code
74 from Python without learning additional language or API.
75
76 This package contains Python 3 module.
77
78 %description -n python3-cffi -l pl.UTF-8
79 CFFI to interfejs funkcji obcych (FFI - foreign Function Interface) do
80 wywoływania kodu w C z Pythona. Celem projektu jest dostarczenie
81 wygodnego i wiarygodnego sposobu wywoływania kodu w C z Pythona bez
82 potrzeby nauki dodatkowego języka lub API.
83
84 Ten pakiet zawiera moduł Pythona 3.
85
86 %package apidocs
87 Summary:        API documentation for Python CFFI module
88 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona CFFI
89 Group:          Documentation
90 BuildArch:      noarch
91
92 %description apidocs
93 API documentation for Python CFFI module.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API modułu Pythona CFFI.
97
98 %prep
99 %setup -q -n cffi-%{version}
100
101 %build
102 %if %{with python2}
103 %py_build
104
105 %if %{with tests}
106 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
107 PYTHONPATH=$(pwd):$(echo $(pwd)/build-2/lib.linux-*) \
108 %{__python} -m pytest c testing
109 %endif
110 %endif
111
112 %if %{with python3}
113 %py3_build
114
115 %if %{with tests}
116 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
117 PYTHONPATH=$(pwd):$(echo $(pwd)/build-3/lib.linux-*) \
118 %{__python3} -m pytest c testing
119 %endif
120 %endif
121
122 %if %{with doc}
123 %{__make} -C doc html
124 %endif
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %if %{with python2}
130 %py_install
131
132 %py_postclean
133 %endif
134
135 %if %{with python3}
136 %py3_install
137 %endif
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %if %{with python2}
143 %files
144 %defattr(644,root,root,755)
145 %doc AUTHORS LICENSE README.md
146 %attr(755,root,root) %{py_sitedir}/_cffi_backend.so
147 %dir %{py_sitedir}/cffi
148 %{py_sitedir}/cffi/_cffi_errors.h
149 %{py_sitedir}/cffi/_cffi_include.h
150 %{py_sitedir}/cffi/_embedding.h
151 %{py_sitedir}/cffi/parse_c_type.h
152 %{py_sitedir}/cffi/*.py[co]
153 %{py_sitedir}/cffi-%{version}-py*.egg-info
154 %endif
155
156 %if %{with python3}
157 %files -n python3-cffi
158 %defattr(644,root,root,755)
159 %doc AUTHORS LICENSE README.md
160 %attr(755,root,root) %{py3_sitedir}/_cffi_backend.cpython-*.so
161 %dir %{py3_sitedir}/cffi
162 %{py3_sitedir}/cffi/_cffi_errors.h
163 %{py3_sitedir}/cffi/_cffi_include.h
164 %{py3_sitedir}/cffi/_embedding.h
165 %{py3_sitedir}/cffi/parse_c_type.h
166 %{py3_sitedir}/cffi/*.py
167 %{py3_sitedir}/cffi/__pycache__
168 %{py3_sitedir}/cffi-%{version}-py*.egg-info
169 %endif
170
171 %if %{with doc}
172 %files apidocs
173 %defattr(644,root,root,755)
174 %doc doc/build/html/{_static,*.html,*.js}
175 %endif
This page took 0.085357 seconds and 4 git commands to generate.