]> git.pld-linux.org Git - packages/python-wtforms.git/blob - python-WTForms.spec
- cleanup
[packages/python-wtforms.git] / python-WTForms.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  WTForms
6 Summary:        A flexible forms validation and rendering library for python web development
7 Summary(pl.UTF-8):      -
8 Name:           python-%{module}
9 Version:        1.0.1
10 Release:        0.1
11 License:        BSD
12 Group:          Development/Languages/Python
13 Source0:        http://pypi.python.org/packages/source/W/WTForms/%{module}-%{version}.zip
14 # Source0-md5:  d4284596daadf7eae048aef8e449c543
15 URL:            http://wtforms.simplecodes.com/
16 BuildRequires:  python-distribute
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.219
19 BuildRequires:  unzip
20 Requires:       python-modules
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 A flexible forms validation and rendering library for python web
26 development.
27
28 %prep
29 %setup -q -n %{module}-%{version}
30
31 %build
32 %{__python} setup.py build
33
34 %{?with_tests:%{__python} setup.py test}
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 %{__python} setup.py install \
39         --skip-build \
40         --optimize=2 \
41         --root=$RPM_BUILD_ROOT
42
43 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
44 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
45 %py_postclean
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc AUTHORS.txt CHANGES.txt README.txt
53 %{py_sitescriptdir}/wtforms
54 %if "%{py_ver}" > "2.4"
55 %{py_sitescriptdir}/%{module}-*.egg-info
56 %endif
This page took 0.104413 seconds and 4 git commands to generate.