]> git.pld-linux.org Git - packages/python-SOAP.git/blob - python-SOAP.spec
- version 0.11.6
[packages/python-SOAP.git] / python-SOAP.spec
1 Summary:        A SOAP library for Python
2 Summary(pl):    Biblioteka SOAP dla Pythona
3 Name:           python-SOAP
4 Version:        0.11.6
5 Release:        1
6 License:        Python
7 Group:          Libraries/Python
8 Source0:        http://dl.sourceforge.net/pywebsvcs/SOAPpy-%{version}.tar.gz
9 # Source0-md5:  51ac835366badedd932c64f26fa8336b
10 URL:            http://sourceforge.net/projects/pywebsvcs/
11 %pyrequires_eq  python
12 BuildRequires:  python-devel >= 2.3
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  python-fpconst
15 BuildRequires:  python-PyXML
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Web services for Python programmers, both client and servers. This
21 includes SOAP, WSDL, UDDI, etc.
22
23 %description -l pl
24 Serwisy WWW dla programistów Pythona, zarówno klient i serwery. W tym
25 SOAP, WSDL, UDDI itp.
26
27 %prep
28 %setup -q -n SOAPpy-%{version}
29
30 %build
31 python setup.py build
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35 install -d $RPM_BUILD_ROOT%{py_sitescriptdir}
36
37 python setup.py install \
38         --optimize=2 \
39         --root=$RPM_BUILD_ROOT
40
41 find $RPM_BUILD_ROOT%{py_sitescriptdir} -type f -name "*.py" -exec rm {} \;
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc README docs/*.txt validate tests tools contrib bid
49 %dir %{py_sitescriptdir}/SOAPpy
50 %{py_sitescriptdir}/SOAPpy/*.py?
51 %dir %{py_sitescriptdir}/SOAPpy/wstools
52 %{py_sitescriptdir}/SOAPpy/wstools/*.py?
This page took 0.03802 seconds and 4 git commands to generate.