]> git.pld-linux.org Git - packages/python-SOAP.git/blob - python-SOAP.spec
- require python >= 2.1 and cosmetics.
[packages/python-SOAP.git] / python-SOAP.spec
1 Summary:        A SOAP library for Python
2 Name:           python-SOAP
3 Version:        0.9.7
4 Release:        1
5 License:        Python License
6 Source0:        http://prdownloads.sourceforge.net/pywebsvcs/SOAPpy097.tgz
7 URL:            http://sourceforge.net/projects/pywebsvcs/
8 Group:          Development/Languages/Python
9 Group(de):      Entwicklung/Sprachen/Python
10 Group(pl):      Programowanie/Jêzyki/Python
11 Requires:       python >= 2.1
12 BuildRequires:  python-devel >= 2.1
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define python_prefix      %(echo `python -c "import sys; print sys.prefix"`)
17 %define python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
18 %define python_libdir      %{python_prefix}/lib/python%{python_version}
19 %define python_sitedir     %{python_libdir}/site-packages
20
21 %description
22 Web services for Python programmers, both client and servers. 
23 This includes SOAP, WSDL, UDDI, etc.
24
25 %prep
26 %setup -q -n SOAPpy097
27
28 %build
29 python -c 'import py_compile; py_compile.compile("SOAP.py");'
30 python -O -c 'import py_compile; py_compile.compile("SOAP.py");'
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 install -d $RPM_BUILD_ROOT%{python_sitedir}
35
36 install SOAP.py? $RPM_BUILD_ROOT%{python_sitedir}
37
38 gzip -9nf README CHANGELOG docs/*.txt 
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %files
44 %defattr(644,root,root,755)
45 %doc *.gz docs/*.gz validate tests tools contrib bid *.py
46 %{python_sitedir}/*.py?
This page took 0.028462 seconds and 4 git commands to generate.