]> git.pld-linux.org Git - packages/python-MySQLdb.git/blob - python-MySQLdb.spec
- pl summary, cosmetics; release 2
[packages/python-MySQLdb.git] / python-MySQLdb.spec
1 Summary:        An Python interface to MySQL
2 Summary(pl):    Interfejs Pythona do MySQL
3 Name:           python-MySQLdb
4 Version:        0.9.0
5 Release:        2
6 License:        GPL
7 Group:          Development/Languages/Python
8 Group(de):      Entwicklung/Sprachen/Python
9 Group(pl):      Programowanie/Jêzyki/Python
10 Source0:        http://prdownloads.sourceforge.net/mysql-python/MySQL-python-%{version}.tar.gz
11 URL:            http://sourceforge.net/projects/mysql-python/
12 Requires:       mysql >= 3.22.32 
13 Requires:       python >= 1.5.2
14 BuildRequires:  python-devel >= 1.5.2
15 BuildRequires:  mysql-devel
16 BuildRequires:  zlib-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19
20 %description
21 An interface to the popular MySQL database server for
22 Python. The design goals are:
23
24 - Compliance with Python database API version 2.0
25 - Thread-safety
26 - Thread-friendliness (threads will not block each other)
27
28 %description -l pl
29 Ten pakiet zapewnia dostêp do baz danych MySQL z poziomu skryptów
30 jêzyka Python.
31
32 %prep
33 %setup -q -n MySQL-python-%{version}
34
35 %build
36 env CFLAGS="%{rpmcflags}" %{_bindir}/python setup.py build
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 %{_bindir}/python -- setup.py install --root=$RPM_BUILD_ROOT --record=INSTALLED_FILES
41 gzip -9nf README
42 tmpfile=INSTALLED_FILES.$$
43 grep -v 'py$' INSTALLED_FILES | sort > $tmpfile && mv $tmpfile INSTALLED_FILES
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files -f INSTALLED_FILES
49 %defattr(644,root,root,755)
50 %doc *.gz doc/*.html
This page took 0.025186 seconds and 3 git commands to generate.