]> git.pld-linux.org Git - packages/python-MySQLdb.git/blob - python-MySQLdb.spec
- removed %%include /usr/lib/rpm/macros.python
[packages/python-MySQLdb.git] / python-MySQLdb.spec
1
2 Summary:        A Python interface to MySQL
3 Summary(pl):    Interfejs Pythona do MySQL
4 Name:           python-MySQLdb
5 Version:        1.1.0
6 Release:        1
7 License:        GPL
8 Group:          Libraries/Python
9 Source0:        http://dl.sourceforge.net/mysql-python/MySQL-python-%{version}.tar.gz
10 # Source0-md5:  e961a6bca10dc3d502db74ad75423b0e
11 URL:            http://sourceforge.net/projects/mysql-python/
12 #Requires:      mysql >= 3.23.49
13 BuildRequires:  mysql-devel >= 4.0.10
14 BuildRequires:  python-devel >= 2.2.1
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  zlib-devel
17 %pyrequires_eq  python-modules
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 An interface to the popular MySQL database server for Python. The
22 design goals are:
23
24 - Compliance with Python database API version 2.0
25 - Thread-safety
26 - Thread-friendliness (threads will not block each other)
27
28 %description -l pl
29 Ten pakiet zapewnia dostêp do baz danych MySQL z poziomu skryptów
30 jêzyka Python.
31
32 %prep
33 %setup -q -n MySQL-python-%{version}
34
35 %build
36 env CFLAGS="%{rpmcflags}" %{_bindir}/python setup.py build
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 python -- setup.py install \
41         --root=$RPM_BUILD_ROOT \
42         --install-lib=%{py_sitescriptdir} \
43         --optimize=2
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc README CHANGELOG doc/*
51 %attr(755,root,root) %{py_sitescriptdir}/*.so
52 %{py_sitescriptdir}/*.py?
53
54 %dir %{py_sitescriptdir}/MySQLdb
55 %{py_sitescriptdir}/MySQLdb/*.py?
56
57 %dir %{py_sitescriptdir}/MySQLdb/constants
58 %{py_sitescriptdir}/MySQLdb/constants/*.py?
This page took 0.028288 seconds and 3 git commands to generate.