]> git.pld-linux.org Git - packages/python-M2Crypto.git/blob - python-M2Crypto.spec
- ahh, what the hell: openssl 0.9.7c
[packages/python-M2Crypto.git] / python-M2Crypto.spec
1 %include        /usr/lib/rpm/macros.python
2
3 Summary:        Python interface to OpenSSL
4 Summary(pl):    Interfejs Pythona do OpenSSL
5 Name:           python-M2Crypto
6 Version:        0.11
7 Release:        1
8 License:        BSD-like
9 Source0:        http://www.pobox.org.sg/home/ngps/m2/m2crypto-%{version}.zip
10 # Source0-md5:  c018c94e00b33aac969fbbe02b244aba
11 Patch0:         M2Crypto-smime_callback.patch
12 URL:            http://www.pobox.org.sg/home/ngps/m2/
13 Group:          Development/Languages/Python
14 %pyrequires_eq  python
15 BuildRequires:  python-devel >= 2.2.1
16 BuildRequires:  openssl-devel >= 0.9.7c
17 BuildRequires:  swig >= 1.3.17
18 BuildRequires:  rpm-pythonprov
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 M2Crypto makes accessible to the Python programmer the following:
23 - DH, RSA, DSA, symmetric ciphers, message digests, HMACs.
24 - SSL functionality to implement clients and servers.
25 - S/MIME v2.
26
27 M2Crypto is released under a very liberal BSD-like licence. See
28 LICENCE for details.
29
30 %description -l pl
31 M2Crypto udostêpnia z poziomu Pythona nastêpuj±ce funkcje:
32 - DH, RSA, DSA, szyfry symetryczne, skróty, HMAC
33 - SSL do implementacji klientów i serwerów
34 - S/MIME v2.
35
36 %prep
37 %setup -q -n m2crypto-%{version}
38 %patch0 -p1
39
40 %build
41 # workaroud (no way to pass -ISWIG to swig invocation)
42 cp SWIG/*.i SWIG/*.h .
43 python setup.py build 
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{py_sitedir}
48
49 python setup.py install \
50         --root=$RPM_BUILD_ROOT \
51         --optimize=2
52
53 # shutup check-files
54 find $RPM_BUILD_ROOT/%{py_sitedir} -name \*.py \
55         -exec rm {} \;
56         
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc BUGS CHANGES INSTALL LICENCE README STORIES doc/*.html demo
63 %attr(755,root,root) %{py_sitedir}/M2Crypto/*.so
64 %{py_sitedir}/M2Crypto/*.py[oc]
65 %dir %{py_sitedir}/M2Crypto/SSL
66 %{py_sitedir}/M2Crypto/SSL/*.py[oc]
67 %dir %{py_sitedir}/M2Crypto/PGP
68 %{py_sitedir}/M2Crypto/PGP/*.py[oc]
This page took 0.606015 seconds and 4 git commands to generate.