]> git.pld-linux.org Git - packages/python-M2Crypto.git/blob - python-M2Crypto.spec
- updated to 0.17beta1
[packages/python-M2Crypto.git] / python-M2Crypto.spec
1 Summary:        Python interface to OpenSSL
2 Summary(pl):    Interfejs Pythona do OpenSSL
3 Name:           python-M2Crypto
4 Version:        0.17
5 %define bver    beta1
6 Release:        0.%{bver}.2
7 License:        BSD-like
8 Group:          Development/Languages/Python
9 Source0:        http://wiki.osafoundation.org/pub/Projects/MeTooCrypto/m2crypto-%{version}%{bver}.tar.gz
10 # Source0-md5:  da7da465e423adc44e46cc160dc1fa89
11 Patch0:         %{name}-swig_sources.patch
12 Patch1:         %{name}-store2ssl.patch
13 URL:            http://wiki.osafoundation.org/bin/view/Projects/MeTooCrypto
14 BuildRequires:  openssl-devel >= 0.9.7d
15 BuildRequires:  python-devel >= 1:2.5
16 BuildRequires:  swig-python >= 1.3.24
17 BuildRequires:  unzip
18 %pyrequires_eq  python
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 M2Crypto makes accessible to the Python programmer the following:
23 - DH, RSA, DSA, symmetric ciphers, message digests, HMACs.
24 - SSL functionality to implement clients and servers.
25 - S/MIME v2.
26
27 M2Crypto is released under a very liberal BSD-like licence. See
28 LICENCE for details.
29
30 %description -l pl
31 M2Crypto udostêpnia z poziomu Pythona nastêpuj±ce funkcje:
32 - DH, RSA, DSA, szyfry symetryczne, skróty, HMAC
33 - SSL do implementacji klientów i serwerów
34 - S/MIME v2.
35
36 %prep
37 %setup -q -n m2crypto-%{version}%{bver}
38 %patch0 -p1
39 %patch1 -p1
40
41 find demo -type d -name CVS | xargs rm -rf
42
43 %build
44 python setup.py build
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT%{py_sitedir}
49
50 python setup.py install \
51         --root=$RPM_BUILD_ROOT \
52         --optimize=2
53
54 # shutup check-files
55 find $RPM_BUILD_ROOT%{py_sitedir} -name \*.py \
56         -exec rm {} \;
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc CHANGES LICENCE README doc/*.html demo
64 %dir %{py_sitedir}/M2Crypto
65 %attr(755,root,root) %{py_sitedir}/M2Crypto/*.so
66 %{py_sitedir}/M2Crypto/*.py[oc]
67 %dir %{py_sitedir}/M2Crypto/SSL
68 %{py_sitedir}/M2Crypto/SSL/*.py[oc]
69 %dir %{py_sitedir}/M2Crypto/PGP
70 %{py_sitedir}/M2Crypto/PGP/*.py[oc]
71 %{py_sitedir}/M2Crypto-*.egg-info
This page took 0.060895 seconds and 4 git commands to generate.