]> git.pld-linux.org Git - packages/python-M2Crypto.git/blob - python-M2Crypto.spec
- adapterized (killed trailing spaces/tabs)
[packages/python-M2Crypto.git] / python-M2Crypto.spec
1 Summary:        Python interface to OpenSSL
2 Summary(pl):    Interfejs Pythona do OpenSSL
3 Name:           python-M2Crypto
4 Version:        0.13
5 Release:        5
6 License:        BSD-like
7 Source0:        http://sandbox.rulemaker.net/ngps/Dist/m2crypto-%{version}.zip
8 # Source0-md5:  be2790a34349ab452dddbcfe4c95606a
9 #               http://sandbox.rulemaker.net/ngps/Dist/0.13p1.patch
10 Patch0:         %{name}-0.13p1.patch
11 Patch1:         %{name}-swig_sources.patch
12 Group:          Development/Languages/Python
13 URL:            http://sandbox.rulemaker.net/ngps/m2/
14 %pyrequires_eq  python
15 BuildRequires:  openssl-devel >= 0.9.7d
16 BuildRequires:  python-devel >= 2.2.1
17 BuildRequires:  swig < 1.3.24
18 BuildRequires:  swig >= 1.3.21
19 #BuildRequires: swig-python >= 1.3.25
20 BuildRequires:  unzip
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 M2Crypto makes accessible to the Python programmer the following:
25 - DH, RSA, DSA, symmetric ciphers, message digests, HMACs.
26 - SSL functionality to implement clients and servers.
27 - S/MIME v2.
28
29 M2Crypto is released under a very liberal BSD-like licence. See
30 LICENCE for details.
31
32 %description -l pl
33 M2Crypto udostêpnia z poziomu Pythona nastêpuj±ce funkcje:
34 - DH, RSA, DSA, szyfry symetryczne, skróty, HMAC
35 - SSL do implementacji klientów i serwerów
36 - S/MIME v2.
37
38 %prep
39 %setup -q -n m2crypto-%{version}
40 %patch0 -p0
41 %patch1 -p1
42
43 find demo -type d -name CVS | xargs rm -rf
44
45 %build
46 python setup.py build
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{py_sitedir}
51
52 python setup.py install \
53         --root=$RPM_BUILD_ROOT \
54         --optimize=2
55
56 # shutup check-files
57 find $RPM_BUILD_ROOT%{py_sitedir} -name \*.py \
58         -exec rm {} \;
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc BUGS CHANGES INSTALL LICENCE README doc/*.html demo
66 %dir %{py_sitedir}/M2Crypto
67 %attr(755,root,root) %{py_sitedir}/M2Crypto/*.so
68 %{py_sitedir}/M2Crypto/*.py[oc]
69 %dir %{py_sitedir}/M2Crypto/SSL
70 %{py_sitedir}/M2Crypto/SSL/*.py[oc]
71 %dir %{py_sitedir}/M2Crypto/PGP
72 %{py_sitedir}/M2Crypto/PGP/*.py[oc]
This page took 0.084594 seconds and 4 git commands to generate.