]> git.pld-linux.org Git - packages/pylint.git/blob - pylint.spec
- tab
[packages/pylint.git] / pylint.spec
1 Summary:        Python tool that checks if a module satisfy a coding standard
2 Summary(pl.UTF-8):      Pythonowe narzędzie sprawdzające zgodność modułu ze standardem kodowania
3 Name:           pylint
4 Version:        0.14.0
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages/Python
8 Source0:        ftp://ftp.logilab.fr/pub/pylint/%{name}-%{version}.tar.gz
9 # Source0-md5:  a6a6a1c68e56506d6fca7569f622767a
10 URL:            http://www.logilab.org/projects/pylint/view
11 BuildRequires:  python-devel
12 BuildRequires:  python-modules >= 2.2.1
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  rpmbuild(macros) >= 1.219
15 %pyrequires_eq  python-modules
16 Requires:       python-logilab-astng >= 0.17.0
17 Suggests:       python-devel-src
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Python tool that checks if a module satisfy a coding standard.
23
24 %description -l pl.UTF-8
25 Narzędzie sprawdzające zgodność modułów napisanych w języku Python
26 z regułami tworzenia kodu źródłowego.
27
28 %package gui
29 Summary:        GUI for pylint
30 Summary(pl.UTF-8):      Graficzny interfejs użytkownika dla pylinta
31 Group:          Development/Languages/Python
32 Requires:       %{name} = %{version}-%{release}
33 Requires:       python-tkinter
34
35 %description gui
36 Tk based GUI for pylint.
37
38 %description gui -l pl.UTF-8
39 Oparty na bibliotece Tk graficzny interfejs użytkownika dla pylinta.
40
41 %prep
42 %setup -q
43
44 %build
45 python setup.py build
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_mandir}/man1}
50
51 python setup.py install \
52         --optimize=2 \
53         --root=$RPM_BUILD_ROOT
54
55 install man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
56 install examples/pylintrc $RPM_BUILD_ROOT%{_sysconfdir}/pylintrc
57
58 %py_postclean
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc ChangeLog TODO README examples/* doc/*.txt
66 %attr(755,root,root) %{_bindir}/pylint
67 %attr(755,root,root) %{_bindir}/symilar
68 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pylintrc
69 %{py_sitescriptdir}/*
70 %{_mandir}/man1/*
71
72 %files gui
73 %defattr(644,root,root,755)
74 %attr(755,root,root) %{_bindir}/pylint-gui
This page took 0.088794 seconds and 4 git commands to generate.