]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- added {chfn,chsh}.allow as config(noreplace) (fixes upgrade from shadow*)
[packages/pwdutils.git] / pwdutils.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # build without LDAP support
4 %bcond_without  selinux         # build without SELinux support
5 #
6 Summary:        Utilities to manage the passwd and shadow user information
7 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
8 Name:           pwdutils
9 Version:        2.6.92
10 Release:        0.2
11 License:        GPL
12 Group:          Applications/System
13 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
14 # Source0-md5:  59c677ac55d2d8406224eb9b2470a3c0
15 Source1:        %{name}.useradd
16 Source2:        %{name}.rpasswdd.init
17 Source3:        %{name}.login.defs
18 Source4:        chage.pamd
19 Source5:        chfn.pamd
20 Source6:        chsh.pamd
21 Source7:        passwd.pamd
22 Source8:        useradd.pamd
23 Source9:        userdb.pamd
24 Source10:       %{name}-pl.po
25 Patch0:         %{name}-f-option.patch
26 URL:            http://www.thkukuk.de/pam/pwdutils/
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  gcc >= 5:3.2
30 BuildRequires:  gettext-devel
31 BuildRequires:  libnscd-devel
32 %{?with_selinux:BuildRequires:  libselinux-devel}
33 %{?with_ldap:BuildRequires:     openldap-devel}
34 BuildRequires:  openssl-devel >= 0.9.7d
35 BuildRequires:  openslp-devel
36 BuildRequires:  pam-devel
37 BuildRequires:  sed >= 4.0
38 Provides:       shadow = 2:%{version}-%{release}
39 Provides:       shadow-extras = 2:%{version}-%{release}
40 Obsoletes:      shadow
41 Obsoletes:      shadow-extras
42 Obsoletes:      shadow-utils
43 Conflicts:      util-linux < 2.12-10
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 # for pam module in /%{_lib}/security
47 %define         _libdir         /%{_lib}
48
49 %description
50 pwdutils is a collection of utilities to manage the passwd and shadow
51 user information. The difference to the shadow suite is that these
52 utilities can also modify the information stored in NIS, NIS+, or
53 LDAP. PAM is used for user authentication and changing the pasword. It
54 contains passwd, chage, chfn, chsh, and a daemon for changing the
55 password on a remote machine over a secure SSL connection. The daemon
56 also uses PAM so that it can change passwords independent of where
57 they are stored.
58
59 %description -l pl
60 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
61 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
62 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
63 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
64 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
65 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
66 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
67 has³a niezale¿nie od tego, gdzie s± przechowywane.
68
69 %package -n rpasswdd
70 Summary:        Remote password update daemon
71 Summary(pl):    Demon do zdalnego uaktualniania hase³
72 Group:          Applications/System
73 PreReq:         rc-scripts
74 Requires(post,preun):   /sbin/chkconfig
75
76 %description -n rpasswdd
77 rpasswdd is a daemon that lets users change their passwords in the
78 presence of a directory service like NIS, NIS+ or LDAP over a secure
79 SSL connection. rpasswdd behaves like the normal passwd(1) program and
80 uses PAM for authentication and changing the password, so it can be
81 configured very flexibel for the local requirements.
82
83 %description -n rpasswdd -l pl
84 rpasswdd to demon pozwalaj±cy u¿ytkownikom zmieniaæ has³a w obecno¶ci
85 us³ug katalogowych takich jak NIS, NIS+ czy LDAP po bezpiecznym
86 po³±czeniu SSL. rpasswdd zachowuje siê tak, jak normalny program
87 passwd(1) i u¿ywam PAM do uwierzytelniania i zmiany hase³, wiêc mo¿e
88 byæ bardzo elastycznie konfigurowany dla lokalnych wymagañ.
89
90 %package -n pam-pam_rpasswd
91 Summary:        pam_rpasswd - PAM module to change remote password
92 Summary(pl):    pam_rpasswd - modu³ PAM do zdalnej zmiany has³a
93 Group:          Base
94 # rpasswd.conf is in base
95 Requires:       %{name} = %{version}-%{release}
96
97 %description -n pam-pam_rpasswd
98 The pam_rpasswd PAM module is for changing the password of user
99 accounts on a remote server over a secure SSL connection. It only
100 provides functionality for one PAM management group: password
101 changing.
102
103 %description -n pam-pam_rpasswd -l pl
104 Modu³ PAM pam_rpasswd s³u¿y do zmiany hase³ dla kont u¿ytkowników na
105 zdalnym serwerze po bezpiecznym po³±czeniu SSL. Udostêpnia
106 funkcjonalno¶æ tylko dla jednej grupy zarz±dzania PAM: zmiany hase³.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111
112 cp %{SOURCE10} po/pl.po
113 sed -i -e 's/\(ALL_LINGUAS\)="de"/\1="de pl"/' configure.in
114 rm -f po/stamp-po
115
116 sed -i -e 's#EXTRA_CFLAGS=.*#EXTRA_CFLAGS="-W -Wall"#g' configure.in
117
118 %build
119 %{__gettextize}
120 %{__aclocal}
121 %{__autoconf}
122 %{__autoheader}
123 %{__automake}
124 %configure \
125         --enable-pam_rpasswd \
126         --%{?with_selinux:en}%{!?with_selinux:dis}able-selinux \
127         --enable-slp \
128         --enable-ssl \
129         --%{?with_ldap:en}%{!?with_ldap:dis}able-ldap \
130         --enable-nls \
131         --disable-rpath
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pwdutils,security,skel}
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 mv $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
142 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
143 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
144 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
145
146 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
147 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
148 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
149 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
150 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
151 install %{SOURCE9} $RPM_BUILD_ROOT/etc/pam.d/shadow
152
153 :> $RPM_BUILD_ROOT%{_sysconfdir}/shadow
154 :> $RPM_BUILD_ROOT/etc/security/chfn.allow
155 :> $RPM_BUILD_ROOT/etc/security/chsh.allow
156
157 %find_lang %{name}
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post
163 if [ ! -f /etc/shadow ]; then
164         %{_sbindir}/pwconv
165 fi
166
167 %post -n rpasswdd
168 /sbin/chkconfig --add rpasswdd
169 if [ -f /var/lock/subsys/rpasswdd ]; then
170         /etc/rc.d/init.d/rpasswdd restart 1>&2
171 else
172         echo "Run \"/etc/rc.d/init.d/rpasswdd start\" to start rpasswdd daemon."
173 fi
174
175 %preun -n rpasswdd
176 if [ "$1" = "0" ]; then
177         if [ -f /var/lock/subsys/rpasswdd ]; then
178                 /etc/rc.d/init.d/rpasswdd stop 1>&2
179         fi
180         /sbin/chkconfig --del rpasswdd
181 fi
182
183 %files -f %{name}.lang
184 %defattr(644,root,root,755)
185 %doc ChangeLog NEWS README THANKS TODO
186 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %ghost %{_sysconfdir}/shadow
187 %attr(750,root,root) %dir %{_sysconfdir}/default
188 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/default/*
189 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
190 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.local
191 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chage
192 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chfn
193 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chsh
194 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/passwd
195 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/useradd
196 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/shadow
197 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
198 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/rpasswd.conf
199 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/chfn.allow
200 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/chsh.allow
201 %dir /etc/skel
202 %attr(755,root,root) %{_bindir}/chage
203 %attr(4755,root,root) %{_bindir}/chfn
204 %attr(4755,root,root) %{_bindir}/chsh
205 %attr(4755,root,root) %{_bindir}/expiry
206 %attr(4755,root,root) %{_bindir}/gpasswd
207 %attr(755,root,root) %{_bindir}/newgrp
208 %attr(4755,root,root) %{_bindir}/passwd
209 %attr(755,root,root) %{_bindir}/rpasswd
210 %attr(755,root,root) %{_bindir}/sg
211 %attr(755,root,root) %{_sbindir}/chpasswd
212 %attr(755,root,root) %{_sbindir}/groupadd
213 %attr(755,root,root) %{_sbindir}/groupdel
214 %attr(755,root,root) %{_sbindir}/groupmod
215 %attr(755,root,root) %{_sbindir}/grpconv
216 %attr(755,root,root) %{_sbindir}/grpck
217 %attr(755,root,root) %{_sbindir}/grpunconv
218 %attr(755,root,root) %{_sbindir}/pwconv
219 %attr(755,root,root) %{_sbindir}/pwck
220 %attr(755,root,root) %{_sbindir}/pwunconv
221 %attr(755,root,root) %{_sbindir}/rpasswdd
222 %attr(755,root,root) %{_sbindir}/useradd
223 %attr(755,root,root) %{_sbindir}/userdel
224 %attr(755,root,root) %{_sbindir}/usermod
225 %attr(755,root,root) %{_sbindir}/vigr
226 %attr(755,root,root) %{_sbindir}/vipw
227 %{_mandir}/man?/*
228 %exclude %{_mandir}/man8/rpasswdd.8*
229 %exclude %{_mandir}/man8/pam_rpasswd.8*
230
231 %files -n rpasswdd
232 %defattr(644,root,root,755)
233 %attr(755,root,root) %{_sbindir}/rpasswdd
234 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
235 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/rpasswd
236 %{_mandir}/man8/rpasswdd.8*
237
238 %files -n pam-pam_rpasswd
239 %defattr(644,root,root,755)
240 %attr(755,root,root) /%{_lib}/security/pam_rpasswd.so
241 %{_mandir}/man8/pam_rpasswd.8*
This page took 0.067162 seconds and 4 git commands to generate.