]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- updated to 2.6 (pam_rpasswd needs subpackage)
[packages/pwdutils.git] / pwdutils.spec
1 Summary:        Utilities to manage the passwd and shadow user information
2 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
3 Name:           pwdutils
4 Version:        2.6
5 Release:        1
6 License:        GPL
7 Group:          Applications/System
8 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
9 # Source0-md5:  8567328b1ad7609f8851eec57658f1a0
10 Source1:        %{name}.useradd
11 Source2:        %{name}.rpasswdd.init
12 Source3:        %{name}.login.defs
13 Source4:        chage.pamd
14 Source5:        chfn.pamd
15 Source6:        chsh.pamd
16 Source7:        passwd.pamd
17 Source8:        useradd.pamd
18 Source9:        userdb.pamd
19 URL:            http://www.thkukuk.de/pam/pwdutils/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  gcc >= 5:3.2
23 BuildRequires:  gettext-devel
24 BuildRequires:  libselinux-devel
25 BuildRequires:  openldap-devel
26 BuildRequires:  openssl-devel
27 BuildRequires:  openslp-devel
28 BuildRequires:  pam-devel
29 BuildRequires:  sed >= 4.0
30 Provides:       shadow = 2:%{version}-%{release}
31 Provides:       shadow-extras = 2:%{version}-%{release}
32 Obsoletes:      shadow
33 Obsoletes:      shadow-extras
34 Conflicts:      util-linux < 2.12-10
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 pwdutils is a collection of utilities to manage the passwd and shadow
39 user information. The difference to the shadow suite is that these
40 utilities can also modify the information stored in NIS, NIS+, or
41 LDAP. PAM is used for user authentication and changing the pasword. It
42 contains passwd, chage, chfn, chsh, and a daemon for changing the
43 password on a remote machine over a secure SSL connection. The daemon
44 also uses PAM so that it can change passwords independent of where
45 they are stored.
46
47 %description -l pl
48 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
49 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
50 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
51 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
52 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
53 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
54 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
55 has³a niezale¿nie od tego, gdzie s± przechowywane.
56
57 %package -n rpasswdd
58 Summary:        Remote password update daemon
59 Summary(pl):    Demon do zdalnego uaktualniania hase³
60 Group:          Applications/System
61
62 %description -n rpasswdd
63 rpasswdd is a daemon that lets users change their passwords in the
64 presence of a directory service like NIS, NIS+ or LDAP over a secure
65 SSL connection. rpasswdd behaves like the normal passwd(1) program and
66 uses PAM for authentication and changing the password, so it can be
67 configured very flexibel for the local requirements.
68
69 %description -n rpasswdd -l pl
70 rpasswdd to demon pozwalaj±cy u¿ytkownikom zmieniaæ has³a w obecno¶ci
71 us³ug katalogowych takich jak NIS, NIS+ czy LDAP po bezpiecznym
72 po³±czeniu SSL. rpasswdd zachowuje siê tak, jak normalny program
73 passwd(1) i u¿ywam PAM do uwierzytelniania i zmiany hase³, wiêc mo¿e
74 byæ bardzo elastycznie konfigurowany dla lokalnych wymagañ.
75
76 %prep
77 %setup -q
78
79 %build
80 sed -i -e 's#EXTRA_CFLAGS=.*#EXTRA_CFLAGS="-W -Wall"#g' configure.in
81 %{__gettextize}
82 %{__aclocal}
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86 %configure \
87         --enable-pam_rpasswd \
88         --enable-selinux \
89         --enable-slp \
90         --enable-ssl \
91         --enable-ldap \
92         --enable-nls \
93         --disable-rpath
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d/,pwdutils,skel}
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 mv $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
104 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
105 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
106 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
107
108 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
109 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
110 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
111 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
112 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
113 install %{SOURCE9} $RPM_BUILD_ROOT/etc/pam.d/shadow
114
115 :> $RPM_BUILD_ROOT/etc/shadow
116
117 %find_lang %{name}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post
123 if [ ! -f /etc/shadow ]; then
124         %{_sbindir}/pwconv
125 fi
126
127 %post -n rpasswdd
128 /sbin/chkconfig --add rpasswdd
129 if [ -f /var/lock/subsys/rpasswdd ]; then
130         /etc/rc.d/init.d/rpasswdd restart 1>&2
131 else
132         echo "Run \"/etc/rc.d/init.d/rpasswdd start\" to start rpasswdd daemon."
133 fi
134
135 %preun -n rpasswdd
136 if [ "$1" = "0" ]; then
137         if [ -f /var/lock/subsys/rpasswdd ]; then
138                 /etc/rc.d/init.d/rpasswdd stop 1>&2
139         fi
140         /sbin/chkconfig --del rpasswdd
141 fi
142
143 %files -f %{name}.lang
144 %defattr(644,root,root,755)
145 %doc ChangeLog NEWS README THANKS TODO
146 %attr(600,root,root) %config(noreplace) %verify(not md5 size mtime) %ghost %{_sysconfdir}/shadow
147 %attr(750,root,root) %dir %{_sysconfdir}/default
148 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/default/*
149 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
150 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/*.local
151 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chage
152 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chfn
153 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chsh
154 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/passwd
155 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/useradd
156 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/shadow
157 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
158 %dir /etc/skel
159 %attr(755,root,root) %{_bindir}/chage
160 %attr(4755,root,root) %{_bindir}/chfn
161 %attr(4755,root,root) %{_bindir}/chsh
162 %attr(4755,root,root) %{_bindir}/expiry
163 %attr(4755,root,root) %{_bindir}/gpasswd
164 %attr(755,root,root) %{_bindir}/newgrp
165 %attr(4755,root,root) %{_bindir}/passwd
166 %attr(755,root,root) %{_bindir}/rpasswd
167 %attr(755,root,root) %{_sbindir}/chpasswd
168 %attr(755,root,root) %{_sbindir}/groupadd
169 %attr(755,root,root) %{_sbindir}/groupdel
170 %attr(755,root,root) %{_sbindir}/groupmod
171 %attr(755,root,root) %{_sbindir}/grpconv
172 %attr(755,root,root) %{_sbindir}/grpck
173 %attr(755,root,root) %{_sbindir}/grpunconv
174 %attr(755,root,root) %{_sbindir}/pwconv
175 %attr(755,root,root) %{_sbindir}/pwck
176 %attr(755,root,root) %{_sbindir}/pwunconv
177 %attr(755,root,root) %{_sbindir}/rpasswdd
178 %attr(755,root,root) %{_sbindir}/useradd
179 %attr(755,root,root) %{_sbindir}/userdel
180 %attr(755,root,root) %{_sbindir}/usermod
181 %attr(755,root,root) %{_sbindir}/vigr
182 %attr(755,root,root) %{_sbindir}/vipw
183 %{_mandir}/man?/*
184 %exclude %{_mandir}/man8/rpasswdd*
185
186 %files -n rpasswdd
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_sbindir}/rpasswdd
189 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
190 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/rpasswd
191 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/rpasswd.conf
192 %{_mandir}/man8/rpasswdd*
This page took 0.060491 seconds and 4 git commands to generate.