]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- added PreReq: rc-scripts and Requires(): /sbin/chkconfig for daemon
[packages/pwdutils.git] / pwdutils.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # build without LDAP support
4 %bcond_without  selinux         # build without SELinux support
5 #
6 Summary:        Utilities to manage the passwd and shadow user information
7 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
8 Name:           pwdutils
9 Version:        2.6.90
10 Release:        3
11 License:        GPL
12 Group:          Applications/System
13 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
14 # Source0-md5:  477703b1d538d96a0747e2ef0ee0081d
15 Source1:        %{name}.useradd
16 Source2:        %{name}.rpasswdd.init
17 Source3:        %{name}.login.defs
18 Source4:        chage.pamd
19 Source5:        chfn.pamd
20 Source6:        chsh.pamd
21 Source7:        passwd.pamd
22 Source8:        useradd.pamd
23 Source9:        userdb.pamd
24 Patch0:         %{name}-f-option.patch
25 URL:            http://www.thkukuk.de/pam/pwdutils/
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  gcc >= 5:3.2
29 BuildRequires:  gettext-devel
30 %{?with_selinux:BuildRequires:  libselinux-devel}
31 %{?with_ldap:BuildRequires:     openldap-devel}
32 BuildRequires:  openssl-devel >= 0.9.7d
33 BuildRequires:  openslp-devel
34 BuildRequires:  pam-devel
35 BuildRequires:  sed >= 4.0
36 Provides:       shadow = 2:%{version}-%{release}
37 Provides:       shadow-extras = 2:%{version}-%{release}
38 Obsoletes:      shadow
39 Obsoletes:      shadow-extras
40 Obsoletes:      shadow-utils
41 Conflicts:      util-linux < 2.12-10
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 # for pam module in /%{_lib}/security
45 %define         _libdir         /%{_lib}
46
47 %description
48 pwdutils is a collection of utilities to manage the passwd and shadow
49 user information. The difference to the shadow suite is that these
50 utilities can also modify the information stored in NIS, NIS+, or
51 LDAP. PAM is used for user authentication and changing the pasword. It
52 contains passwd, chage, chfn, chsh, and a daemon for changing the
53 password on a remote machine over a secure SSL connection. The daemon
54 also uses PAM so that it can change passwords independent of where
55 they are stored.
56
57 %description -l pl
58 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
59 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
60 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
61 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
62 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
63 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
64 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
65 has³a niezale¿nie od tego, gdzie s± przechowywane.
66
67 %package -n rpasswdd
68 Summary:        Remote password update daemon
69 Summary(pl):    Demon do zdalnego uaktualniania hase³
70 Group:          Applications/System
71 PreReq:         rc-scripts
72 Requires(post,preun):   /sbin/chkconfig
73
74 %description -n rpasswdd
75 rpasswdd is a daemon that lets users change their passwords in the
76 presence of a directory service like NIS, NIS+ or LDAP over a secure
77 SSL connection. rpasswdd behaves like the normal passwd(1) program and
78 uses PAM for authentication and changing the password, so it can be
79 configured very flexibel for the local requirements.
80
81 %description -n rpasswdd -l pl
82 rpasswdd to demon pozwalaj±cy u¿ytkownikom zmieniaæ has³a w obecno¶ci
83 us³ug katalogowych takich jak NIS, NIS+ czy LDAP po bezpiecznym
84 po³±czeniu SSL. rpasswdd zachowuje siê tak, jak normalny program
85 passwd(1) i u¿ywam PAM do uwierzytelniania i zmiany hase³, wiêc mo¿e
86 byæ bardzo elastycznie konfigurowany dla lokalnych wymagañ.
87
88 %package -n pam-pam_rpasswd
89 Summary:        pam_rpasswd - PAM module to change remote password
90 Summary(pl):    pam_rpasswd - modu³ PAM do zdalnej zmiany has³a
91 Group:          Base
92 # rpasswd.conf is in base
93 Requires:       %{name} = %{version}-%{release}
94
95 %description -n pam-pam_rpasswd
96 The pam_rpasswd PAM module is for changing the password of user
97 accounts on a remote server over a secure SSL connection. It only
98 provides functionality for one PAM management group: password
99 changing.
100
101 %description -n pam-pam_rpasswd -l pl
102 Modu³ PAM pam_rpasswd s³u¿y do zmiany hase³ dla kont u¿ytkowników na
103 zdalnym serwerze po bezpiecznym po³±czeniu SSL. Udostêpnia
104 funkcjonalno¶æ tylko dla jednej grupy zarz±dzania PAM: zmiany hase³.
105
106 %prep
107 %setup -q
108 %patch0 -p1
109
110 %build
111 sed -i -e 's#EXTRA_CFLAGS=.*#EXTRA_CFLAGS="-W -Wall"#g' configure.in
112 %{__gettextize}
113 %{__aclocal}
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 %configure \
118         --enable-pam_rpasswd \
119         --%{?with_selinux:en}%{!?with_selinux:dis}able-selinux \
120         --enable-slp \
121         --enable-ssl \
122         --%{?with_ldap:en}%{!?with_ldap:dis}able-ldap \
123         --enable-nls \
124         --disable-rpath
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pwdutils,skel}
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 mv $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
135 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
136 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
137 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
138
139 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
140 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
141 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
142 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
143 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
144 install %{SOURCE9} $RPM_BUILD_ROOT/etc/pam.d/shadow
145
146 :> $RPM_BUILD_ROOT/etc/shadow
147
148 %find_lang %{name}
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post
154 if [ ! -f /etc/shadow ]; then
155         %{_sbindir}/pwconv
156 fi
157
158 %post -n rpasswdd
159 /sbin/chkconfig --add rpasswdd
160 if [ -f /var/lock/subsys/rpasswdd ]; then
161         /etc/rc.d/init.d/rpasswdd restart 1>&2
162 else
163         echo "Run \"/etc/rc.d/init.d/rpasswdd start\" to start rpasswdd daemon."
164 fi
165
166 %preun -n rpasswdd
167 if [ "$1" = "0" ]; then
168         if [ -f /var/lock/subsys/rpasswdd ]; then
169                 /etc/rc.d/init.d/rpasswdd stop 1>&2
170         fi
171         /sbin/chkconfig --del rpasswdd
172 fi
173
174 %files -f %{name}.lang
175 %defattr(644,root,root,755)
176 %doc ChangeLog NEWS README THANKS TODO
177 %attr(600,root,root) %config(noreplace) %verify(not md5 size mtime) %ghost %{_sysconfdir}/shadow
178 %attr(750,root,root) %dir %{_sysconfdir}/default
179 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/default/*
180 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
181 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/*.local
182 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chage
183 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chfn
184 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chsh
185 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/passwd
186 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/useradd
187 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/shadow
188 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
189 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/rpasswd.conf
190 %dir /etc/skel
191 %attr(755,root,root) %{_bindir}/chage
192 %attr(4755,root,root) %{_bindir}/chfn
193 %attr(4755,root,root) %{_bindir}/chsh
194 %attr(4755,root,root) %{_bindir}/expiry
195 %attr(4755,root,root) %{_bindir}/gpasswd
196 %attr(755,root,root) %{_bindir}/newgrp
197 %attr(4755,root,root) %{_bindir}/passwd
198 %attr(755,root,root) %{_bindir}/rpasswd
199 %attr(755,root,root) %{_bindir}/sg
200 %attr(755,root,root) %{_sbindir}/chpasswd
201 %attr(755,root,root) %{_sbindir}/groupadd
202 %attr(755,root,root) %{_sbindir}/groupdel
203 %attr(755,root,root) %{_sbindir}/groupmod
204 %attr(755,root,root) %{_sbindir}/grpconv
205 %attr(755,root,root) %{_sbindir}/grpck
206 %attr(755,root,root) %{_sbindir}/grpunconv
207 %attr(755,root,root) %{_sbindir}/pwconv
208 %attr(755,root,root) %{_sbindir}/pwck
209 %attr(755,root,root) %{_sbindir}/pwunconv
210 %attr(755,root,root) %{_sbindir}/rpasswdd
211 %attr(755,root,root) %{_sbindir}/useradd
212 %attr(755,root,root) %{_sbindir}/userdel
213 %attr(755,root,root) %{_sbindir}/usermod
214 %attr(755,root,root) %{_sbindir}/vigr
215 %attr(755,root,root) %{_sbindir}/vipw
216 %{_mandir}/man?/*
217 %exclude %{_mandir}/man8/rpasswdd*
218 %exclude %{_mandir}/man8/pam_rpasswd.8*
219
220 %files -n rpasswdd
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_sbindir}/rpasswdd
223 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
224 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/rpasswd
225 %{_mandir}/man8/rpasswdd*
226
227 %files -n pam-pam_rpasswd
228 %defattr(644,root,root,755)
229 %attr(755,root,root) /%{_lib}/security/pam_rpasswd.so
230 %{_mandir}/man8/pam_rpasswd.8*
This page took 0.042067 seconds and 4 git commands to generate.